Sign in to follow this  
Followers 0

[BETA] CAO-Faktura Schnittstelle


212 posts in this topic

Posted · Report post

Absolut nette Sache also ich hab noch keine Fehler gefunden muss mich da aber erst rein arbeiten is gar nicht so einfach. Viele möglichkeiten! Daumen hoch! Super gemacht xt:commerce Team

MfG Luckpf

Share this post


Link to post
Share on other sites

Posted · Report post

Was noch zu beachten ist bei den Einstellungen in CAO:

Datei -> Shop-Setup

Lieferart

Hier müssen die Versandmodule aus dem shop angegeben werden (shipping_class = Versandcode aus VEYTON, zb "Standard").

Zahlart

Hier muss man ebenfalls den Code verwenden, PayPal zb xt_paypal etc.

Order Status

Hier müssen die Bestellstatus aus dem Shop angelegt werden (Einstellungen -> Systemstatus), darauf achten das die gleichen IDS vergeben werden wie im Shopadmin.

Share this post


Link to post
Share on other sites

Posted · Report post

Hallo,

erstmal vielen Dank für das Modul.

mir ist aufgefallen das beim Artikelimport aus dem Shop die Umlaute nicht korrekt in CAO übernommen werden.

V.G. Micha

Share this post


Link to post
Share on other sites

Posted · Report post

welche cao version und welche DB version ?

Bei unserer testversion mit mysql4 klappte dies ohne probleme.

Share this post


Link to post
Share on other sites

Posted · Report post

Hallo,

vielen Dank für die Antwort.

ich nutze CAO (wie auch von CAO ausdrücklich empfohlen) die MySQL Version 3.23 und die CAO-Faktura 1.4.1.16.

Alles aktuell aus dem CAO Forum von heute morgen ;)

Viele Grüße Micha

Share this post


Link to post
Share on other sites

Posted · Report post

Weiterhin ist mir aufgefallen.

Die Kategorien sind zwar während des Import Veyton --> CAO zu sehen, danach aber in der Wawi nicht. Die Artikel sind nicht in den Kategorien hinterlegt, sondern alle Artikel sind in der Warengruppe 1 hinterlegt.

Erweiterte Produktbeschreibung wird auch nicht mit importiert.

V.G. Micha

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

warengruppe != Shopkategorie in CAO.

die Kategorien findet man bei den Artikel im Reiter Shop (links unten), dort sollte dann auch die beschreibung sein.

Edited by mzanier

Share this post


Link to post
Share on other sites

Posted · Report post

Was hält ihr von einer Master/Slave unterstützung über CAO Faktura ?

Wir könnten dies über "Steuercodes" in der Artikelbeschreibung/Langtext machen.

zb wenn in CAO in der Artikelbeschreibung:

SLAVE_START

Master:art001

Farbe:rot$Größe:L

SLAVE_STOP

eingegeben würde, würde die Schnittstelle hier einen Slave Artikel mit den Eigenschaften Rot und der Größe L anlegen, und diesen dem Masterartikel mit der Artikelnummer art001 zuweisen.

Was sagen die Shopbetreiber, praktikabel, ja/nein ? bessere Vorschläge ?

Share this post


Link to post
Share on other sites

Posted · Report post

#Update CAO 4.1#

Umlaute sollte nun alle Funktionieren.

Für Update nur ordner xt_cao/classes/ ersetzen.

Share this post


Link to post
Share on other sites

Posted · Report post

Bei updates von CAO->Shop (Wie zum Beispiel Bestellstatus) funktioniert nicht! Der Bestellstatus ist dann immer leer und diese fehlermeldung kommt bei CAO dann:

pic1e.th.jpg

Was hab ich falsch gemacht?

Share this post


Link to post
Share on other sites

Posted · Report post

Zeigmal die einstellungen der Bestellstatis und der Shop Einstellungen in CAO.

Und steht was im Transfer Log ?

Share this post


Link to post
Share on other sites

Posted · Report post

Also die Statusänderung geht jetzt hatte ne falsche ID. Dankeschön

Share this post


Link to post
Share on other sites

Posted · Report post

Hallo ich hab die Einsttellungen alle so vorgenommen wie oben angegeben, zudem auch die oben genannte CAO version installiert und XT:commerce 4.0.11..

allerdings bekomme ich immer folgende fehlermeldung

XML Fehler:

Code: 0x800C000C Der Server hat die Anfrage nicht verstanden oder die Anfrage war ungültig. Fehler beim Bearbeiten der Ressource 'http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd'.

Text: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"

"http:/www.w3.org/TR/xhtml1/DTD/html1-transitional.dtd">

Zeile: 1 Position: 122

klingt nicht logisch meiner Meinung nach...

Share this post


Link to post
Share on other sites

Posted · Report post

plugin im admin aktiviert ? richtige url eingegeben in einstellungen ?

Share this post


Link to post
Share on other sites

Posted · Report post

Weiß jemand wie man Cao-Faktura mit eBay verbinden kann um von eBay Bestellungen abzurufen.

Share this post


Link to post
Share on other sites

Posted · Report post

Weiß jemand wie man Cao-Faktura mit eBay verbinden kann um von eBay Bestellungen abzurufen.

Hallo Ravemaster,

also direkt kenne ich keine Verbindung zu CAO, aber es gibt eine Schnittstelle, die ebay-Verkäufe in XT importiert und Kunden anlegt. Wäre das für Dich auch eine Lösung?

Gruß

Michael

Share this post


Link to post
Share on other sites

Posted · Report post

also die Schnittstelle zu CAO ist erstmal ne super Sache!

Der Download funktioniert gut und auch das Arbeiten mit der WAWi scheint einfach zu funktionieren.

Nun kann ich aber leider die Daten nicht in Veyton uploaden :-(

Ich bekomme diese Fehlermeldung:

"-1-XML Fehler: Only one top level element is allowed in an XML document."

Wer kann mir Helfen???

Share this post


Link to post
Share on other sites

Posted · Report post

was steht im transfer log ?

Share this post


Link to post
Share on other sites

Posted · Report post

XML Fehler

Code:0XC00CE%%% Only one top Level element is allowed in an XML document.

Text:<b>Fatal erroer</B>: Class´MediaImages´not found in <b>/home................/class.product.php</b> on line <b>1113</b><br/>

Zeile:2

Position:2

Leider kann eine Bilder Hochladen, sonst hätte ich mal nen Bild gemacht.

Share this post


Link to post
Share on other sites

Posted · Report post

XML Fehler

Code:0XC00CE%%% Only one top Level element is allowed in an XML document.

Text:<b>Fatal erroer</B>: Class´MediaImages´not found in <b>/home................/class.product.php</b> on line <b>1113</b><br/>

Zeile:2

Position:2

Leider kann eine Bilder Hochladen, sonst hätte ich mal nen Bild gemacht.

welche shopversion wird verwendet ? 4.0.11 ?

Und welches Bildformat (gif, jpeg? ) wird hochgeladen ?

Share this post


Link to post
Share on other sites

Posted · Report post

war dies eine originale .11 installation oder ein update ? wenn udpate wurden auch alle datein ersetzt ?

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0