Sign in to follow this  
Followers 0
Sawyer

Fehlöer 404 nach Installation

27 posts in this topic

Guten Tag zusammen,

ich habe soebendie XT Commerce Software installiert (leider schon zum 2. Mal) und bekomme immer, egal wohin ich auf der Shopseite klicke, die folgende Meldung:

"Objekt nicht gefunden!

Der angeforderte URL konnte auf dem Server nicht gefunden werden. Der Link auf der verweisenden Seite scheint falsch oder nicht mehr aktuell zu sein. Bitte informieren Sie den Autor dieser Seite über den Fehler.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.

Error 404"

Unter "bekannte Probleme" konnte ich dieses Problem im Handbuch nicht finden.

Könnte jemand sagen woran es liegen könnte ? Installiere es nun das 2. Mal mit dem gleichen Problem. Im "Backend" Bereich kann ich mich allerdings einloggen.

Grüße

Edited by Sawyer

Share this post


Link to post
Share on other sites

Hallo Leidensgenosse,

ich habe das gleiche Problem und bin nun schon seit einer Woche am verzweifeln.

Auch ich wäre zu tiefst dankbar, wenn sich jemand, der die Lösung kennt erbarmen würde und uns diese mitteilen würde.

Als Anreiz poste ich mal meine .htaccess-Datei.


AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

Options +FollowSymlinks

#RewriteEngine on
#RewriteRule !\.(js|ico|gif|jpg|png|css)$ index.php

DirectoryIndex index.php

RewriteEngine on
RewriteBase /shop
RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/extAdmin/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

RewriteRule .* index.php
[/PHP]

Meine httpd.conf datei ist leer, da ist nichts drin.

Vielen Dank schon mal im Vorraus.

Gruss,

Daywalker

Share this post


Link to post
Share on other sites

Dann gibt es am server probleme mit mod_rewrite.

-> Bitte an den Hoster wenden oder mod_rewrite (seo urls) deaktivieren im Admin.

Share this post


Link to post
Share on other sites

@leverage

Was ist immer das gleiche?

Mich würde eine Lösung für die Zukunft interessieren.

@daywalker_

@sawyer

Hat es gefunzt?

Share this post


Link to post
Share on other sites

@creativo

immer das gleiche heißt:

Dieser Fehlerangabe ist im Forum sehr häufig zu lesen.

Mögliche Fehler:

  • Falsche Einstellung am Server,
  • Nutzung unzureichender Billig-Hoster
  • oder Billiger Hosting-Angebote,
  • falsche Rechtevergabe,
  • falsche Domain-Zuweisung,
  • Fehlkonfiguration bei Installation...

Deshalb immer das gleiche wie folgt:

Fehler schrittweise eingrenzen:

bei 404 nach Installation erst Tipps im Handbuch befolgen

dann die Suchfunktion des Forums nutzen

und wenn es dann nicht klappt,

mal Geld ausgeben und sich helfen lassen

Share this post


Link to post
Share on other sites

Bei mir war der gleiche Fehler - auch das mod_rewrite... Jetzt scheint alles zu funktionieren.

ABER: Mein Hoster ist garantiert (wie einem hier unterschwellig vorgeworfen wird) ein Billighoster

Bzgl. mod_rewrite ist SERVERSEITIG alles korrekt gesetzt (habe ich selbst nochmals überprüft)

Ich bin mir da folglich nicht so sicher ob da nicht etwas schlampig programmiert wurde, sorry...

Share this post


Link to post
Share on other sites

Was soll man zu solch blöden und unprofessionellen Sprüchen sagen?

Vielen Dank!

Und das Problem tritt immer wieder auf...

@creativo

immer das gleiche heißt:

Dieser Fehlerangabe ist im Forum sehr häufig zu lesen.

Mögliche Fehler:

  • Falsche Einstellung am Server,
  • Nutzung unzureichender Billig-Hoster
  • oder Billiger Hosting-Angebote,
  • falsche Rechtevergabe,
  • falsche Domain-Zuweisung,
  • Fehlkonfiguration bei Installation...

Deshalb immer das gleiche wie folgt:

Fehler schrittweise eingrenzen:

bei 404 nach Installation erst Tipps im Handbuch befolgen

dann die Suchfunktion des Forums nutzen

und wenn es dann nicht klappt,

mal Geld ausgeben und sich helfen lassen

Share this post


Link to post
Share on other sites

Man hätte auch sagen können "Glaskugel" dann wärst du auch so weit wie jetzt.

Url wäre immer schön zu wissen und ob der Fehler auch im Adminbereich auftritt oder nur im Shop selber.

u.s.w.

Und warum die Leute teilweise stinkig sind?

Weil die SuFu fast nie genutzt wird und wenn geholfen wird in 90% der Fälle kein Danke kommt.

Und du willst von deinem Shop leben dann überlege dir ob du nicht Profis nimmst für die Installation.

Share this post


Link to post
Share on other sites

Danke für die schnelee Antowrt.

Ich habe mir schon im Internet "Einen abgesucht" bevor ich dieses Thema überhaupt vor die Augen bekommen habe.

Dann freut man sich eigentlich über die "nahe" Lösung und dann das...:mad:

Zum Problem:

habe den Shop bei mir lokal installiert - Apache auf einem MacBook. Installation erfolgreich, Backend - Bereich funzt einwandfrei, frontend zeigt nur die Startseite - jeder klick auf die links ( egal, Imressum Artikel, Kategorien) bringt Error 404 - zum Verzweifeln!

Habe bereits den Shop aus den unterverzeichnis rausgelöscht und neu in das Hauptverz. htdocs installiert - ohne Änderung!:confused::confused::confused:

Also, hier für jeder Art Hilfe wäre ich dankbar...

Man hätte auch sagen können "Glaskugel" dann wärst du auch so weit wie jetzt.

Url wäre immer schön zu wissen und ob der Fehler auch im Adminbereich auftritt oder nur im Shop selber.

u.s.w.

Und warum die Leute teilweise stinkig sind?

Weil die SuFu fast nie genutzt wird und wenn geholfen wird in 90% der Fälle kein Danke kommt.

Und du willst von deinem Shop leben dann überlege dir ob du nicht Profis nimmst für die Installation.

Share this post


Link to post
Share on other sites

Ich bin kein Verkäufer, sondern Entwickler, der auch mal mit einer Shop-Installtion sich vertraut machen möchte, also wen und für was soll ich den bezahlen? Warum muss alles gleich ins Geld gehen?:confused:

Und du willst von deinem Shop leben dann überlege dir ob du nicht Profis nimmst für die Installation.

Share this post


Link to post
Share on other sites

Aber hallo - wer sagt denn, dass ich gleich im ersten Post meckere?

Als Forumbenutzer sollte man sich wiederum aufs Wesentliche konzentrieren, dann wären die Foren hilfsreicher...

Anstatt zu jammern, verhilft man ja viel besser mit einem Link auf das ähnliche Thema ( wenn Einer schon solch ein "Kenner" ist...) und für die Unterhaltung entsprechde Seiten nutzen...

Als Entwickler sollte man aber nicht gleich im ersten Post meckern, sondern sich das System mal anschauen und das Forum konkret durchsuchen, dann würdest du merken, das dass, was Le-Seaw gesagt hatte, zu 99% zutrifft;)

@Le-Seaw: steht schon hier: http://www.xt-commerce.com/forum/fragen-zur-software/83462-fehl-er-404-nach-installation.html#post380483

Share this post


Link to post
Share on other sites

Du hast gesagt du bist Entwickler.

Und ich ging davon aus das du nur wissen wolltest nach was du suchen sollst.

Die Lösung ist individuell, und wenn du es nicht schaffst sie dir zu suchen dann ...

gib auf :)

Share this post


Link to post
Share on other sites

Wie gesagt: blablablabla...

Ergebnis: endlose Beiträge und keine Lösung...

Du solltest wirklich mal überlegen, ob Deine offtops hier sinnvoll sind...

Du hast gesagt du bist Entwickler.

Und ich ging davon aus das du nur wissen wolltest nach was du suchen sollst.

Die Lösung ist individuell, und wenn du es nicht schaffst sie dir zu suchen dann ...

gib auf :)

Share this post


Link to post
Share on other sites

Die SEO-URLS isnd übrigens nicht das Probelm: nach wie vor kann man keine Kategorien, Impressum und AGB-Links anklicken, obwohl die SEO-Urls auf false gesetzt wurde.

Anscheinend ist es "zu schwer" auch für die Super-Duper-Entwickler, wie Dich.

Wie gesagt: blablablabla...

Ergebnis: endlose Beiträge und keine Lösung...

Du solltest wirklich mal überlegen, ob Deine offtops hier sinnvoll sind...

Share this post


Link to post
Share on other sites

Ist es so schwer in der SuFu

mod_rewrite

einzugeben?

Dann findest du einen haufen Lösungen, welche davon passt weisst doch nur du. Und anstatt hier rumzunöhlen solltest du mal lieber in dich gehen und

Aufgeben

wenn du es nicht schaffst die SuFu zu bedienen.

Und dann wundern sich die Leute das sie angemacht werden von der Seite.

Grosser Entwickler aber kann die SuFu nicht benutzen.

Bei 1und1 und strato gibt es diese Shops samt Webspace, solltest du dir überlegen ob du nicht dort was nimmst anstatt selber zu basteln.

Cache leeren

Share this post


Link to post
Share on other sites

Nochmals für die "Schwerfälle" unter uns: ich will keinen Shop betreiben, ich will mich damit nur auskennen!

Aufgeben war noch nie mein Fall, obwohl es nicht immer einfach ist dank solchen Typen, wie dir, im Internet ne richtige Lösung zu finden.

Und dann wundert er sich, dass sich Keiner bei ihm bedankt.... Wofür eigentlich?:confused::confused::confused:

Soviel Zeit verloren in diesem Forum...

Im Gegensatz zu Dir in einem anderen Forum wird gleich Hilfe zum Thema angeboten ohne blöden Anmachen...

Es läuft jetzt, also, kannst Dich mal entspannen...

Ist es so schwer in der SuFu

mod_rewrite

einzugeben?

Dann findest du einen haufen Lösungen, welche davon passt weisst doch nur du. Und anstatt hier rumzunöhlen solltest du mal lieber in dich gehen und

Aufgeben

wenn du es nicht schaffst die SuFu zu bedienen.

Und dann wundern sich die Leute das sie angemacht werden von der Seite.

Grosser Entwickler aber kann die SuFu nicht benutzen.

Bei 1und1 und strato gibt es diese Shops samt Webspace, solltest du dir überlegen ob du nicht dort was nimmst anstatt selber zu basteln.

Cache leeren

Share this post


Link to post
Share on other sites

Außerdem, wocher soll denn ein Newcomer wissen, was mod_rewrite mit Fehler 404 zu tun hat?

Und warum werden die Werte, die so nicht laufen, weder bei der Installation nocht im Handbuch erwähnt? Schwach eben...

Hier wird einem ne kostenlose Version "angedreht" um dann die Kohle beim Support abzusahnen... Schwach ( ich wiederhole mich...)

Ist es so schwer in der SuFu

mod_rewrite

einzugeben?

Dann findest du einen haufen Lösungen, welche davon passt weisst doch nur du. Und anstatt hier rumzunöhlen solltest du mal lieber in dich gehen und

Aufgeben

wenn du es nicht schaffst die SuFu zu bedienen.

Und dann wundern sich die Leute das sie angemacht werden von der Seite.

Grosser Entwickler aber kann die SuFu nicht benutzen.

Bei 1und1 und strato gibt es diese Shops samt Webspace, solltest du dir überlegen ob du nicht dort was nimmst anstatt selber zu basteln.

Cache leeren

Share this post


Link to post
Share on other sites

Hast du deine Lösung mal durchgelesen?

Das hättest du mit der SuFu in 2 Minuten gefunden nachdem schon alles gesagt war

Seo aus

mod_rewrite aus

und das war so schwer?

es selber zu suchen

Und du machst dich eben lächerlich, merkste hoffentlich.

Erst sagts du das du Entwickler bist und dann kennst du nicht mal mit die einfachsten Sachen?

Und hier wird dir nichst angedreht, du bist zu faul dich mit der Materie zu beschäftigen.

Es läuft halt mal nicht out-of-the-box wenn man sich nicht damit Beschäftigen will.

Edited by Le-Seaw

Share this post


Link to post
Share on other sites

Du sitzt da, und anstatt zu helfen, spionierst nach, welchen Themen ich beitragen?

Macht's Spass? Das ist doch krank...

Zu Deiner Info:

ich habe "Fehler 404" in SuFu vor 3 std. eingegeben, aber nach einigen "sinnlosen" Beiträgen wie z.B. "immer das gleiche" o.ä. überlegt, vielleicht frage ich mal die Leute selbst... Hier führte es leider zu noch so einem sinnlosesten Beitrag aller Zeiten...

Hoffentlich hast Du Deine Befriedigung bekommen...

Ende der Durchsage...

Hast du deine Lösung mal durchgelesen?

Das hättest du mit der SuFu in 2 Minuten gefunden nachdem schon alles gesagt war

Seo aus

mod_rewrite aus

und das war so schwer?

es selber zu suchen

Share this post


Link to post
Share on other sites

Du sitzt da, und anstatt zu helfen, spionierst nach, welchen Themen ich beitragen?

Ist ja bei deinen elf Beiträgen nicht sehr schwer, und von den 11 sind gleich 5 mit Mosern und Meckern zugepflastert, inkl. dem persönlichen Angriff auf (div.) User...

Was soll man zu solch blöden und unprofessionellen Sprüchen sagen?

Als Forumbenutzer sollte man sich wiederum aufs Wesentliche konzentrieren, dann wären die Foren hilfsreicher...

Wie gesagt: blablablabla...

Anscheinend ist es "zu schwer" auch für die Super-Duper-Entwickler, wie Dich...
Anm. "wie dich" ist wohl Le-Seaw

Aufgeben war noch nie mein Fall, obwohl es nicht immer einfach ist dank solchen Typen, wie dir, im Internet ne richtige Lösung zu finden.

Ja ja, diese Entwickler immer:)

Im Gegensatz zu Dir in einem anderen Forum wird gleich Hilfe zum Thema angeboten ohne blöden Anmachen...

Höchstwahrscheinlich war die Antwort SEO-URL und mod_rewrite?!

In anderen Foren hätte man dich zumindest schon verwarnt für so eine unhöflichkeit!

EDIT sagt:

Vielen Dank oldbear, mit diesen Einstellungen( s. unten) läuft es:

Mod Rewrite = false

SEO-URLs für Seiten = false

Warum, weiss ich selber nicht...

http://www.xt-commerce.com/forum/fragen-zur-software/83108-404-fehler-beim-aufruf-von-seiten.html

Das ist exakt das worum es hier geht und wurde sechs mal hier im Thread erwähnt... wenn das nicht so traurig wäre, würde ich lachen... Entwickler... ja ja..

Edited by Fry

Share this post


Link to post
Share on other sites

Oh, ihr Meister des Dummgebappels...

Mal sehen:

am 06.05 - Anfrage von einem newcomer - keine Antwort

am 07.05 - Wiederholte Anfrage vom selben newcomer - keine Antwort

am 11.05 - noch eine Anfrage von einem anderen newcomer - keine Antwort...

Hat da einer nachgedacht, ob die newcomer überhaupt wissen um welches mo_rewrite es hier überhaupt geht? Lauter Stichwörter ohne präzise zu erklären, ob die Einstellung im Shop ist oder im .htaccess. Stattdessen nur giftige Bemerkungen hinschmeissen...

Und jetzt komme ich da zufällig vorbei, blättere durch die threads durch, kann nicht halten ohne mit einer Frechheit auf eure Frechheit zu antworten und plötzlich sieh da: der THREAD LEBT!!! Und wie! mehrere Antworten innerhalb 1-2 Stunden!

Und dann auch noch so fleissig zitieren...

Kein Kommentar hierzu... Ihr seid ja große Hilfe...:(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0