Jump to content
xt:Commerce Community Forum

DragonSport

Members
  • Content Count

    5
  • Joined

  • Last visited

About DragonSport

  • Rank
    Neuer Benutzer
  1. Hallo, wir haben das Problem (Version 4.1.0), dass bei Master/Slave-Artikeln unter Produktvariation keine Slave-Artikel angezeigt werden. Grüße Michael ------------------------ Die Erkenntnis: Klar - hängt natürlich von der Einstellung im Master/Slave-PlugIn ab -> Slaveartikel Liste: "Anzahl Ausgabe". Ist dieser Wert zu niedrig angegeben erfolgt KEINE Ausgabe!
  2. Hallo, wir bekommen von unserem Shop (V4.1.0) folgende SQL-Fehlermeldung: mysql error: [1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''94''' at line 1] in EXECUTE("SELECT url_text FROM xt_seo_url WHERE language_code = '' AND link_type = '3' AND link_id = '94''") Eigentlich müsste doch als language_code = bei uns zumindest 'de' bzw. 'en' eingetragen sein (?) und bei link_id ist ein Hochkomma ' zuviel, um die Abfrage korrekt auszuwerten. In der Datei class.seo.php wird die Abfrage scheinbar nicht generiert, also bliebe nur noch die seo_optimization.php (verschlüsselt) übrig - oder? Wer hat vielleicht einen Hinweis / eine Idee zur Lösung? Danke und Kopf hoch! Michael
  3. Hallo Ballonsupermarkt, die Konfiguration innerhalb der Datei sieht so aus: define('_SYSTEM_CHARSET', 'utf-8'); define('_SYSTEM_DB_CHARSET', 'utf8'); Rausgefunden habe ich, dass das Vorkommen folgender Zeichen zum Fehlen des Kommentars führt: " ' < ` ´ \ Ich gehe davon aus, dass die DB insbesondere die Hochkommas als "Steuerzeichen" deutet und nicht mag(?). Ab und an finden halt Zeichen wie " ' oder < Verwendung im Kundenkommentar. Und dieses Zeichen-Problem hat wirklich keiner? Auch nicht in normalen Formularen? Danke und Grüße Michael Was ist in der Konfig richtig? utf8 oder utf-8 oder beides?
  4. Hallo oldbear, der Kommentar wird bei uns nicht mit der eMail verschickt und er wird eben nicht in der DB eingetragen. Es verhält sich so, als hätte der Kunde gar keinen Kommentar geschrieben. Im Checkout-Prozess (xtCore/pages/checkout.php - ca. Zeile 151) wird der Kommentar gefiltert. Diese Funktion resultiert scheinbar aus der Klasse class.filter.php im xtFramework. Die Datei ist codiert - Inhalt? Wir haben das System jetzt so übernommen. D.h. vorher war eine Firma am Start, welche unser System warten sollte. Der Fehler, das Kommentare nicht übertragen werden, wurde denen bereits ca. Mitte 2010 mitgeteilt, aber u.a. bis heute nicht behoben. Jetzt hat sich herausgestellt - insbesondere auch mit Formularen -, dass es an der Verwendung von "Sonderzeichen/Umlauten" liegt. Welche Zeichen genau ausschlaggebend sind, gilt es evtl. noch zu ermitteln - um das Problem näher eingrenzen zu können. Wir wissen jetzt auch nicht, ob evtl. seitens der Firma irgendwo schon "gefummelt" wurde. Hätte ja sein können, dass wir vielleicht ein Update o.ä. verpasst haben. Grüße Michael
  5. Hallo, vielleicht haben wir etwas verpasst oder sind gar die einzigen? In den FAQs haben wir nur etwas zur Formatierung, Verkürzung etc. gefunden, was uns aber nicht weiterhilft. Wir benutzen xt:Commerce Veyton 4.0.14 und haben das Problem, dass falls ein Kunde einen Kommentar zur Bestellung schreibt, dieser - je nachdem scheinbar welche Zeichen eingetippt werden (Umlaute, ?, !, ' ...) - nicht übermittelt wird. Für uns sind gerade diese Informationen sehr wichtig! Frage: Wo, wie wird der Kommentar-String (comments) ggf. auf Eingaben/Zeichen kontrolliert? Evtl. geschieht dies garnicht und man müsste Zeichen, wie z.B. das Hochkomma ('), vorher herausfiltern, um keine Probleme bei der Speicherung in der DB zu bekommen. Gibt es vielleicht auch schon Lösungen/Anpassungen? Für einen Tipp etc. wären wir äußerst dankbar! Grüße Michael
×
×
  • Create New...