Jump to content
xt:Commerce Community Forum

totto

Members
  • Content Count

    77
  • Joined

  • Last visited

Posts posted by totto


  1. Das ist abh?ngig vom Betriebssystem auf dem Server...

    Bei einem Debian Woody ist z. B. die Einstellung

    @setlocale(LC_TIME, 'de_DE');
    
    

    korrekt. Das ist aber in der german.php kommentiert.

    Voraussetzung ist nat?rlich, dass die language packs auf den Server korrekt installiert sind. Bei Debian ist dies nach der Installation nicht der Fall (bekannter Bug), da m?ssen die explizit nochmal nachinstalliert werden.


  2. HEUREKA, ich hab's gefunden....!!!!! :bounce: :) :pint: :z:

    Wenn man bedenkt, dass ich eigentlich so gut wie keine PHP Kenntnisse habe, bin ich doch schon ein echter B?r...!!! :):):) Es geht doch nix ?ber Erfolgserlebnisse...!!!

    Also:

    In der xtc_get_products_price.inc.php steht in der Zeile 110 folgendes:

    $price_string=xtc_format_special_price($rabatt_string,$price_string,$price_special,$calculate_currencies=false,$quantity,$products_tax);
    
    
    Und hier muss einfach nur das Flag f?r die W?hrungsumrechnung auf "true" gesetzt werden, sprich, die Zeile muss so aussehen:
    $price_string=xtc_format_special_price($rabatt_string,$price_string,$price_special,$calculate_currencies=true,$quantity,$products_tax);
    
    

    Und schon werden die Rabatte auch in den anderen W?hrungen richtig dargestellt.


  3. Ich habe jetzt schon an einigen Stellen etwas von der neuen "Sponsor" Version gelesen...

    Was muss man sich denn unter einer "Sponsor" Version vorstellen? Da wird doch nicht etwa ein Sponsoren-Logo oder ?hnliches im Code verankert sein, welches man nicht entfernen kann/darf...???

    Ebenso habe ich gelesen, dass diese in k?rze released werden soll, gibts da schon einen ungef?ren Termin?


  4. Originally posted by heiko228@Aug 6 2004, 10:26 AM

    Hi,

    kann sein das ich jetzt etwas verwechsle. Ich wollte iegentlich nur die Box der Kundengruppe weg haben und an dieser Stelle wollte ich die Box der Anmeldung haben.

    Was denn f?r 'ne Box der Kundengruppe...??? :grml:

    Du meinst doch nicht etwa die Statistikbox die erscheint, wenn der Admin eingeloggt ist, oder...???


  5. Originally posted by viperde@Aug 6 2004, 10:59 AM

    Kopieren der upse Dateien in upss Dateien war ja nur der erste Gedanke.

    Danach habe ich erst gesehen das es bereits ein ups standard modul gibt. (ups.php). Hier gehts dann mit meinem vorherigen posting weiter.

    Hmmm, entweder hast Du eine ?ltere Version von XTC, oder Du hast Dir was vergeigt.

    In der Standard-Installation der v2.0 RC1.2 stehen die Module United Parcel Service Standard (ups) und UPS Express (upse) im Admin zur Verf?gung.


  6. Originally posted by dariusboy@Aug 5 2004, 19:34 PM

    Hallo

    Ich denke das hat mal was mit dem Bug 0000184 zu tun

    oder nicht ?

    Greets

    Kann schon sein, dass da ein und das gleiche Modul angezogen wird, was den Fehler verursacht... Kann ich aber nix genaues zu sagen, ich hab' mich mit den Gutscheinen noch nicht auseinander gesetzt...


  7. Wie nachl?ssig, Deine Glaskugel ausgerechnet jetzt in den Urlaub zu schicken... :)

    Also, Shopversion ist XTC v2.0 RC1.2, Sicherheitsdingens wegen dem Smarty ist auch installiert.

    Der Fehler tritt auf wenn:

    Ein User sich einloggt, der Rabatt auf jedes Produkt bekommt. Es werden immer die EUR Werte des Preises angezeigt, nur die vorgestellte W?hrung wechselt von EUR auf US$, und zur?ck... AUSSER: das Produkt ist ein Sonderangebot (Special), dann wird der Preis korrekt von US$ auf EUR umgerechnet.


  8. Hallo,

    ich habe ein etwas gr??eres Problem, und komme nicht mehr weiter...

    Im Shop werden zwei W?hrungen angeboten, EUR und US$. Soweit funktioniert das auch...

    Wenn jedoch ein Kunde sich anmeldet, der in einer Gruppe ist, wo auf die Artikel ein Rabatt gew?hrt wird, wird bei der Umstellung der W?hrung diese nur bei solchen Artikeln der richtige Preis angezeigt, wenn diese Artikel als Sonderangebote deklariert sind (da gibt's ja eh keinen Rabatt mehr). Bei "normalen Artikeln" wird jedoch nur das EUR in US$ ge?ndert, der Preis ?ndert sich jedoch nicht... Es wird immer der Preis mit dem korrekten Rabatt des Kunden angezeigt, aber immer der EUR Wert...

    Ich hab' schon ?berall geschaut, wo ich dachte, da k?nnte es dran liegen, nun bin ich aber mit meinem Latein am Ende...

    Kann mir evtl. jemand weiterhelfen...???

    Danke schon mal...!!!


  9. Ich hab mal ne Frage zur Datenbank...

    Auf Grund einer riesen Problematik mit der Schweiz (Steuerzone = Welt, Versand Zone = EU), m?sste ich f?r meine etwas komplexe Abwicklung der Bezahlung und Versendung (z.B. Paypal -> ?berall, nur nicht in Deutschland) alle ISO-2 Codes einf?gen, au?er DE.

    Diese kommen in das Feld configuration_value der Tabelle configuration. Dieses Feld ist aber ein VARCHAR 255, und 255 sind hierf?r zu kurz... :grml:

    Ist es m?glich das Feld auf, sagen wir 1.000 Zeichen, zu vergr??ern, ohne dass es Probleme gibt?

    Oder gibt es evtl. noch eine andere L?sung?

    Vielen Dank schon mal...!!!

×
×
  • Create New...