Jump to content
xt:Commerce Community Forum

Fusco

Members
  • Content Count

    37
  • Joined

  • Last visited

  1. Hallo, bin gerade über Deinen Beitrag gestolpert, weil ich genau so etwas gesucht habe, aber für die update_order-admin. Es gibt wohl keinen anderen Weg als in der verantwortlichen PHP-Datei den Befehl für den Mailversand auszukommentieren oder halt raus zu löschen. Du findest Sie unter xtFramework -> classes -> class_order.php und dort nach function _sendOrderMail suchen (für send_order) oder nach function _sendStatusMail suchen (für update_order-admin). Wenn Du die Funktion raus genommen hast, kommen auch keine Template missing Mails mehr. Auch wenn Du es nach all der Zeit vielleicht schon gelöst hast oder meine Antwort nicht mehr liest, so hilft es vielleicht anderen, die auch danach suchen. beste Grüße von Fusco
  2. ich sehe gerade, dass im Bereich "Mein Konto" zumindest die Daten aus der sa_orders angezeigt werden. Nichtsdestotrotz wird die xt_orders verlangt.
  3. Hallo, ich habe gerade einen verzwickten Fehler gefunden und weiß nicht, was ich tun kann. Folgendes: mein Shop - Version 4.1. - hat derzeit ein Problem mit einer Tabelle in der Datenbank. Es geht um die xt_orders. Ich hatte bei der Shopinstallation anstatt "xt" etwas anderes gewählt: sa_orders. Der Shop speichert nun aber ordnungsgemäß Daten in die sa_orders. "Will" aber Daten aus der xt_orders lesen. Z.B. bei "Mein Konto" (wenn bereits Bestellungen getätigt wurden). Oder wenn die Seite shop/checkout/success nach "zahlungspflichtig bestellen" aufgerufen werden soll. Wenn die xt_orders nicht existiert, kommt nur eine weiße Seite. Ich war schon am verzweifeln, habe aber zumindest den Fehler erkannt und die sa_orders kopiert und als xt_orders gespeichert (die xt_orders ist dann natürlich nur der aktuelle Stand vom Kopieren). Was kann man in diesem Fall tun, damit der Shop die sa_orders korrekter weise ausliest? Ich kann auch leider nicht sagen, wie der Fehler entstanden ist. Das einzige eingreifende, was ich getan habe, ist, xtPayments zu registrieren. Am Template liegt es nicht, der Fehler lässt sich auch mit dem Originalem reproduzieren.
  4. Hallo in die Runde, gibt es eine einfach Möglichkeitet im Kundenbereich auf der Seite: ...customer/download_overview die Downloadartikel anders herum anzuordnen, also die neuesten nach Oben? Ich weiß gar nicht, warum das nicht von vornherein so gemacht wird, wie ja auch auf der Bestellübersichtsseite: ...customer/order_overview Kann mir da jemand einen Rat geben? beste Grüße von Fusco
  5. Ich habe gerade das Plugin "Canonical Tags" aktiviert und bin sehr begeistert (Meine Shop-Version 4.0.16). Alles funktioniert tadellos und ich kann es nur jedem empfehlen, der das Problem des doppelten Content für die Suchmaschinen lösen möchte. Es gibt nur eine Kleinigkeit, die mich stört. Kann ich die irgendwo beheben? Ich nutze mehrere Sprachen und bei der Startseite, sieht dann der canonical tag so aus: www.meineshopseite.com/de/index Mir geht es um das "index", einmal im canocial tag und zum anderen aber auch in der url selbst. Ist das irgendwie wegzubekommen? viele Grüße Fusco
  6. Hallo Oldbear, ja genau das ist es. Das habe ich gesucht. Hab' vielen Dank für Deine schnelle kompetente Hilfe! Gut, dass es den alten Bären gibt :-) beste Grüße Fusco
  7. Hallo, ich möchte gerne die Hersteller ID in der product_listing_v1.html und product.html nutzen. Damit soll auf einfachen Weg der Hersteller angezeigt werden (es gibt nicht so viele). Quasi nach folgendem Schema: {if manufacturers_id == '1'}Hersteller 1{else} {manufacturers_id == '2'}Hersteller 2{/if} Dafür muss ja erst mal die ID zur Verfügung gestellt werden. Das weiß ich, nur nicht wie. Ich denke irgendwie mit {$smarty.session...} oder {assign...} ? Oder geht das so gar nicht? Weiß jemand dazu eine Lösung? viele Dank schon einmal und beste Grüße Fusco
  8. Hallo Manfred, hab' ganz herzlichen Dank für Deine Antwort. Mit dem rechtlichen Aspekt hatte ich mich bzgl. Newsletter noch gar nicht befasst. Aber mittlerweile einige Seite dazu studiert. Deine Umsetzung ist ja sehr clever, wäre mir aber jetzt etwas zu umständlich, aber mal schauen, wenn es gar nicht anders geht... Im Prinzip brauche ich nur 2 Dinge. 1. Beim Bestellvorgang ein Häckchen zur Newsletter-Anmeldung 2. Wie Du ein Formular, dann mit Double-Opt-In Es gibt ja 2 Plugins für Veyton: einmal CleverReach und dann noch das teuere "Newsletter-Plugin für Veyton", wo mir der Funktionsumfang allerdings zu groß ist. Meine Frage wäre zu CleverReach: man muss sich ja da wohl sicherlich anmelden, so wie ich das verstanden habe. Im Gratis-Tarif ist die Verwaltung von 250 Empfängern enthalten. Bedeutet dies, dass sich nur 250 Leute anmelden können? Ich will eigentlich gar nichts verwalten lassen. Newletter verschicke ich mit Supermailer, meinem Lieblingsprogamm dazu. Und brauche eigentlich nur die 2 oben aufgeführten Dinge. beste Grüße Fusco
  9. Ich habe gerade eine tolle Lösung für mich gefunden, wie ich im Warenkorb die Slave-Artikel zu ihren Master-Artikel verlinke. Vielleicht keine effektive Lösung, dafür eine sehr einfache und sie funktioniert mit Suma-URLs. Also standardmäßg ist es ja so, dass wenn ein Slave-Artikel in den Warenkorb gelegt wird, man den Artikel im Warenkorb anklicken kann und er dann zu sich selbst führt. Viele Shopbetreiber wünschen sich aber lieber, dass statt dessen der Link zum Master-Arikel führt. Im Forum hatte ich dazu folg. Eintrag gefunden: http://www.xt-commerce.com/forum/fragen-zur-software/78196-warenkorb-link-auf-master-artikel.html Die erste Lösung dort geht nicht mit Suma-URLs und die zweite habe ich nicht hinbekommen. Daher für Einsteiger und nicht Profiprogammierer folgende Lösung: 1. In der cart.html muss nur folgender Link geändert werden: href="{$data.products_link}" in href="{$data.products_url}" Damit wird sozusagen das Feld "URL" unter "Arikel Bearbeiten" ausgelesen. 2. Und in diesem Feld "URL" tragen wir dann bei jedem Slave-Artikel den Link zum Master-Artikel ein. Und zwar genau den, der bei "Suma-URL" beim Master-Artikel steht (jeweils für die jeweiligen Sprachen). FERTIG :-) Vielleicht etwas umständlich, aber es funktioniert hervorragend. Schritt 1 kann dann natürlich noch in der subpage_confirmation.html wiederholt werden oder wo es sonst noch wichtig ist. Beachte: Schritt 2 muss nun aber auch bei Artikeln angewandt werden, die keine Master / Slave sind, sondern ganz normale Artikel. --------------- Das einzige, was ich nicht nachvollziehen konnte, ist der Hinweis aus der Dokumentation. Da steht zum Feld URL u.a.: "Der Link erscheint dann in der Detailansicht des Artikels." Ist bei mir aber nicht so. Keine Ahnung unter welchen Umständen er erscheint. beste Grüße Fusco
  10. Hallo, es ist ja recht leicht, beliebigen Content in eine Seite einzubinden, siehe: https://xtcommerce.atlassian.net/wiki/display/MANUAL/Beliebiges+Content+Element+Anzeigen Gibt es nach einem ähnlichen Schema ebenso die Möglichkeit, Content MIT Formular, wie z.B. die contact.php auf diese Art und Weise (oder als box) einzubinden? Mir schwebt vor, aus der contact-Seite ein einfaches Newsletter-Eintragefeld zu basteln und dieses dann in den Footer zu platzieren. ich danke Euch schon einmal für eine Antwort beste Grüße Fusco
  11. Ergänzung: falls es jemand interessiert... ganz konkret kommt das Dropdown mit den Anführungszeichen " nicht zurecht. Und wenn ich die weg lasse, funktioniert es aber trotzdem: Juhuuu :-) Also Problem gelöst.
  12. Also, jetzt habe ich doch noch den Fehler erkannt. Der Hinweis mit den Sonderzeichen ging aber in genau die richtige Richtung. Denn es dürfen auf jeden Fall keine Sonderzeichen beim Produktnamen selbst auftreten. Und da hatte ich etwas mit <span> anders formatiert, was mir sehr wichtig ist. (D.h. auch es gab keinen Zusammenhang mit dem Löschen oder Ändern der Artikelnummer) Ich finde es blöd, dass das nicht geht. Aber so gibt es wohl nur eine Lösung: entweder darauf verzichten oder etwas umständlich jedes mal bei einem Master / Slave Artikel in die Datenbank gehen. Ich danke Euch ganz herzlich für Eure Anteilnahme und Hilfe und freue mich, dass nun klar ist, woran es liegt. beste Grüße Fusco
  13. ja korrekt. Also der Fehler war mit den alten Artikeln passiert. Da wurde etwas zerstört. Seit dem hat sich der Fehler irgendwo eingenistet und tritt halt auch bei den neuen Artikeln auf. Selbst wenn ich jetzt wieder Artikel frisch rein setze, dann muss gar nichts groß gemacht werden, das Dropdown-Menü geht einfach nicht mehr korrekt (also es zeigt die Artikel mit der o.g. "class..." an, so werden auch alle angezeigt mit der fehlerhaften Anzeige, aber es lässt sich nichts auswählen und wie gesagt, wenn etwas rein geschrieben wird, wird es nicht in die Datenbank übertragen).
  14. danke für Dein Angebot. Ich muss dazu sagen, dass ich nach dem Fehler gleich alle Testartikel gelöscht hatte und nochmal die Master / Slaves und die Artikel alle neu erstellt habe. In der Datenbank habe ich bei den Artikeln nichts außergewöhnliches entdeckt. Sieht alles ok aus (sowohl bei der Struktur als auch der Anzeige).
  15. Danke Jeldrik für Deine Antwort. Die Master Artikelnummer war ganz simpel: art001 Ich hatte vergessen, dass sie ja von den Slaves gebraucht wird. Und da ich sie im Shop selbst nicht brauche, hatte ich sie erst mal gelöscht. Und danach wieder eingetippt. Aber wahrscheinlich lag das Problem beim löschen (das hätte ich noch genauer schreiben sollen beim ersten Post). Ich weiß nicht, wie es ist, wenn sie nur geändert wird. Jedenfalls waren und sind da keine Sonderzeichen eingetragen. Im Quellcode habe ich nicht viel erkennen können. Wenn ich im FTP die Daten vergleiche, sehe ich auch keine Änderung. Ich vermute den Fehler irgendwo in einem fehlerhaften Eintrag in der Datenbank, der durch das Löschen der ArNr entstanden ist.
×
×
  • Create New...