Jump to content
xt:Commerce Community Forum

nbg12

Members
  • Content Count

    126
  • Joined

  • Last visited

About nbg12

  • Rank
    Erfahrener Benutzer
  1. ich hab mal probiert einfach die URL von der payment Seite als action zu hinterlegen, aber eigentlich kann das ja gar nicht funktionieren, weil dann der LoginProzess gar nicht mehr durchlaufen wird, sondern einfach direkt alles per POST Formular an unsere payment Page geleitet wird... was könnte man denn da noch versuchen, hab auch leider in der Forensuche nichts gefunden -.- DANKE vorab!
  2. Hallo an alle, wir würden gerne (da wir eh IMMER nur mit DHL shippen) einen Schritt im Checkoutprozess einsparen und würden gerne nach der Registrierung bzw. Login DIREKT zu: https://www.domain.de/de/checkout/payment gelangen statt erst vorher zu https://www.domain.de/de/checkout/shipping wie muss ich den action handler modifizieren, dass das klappen könnte? Danke vorab! Grüße
  3. Hey @ all, wir haben schon die Suche benutzt und auch zu dem Thema ein paar Beiträge gefunden, dennoch immer veraltete versionen oder nicht ganz das passende dabei gewesen... Wir wollten aufgrund vieler Tracking Erkenntnisse nun die Weiterleitung direkt in den Warenkorb verhindern. Nachdem der user auf "in den Warenkorb" geklickt hat, soll er auf der Produktseite bleiben... der action handler unserer product.html steht derzeit auf: {form type=form name=product action='dynamic' link_params=getParams method=post} dynamic, was muss ich verändern? Hab auch schon das Handbuch durchforstet UND hab auch schon in den Shop Backend Einstellungen gesucht, dass mans dort vlt einstellen kann, aber ich finde leider keine option hierfür! Wie immer für jeden Tip dankbar! Greetz!
  4. weiß jemand noch, wie ich einen Link so definieren kann, dass er die Seite nicht reloaded sondern z.b. einfach auf sich selbst zeigt wie ein '#' ich google in der Zeit weiter meine Finger wund ?? Danke vorab!
  5. mann o mann... Tagelang nen Fehler suchen und dann fällt mir erst gerade auf, dass die scripts.js nicht in der js.php eingebunden war... Gibts hier kein Smiley mit nem Hammer auf nen Kopf schlagennnnnnn :D Trotzdem Danke an alle! besonders Alex!
  6. mann o mann... Tagelang nen Fehler suchen und dann fällt mir erst gerade auf, dass die scripts.js nicht in der js.php eingebunden war... Gibts hier kein Smiley mit nem Hammer auf nen Kopf schlagennnnnnn :D Trotzdem Danke an alle! besonders Alex!
  7. also ich hab jetzt mal im grid das Ganze ausprobiert, funktioniert wunderbar... nur im eigenen Template nicht Worauf deutet das? Das ein anderes geladenes JS vielleicht die Zeilen die ich versuche einzupflegen blockieren bzw. überschreiben oder so? ich versuch mal all anderen js auszukommentieren... mal sehen
  8. ja das stimmt zwar schon ABER, es kann ja nicht sein, dass ein ganz einfacher Code wie dieser hier: ..\script.js $(document).ready(function(){ // code: $( "button" ).click(function() { $( "p" ).toggle(); }); [/PHP] beliebige Datei: [PHP]<button>Toggle</button> <p>Hello</p> <p style="display: none">Good Bye</p>[/PHP] bei uns nicht funktionieren?!? Es geht ja nicht nur um die Sache mit dem Warenkorb, sondern auch mal um normale Infoboxen oder einfach inlinePopups mit Jquery... hat jmnd noch ne Idee, woran das liegen könnte? danke schon mal
  9. Hab jetzt auch mal das hier ausprobiert: {literal} script src="https://code.jquery.com/jquery-1.10.2.js"></script> script> $( "button" ).click(function() { $( "p" ).toggle(); }); </script> {/literal} <button>Toggle</button> <p>Hello</p> <p style="display: none">Good Bye</p> also da ist ja jetzt keinerlei Verlinkung drinnen (also kein reload oder sowas wegen dem "#") ...und trotzdem funzt es nicht, wir haben natürlich noch andere jquery .js files die wir laden, die habe ich aber auch mal sicherheitsh. komplett auskommentiert um sicher zu gehen, dass auch nur das .toogle() js geladen wird. Hat auch nix geholfen. Das kann doch nicht sein oder? -.- --> Bei mir steht nur "Hello" und wenn ich auf den BUtton klicke, passiert nix nicht wundern "<" musste ich weglassen, sonst hätte ich den Post nicht absenden können, wurde geblockt!
  10. danke für d Antwort... Haben nur ne 4.1er normal also keine prof+ -.-
  11. nein, das hab ich schon gecheckt... ein Alert klappt wunderbar überall habe ich noch nicht ausprobiert, werde ich aber... JA!!! Das ist glaub ich eher das Problem... genau das! weil er läd dann immer neu und dann geht gar nichts mehr... --> Aber hier in unserer Product.html bei den ganzen image thumbnails klappt das mit dem Verweis auf sich selbst auch wunderbar habe ich gesehen, ist auch so ne Art inlinePopup, was dann nen neuen DIV Layer läd glaube ich Hier der Code: <div class="span4"> <div class="product-images"> <div class="box"> <div class="primary" id="zoom"> <img src="{img img=$products_image type=m_info path_only=true}" data-zoom-image="{img img=$products_image type=m_popup path_only=true}" alt="{$products_name|escape:"html"}" /> </div> {if $more_images !=''} <div class="thumbs" id="gallery"> <ul class="thumbs-list"> <li> [B][COLOR="Red"] <a class="active" href="#" data-image="{img img=$products_image type=m_info path_only=true}" title="Chaser Overalls" data-zoom-image="{img img=$products_image type=m_popup path_only=true}"> <img src="{img img=$products_image type=m_thumb path_only=true}" alt="{$products_name|escape:"html"}" /> </a>[/COLOR][/B] </li> {foreach name=aussen item=img_data from=$more_images} <li> <a href="#" data-image="{img img=$img_data.file type=m_info path_only=true}" title="{$products_name|escape:"html"}" data-zoom-image="{img img=$img_data.file type=m_popup path_only=true}"> <img src="{img img=$img_data.file type=m_thumb path_only=true}" alt="{$products_name|escape:"html"}" /> </a> </li> {/foreach} </ul> </div> {/if} <div class="social"> {hook key=products_images_tpl} </div> </div> </div> </div> Das ist ja auch ein Link auf sich selbst und da klappts wunderbar... Hab ich aber auch erst eben entdeckt... jetzt werde ich mir mal den Link schnappen und versuchen an anderer Stelle (also in unserem Warenkorb auch einen Link zu platzieren, der ein Popup auslößt, nur ganz so einfach ist das irgendwie nicht) will ja einfach ein kleines Popup über den ganzen Bildschirm (ähnlich wie light- oder thickbox, nur ohne Bild sondern mit ner meldung "Ihr Artikel wurde erfolgreich in den Warenkorb gelegt" ---> "weiter shoppen" ---> "zur Kasse" Wird ja wohl nicht so schwer sein, habe ja schon einges an super Samples gesehen, aber wie gesagt funktioniert nicht in den xtc Files, weil es immer wieder neu reloaded und dann auf die Startseite verweist.... obowhl ein "#" als Ziel im Link definiert ist... Ich tüftel mal weiter in der Zeit... Für jeden Tip bin ich,wie immer, dankbar! Greetz
  12. Hallo an alle ...wir haben die 4.1.10 Version und wollten mal nachfragen, wieso es eine modal popup box im code gibt, diese aber nicht funktioniert? Also sprich wenn etwas in den Warenkorb gelegt worden ist ne infobox aufgeht... Es gibt sogar ne Sprachtexte Vorlage, diese Funktion ist sehr wichtig für uns und wir haben auch eine bezahlte Version, wieso können wir diese Funktion nicht nutzen? hier die Zeilen aus der product.html Danke für jeglichen Hinweis.... <!-- Added to cart modal window --> <div id="added" class="modal fade" tabindex="-1"> <div class="modal-header"> <button type="button" class="close" data-dismiss="modal" aria-hidden="true">X</button> <div class="hgroup title"> <h3>{txt key=TEXT_PRODUCT_IN_CART}</h3> <h5>{$products_name}</h5> </div> </div> <div class="modal-footer"> <div class="pull-right"> <a href="{link page='cart'}" title="zum Warenkorb →" class="btn btn-primary btn-small"> {txt key=TEXT_CART} <i class="icon-chevron-right"></i> </a> </div> </div> </div> <!-- End id="added" -->
  13. danke für deine Antwort, aber ich hab ja einen Alert in einem test.js auch schon versucht und das hat wunderbar geklappt, deshalb dachte ich eigentlich, dass es nicht am java script code liegt oder was denkst du? Wirklich seltsam, dass ich als Linkziel ein Rautezeichen als Eigenverweis nutze und er mich einfach nach dem Klick auf die Startseite leitet, weil dann wird ja gar nicht das popup geladen oder? Kann es sein, dass da XTC irgendwie in die Verlinkungsstruktur eingreift? und das Ganze deshalb nicht klappt? Danke schon mal
  14. Hallo an alle, ich würde gerne ein kleines popup Fenster implementieren, aber sobald ich meinen Code, der lokal super funktioniert auf unser XTC Template anwende, funktioniert es nicht, das hier waren meine Code Schnipsel: HTML: <a href="#" class="popup_oeffnen">Popup öffnen</a> <div id="popup"> <div class="schliessen"></div> <div id="popup_inhalt"> <p><h2>Mega Cocktailparty am 31.12.13!</h2></p> <p style="text-align:justify;"> <div style="text-align:center;"><img src="bild.jpg" alt="Cocktailparty" border="0"/><br/> Quelle: Flickr.com <a href="http://www.flickr.com/photos/polif/" target="_new">PabloMFernandez</a></div><br/> <span>Am 31.12.13 steigt die größte Party des Jahres! Es werden die beliebtesten Cocktails aus aller Welt von unseren Profi-Barkeepern serviert. Sei auch du dabei und melde dich über unser Anmeldungsformular <a href="#">hier</a> zu unserer Party an.</span></p> </div> </div> <div id="hintergrund"></div> CSS: #hintergrund { display:none; z-index:1; position: fixed; height:100%; width:100%; top:0px; left:0px; background:#000000; } #popup { display: none; z-index: 2; position: fixed; width:450px; top: 20%; left: 50%; margin-left: -250px; background: none repeat scroll 0 0 #FFFFFF; border: 8px solid #ccc; border-radius: 5px 5px 5px 5px; font-family: Verdana, Geneva, sans-serif; font-size: 14px; color: #000; } div.schliessen { position: relative; height: 30px; width: 30px; left: 27px; bottom: 24px; background: url("close.png") no-repeat scroll 0 0 transparent; float: right; cursor: pointer; } #popup_inhalt { margin: 8px 14px; } popup.js jQuery(function($) { var popup_zustand = false; $(".popup_oeffnen").click(function() { if(popup_zustand == false) { $("#popup").fadeIn("normal"); $("#hintergrund").css("opacity", "0.7"); $("#hintergrund").fadeIn("normal"); popup_zustand = true; } return false; }); $(".schliessen").click(function() { if(popup_zustand == true) { $("#popup").fadeOut("normal"); $("#hintergrund").fadeOut("normal"); popup_zustand = false; } }); }); und die jquery-1.9.1.min.js (wäre zu lang hier zu posten) so das ganze habe ich sauber per js.php eingebunden, wurde auch gefunden, denn die Links sind sauber im Quelltext zu sehen und ein test alert funzt auch... die CSS wird auch übernommen, ABER ich vermute, dass es etwas mit dem Link an sich zu tun haben muss, dass mein popup nicht erscheint, denn irgendwie wenn ich als Link Adresse einfach nur ein # benutze, geht xtc danach auf die Startseite, also nehme ich an, dass ich da etwas mit der Verlinkung falsch mache... Was muss ich tun, um das mein Code (wie lokal) auch in XTC funktioniert? Muss ich die URL in einer bestimmten Form angeben... aber ich möchte ja gar nicht, dass ne neue Seite geöffnet wird sondern lediglich mein popup auf der gleichen Seite aufgeht... Wie stell ich da am besten an? Danke vorab! Grüße
  15. also js läuft scheinbar, hab mal n normalen alert ausgeben lassen! Geht per js.php Einbindung, dann muss s wohl daran liegen, dass ich den DIV Layer irgenwie falsch platzieren oder was könnte noch der Grund sein, dass mein inline Popup immer sofort im geklickten Zustand angezeigt wird und somit nicht richtig als popup funktionieren kann? Danke vorab!
×
×
  • Create New...