Jump to content
xt:Commerce Community Forum

ARS

Members
  • Content Count

    16
  • Joined

  • Last visited

About ARS

  • Rank
    Neuer Benutzer

Converted

  • Wohnort
    Bern (CH)
  1. Hallo zusammen Wir sind gerade daran unseren Shop auf Version 4.2 zu aktualisieren und haben bisher leider nur Probleme. Angefangen schon damit, dass er nach dem Update das Template zerschiesst, da er ein total falsches CSS ansteuert und zwar das von einem Plugin - wissen die Götter warum.... Nun bin ich auf der Suche, wo/in welcher Datei das CSS (stylesheet.css) angesteuert wird ? Hat mir einer einen Hinweis ? Werde einfach nicht fündig.... Danke & Gruss Beat
  2. Hallo zusammen Ist es möglich, zwei verschiedene Startseiten (index.html) im gleichen Shop/Template zu verwenden ? Ich hatte es probiert mit einer index1.html - aber kein Erfolg - es wird immer die index.html angezeigt. Gibt es keine Möglichkeit dies zu machen ? Ich möchte dies machen, weil im selben Shop drin beim Aufruf der zweiten Startseite nur gewisse Dinge angezeigt werden sollen. Das Grunddesign bleibt gleich - ich möchte da jedoch gewisse Boxen ausblenden, andere einblenden und auch über eine eigene categorie_listing & product_listing die Artikel ein wenig anderst darstellen... Shopsoftware ist im Moment noch Merchant 4.0.16. Gruss Beat
  3. Hallo Alex Hat schon was - war auch mehr so als Grundinfo gedacht... Denke eine gute Firma nimmt einfach zuerst mal Kontakt auf und holt sich nähere Infos oder schreibt hier mal darunter, so dass wir Kontakt aufnehmen können. Danke für den Link - ist schon länger ausgefüllt und abgesendet... Gruss
  4. Hallo Wir suchen eine Firma, welche unseren 4.0.16 Merchant Shop auf die aktuellste Version der Software bringt. Die Shops findet man unter folgenden Adressen: shop.koiparadies.ch shop.gartenparadies.ch (noch keine Artikel erfasst) www.aquariumredsea.ch Kontaktaufnahme unter info (at) aquarium-red-sea.ch oder unter 0041 31 992 80 00. Gerne erwarten wir Ihren Kostenvoranschlag. freundliche Grüsse
  5. Hiho So, habe noch den Tipp erhalten - dass ich das Template nicht nur in den Shopeinstellungen, sondern auch noch den jeweiligen Kundengruppen richtig hinterlegen soll. Gemacht - aber leider immer noch nicht mit dem gewollten Effekt ! Hat mir sonst jemand noch einen Tipp welcher vielleicht ans Ziel führt ?? Gruss Beat
  6. Hallo zusammen Ja, ich habe die SuFu benutzt - auch einiges gefunden - aber ich blick nicht ganz durch...ich habe auch schon ein Ticket bei xtc gelöst....aber naja, da gibts nur Gegenfragen oder sehr kurze nicht hilfreiche Antworten. Nun hoffe ich, dass mir hier jemand weiterhelfen kann - denn sonst komm ich nicht weiter... Wir haben die Shopsoftware Veyton 4.0.16 (Multishop) - alle drei Shops sind online, aber bisher erst einer öffentlich für die Kunden. Nun bin ich am zweiten dran und habe festgestellt, dass es ein paar komische Verlinkungen/Templatedarstellungen gibt. Die drei URLs: shop.koiparadies.ch (ist schon für Kunden zugänglich) shop.gartenparadies.ch (noch leer) www.aquariumredsea.ch (möchte ich nun eigentlich mit Artikeln befüllen) Gehe ich nun auf den Gartenparadies oder Aquarium Shop und klicke da auf Ihr Konto oder Anmelden - so stimmt zwar die URL, aber das Design kommt vom Koiparadies-Shop. Was läuft hier falsch ? Gehe ich auf den Gartenparadies oder Aquarium Shop und klicke da auf Kasse - so ändert die URL und das Design....es kommt jeweils das Koiparadies. Wo liegt hierbei der Fehler ? Dann bekomme ich auch noch eine Fehlermeldung. Und zwar wenn ich beim Gartenparadies oder Aquarium Shop unter Informationen auf Kontakt klicke, komme ich auf eine Fehlerseite mit dem Koiparadies-Layout. Der Link jedoch stimmt - er zeigt auf die richtige ID vom Content welcher auch angelegt und aktiv ist. Was hat er da für ein Problem ? Auch ist es so, wenn ich im Browser (Firefox) z.B. www.aquariumredsea.ch eingebe, hängt er mit automatisch ein https:// davor dran und ich lande auf dem Koiparadies-Shop, jedoch mit der richtigen URL-Anzeige im Browser (dasselbe auch mit shop.gartenparadies.ch). Gibt es dafür eine Lösung, dass auch die URL aufgerufen und angezeigt wird, welche man eingibt ? Wenn ich mich dazu richtig durchgelesen haben - muss ich wahrscheinlich etwas an der htaccess-Datei ändern...sehe ich das richtig ? Werden dadurch all meine Probleme beseitigt ? Wenn ja, kann mir jemand sagen was genau ? Besten Dank schon im Vorraus für eure Hilfe ! Gruss Beat, welcher gerade sehr gefrustet ist über diese "sogenannte Multishopsoftware"....
  7. Hi Vielen dank für den Code ! Hier der Code meiner Variante - falls mal jemand die Angebote (special_products) auch so einbauen möchte. <h2 class="boxheader">{txt key=TEXT_BOX_TITLE_CATEGORIES}</h2> <ul id="categorymenu"> <li class="level1"><a href="{link page='xt_special_products'}" title="{txt key=TEXT_HEADING_SPECIAL_PRODUCTS}">{txt key=TEXT_HEADING_SPECIAL_PRODUCTS}</a></li> {foreach name=aussen item=module_data from=$_categories} <li class="level{$module_data.level}{if $module_data.active} active{/if}"><a href="{$module_data.categories_link}" title="{$module_data.categories_heading_title}">{$module_data.categories_name}</a></li> {/foreach} </ul> [/PHP] gruss Beat
  8. Hi Oliver Danke für die Antwort ! Wenn ich dich richtig verstehe also einfach "Hardcodiert" da rein ? Auf die Idee bin ich auch schon gekommen....aber wie steuere ich das dann bei verschiedenen Sprachen ? Der Shop läuft auf Deutsch & Französisch... Müsste ich da den Link-Text dann nicht irgendwie speziell verknüpfen ? Hast Du mir dazu vielleicht noch ein Tip ? Danke & Gruss Beat
  9. Hallo zusammen Gibt es eine Möglichkeit, in die Navigation einen Link einzubauen ? Und zwar möchte ich dass als erster Navipunkt - vor allen Kategorien - ein Link "Unsere Spezial-Angebote" erscheint und da drauf dann per Link zu der xt_special_products-Seite verweisen. Als einzelne Box ist es ja schon da - aber welcher Kunde klickt da gewollt auf den Titel und landet so auf der Seite wo all diese Produkte angezeigt werden ? Dies passiert höchstens per Zufall... Sicherlich könnte ich die Box abändern und da einen fixen Link reinmachen - aber da mir die Spalten Links & Rechts ein bisschen zu voll werden wäre es toll dies in die Hauptnavigation einbauen zu können.... Sollte doch irgendwie machbar sein - oder nicht ? Gruss Beat
  10. Hiho Ja, genau den benutze ich - ok, den Fehler in dem Fall auch gefunden - primafein. Vielen Dank für deine Hilfe ! Denke nun sollte dem nächsten Export & Import nichts mehr im Wege stehen... gruss Beat
  11. Hi giller Besten Dank für deine ausführliche Beschreibung ! Habs zwar erst auf meinem Computer getestet ob ich die Schritte kapiere - aber bisher schauts nicht schlecht aus. Muss dann aber auch mal einen Import so machen.....aber ich getrau mich noch nicht... Denn, wenn ich von den vorhandenen Artikeln ein Export mache um dann mit dem wieder arbeiten zu können - z.B. für Preisänderung oder was auch immer - und die öffne....da wird mir fast schlecht.... Ist es normal, dass da tonnenweise HTML-Code drin steht ?? Sollte doch nicht sein oder ? Langsam fang ich an, an mir zu zweifeln....hab mich glaube ich doch ein wenig übernommen mit dem Shop... Danke jetzt schon für jede Hilfe ! Gruss Beat
  12. Hallo zusammen Ich probier nun seit Stunden Artikel in unseren Shop zu importieren. Funktioniert auch alles prima - ausser es kommt ein "ä,ü,ö" vor - dann wird der Text abgeschnitten. Hab schon fleissig die SUFU missbraucht - auch schon viel darüber gelesen wegen Excel / Notepad++....aber entweder haben alle Programme etwas gegen mich oder ich steh sonst irgendwie auf der Leitung.... Ich habe meine Excel-CSV-Datei mit meinen gewünschten Feldangaben, diese nehme ich und schreibe da alle meine Artikel rein. Danach speichere ich sie wieder als CSV ab und schliesse sie. Danach öffne ich diese Datei mit Notepad++, stelle die Kodierung auf UTF-8 um und speichere diese per Diskettenicon oben so ab. Lade diese Datei auf den Server, gehe auf Import und starte den Import. Dieser klappt prima - aber dennoch werden Artikelnamen usw. welche ein ä,ü oder ö enthalten abgeschnitten. Jedesmal wenn ich die Datei mit Notepad++ wieder öffne, stimmt das mit der Kodierung noch - egal ob schon raufgeladen, wieder runtergeladen....spielt keine Rolle. z.B. das Wort Frühjahr wir darin so geschrieben FrxFChjahr (xFC ist schwarz hinterlegt und in weissen Buchstaben geschrieben) - ich nehme mal an das hat so seine Richtigkeit.... ? Ach ja, Shopversion XTCommerce Veyton 4.0.16 Multishop MySQL-Zeichensatz: UTF-8 Unicode (utf8) Kollation: utf8_general_ci Was mache ich verkehrt ?? Bin um jeden Tip dankbar ! Danke & Gruss Beat
  13. Hallo oldbear Danke für den lösenden Hinweis ! Vor lauter "welche Variable ist für was" suchen hab ich das $data komplett übersehen... Den Haken sprachabhängig gibts ja nicht mehr....eher eine Sprachauswahl... Wenn ich das nun richtig verstehe, mach ich ein Export für DE und einen für FR ? Dann noch zwei andere Fragen - vielleicht hast Du da auch noch den richtigen Hinweis für mich bereit... 1. Ich habe paar Artikel, denen ich eine fixe Versandarten zuteile. Dies kann ich ja entweder bei "Artikel bearbeiten" - da fixe Versandkosten zuteilen. Oder in der Artikübersicht per "Versandkostenmodule zuweisen". Wir haben dazu noch das Plugin Artikel-Versandkosten gekauft. Nun denn, wie lese ich das nun genau aus in der Export-Datei ? Wenn ich da im Body $data.products_shipping_costs eingeben, habe ich danach in der Tabelle nur "Array" stehen. Was mach ich hier falsch ? Ein Tip für mich wie ich das zugewiesene Versandkostenmodul auslesen kann und somit dann auch beim Import mitgeben kann ? 2. Thema Kategorien. Die lese ich nun schön aus mit $data.category - aber wenn ichs recht gelesen haben, brauchts für den Import dann $data.categories. Beim Export mit $data.category gibt er mir ja den Namen der jeweiligen Kategorie an... Beim Import sollte man ja aber die ID mitgeben können, von der Kategorie wo der Artikel rein soll. Gibt es keine Möglichkeit die beim Export auch schon so auszulesen ? Denn ich möchte ja nun eine sauber funktionierende Datei per Export erstellen, diese dann nehmen mit meinen Artikeln füllen und die Datei per Import einspielen... Steh ich da auch wieder auf dem Schlauch oder suche ich zu weit ? Bin froh über jede Hilfe ! Danke & Gruss Beat
  14. Hallo zusammen Ich kämpfe nun schon seit Tagen mit dem Export-Manager... (Inhalte->Exporte->Export-Manager) Und zwar habe ich einen Neuen erstellt wie folgt: Export ID: kommt automatisch Shop ID: 1 Titel: Export Koiparadies Export Typ: Artikel Header: "EAN";"Artikelnummer";"Preis";"Steuersatz";"Hersteller ID";"Artikelgewicht in kg";"Verpackungseinheit";"VPE Status";"VPE Faktor";"Lieferzeit";"Versandkosten";"Artikelname DE";"Artikelbeschreibung DE";"Artikelkurzbeschreibung DE";"Meta Titel DE";"Meta Beschreibung DE";"Meta Keywords DE";"Artikelname FR";"Artikelbeschreibung FR";"Artikelkurzbeschreibung FR";"Meta Titel FR";"Meta Beschreibung FR";"Meta Keywords FR";"Shop";"Kategorie";"Produktsortierung";"Produktestatus";"Kundengruppenrabatt";"Produkte ID" Body: {products_ean}~{products_model}~{products_price}~{products_tax_class_id}~{manufacturers_id}~{products_weight}~{products_vpe}~{products_vpe_status}~{products_vpe_value}~{products_shippingtime}~{products_shipping_costs}~{products_name_de}~{products_description_de}~{products_short_description_de}~{meta_title_de}~{meta_description_de}~{meta_keywords_de}~{products_name_fr}~{products_description_fr}~{products_short_description_fr}~{meta_title_fr}~{meta_description_fr}~{meta_keywords_fr}~{products_owner}~{categories}~{products_sort}~{products_status}~{group_discount_allowed}~{products_id}[/code] Footer: leer Dateiname: export_koiparadies Dateityp: .csv Zeichensatz: UTF-8 Auf Server speichern: Haken (ja) Datensätze pro Durchgang: 100 Zeilenumbruch im Body deaktivieren: kein Hacken (Nein) Sprache: nicht angegeben Währung: CHF Kundengruppe: nicht angegeben Deaktivierte Produkte exportieren: Haken (ja) Slaves eportieren: Haken (ja) Sodele, das wären alle Angaben wo bei mir da auch was drin steht. Speichere ich den nun so und starte ihn danach in der Export-Manager Übersicht.........tja, dann .... was dann.... Er macht irgendwas und es erscheint nur eine weisse Seite. Manchmal finde ich eine Datei auf dem Server, manchmal aber auch nicht. Wenn ich eine habe und die öffne, dann ist da nur der Header drin und mehr nicht - keine Artikel. Im Shop sind bisher nur die drei Artikel von der Installation her - mehr nicht. Denn ich möchte ja eine saubere Exportdatei haben, um diese dann zu verfollständigen und ca. 5000 Artikel zu importieren..... Ach ja, Shopversion ist XTCommerce Veyton 4.0.16 Multishop - es sind auch drei Shops enthalten......aber wir kämpfen immer noch um den ersten fertig an den Start zu kriegen... Ich hoffe es kann mir jemand helfen und einen brauchbaren Tip geben was ich denn falsch mache.....würde gerne mal was anderes tun als gegen das AdminPanel zu kämpfen... danke & gruss Beat
  15. Hallo Ich hoffe es kann mir jemand weiterhelfen - denn ich blicke nicht mehr wirklich durch....und zwar geht es um die Einrichtung der Multishops, dass diese auch erreichbar sind. Ich habe die Merchant Version 4.0.16. 3 URL's sind vorhanden, laufen und liegen alle auch auf dem selben Server. Auf URL 1 ist in dem Verzeichnis www.1.ch/shop die Software installiert und der erste Shop läuft auch unter dieser Adresse. Soweit so gut.... Nun möchte ich, dass unter URL 2 www.2.ch/shop der zweite Shop erreichbar ist und unter URL 3 www.3.ch (hier direkt im Hauptverzeichnis) der dritte Shop. Habe schon sehr viel darüber mit der Suchfunktion gefunden - aber ich kapiers glaube ich einfach nicht... Viel gelesen über .htaccess Dateien ändern, Weiterleitungen usw.... Kann mir dies vielleicht jemand so erklären, dass ich es auch kapiere und so einrichten kann ? Was muss ich im Adminbereich einstellen und was muss ich sonst noch alles ändern/einrichten ? Danke & Gruss Beat
×
×
  • Create New...