Jump to content
xt:Commerce Community Forum

oputz

Members
  • Content Count

    40
  • Joined

  • Last visited

Everything posted by oputz

  1. Finde es prima, dass du hier weiterschreibst trotz fehlender Unterstützung aus dem Forum. *daumen hoch*
  2. Hallo, wie macht ihr das, wenn Kunden Packstationen angeben wollen/dürfen? Der Klarna Checkout hat bei Lieferadresse nur ein freies Feld für Firma. Ändern kann man das wohl nicht. Selbst wenn im Adressbuch ein Firmenname angegeben ist, wird dieser nicht übernommen. Klickt man den Haken bei "Abweichende Lieferadresse" weg und setzt ihn später wieder rein, werden auch Straße, Nummer und Ort nicht übernommen. Eine andere Lieferadresse auswählen geht schon mal gar nicht. Ist bei mir was vermurkst oder soll das so? Ich schweife ab ... Also wie macht ihr das mit Packstationen?. Gruß oputz
  3. Hallo, da Klarna verschiedene Zahlungsweisen anbietet wäre es ja interessant welche der Kunde nun gewählt hat. Nach Bestellungen ist aber immer nur zu sehen: - in der Übersicht (oder Emails): Zahlungsweise Klarna - In der Bestellung: Zahlungsart Code: klarna_kco - erst hier in Details und öffnen von initial_payment_method sieht man: type INVOICE description Pay later Kann man das irgendwo ändern, so dass in der Bestellung und in Emails gleich etwas aussagekrätigeres steht? Gruß oputz
  4. Ich hoffe es geht inzwischen? Verwende die beiden Plugins ebenfalls und habe kein Problem.
  5. Hab nun da statt NULL eingegeben 0000-00-00 00:00:00 damit es durchläuft. Die Zeilen löschen ist dann wohl das selbe. Das andere war: Failed to execute Executing query: ALTER TABLE `xt_pdf_manager_content` CHANGE COLUMN `template_body` `template_body` TEXT NOT NULL DEFAULT '' ; Die Tabelle hat keine Datensätze. Hier hilft dann wohl wirklich nur die Zeile aus dem update.sql zu entfernen, oder?
  6. Failed to execute Executing query: UPDATE `xt_feed` SET feed_date_from_orders = NULL WHERE `feed_date_from_orders` < '1000-01-01 00:00:00'; Die Tabelle gibt es, die Spalte ist gefüllt mit: 0000-00-00 00:00:00 Typ ist datetime
  7. Das kann gut sein, dass die 4.2 nicht sauber war. Wurde ab 4.0.14 hochgeschleppt. Dann war ich zu schnell mit dem Löschen, hatte angenommen die Plugins müssen da sein. Werde es wiederholen, lässt sich sicher reproduzieren hier.
  8. Hallo, scheinbar hatten alle eure Tester ein Plugin xt_feed. Ich nicht und deshalb bricht der Wizard beim Update der Datenbank hier ab. Im 1. Schritt Update DB von 4.2 auf 5.0.08. Außer "weiter" kann man nichts machen. Dann versucht er es nochmal und bleibt wieder stecken. "Failed to execute Executing query: UPDATE `xt_feed` ..." Ähnliches im letzten Schritt 6.0 auf 6.1.x, Plugin gibt’s hier nicht: "Failed to execute Executing query: ALTER TABLE `xt_pdf_manager_content` ..." Lösung für mich war die entsprechenden Zeilen aus der jeweiligen update.sql zu löschen. Auskommentieren reichte nicht.
  9. Dann scheint wohl noch etwas aufgetreten zu sein. Aber vielleicht nur eine Kleinigkeit und nächste Woche wird veröffentlicht?
  10. Hi, beide Einträge hatten type 0, obwohl unterschiedlichen Status. Ich habe nun den Gast auf 1 gesetzt und schon kann man sich einloggen. Besten Dank für den Tipp! :-) *thumbup* Gruß oputz
  11. Hallo, xtc4.2, PHP5.6 ein Kunde kann sich seit heute nicht mehr einloggen. Falscher Benutzername oder Passwort. Aber auch nach Ändern des Passwortes per "Passwort vergessen" oder im Backend ist kein Login möglich. Logfiles Fehlgeschlagene Logins: 1, trotz zig Versuchen. System-Log: Quelle/Info: customers_login ; ID: 0 ; Klasse: intrusion Der Kunde ist also ein Intruder, Emailadresse stimmt, IP beginnt mit 77. Der Kunde hatte bis dahin einmal als Gast und einmal als Kunde bestellt, mit gleicher Emailadresse. Scheinbar ist seine Emailadresse nun gesperrt für den Login. Der Kunde meldete sich, weil er nicht reinkam. Wir als Tester kamen auch nicht rein mit seinen Daten. Wie kann man das lösen? Gruß oputz
  12. Hallo, ein guter Platz für die Mikrodaten könnte die Datei product.html sein in templates/dein_Template/xtCore/pages/product/ So hab ich es jedenfalls versucht. Preis und Verfügbarkeit wird mir trotzdem angemeckert. Liegt vielleicht daran, dass ich die ganzen Microdaten als versteckten extra Block unter den ganzen HTML Kram gepackt habe.
  13. Hallo, xtc4.2, PHP5.6 woran könnte es liegen, dass ein Neukunde für eine Bestellung zwei Bestellbestätigungen erhielt. 1x mit Zahlungsart PayPal und 1x mit Rechnung. Im Shop ist nur eine Bestellung zu sehen, Zahlungsart Rechnung, aber IPN Code wurde bestätigt und Status ist somit "Zahlung erhalten", Geld ist per PayPal eingegangen. Die Bestellung wurde gestern kurz vor 0 Uhr getätigt. Hoffe jemand hat eine Idee oder die richtigen Fragen. :-) Gruß oputz
  14. Hi, kann den Fehler bei Hochkomma in der Suche bestätigen (ab 2 Zeichen + Hochkomma).
  15. Danke für den Schubser. Habe nun in der default.html hinzugefügt: {page name=xt_special_products type=user order_by='rand()'} Da war vorher nur der Aufruf für Startseitenprodukte. So wird es schon mal genauso angezeigt wie die anderen Startseiten-Produkte auch. :-)
  16. Das war so eingestellt. Ich dachte er zeigt es im Content wie bei Startpage Produkte. Geht aber scheinbar nur als Box?
  17. Hallo, es geht mir darum Artikel vorzubereiten. Sonderpreis von dann bis dann. Und wenn der Sonderpreis aktiv ist, dann soll das Produkt auf der Sartseite (special_page) erscheinen. Geht das? Im Moment muss man die Artikel für die Startseite händisch zuordnen und kann sie nicht zeitgesteuert anzeigen lassen. Hat da jemand Ideen? (xtCommerce 4.2) Gruß oputz
  18. Hallo Gemeinde, nach Update von 4.0.14 zu 4.0.15 zeigt die Startseite ein komisches Verhalten. Vielleicht ist es nur eine Kleinigkeit, bin für jeden Rat dankbar. Der Shop lief mit SEO-URLs einwandfrei. Nach dem Update hat die Startseite bzw. die dort gelisteten Artikel das Problem mit den "in den Warenkorb"-Buttons. Diese führen plötzlich zur index.html und zeigen "not found". Die Links zu den Produkten funktionieren dagegen wie sie sollen. Im Rest der Shops gab es bis jetzt noch keine Probleme mit Verlinkungen oder SEO-URLs. Gleiches Problem mit der index.html ist beim "weiter"-Button in der checkout_success.html. Lösung bis jetzt ist: SEO-URLs für Seiten (pages) zu deaktivieren. Dadurch funktioniert das wieder auf der Startseite. Leider haben die Seiten Anmeldung, Warenkorb, Checkout nun häßliche URLs. Produktseiten oder Impressum u.ä. haben schöne URLs. Aktuelle Einstellungen für Suchmaschinen: Mod Rewrite URL: ja 404 Seite bei falscher Url: nein Sperre SEO Url manuell bearbeiten: nein SEO-URLs für Seiten (pages): nein Sprachabhängige Seo Urls: nein Produkt-URLS mit Kategorien: ja Dateiendung der Seo Urls: html Hat jemand eine Idee wo das Problem liegen könnte? Gruß oputz
  19. Nein, du bist nicht der Einzige. Da es keine Funktion gibt muss man wohl selbst ran. Es läuft wohl auf einen Cronjob hinaus und diesem Posting: http://www.xt-commerce.com/forum/fragen-zur-software/72461-kundengruppen-automatisch-zuweisen.html#post336284 Noch ungetestet.
  20. Hallo, sieht nicht so aus als ob es was Kostenloses geben wird. Im Store gibt es ein Bundle-Addon für 169,-€. Klingt ja fast schon günstig. Leider finde ich nichts dazu im Forum. Kann irgendjemand etwas dazu sagen? Das Addon heißt 'BB Product-Bundle'. http://addons.xt-commerce.com/de/Plugins/Produktkonfiguratoren/BB-Product-Bundle.html
  21. Hallo, ich hatte ebenfalls diese Fehlermeldung "Column 'products_name' cannot be null". In der DB sah ich nicht wirklich etwas Verdächtiges. Aber es scheint so als ob jemand einen Artikel im Warenkorb hatte, der zwischenzeitlich deaktiviert wurde. Nach Löschen der letzten Bestellungen mit der product_id des deaktivierten Artikels, erschien die Seite Bestellungen wieder. Es geht um Veyton 4.0.14. Sollten deaktivierte/gelöschte Produkte nicht automatisch aus den gespeicherten Warenkörben entfernt werden?
  22. Bedeutet meistens, dass du auf der Seite irgendetwas mit http lädst. Also irgendein Bild wird z.B. per http reingeladen und nicht per https. Im Firefox mal auf Extras > Seiteninformationen > Medien gehen. In der Liste müsste mind. 1 Adresse mit http zu finden sein, die das verursacht.
  23. Hallo, das PHP-Gedöns würde mich auch interessieren. Hat das schon jemand erfolgreich umgesetzt? Benutzt wird Veyton 4.0.14. Mir geht es darum den Grundpreis pro 100ml in der Staffeltabelle mit anzuzeigen. Alternativ: nicht in der Tabelle, den Grundpreis des kleinsten Staffelpreises unterhalb der großen Preisangabe. Bei mir also unter "ab X €". Dort würde normalerweise der Grundpreis für ein einzelnes Produkt angezeigt. Gruß oputz
  24. Shop-Einstellungen > Mandanten > "Dein Shop" ... SSL anhaken.
  25. Kann die Meldung in deinem Shop bestätigen. Der Bestellprozess läuft bei dir nicht unter https? Rechtssicher hast du den Shop auch noch nicht genacht (z.B. "Jetzt kaufen" statt "Bestellung abschicken"). Da gibts doch eine Anleitung für.
×
×
  • Create New...