Jump to content
xt:Commerce Community Forum

gatewayer

Members
  • Content Count

    7
  • Joined

  • Last visited

  1. Herzlichen Dank auch! Es gab da fast 1000 Kategorien umzuändern.....dabei war der Update Sql Befehl gold wert :-) Danke,
  2. Hallo! Leider komme ich nicht so weiteres auf die Lösung, obwohl ich mir sicher bin, dass ich kurz davor stehe, daher rufe ich für die letzten 5% zum Ziel um Hilfe: Ich würde gerne Produkte standardmäßig nach deren Namen sortieren lassen und nicht nach Eintragsdatum oder was da auch immer standardmäßig hinterlegt ist. Es gibt dazu im Veyton ein Verzeichnis mit der class.product_sql_query.php (im XtCore), da vermute ich, dass ich der Lösung am nächsten bin, doch egal, was ICH da ändere, es erscheint ein Fehler im Shop-Frontend für Kunden. Desweiteren gibts im Template-ordner auch product_listing_v1.html, nur fabriziere ich dort auch nur humbutz. Ich würde gerne die Kategorien und Produkte immer nach Produktnamen sortiert haben. BITTE UM HILFE!!! Danke ps: Habe das Posting ausversehen im English-Forum gepostet. Sorry
  3. Jetzt hab ichs rausbekommen, und dieser "Fehler" zieht sich durch ALLE Versionen. Bei 20k Artikel und 10k verkauften Artikel dauert das eben eine Zeit weils tausende von DAtensätzen durchsucht. Eigentlich ein Witz für alle, die sich mit dem Coding auskennen. Wer allerdings dasselbe Problem mit der Startseite und den Ladezeiten hat, kann mich gerne kontaktieren. [email protected] Lg
  4. Hallo, ich habe zwar schon mit Xtcommerce Kontakt aufgenommen, aber bereitet vieles viele Probleme, wobei ich alle Probleme nur auf mich nehmen würde, wegen einer Kleinigkeit, die mir sehr am Herzen liegt: Ladezeit der Startseite! >10 Sek! ShopVesioN: XT-Commerce Version - XT-C v1.0 Beta2 Artikel: >22.000 Artikel Ladezeiten INNERHALB der Artikel, sehr zügig, alles kein Problem. Ladezeit der index.php ohne Aufrufen eines Artikels (also beim Betreten der Website) dauert einfach zu lange, mit über 10 Sek. Das sagt mir, dass nicht der PC zu langsam ist (<2 Jahre alt) sondern, dass beim Betreten irgendwas gemacht wird, was extremst viel CPU in Anspruch nimmt (>10 Sek volllast). Beim Klick eines Artikels geht alles schnell, aber wie geschrieben, NUR die Startseite so langsam. Ich weiß, der Shop selbst ist ur alt, aber hatte ich schon selbe Erfahrung mit Version 3.0.2 mit Sp2 oder Sp3 (falls es das gibt). Es muss daher hier irgendwas aufgerufen werden, was solange dauert?! ArtikelANZAHL wird NICHT angezeigt auf der Startseite. Alle Boxen wurden ebenfalls deaktiviert, d.h. die Boxen bereiten auch keinen Stress. Es MUSS daher irgendwas sein, was beim erstmaligen Aufrufen der Website miteinbezogen wird, was später nicht mehr angegriffen wird. Nur leider fehlt mir die Kentniss dahinterzu kommen was genau. Vllt teilt wer die Erfahrung und weiß ne Lösung was zu ändern/löschen wäre/Code zu bearbeiten wäre. --------------- nachtrag: soeben sehe ich bei processes in mysql: select distinct p.products_id, p.products_image, pd.products_name from products p, products_description pd, categories c where p.products_status = '1' and c.categories_status = '1' and p.products_ordered > 0 and p.products_id = pd.products_id and pd.language_id = '2' order by p.products_ordered desc, pd.products_name limit 20 Status: Copying to tmp table Das muss der Grund allen Übels sein!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! Leider finde ich keine einzige Datei die "select distinct p.products_id" aufweist. Hat wer Hilfe für mich? Genau diese eine Abfrage dauert die 12 Sekunden! Danach ist alles gut und es läuft (abgesehen von Startseite weiterhin) ----------- LG, Roman
  5. ja jetzt, wollte gerade die problemlösung posten: liegt NICHT am shop selbst, sondern an der standardkonfiguration von XAMPP unter windows der ZEND ist schuld -> dem dauert das zu lange also unterbricht er alles. deswegen ab in die php.ini datei und dort ZEND deaktiveren (alles mit ";") und den eAccelerator aktivieren. sollte dann so aussehen die php.ini [APC] ; eAccelerator alternative apc.enabled = 1 apc.shm_segments = 1 apc.shm_size = 64 apc.optimization = 1 apc.num_files_hint = 1000 apc.ttl = 0 apc.gc_ttl = 3600 apc.cache_by_default = On apc.slam_defense = 0 apc.file_update_protection = 2 apc.enable_cli = 0 apc.stat=0 [Zend] ;zend_extension_ts = "C:\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll" ;zend_extension_manager.optimizer_ts = "C:\xampp\php\zendOptimizer\lib\Optimizer" ;zend_optimizer.enable_loader = 0 ;zend_optimizer.optimization_level=15 ;zend_optimizer.license_path = problem gelöst
  6. hallo, ab 40 unterkategorien wird die seite als NICHT GEFUNDEN angezeigt (fehler 404 - webserver fehlerseite) lösche ich mehrere unterkategorien raus, gehts wieder offensichtlicher fehler, aber WIESO und kann man dagegen was machen?? vielleicht gibts bereits eine lösung dazu?? live zu sehen unter http://test.briefmarken-westermayr.at kategorie: tester alles andere geht
  7. Hallo! beim Newsletter sehe ich CC, sodass man noch an andere Adressen den Newsletter schicken kann! Allerdings 1. Problem: Die CC Leute bekommen nix, auch wenn ich Newsletter neu schreibe, CC 2 Adressen eintrage und speichere und nachher gleich wieder anschaue (mit bearbeiten) sehe ich keine CC adressen und es wurde auch nicht gespeichert, dass nur admins angeschrieben werden sollen (und nicht alle kunden,...) l?scht er irgendwie bzw. speichert er nie? 2. wird bei cc standard als CC gesendet oder als BCC ? (bcc is f?r newsletter nat?rlich besser und auch sicherer, cc zeigt ja alle adressen an!) bitte um Antwort! ps: falls m?glich welche Dateien sind alle f?r Newsletter eingebunden?
×
×
  • Create New...