Jump to content
xt:Commerce Community Forum

littlestore

Members
  • Content Count

    10
  • Joined

  • Last visited

About littlestore

  • Rank
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hallo Ich führe den xtWizard aus, seit zig minuten hängt das Update bei diesem Schritt: Update 5.0.8 -> 5.1 hängt bei "Neues DB-Feldd / Attribut: customer titel Was kann die Ursache sein? Gruss littlestore
  2. Hallo zusammen Vor einigen Monaten hatte ich beim Suppor nach einem entsprechendem Update bzw. Template für das neue Datenschutzgesetz gefragt. Es wurde mir mitgeteilt, dass xt commerce hier bis zum Stichtag etwas liefert. Was mich etwas wundert, mit der Suchfunktion im Forum (DSGVO) finde ich nicht viele Einträge (oder ich suche falsch...). DIeses Thema sollte nun doch immer heisser werden? Gruss Littlestore
  3. Hallo vielen Dank für die Antwort! Ich habe parallel noch eine Frage an den Hoster geschickt. In der Tat haben diese vor zwei Tagen etwas umgestellt. Hier die Antwort, falls andere auch mal solche Probleme haben: Die PHP Version 5.6 wurde von 5.6.31 auf 5.6.34 aktualisiert. Dabei werden jeweils auch die verfügbaren PHP Extension aktualisiert. So wurde u.a die Extension "libxml" auf die Version 2.9.7 aktualisiert. Ihr Shop verwendet für das Generieren von PDFs die Komponente "dompdf". Diese Komponente wiederum ist abhängig von der PHP Extension "libxml". Damit nun "dompdf" wieder korrekt PDFs generieren kann muss die Option "DOMPDF_ENABLE_HTML5PARSER" aktiviert sein. Dies haben wir nun für Sie gemacht indem wir in der Datei "shop/xtFramework/library/dompdf/dompdf_config.custom.inc.php" folgende Zeile eingefügt haben: define("DOMPDF_ENABLE_HTML5PARSER", true);
  4. Hallo Ich habe plötzlich ein Problem mit dem PDF erzeugen. Es erscheint ebenfalls nur eine weisse Seite. An den Plugin und Storeconfig habe ich nichts verändert. In den Server Logfiles sowie im Shop Log sehe ich keine Fehler. Was empfehlt ihr mir? cleancache oder Plugin neu installieren? Shop Version 5.0.8, PDF Rechnung 5.0.3 Vielen Dank für weiterführende Tipps. Gruss
  5. Hallo zusamen Ich verwende in der aktuellsten 5.0.8 xt commerce das newsletter2go plugin. Bei der Kunden Neuanlage ist die Checkbox für die Newsletter Anmeldung sichtbar. Was mir fehlt, ist die Möglichkeit, den Newsletter vom Kunden im Kundenkonto oder anderswo zu aktivieren bzw. deaktivieren. Wie erreiche ich dies am besten? Gruss und vielen Dank für Tipps littlestore
  6. Hallo zusammen Ich habe die Standard Installation vom 5.0 shop, keinerlei Templateanpassung. Die Kategorie Navigation (Klasse "navbar-nav") auf der Startseite (oben, schwarz) stört mich, ich hätte diese lieber wie bei 4.x auf der linken Seite, da recht unübersichtlich. Gibt es hier ein Beispiel oder eine relativ einfache Anpassung um dies zu bewerkstelligen? Gruss Tom
  7. Ich habe im Shop (ausser Content) nichts individualisiert, auch keinerlei Codeanpassungen (ausgenommen dem Mail und PDF) vorgenommen. Daher sollte ich dies machen können. Gibt es irgendwo eine "Vollversion" wo die Dateien mit den Anpassungen enthalten sind? Zudem finde ich die Anleitung demzufolge irreführend: Um das Dateisystem des Shop auf den neuesten Stand zu bringen, müssen Sie lediglich alle Shopdatein bis auf folgende Dateien uns Verzeichnisse mit den Dateien aus dem neuen Shoparchiv (4.1.10) überschreiben Es ist nirgends erwähnt, den template ordner auszuschliessen. Demzufolge würden streng nach Anleitung vorgegangen alle Dateien eh überschrieben werden. Gruss Tom
  8. Hallo Ich werde mich dem Prozedere unterwerfen Nur zur Sicherheit: in der Anleitung steht, dass alle Ordner (bis auf ein paar Plugins und config.php) der Vollversion 4.1.10 kopiert werden müssen. Überschrieben werden somit auch alle templates Dateien (xtGrid etc.). Meine Frage hierzu: weshalb muss eine so kopierte Datei in den templates nachträglich manuell noch ergänzt werden, wenn bestehende (allenfalls angepasste) eh überschrieben werden? Dies geht mir nicht ganz in den Kopf oder ich habe etwas falsch verstanden. Gruss Tom
  9. Hallo zusammen Ich setze aktuell den Shop 4.1.0 ein, habe aber schon einige Male Probleme mit dem Upgrade gehabt. Da ich ausser dem Rechnungs- und Mailtemplate keine Anpassungen an die templates gemacht habe, die Frage: Gibt es keine Möglichkeit eine Vollversion zu installieren und eine migrierte bestehende Datenbank (xtUpdater auf 4.1.10) anzuhängen, die zwei Templates danach manuell anzupassen? Bei der Version 4.1.10 gibt es einen xtWizard, sind damit die Updates auf 4.2. etc. vollständig automatisch (ohne die leidigen Templateanpassungen)? Gruss Tom
  10. Hallo zusammen Ich fürchte mich ein wenig vor der Updateprozedur und möchte dies keinesfalls im Livesystem direkt ausführen. Mein Vorgehen wäre: Aktuelles shopverzeichnis /shop lokal kopieren. Cacheverzeichnisse leerenDatenbank dumpen und in neue Datenbank installierenKonfiguration lokal auf neue DB anpassen, auf webserver laden /shoptestxtUpdater (z.B. 4100 auf 4110) runterladen und auf /shoptest ausführenNeue Dateien (V4110) heraufladen sowie lokalDie zahlreichen (!) Änderungen am Template/Scripts lokal anpassenGeänderte Dateien aufladen.Wenn alles ok, umbenennen des shop nach shopold, shoptest nach shop.Wäre dies so möglich? Besten Dank für die Rückmeldungen Dave
×
×
  • Create New...