Jump to content
xt:Commerce Community Forum

Donja

Members
  • Content Count

    33
  • Joined

  • Last visited

About Donja

  • Rank
    Advanced Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hallo Ihr, ich habe zwei Produkte im Warenkorb. Eines mit Steuersatz "ermäßigt" (in unserem Fall 5%). Und eines mit Steuersatz "Standard" (in unserem Fall 16%). In meinem Warenkorb werden aber lediglich die 5% aus gepriesen. Bzw. werden nur die 5% auf das eine Produkt bezogen, aus gepriesen. Das 16%-Produkt wird in der Mehrwertsteuer "ignoriert". Dieses Produkt hat aber den Steuersatz "Standard", im Backend zugewiesen. Auch wenn ich den Bestellprozess bis kurz vorm Kauf weiterführe, werden lediglich 5% kalkuliert. Fehlt mir noch irgendwo eine andere Einstellung im System? Viele Grüße Donja -------------------- Ok, habe gemerkt das ich bei meiner Testbestellung als Lieferort die Schweiz hatte. Sobald ich auf Deutschland gewechselt habe, wurden die Steuern abgebildet. Wie bekomme ich das nun auch für die Schweiz hin? Wieso erscheinen da die 5%? Habe für die Schweiz nichts extra angelegt.
  2. Danke. Leider sieht man nicht wie es final ausschaut und auch auf www.shopx.de kann man nichts dazu finden. Versuche gerade mein eigenes "Glück". Mir fehlt noch eine Konvertierung einer Smarty-Variable von String zu Float. Das will irgendwie nicht klappen.
  3. Hallo Ihr, gibt es ein Plugin oder Möglichkeit eine Art Counter im Bestellprozess abzubilden der "sagt": "Nur noch 22€ bis kostenfreiem Versand" Die 22 sind hier fiktiv und berechnen sich jedes mal automatisch sobald sich der Warenkorbpreis ändert. Gibt es so etwas vielleicht schon? Habe dazu nichts richtiges gefunden und vielleicht auch die falschen Keywords genutzt. Viele Grüße Donja
  4. Wie bereits erwähnt funktioniert das auch nicht. Es wird zwar der Master angezeigt (inkl. von-bis-Preis, Aritkelnummer etc.) allerdings ist dennoch eine Option vorausgewählt. Das ist noch mehr verwirrend. Ich bin wirklich mehr als enttäuscht. Das solch ein Stolperstein auf dem Weg liegt. Solche Bugs sollten rot und groß markiert sein. So hätte ich mich wahrscheinlich (inkl. noch anderer Stolpersteine) nie für dieses System entschieden.
  5. Was genau meinst Du mit Q1? Finde ich schon seltsam. Denn an sich scheint es ja die Option zu geben aber funktionieren tut sie nicht. Zumindest nicht bei mir oder ich mache etwas falsch. Wie wurde das denn bisher gelöst? Ich kann leider auch nicht den Master, ohne Vorausgewählte Option anzeigen. Das wäre noch eine vertretbare Option. Aber auch das geht bei mir leider nicht. Zumindest wird der Master dargestellt mit "von - bis Preisen" aber mit vorausgewählten Optionen. Heißt, es ist 1000g und Karton ausgewählt aber der Preis/Artikelnummer/etc. wird nicht abgebildet. Es kann final nicht Sinn der Sache sein, das beliebig eine Option vorausgewählt ist?
  6. Ich habe auch laut dieser Anleitung "750g - Karton" auf Reihenfolge -1 gesetzt. https://xtcommerce.atlassian.net/wiki/spaces/MANUAL/pages/917527/Produktoptionen+-+Master+Slave Den gesamten Cache gelöscht, auch die SEO-URLs generiert. Es bleibt dabei das "1000g - Karton" vorausgewählt ist.
  7. Hallo, ich habe einen Master, dieser hat 5 Slaves: 750g - Karton (1) 1000g - Karton (10) 1000g - Holz (20) 1000g - Metall (30) 1500g - Karton (40) In Klammern steht der Wert den ic unter "Reihenfolge" (in dem Slave) eingetragen habe. Wenn ich nun im Frontend, auf den Master klicke, ist dann folgender Slave vorausgewählt: 1000g - Karton (10) Könnt Ihr mir sagen warum das so ist? Ich möchte das "750g - Karton (1)" vorausgewählt ist. Die ID des 750er ist auch kleiner als die der 1000er. Ich finde nicht die Position wo ich diese "Reihenfolge" bzw. das "Vorausgewählte" einstellen kann. Und kann es sein das in Version 6.2.2. es die Bezeichnung "Master" garnicht mehr gibt? In meinem Master steht "Artikelvarianten" und nicht mehr "Master/Slaves". Vielen Dank für Eure Hilfe Donja
  8. Ich kann es dort versuchen. Es besteht kein SupportAbo. SupportAbo in Höhe von 759,- € wäre für diesen Fall einfach zu teuer. Zur Not setze ich das System nochmal neu auf und teste durch. Wenn es sonst nirgends auftaucht, kann es nur am Theme liegen oder an einem spezifischen Plugin. Die Anbieter schreibe ich auch nochmal an. Ich gebe Bescheid, falls sich was tut.
  9. Hast Du eine andere Lösung? Wie genau kann ich das denn verhindern? Ohne das besagte Textfeld kann ich, wie gesagt, das Backend nicht mehr anschauen, solange PayPal aktiv ist.
  10. Im Shopsystem - Original, steht in /.../xtFramework/classes/class.order.php on line 890 genau das gleiche: $record->fields['order_info_options'][] = array('text'=>constant('TEXT_'.strtoupper($tkey)), 'data'=>$tkey, 'value'=>$tval); Die "Phrase TEXT_PAYPAL_TXN_ID" existiert auch nicht direkt in meinen Dateien. Unter plugins\xt_paypal\callback\class.callback.php Zeile 151: steht bei mir auch das wie bei Dir: $txn_data = array("paypal_txn_id"=> $this->data['txn_id']); Habe nun Sorge das dieses Verhalten auch andere Zahlungsmittel betreffen könnte. Da ich hier nicht genau nachvollziehen kann warum ich das an dieser Stelle so lösen muss.
  11. in der php-error-log steht folgendes: PHP Warning: constant(): Couldn't find constant TEXT_PAYPAL_TXN_ID in /.../xtFramework/classes/class.order.php on line 890 In Zeile 890 steht folgendes: $record->fields['order_info_options'][] = array('text'=>constant('TEXT_'.strtoupper($tkey)), 'data'=>$tkey, 'value'=>$tval); Wenn ich in der Datenbank aus: a:1:{s:13:"paypal_txn_id";s:17:"7XN04652C3399091R";} folgendes mache: a:1:{s:13:"TEXT_PAYPAL_TXN_ID";s:17:"7XN04652C3399091R";} funktioniert die Darstellung im Backend wieder. Das kam mir seltsam vor. Scheint ja so das eine Text-Phrase nicht vorhanden ist. Ich habe jetzt für den Sprachtext: TEXT_PAYPAL_TXN_ID den Wert paypal_txn_id eingetragen, im Backend. Und nun scheint es zu gehen. Verrückt. Wie kann das passieren? Fehlen hier Schreibrechte bei der Installation/Update etc.?
  12. Hallo, ob F12 oder Strg+R oder das aktualisieren/Neu laden im Backend, macht keinen Unterschied. Das System bringt keine Fehlermeldung trotz Debugmodus. Es mag einfach nicht die Schreibweise " a:1:{s:13:"paypal_txn ...". Mich wundert sehr das es bei Euch scheinbar keine Probleme damit gibt. Ich habe mit allen anderen Zahlungsmitteln kein Problem. Bei den anderen Zahlungsmitteln wird in der Datenbank allerdings nur die ID eingetragen nicht serialisierten Daten. Ich bin ratlos.
  13. Hallo Ihr, ich habe mal ältere Bestellungen mit Paypal in der Datenbank angeschaut. Dort erscheint unter "order_data" auch nur die ID und nicht der Code "a:1{s:13: ...." Das heißt, hier muss/sollte nur die ID (Beispiel: 7XN04652C3399091R) drin stehen. Mich wundert es das es bei Euch mit samt dem Code zu funktionieren scheint.
  14. Hallo Ihr, ja, hatte die Slashes natürlich entfernt. Das war nur der Hinweis welcher bei der Plugin-Aktualisierung da stand Danke dennoch. Leider komme ich kein Stück weiter. Mein Backend hat definitiv ein Problem wenn unter "order_data" folgendes Format steht: a:1:{s:13:"paypal_txn_id";s:17:"7XN04652C3399091R";} Steht nur die "ID", ist alles in Ordnung. Ich weiß hier leider nicht weiter. Bei allen anderen Zahlungsweisen steht unter "order_data" auch immer nur die "ID".
  15. Hallo Ihr, wir haben vor ein paar Tagen PayPal aktualisiert. xt:commerce: 5.1.4 PayPal: 2.10.2 Den Update-Hinweis: "Bitte prüfen Sie in Ihren Templates, dass in product.html das Formular zum Artikel-Hinzufügen eine eindeutige Id hat. Alt:{form type=form name=product action='dynamic' link_params=getParams method=post} NEU:{form type=form name=product action='dynamic' link_params=getParams method=post id=\"main_product_form\" }" bin ich nachgegangen. Nun funktionierte die Bestellübersicht im Backend nicht mehr. Sie war schlichtweg leer. In der Datenbank war allerdings noch alles vorhanden. Demnach lag die Vermutung nah das in den Bestellungen, inhaltlich, irgendwas nicht korrekt drin steht. In der Tabelle xt_orders und der dazugrehörigen Spalte "orders_data" stand bei den letzten PayPal-Bestellungen folgendes drin: a:1:{s:13:"paypal_txn_id";s:17:"7XN04652C3399091R";} Das System lässt aber nur folgende Struktur zu: 7XN04652C3399091R Nachdem ich bei den betreffenden Bestellungen nur den zugelassenen Code eingefügt habe, wurden auch wieder alle Bestellungen abgebildet. Das Plugin habe ich erstmal deaktiviert. Wie kommt das zustande und wie kann ich dem Abhilfe schaffen? Danke und viele Grüße
×
×
  • Create New...