Jump to content
xt:Commerce Community Forum

kchris

Members
  • Content Count

    102
  • Joined

  • Last visited

About kchris

  • Rank
    Erfahrener Benutzer
  1. Noch bessere Lösung: default: $MethodName = "Mark$PRZ"; if (method_exists($this, $MethodName)){ $Result = call_user_func (array($this, $MethodName), $KontoNR); } else { // + Workaround damit Bestellvorgang weitergeht wenn Prüfverfahren nicht da #kk|mheinrich // old //$Result = 3; $Result = 0; // = Workaround damit Bestellvorgang weitergeht wenn Prüfverfahren nicht da #kk|mheinrich } } /* end switch */ Testen auf eigene Gefahr
  2. Workaround da die Prüfunktion anscheinend nicht implementiert ist: /includes/classes/banktransfer_validation.php ca Zeile 2126: // + da es C7 nicht gibt wird ohne Prüfung fortgesetzt #kk|mheinrich case "C7" : $Result = 0; break; // = da es C7 nicht gibt wird ohne Prüfung fortgesetzt #kk|mheinrich bye, kchris
  3. Nach einigen Kopfzerbrechen, konnte es nur an dem Pfad liegen. Wenn ihr selbiges Problem habt sobald Ihr auf Server druchsuchen Klickt ändert den Pfad für den Filetype File folgendermaßen ab - dann führt dieser in den Ordner media. Datei: /admin/includes/modules/fckeditor/editor/filemanager/connectors/php/config.php //Original /* $Config['FileTypesPath']['File'] = $Config['UserFilesPath'] ; $Config['FileTypesAbsolutePath']['File']= ($Config['UserFilesAbsolutePath'] == '') ? '' : $Config['UserFilesAbsolutePath'] ; $Config['QuickUploadPath']['File'] = $Config['UserFilesPath'] ; $Config['QuickUploadAbsolutePath']['File']= $Config['UserFilesAbsolutePath'] ; */ // +++ damit bei file type in media Ordner geleitet wird [email protected] $Config['FileTypesPath']['File'] = $Config['UserFilesPath'] . 'media/' ; $Config['FileTypesAbsolutePath']['File']= ($Config['UserFilesAbsolutePath'] == '') ? '' : $Config['UserFilesAbsolutePath'].'media/' ; $Config['QuickUploadPath']['File'] = $Config['UserFilesPath'] . 'media/' ; ; $Config['QuickUploadAbsolutePath']['File']= $Config['UserFilesAbsolutePath'] . 'media/' ; // === Danke an Hetfield für das Package! bye, kchris
  4. Na das Problem hatte ich jetzt bei einem Shop wieder, danke für deine Lösung. Eventuell gibt es das Problem mit dem neuen Google Analytics ja nicht mehr. bye, kchris
  5. Danke...stand grad vor dem Problem hast mich gerade vom Suchen in der DB entlastet. Die Frage die sich mir jedoch stellt, warum es diese Einstellung, wenn diese sichtlich nicht sinnvoll ist - da man sich ja selbst ausperrt, also bitte ändern oder komplett rausnehmen oder gibts ne andere Lösung? Die Lösung ist halt die Login Box...hinzufügen in der index.html im Template dann gehts auch ohne, aber es sieht nicht so schön aus...ich arbeite mal dran.
  6. Problem: die Mailadresse des Kunden kann zwar geändert werden, jedoch erhält man die Editierseite nach dem Speichern erneut und es wird eine Passworteingabe verlangt (Pflichtfeld) obwohl man diese eigentlich nicht ändern möchte. Lösung: Änderungen in /admin/customers.php //org /* if (strlen($password) < ENTRY_PASSWORD_MIN_LENGTH) { $error = true; $entry_password_error = true; } else { $entry_password_error = false; } */ //new damit man die E-Mail-Adresse ändern kann ohne neues Passwort vergeben zu müssen [[email protected]] if ($password != "" AND strlen($password) < ENTRY_PASSWORD_MIN_LENGTH) { $error = true; $entry_password_error = true; } else { $entry_password_error = false; }[/php]
  7. Wird bestimmt im Blog mitgeteilt.
  8. Wo bekomme ich denn das IPN-Modul her?
  9. Also bei mir geht führt einer eben die Bestellung aus und landet im shopping_cart.php obwohl ja nicht überwiesen wurde sondern nur der Zürckbutton im Browser getätigt wird.
  10. Ich habe vermehrt Probleme mit dem Standard Paypal Modul in der 304Sp2.1 Version, wo gibts den ein neuere Version bzw. das Paypal IPN Modul was in der Anwenderhandbuch steht? Oder wie löst ihr das Problem das bei Klicken auf den Zurückpfeil im Browser (wenn man auf Paypal Seite ist) die Bestellung einfach mal durchführt wird und man wieder im Warenkorb landet. Das kann der Sinn ja wohl nicht sein? MFG kchris
  11. Du könntest ein Problem bekommen, wenn es in deinem Shop Gast Accounts gibt, die gelöscht werden können (Option Löschen von Gast-Accounts). Wird diese Löschung auch in der DB vorgenommen (hab ich nicht überprüft), dann können falsche Werte bei deiner Abfrage nach der höchste Kundennummer entstehen. Nutze doch einfach die Technik wie sie für die nächsten SQL-Befehle verwendet werden (adressbook). in der create_account.php und create_guest_account.php nach $_SESSION['customer_id'] = xtc_db_insert_id(); einfügen //Update Userdaten mit Kundennummer [knips-konsorten.de] if ($_SESSION['customer_id'] != "") { $c_cid = $_SESSION['customer_id']; //hier kann die Nummer wie gewünscht mit werten vor oder nach der ID beeinflusst werden z.B. K0001 $c_cid_query = "UPDATE " . TABLE_CUSTOMERS . " SET customers_cid = '". $c_cid ."' WHERE customers_id = '". $_SESSION['customer_id'] ."'"; xtc_db_query($c_cid_query); } //ENDE [/php]
  12. Also mit der neuen Version 2.4.3 schon das mit dem kopieren nicht zu funktionieren oder ihr nutzt alle nicht den Resource Browser der hinter dem Server durchsuchen Button steckt bei dem Link Generator: also 1. gibts da nur noch unter /fckeditor/editor/filemanager/browser/default/ eine browser.html und keine browser.php mehr so das die Datei fck_wrapper.php beim Aufruf einen Fehler bringt. Kein Problem Datei umgenannt, folgende Zeile vor das html Tag kopiert (aus Vergleich mit alten Datei) <?php defined('_VALID_XTC') or die('Direct Access to this location is not allowed.'); ?>[/PHP] [HTML]<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">[/HTML] und die Pfade von Style vom Stylesheet und src's angepasst z.B.: [HTML] <link href="<? echo DIR_WS_FILEMANAGER; ?>browser.css" type="text/css" rel="stylesheet"> <script type="text/javascript" src="<? echo DIR_WS_FILEMANAGER; ?>js/fckxml.js"></script> [/HTML] Danach gibt ne Fehlermeldung:This connector is disabled. Please check the "editor/filemanager/browser/default/connectors/php/config.php" file Gesagt getan: [PHP]$Config['Enabled'] = true ;[/PHP] Jetzt kommt ne Fehlermeldung: The server didnt' send back a proper XML response. .. ML request error: OK (200) So was ist da falsch, ich bekomme keinen Zugriff auf das Verzeichnis, mit der alten Version geht es, deaktivieren des USer Verzeichnises ging auch nicht. Wer weiss rat?
  13. Gibt es eine Lösung die Warenmenge eines Produktes in Abhängigkeit von 2 oder mehr Attributen zu bestimmen? Also ich hab ein Artikel der in der Farbe blau und Größe 38 20mal da ist und in der Farbe blau und 41 nur 10mal. Die Option Größe 41 soll nicht mehr angezeigtwerden sobald keine Produkte mehr in dieser Größe und Farbe vorhanden ist. Gibt es ein Modul, hat jemand einen Ansatz? MFG kchris
  14. Okay also für alle in der Datei \lang\german\modules\payment\moneyorder.php für die definierten Module MODULE_PAYMENT_MONEYORDER_TEXT_DESCRIPTION und MODULE_PAYMENT_MONEYORDER_TEXT_EMAIL_FOOTER die Variable MODULE_PAYMENT_MONEYORDER_PAYTO gegen den gewünschten Text austauschen, ich habe immer die HTML Umbrüche hingeschrieben, bin mir bei dem EMAIL_FOOTER ob ich nicht lieber /n hätte nehmen sollen. vorher: // define('MODULE_PAYMENT_MONEYORDER_TEXT_DESCRIPTION', 'Zahlungen bitte nur auf das folgende Konto: <br />' . MODULE_PAYMENT_MONEYORDER_PAYTO . '<br /><br />' . 'Ihre Bestellung wird nach Eingang des Geldes versandt.'); nachher: // define('MODULE_PAYMENT_MONEYORDER_TEXT_DESCRIPTION', 'Zahlungen bitte nur auf das folgende Konto: <br /> Ersatztext<br /><br />' . 'Ihre Bestellung wird nach Eingang des Geldes versandt.'); Und ein schönes weiteres Problem sind englische Rechungen im Backend, bei mir gibts nur deutsch/englisch Mischmasch. MFG kchris
×
×
  • Create New...