Jump to content
xt:Commerce Community Forum

halousi

Members
  • Content Count

    128
  • Joined

  • Last visited

Everything posted by halousi

  1. Perfekt! Vielen Dank, das war mir neu. Ich hatte tatsächlich bei "Gast" und "Neuer Kunde" b2c eingestellt. Aber ist es nicht genau andersherum? bei mir steht bei B2B = shipping_address ?
  2. Bei uns hat das bis zur 4.1 funktioniert, seit dem Update auf 6.1 wird die MwSt. fälschlicherweise über die Rechnungsadresse berechnet. Gibt es dafür mittlerweile eine Lösung/Patch? Es ist ziemlich lästig ständig die MwSt. nachzufordern wenn Kunden aus der Schweiz nach Deutschland liefern lassen.
  3. Ich bekomme leider keine Zugriff auf das Verzeichnis "/plugins/xt_ekomi/pages". Ich vermute das PlugIn würde sogar funktionieren, aber ich kann es nicht aufrufen. Auch aus dem Backend bekomme ich nur einen 403 Error angezeigt. Habe die Verzeichnisse schon per .htaccess zusätzlich freigegeben. Bringt leider auch keinen Erfolg?
  4. Hallo zusammen, wir haben unseren Shop auf XTC6 aktualisiert. Leider kann ich das Plugin für ekomi "xt_ekomi" nicht mehr im Store finden? Wo kann ich das bekommen?
  5. Perfekt, dass war’s Vielen, vielen Dank für deine Hilfe.
  6. Hört sich gut an, hast du mir einen Tip wie das geht? Bei mir sieht das so aus
  7. Hallo zusammen, wir aktualisieren gerade unseren Shop von 4.2 auf 6. Im M/S-Plugin hat sich ja viel getan, aber leider haben wir dadurch nun ein Problem mit der Darstellung der Slave-Listen. In der alten Version hat die Anzeige "Slaveartikel-Liste auf Produktseite" auch funktioniert, wenn den Slaves keine Attribute zugewiesen waren. Nurn erscheint bei diesen Artikeln leider die Fehlermeldung: Warning: Illegal string offset 'products_id' in /plugins/xt_master_slave/classes/class.xt_master_slave_products.php on line 1450 Auch der Anzeige der Produktvariation ist dann fehlerhaft. Es werden zwar die richtige Anzahl an Variationen angezeigt, allerdings leider ohne Inhalt und korrekter Verlinkung. Kann man die class.xt_master_slave_products.php so anpassen, daß es die Variationen nicht aufgrund der Attribute erzeugt sondern wie früher über die Zuordnung zur Master-Artikelnummer? Grüße
  8. Hab dasselbe Problem, ich kann anklicken was ich will, der Shop springt immer auf einen beliebigen Slave. Gibt es dazu eine Lösung? Version 6.1.2 Falsch sorry, hab eben den Fehler gefunden. Muss in den Grundeinstellungen hinterlegt sein.
  9. Ja, und zwar sehr erfolgreich. Es gibt durchaus Gründe die gegen ständige Updates und z.B den damit verbundene Einschränkungen in der Darstellung sprechen. Wir haben uns sehr viel Mühe gegeben einen Shop auf die Wünsch und Bedürfnisse unserer Kunden zu konzipieren. Es geht nicht darum das sicherheitsrelevante Updates ausgeführt werden sollen, sondern eher darum, warum das für ältere Systeme nicht möglich ist. Responsive Design ist für uns, unsere Kunden und unsere Produktdarstellung ein Graus. Wir sind B2B Lieferant der Industrie. Kein Mensch benötigt in unserem Segment ein Responsive-Einheitsbrei-Design. 90% unserer Kunden bestellen am Desktop-PC. Leider ist das seit XTC5 nicht mehr möglich. Wir werden jetzt also leider in eine Verschlimmebsserung gezwungen und alle Ideen, Arbeit, und finanziellen Investitionen der letzten Jahre sind damit abgelöst. Warum überlassen wir nicht einfach alle gleich Ebay, Amazon & Co den Markt und sparen uns die ganze Arbeit. Individualität scheint nicht mehr gewünscht zu sein....
  10. Weil die an Anpassungen an unserem System und Templates so umfangreich sind, daß ein Update auf die aktuelle Version extrem aufwändig wird und zum jetzigen Zeitpunk eigentlich auch noch nicht nötig wäre. Wie sagt man so schön: "Never change a running system".
  11. Hallo zusammen, gibt es mittlerweile eine Möglichkeit ältere XTC Versionen (4.1) unter PHP 7.2 oder höher zu betreiben? Die Domainfactory schaltet PHP 5 im März 2020 ab und somit würden ältere Shops nicht mehr unterstützt. Viele Grüß
  12. Hallo, genau das Problem habe ich auch. Ich versuche gerade ein Update aus der Version 4.1 zu machen, dort war ein Attribut noch nicht nötig um einen Artikel in die Slave-Liste aufzunehmen. Wir haben über 1000 Artikel so angelegt, benötigen dazu aber nicht extra nochmals eine Attributangabe. Gibt es eine Möglichkeit die SLAVE-Liste unabhängig von zugeordneten Attributen trotzdem anzuzeigen?
  13. äh, komischer Kommentar [email protected] . Wir machen die Kategorien ja nicht zum Spaß an der Freude. Natürlich brauchen wir diese Anzahl an Kategorien auch. Oder habe ich irgendwo überlesen das 4.2 eine max. Kategorienbeschränkung hat? Die Frage ist, warum geht es mit 4.1 problemlos und mit 4.2 nicht und warum nimmt sich, obwohl das Problem bekannt ist keiner dieser Problematik an, sondern verweist uns auf eine weiteres, kostenpflichtiges Update. 4.2 haben wir auch bezahlt, können es aber nicht verwenden !!!
  14. ... wenn es so einfach wäre. Das wollte ich eigentlich im Moment noch nicht. Wir haben zig Module und Templateanpassungen. Einige davon sind für 5 noch nicht verfügbar. Aber das kann doch nicht so ein großes Problem sein, in der 4.1 hat das doch wunderbar funktioniert?
  15. Das kann ich bestätigen! Wir haben ~ 1.600 Kategorien und genau diese Abfrage erzeugt bei uns eine Ladezeit von ca. 10 Sekunden. Mit der Version 4.1 war das kein Problem. Gibt es dafür wirklich keine Lösung? So ist für uns die 4.2 leider unbrauchbar. SELECT COUNT(parent.categories_id) AS level ,c.*,cd.*,su.*,cl.link_url,group_permission.*,shop.* FROM xt_categories AS c CROSS JOIN xt_categories AS parent LEFT JOIN xt_categories_description cd ON c.categories_id = cd.categories_id and cd.categories_store_id='1' LEFT JOIN xt_seo_url su ON (c.categories_id = su.link_id and su.link_type='2' and su.store_id='1') LEFT JOIN xt_categories_custom_link_url cl ON (cl.categories_id = c.categories_id and cl.store_id='1') left JOIN xt_categories_permission group_permission ON (group_permission.pid = c.categories_id and group_permission.pgroup = 'group_permission_1' ) left JOIN xt_categories_permission shop ON (shop.pid = c.categories_id and shop.pgroup = 'shop_1' ) WHERE c.categories_status = '1' and c.categories_left BETWEEN parent.categories_left AND parent.categories_right and cd.language_code = 'de' and cd.categories_store_id='1' and ((c.category_custom_link=0 and su.language_code = 'de' and su.store_id='1') || (c.category_custom_link=1 and cl.language_code = 'de' and cl.store_id='1') ) and group_permission.permission IS NULL and shop.permission IS NULL GROUP BY c.categories_id, c.categories_left, c.categories_right ORDER BY c.sort_order,c.categories_left,cd.categories_name
  16. Hallo Overtone, ja, kann ich bestätigen. Bei uns tritt das Problem auch auf. Da es aber nicht immer, sondern nur sporadisch nicht funktioniert, habe ich auch vermutet es liegt an bestimmten Zeichen im Passwort. Was ich auf jeden Fall schon herausgefunden habe ist, daß ein Passwort mit einem "&" in der Zeichenkette nicht funktioniert. Das ist definitiv ein BUG und sollte bitte schnellstens behoben werden. Oder kann ich irgendwo Sonderzeichen ausschließen? Version 4.1.10 mit aktuellem Patch
  17. Schau doch mal nach ob du evtl. php mit fastcgi aktiviert hast. Ich habe gerade ein ähnliches Problem, allerdings ohne Fehlerausgabe. Bei mir springt das Backend auf no-loader.php, Frontend funktioniert. FastCGI aus und alles geht. Grüße halousi
  18. Hallo, ich habe heute unseren 4.1.10 Shop auf php5.4.45 mit fastcgi umstellen wollen. Das frontend funktioniert einwandfrei und auch deutlich schneller, allerdings bekomme ich das backend nicht zum laufen. Wenn ich auf die Seite xtAdmin gehe, erhalte ich sofort die Fehlerseite: "xtAdmin/xtWizard/no-loader.php". Stelle ich php auf ohne fcgi um funktioniert es einwandfrei. Der ioncube 5.4 wird demnach korrekt geladen. Auch ein separates hinterlegen in einer php.ini bringt nichts. Sobald fastccgi aktiviert wird ist kein Admin-Login mehr möglich. Kennt jemand das Problem, bzw. gibt es dafür eine Lösung? Ich würde sehr gerne umstellen, der Shop läuft mit fcgi merklich schneller! Viele Grüße halousi
  19. Und wie richte ich den Cronjob ein? Ich habe es mit einem externen Cronjob versucht. Ergebnis: "Direct Access is not allowed."
  20. Genau das würden wir auch benötigen. Außerdem die Möglichkeit Spalten auszublenden. "Mandant", "Bestellweg", "External order source" wird nicht benötigt und macht die Liste nur unübersichtlich
  21. ... würde mich auch interessieren? Gibt es das im Veyton nicht mehr?
  22. Hallo, konnte das Problem finden. Wir haben ca. 2000 Kategorien mit ~ 14.000 Artikel. Das Problem ist wohl, dass in in der xtCore/pages/search.php bei jeder Suchanfrage der Kategoriebaum neu erzeugt wird: "$cat_list = $category->getAllCategoriesList();" Diese Anfrage dauert 29 Sekunden !!!! Ich habe nun diese Abfrage einfach durch ein "$cat_list = array();" ersetzt und nun dauert das ganze noch 1 Sekunde - natürlich wird dadurch auch der Kategoriebaum für eine mögliche Selektion nicht erzeugt, aber damit können wie leben. Warum wird denn dieser Kategoriebaum nicht in einen Cache geladen? Offensichtlich gibt es hier Probleme wenn bei vielen Unterverschachtelungen.
  23. Hallo zusammen, ich habe ein Problem mit der Suchfunktion in der Version 4.1. Der Shop läuft eigentlich ganz ordentlich, nur bei der Suche bekomme ich eine parse time von ~ 30 Sekunden pro Abfrage. Ich kann einfach den Fehler nicht finden. Ich denke es es hat irgendwas mit der Abfrage in der Datenbank xt_categories oder xt_categories_description zu tun. Ich habe bei der Suche nach der Ursache diese Datenbanken einfach mal geleert und siehe da, plötzlich wurden die Suchergebnisse innerhalb 1 Sekunde angezeigt. Kennt jemand dieses Problem bzw. hat eine Idee wie ich die Abfrage optimieren könnte? Vielen Dank & Grüße Hannes
  24. Hallo, ich bekomme es leider auch nicht hin. XTC 4.1.0, alle Daten eingetragen. Wie werden jetzt die Produktbewertungen importiert? Im Modul erscheint: "Invalid login email/ pass." Daten sind aber 100%ig korrekt.
×
×
  • Create New...