Jump to content
xt:Commerce Community Forum

Simpsonight

Members
  • Content Count

    48
  • Joined

  • Last visited

About Simpsonight

  • Rank
    xt:Commerce Support Kunde
  • Birthday 06/01/1978
  1. Dasselbe Problem haben wir ebenfalls und sind kurz davor, die Funktion selbst zu schreiben. Es gibt ja darüber hinaus den Bug, dass dann in den Dropdowns teilweise nur 1 Wert angezeigt wird.
  2. Hallo zusammen, gibt es ein Modul, dass die Seiten payment und shipping zusammen führt? Für xtc 3 gab es ein solches (Easy Chekout). Ansonsten irgendwelche Tipps, wie man das am besten löst? Danke schon mal im Voraus
  3. Hi zusammen, neuerdings arbeite ich mit Veyton. Da ich keinen Hookpoint im Core gefunden habe, und diesen auch nicht ändern möchte, würde ich den PHP-Teil im Template gern erweitern, sodass für Unterpunkte nicht nur der Ebenen-Level in der Class hinterlegt wird, sondern sich jeweils UL-Tags öffnen und schließen. Im Prinzip werden ja alle nötigen Daten geliefert. Hier der typische Code <ul id="categorymenu"> {foreach name=aussen item=module_data from=$_categories} <li class="level{$module_data.level}{if $module_data.active} active{/if}"><a href="{$module_data.categories_link}" title="{$module_data.categories_heading_title}">{$module_data.categories_name}</a></li> {/foreach} </ul>[/html]In dem Foreach möchte ich nun z.B. den Level speichern, um ihn im nächsten Durchlauf abfragen und mit dem aktuellen Level vergleichen zu können. In einem [html]{php} ... {/php}kann ich wohl nicht auf die Variablen zugreifen. Eine Wertezuweisung im Foreach-Block wäre am besten. Aber sowas {$x = $module_data.level}Wird ignoriert. {$x} bleibt immer leer.
  4. Bei mir ist es genauso wie bei meinem Vorposter (13.05.). Weitere Bilder werden nicht angezeigt. Übrigens: Früher gab es für Kategorien doch 2 Bilder (Teaser+Header). Jetzt sehe ich nurn och eins. Für unser neues Projekt brauchen wir sogar insgesamt 3. EDIT: Ok, es liegt wohl daran, dass ich ein Bild aus den Kategorien als Produktbild einsetzen wollte. Wenn ich also Bilder per FTP übertrage gilt wohl dasselbe. Es ist nicht in Kategorie Bilder, also wird es nicht übernommen, wohl aber bei der Auswahl angezeigt.
  5. Selbes Problem auch bei mir. Offensichtlich steht ja Code zur Steuerberechnung in der ot_coupon.php und es lassen sich auch entsprechende Einstellungen vornehmen. Aber auf die MwSt hat das alles keine Auswirkung.
  6. Hallo zusammen, hoffentlich das Thema hier richtig platziert. Und zwar suche ich nach einem Modul, welches je ein Extrafeld für Wasch- (z.B. ab 30 Grad) und Warnhinweise (zb. nicht geeignet unter 3 Jahren) für jedes Produkt anbietet. Über die Attribut-Verwaltung soll es jedenfalls nicht gedreht werden. Es wäre schön, wenn es dieses "Rad" schon gäbe.
  7. Soweit ich herausgefunden habe, ist nicht die Summe falsch, sondern die Auflistung. Die schuldige Query liegt in der admin/includes/classes/sales_report.php // query for attributes $this->queryAttr = "SELECT count(op.products_id) as attr_cnt, o.orders_id, opa.orders_products_id, opa.products_options, opa.products_options_values, opa.options_values_price, opa.price_prefix from " . TABLE_ORDERS_PRODUCTS_ATTRIBUTES . " opa, " . TABLE_ORDERS . " o, " . TABLE_ORDERS_PRODUCTS . " op WHERE o.orders_id = opa.orders_id AND op.orders_products_id = opa.orders_products_id";[/PHP] Die Query muss irgendwie aufgespalten werden, denn es werden die Attribute, wenn auch nciht immer, für sich gezählt. Also: Hat ein Produkt 2 Attribute (Farbe, Größe) - wird das Produkt manchmal 2x gezählt. Nur leider weiß ich nicht, wie die Query korrekt lauten muss. Habe schon einiges probiert.
  8. trtrerz Hsbaoinfredkng bfgnhngf bkjngfnkg nhg
  9. Hi, schaut Euch mal den Beitrag dazu an. Bei mir hat es wunderbar geklappt! http://www.xt-commerce.com/forums/index.ph...ndpost&p=114067
  10. Hallo Peter, hast du eine L?sung f?r Dein Problem bez?glich der Reise-Software gefunden? Mich w?rde interessieren wie eine L?sung in xtCommerce aussieht oder was ihr f?r eine Alternative gefunden habt. Sch?ne Gr??e Simpsonight
  11. Hallo, ich habe da ein seltsames Problem bei den Kundengruppen. Ich habe einige Gruppen angelegt. Jetzt kann ich ja bei den Artikeln etc. die einzelnen Ceckboxen ausw?hlen, welche Gruppe den Artikel sehen darf. Das klappt auch soweit, bis auf die letzte eingetragene Gruppe. Wenn ich hier ein H?ckchen setze und das ganze abspeicher, dann ist beim n?chsten Aufruf das H?ckchen wieder weg!!! Ist das ein Bug oder woran liegt das? Danke schonmal f?r die Hilfe.
  12. Die TTF-Dateien wurden wahrscheinlich beim FTP-Upload auch im ASCII Modus hochgeladen. Bei mir lag es auf jedenfall daran. Nachdem ich die Schriftarten noch einmal in Binary-Modus hochgeladen habe, funktionierte es.
  13. Danke f?r die Antwort. Hatte ich mir schon fast gedacht...
  14. Hi, bin neu hier und brauche Hilfe! Ich suche vergebens nach einer M?glichkeit bei der Versandart "DHL" auszuw?hlen. In den XT-Modulen gibt es nur die M?glichkeit DHL ?sterreich zu aktivieren. Kann mir hier einer helfen?! Danke
×
×
  • Create New...