Jump to content
xt:Commerce Community Forum

shopper

Members
  • Content Count

    5
  • Joined

  • Last visited

  1. Der Fehler bedeutet, dass es in der Tabelle die Spalte mail schon gibt. Also entweder macht das dann nix aus oder Du schaust Dir die Hand voll Statements in der db_changes.sql mal genauer an und f?gst den rest manuell ein. Vielleicht hast Du die Datei aus Versehen zwei mal eingef?gt? Bei mir gabs keine Probleme beim update. Ich empfehle f?r sowas ?brigens die Benutzung des mysql-client, es gibt immer wieder Probleme, die durch die Benutzung von phpmyadmin entstehen. Viel Gl?ck noch!
  2. Also ich kann es nur best?tigen: IIS IST KEINE GEEIGNETER SERVER ZUM PRODUKTIVEN BETRIEB! H?r auf mit dem Rumgequ?ngel und leiste Dir einen ordentlichen Webserver mit Linux und Apache. Sowas gibt es schon f?r 10 Euro im Monat. Insgesamt ist es f?r alle hier besser, wenn Du einfach den MS-Schrott vom Server schmeisst und auch mit ordentlichem Serversystemen arbeitest, es gibt n?mlich genug andere Arbeit zu erledigen. Danke! :alien:
  3. Hi, wir w?rden gerne unseren ipayment account zur Abwicklung von Bezahlungen mit dem XT-Commerce Shop testen. Wenn ich *nur* das ipayment modul aktiviere, kann ich w?hrend des Bezahlvorgangs allerdings nur Kreditkartenzahlung w?hlen, ?ber ipayment sind jedoch mehrere Zahlungsarten m?glich, z.B. auch Bankeinzug oder Moxmo (siehe ipayment.de) Werden diese anderen zahlungsarten nicht unterst?tzt vom aktuell vorhandenen ipayment-modul? Oder muss man den Banktransfer explizit aktivieren? Weitere Frage: Brauche ich curl auf dem Server f?r das ipayment modul? (ja, ich weiss... ich guck am Wochenende mal in die Quellen, bin jetzt zu m?de...) W?re ?ber Infos dankbar! shopper
  4. Ja, ist komischerweise immer so: kurz nachdem ich irgendwohin poste, f?llt mir selber die L?sung auf: categories_status in table categories waren alle auf 0, folglich lieferte die Query keine Ergebnisse. Ich hab die manuell aud 1 gesetzt, dann gings. Ich weiss aber nicht, warum die setflag-links im Admin-Interface nicht das tun, was sie sollen. Ist deren Funktionalit?t noch an eine Bedingung gebunden oder m?ssten die unter allen Umst?nden funktionieren (gr?n/rot) ? Sch?nen Tag noch, ich mach sp?ter weiter, muss morgen arbeiten ...
  5. Hi, m?glicherweise bin ich noch nicht genbug abgetaucht in xt-commerce, es gef?llt mir aber wesentlich besser als osc. Danke erstmal! Ich hab allerdings die ?blichen EInsteiger-Schwierigkeiten, sorry. Gibt es irgendeinen grund, warum die Kategorien nicht angezeigt werden im Shop? ich hab jetzt zwei Test-Kategorien angelegt, leider tauchen die nicht im Frontend auf. Leider gibt es auch keine "neuen Artikel" obwohl ich sogar einen Artikel auf Ebene "top" angelegt habe. Bei Klick auf "neue Produkte" wird wohl folgende Query abgesetzt, die bleibt leider leer (0 ergebnisse, habs im mySQL Client ?berpr?ft), es wundert mich also nicht, das es keine neuen Produkte gibt. Was mich wundert ist, dass ich definitiv welche angelegt habe, sind auch in der Tabelle products drin. Was mach ich falsch? MNir f?llt noch auf, dass ich Schwierigkeiten habe, die Kategorien zu aktivieren, immer, wenn ich auf den setflag link im admin interface klicke (gr?n) komme ich in den Bereich zum Editieren der kategorie, sie bleibt aber trotzdem Rot. Hmm... Wo k?nnte ich nachgucken? Ich bin durchaus bewandert in php, evtl. hilft mir ein kleiner Hinweis... danke! select count(*) as total from products p, categories c, products_to_categories p2c left join manufacturers m on p.manufacturers_id = m.manufacturers_id left join products_description pd on p.products_id = pd.products_id and pd.language_id = '2' left join specials s on p.products_id = s.products_id where c.categories_status=1 and p.products_id = p2c.products_id and c.categories_id = p2c.categories_id and products_status = '1' order by p.products_date_added DESC, pd.products_name shopper
×
×
  • Create New...