Jump to content
xt:Commerce Community Forum

waver

Members
  • Content Count

    77
  • Joined

  • Last visited

  1. Hallo, ich versuche in der Datei new_products.php die Funktionalität einzubauen, dass die VPE auch angezeigt wird. Es funktioniert auch wunderbar, alles wird richtig berechnet. Allerdings steht oben auf der Seite jetzt 5 mal untereinander: Warning: Division by zero in /home/httpd/vhosts/weller-telecom.net/httpdocs/shop1120/includes/modules/new_products.php on line 125 hier mal die entsprechenden Zeilen aus der Datei: $module_content[] = array ('PRODUCTS_NAME' => $new_products['products_name'], 'PRODUCTS_DESCRIPTION' => $new_products['products_short_description'], 'PRODUCTS_PRICE' => $xtPrice->xtcGetPrice($new_products['products_id'], $format = true, 1, $new_products['products_tax_class_id'], $new_products['products_price']), 'PRODUCTS_TAX_INFO' => $tax_info, 'PRODUCTS_SHIPPING_LINK' => $ship_info, 'PRODUCTS_LINK' => xtc_href_link(FILENAME_PRODUCT_INFO, xtc_product_link($new_products['products_id'],$new_products['products_name'])), 'PRODUCTS_IMAGE' => $image, 'PRODUCTS_VPE' => $new_products['products_vpe'], 'PRODUCTS_VPE_EINH' => xtc_get_vpe_name($new_products['products_vpe']), 'PRODUCTS_VPE_VALUE' => $new_products['products_vpe_value'], 'PRODUCTS_VPE_PRICE' => TXT_GP.$xtPrice->xtcFormat($new_products['products_price'] / $new_products['products_vpe_value']*(1+($tax_rate/100)), true).TXT_PER.xtc_get_vpe_name($new_products['products_vpe']), 'BUTTON_BUY_NOW' => $buy_now);[/php] Die Zeile 125 ist die welche mit 'PRODUCTS_VPE_PRICE' => beginnt Sobald ich für [color=Lime]$new_products['products_vpe_value'] [color=Black]etwas anderes nehme, z.B. eine Zahl oder eine andere Variable verschwindet der Fehler. (er rechnet dann aber natürlich mit den falschen werten.) Shop ist Version 3.04 SP1 . Ich hoffe mir kann hier jemand einen Tipp geben. Gruß Roland [/color][/color]
  2. Hallo, also ich habe bisher positive erfahrungen damit gemacht. Man wird auch über notwendige änderungen informiert. Gruß Roland
  3. Hi, ich habe auch diese Fehlermeldung: Ihre Sitemap-Datei beginnt mit einem Leerraum.... Gibts da ne Lösung? Gruß Roland
  4. Hi, wenn du firefox benutzt, kannst du dir die erweitung edit-css installieren. dann kannst du änderungen an der stylesheet datei direkt sehen und ohne gefahr ausprobieren. lohnt sich. Gruß Roland
  5. Hi, laut Quelltext wurde die Funktion von folgender Firma gemacht: http://www.homepage-factory.info Wenn Ihr nähere Infos habt, schreibts mal hier rein. Gruß Roland
  6. Hi, der Bildname befindet sich in der Tabelle products Spalte products_image. Du könntest aber auch anstatt jedesmal einen Artikel neu anzulegen, einen bestehenden kopieren und dann ändern. Dann bleibt das Bild das gleiche. Gruß Roland
  7. Hi, es gibt für osc eine Erweiterung: quick_stockupdate Diese läßt sich sehr einfach auch in xt einsetzen. musst du mal bei oscommerce.com suchen. Gruß Roland
  8. hi, also der Import funktioniert sehr gut, wenn man weis was man macht. Es gibt auch einen Doku Bereich. Gruß Roland
  9. in der 3.04er Version ist ein Import per csv Datei für Artikeldaten enthalten. Gruß Roland
  10. Hi, ja ist möglich. Du musst nur allen Tabellennamen des zweiten Shops ein Prefix voran stellen und in der Datei database_tables entsprechend auch. Sollte dann eigentlich funktionieren. Gruß Roland
  11. Danke, jetzt funktioniert auch der Statuswechsel. Perfekt, weiter so Gru? Roland
  12. Hallo, erst mal gratulation zu EazySales und dem Connector. Endlich gibts mal eine bessere Alternative zu cao. Die Installation verlief bei mir problemlos und der erste Eindruck ist absolut positiv. Das Anlegen von Artikeln und ?bertragen zum Shop funktioniert prima, die Bestellungen und damit auch die Kunden werden wunderbar ?bermittelt. Nur der Bestellstatus ?ndert sich im Shop einfach nicht. Egal ob ich den Artikel als versand markiere oder was auch immer. Beim Internetabgleich steht dann zwar bei Bestellungen eine 1 und irgendwas wird auch ?bertragen, aber es ?ndert sich nichts. Wie funktioniert der Punkt H?ndlerkunden aktivieren ? (bei mir glaub ich gar nicht) Es w?re w?nschenswert, wenn ein in EazySales angelegter Kunde auch zum Shop ?bertragen werden k?nnte und wenn eine ?nderung an den Kundendaten, z.B. Adresse auch mit dem Shop abgeglichen w?rde. Alles in Allem aber schon super gelungen dieses EazySales. Macht weiter so, dann wird EazySales DIE Software f?r XTC. Gru? Roland
  13. Hi, na genau das was in dem Beitrag steht, die Zeile die mit "'shipping_class'=>" beginnt hab ich wieder in den original Zustand gebracht. Bei mir lags daran. Hast du denn die CAO ?nderungen drin? Weil, wenn nicht, kann das auch nicht dein fehler sein. Gru? Roland
  14. nee nee, wie schon gesagt: Gru? Roland
  15. Hi, ich war blind. Andere hatten das Problem auch schon. Es liegt an CAO-Faktura. Die L?sung steht hier: http://www.xt-commerce.com/forums/index.ph...ndpost&p=130424 Bei mir funktioniert es jetzt Gru? Rland
×
×
  • Create New...