Jump to content
xt:Commerce Community Forum

xirlexa

Members
  • Content Count

    23
  • Joined

  • Last visited

About xirlexa

  • Rank
    Neuer Benutzer
  • Birthday 07/25/1970
  1. Hallo zusammen. Ich arbeite mit xt:Commerce v3.0.4 SP2.1. Wie bekomme ich es hin, daß die Hersteller (Maufacturers_Name) in den Suchergebnissen angezeigt wird. Versuche jetzt schon seit zwei Wochen diese Änderung durchzuführen, aber ohne Erfolg. Artikel Nr., kurze und lange Beschreibung alles schon im Suchergebnis integriert. Bloß den sch***ß Hersteller {$module_data.MANUFACTURERS_NAME} krieg ich nicht rein. Das Feld bleibt immer leer. Kann mir bitte einer das Leben erleichtern. THX
  2. Hallo zusammen. Hat denn keiner eine Ahnung. Oder ist es so leicht, daß ich den Wald vor lauter Bäumen nicht sehe. :):D:D:)
  3. Hallo zusammen. Habe jetzt schon seit 2 Tagen das Forum durchsucht und finde dennoch keine Lösung. Ich möchte im Module new_products.html den Herstellernamen anzeigen lassen. Habe den Eintrag {$module_data.MANUFACTURERS_NAME} in alle new_products html Dateien eingetragen. Aber es wird nichts angezeigt, dass Feld bleibt leer. Ich denke, dass ich in irgendeiner PhP Datei etwas ändern muss. Aber woooooooooooo??????????????. Für Hilfe wäre ich dankbar. Das gleiche Problem ergibt sich für mich mit der Anzeige des Herstellers in den Suchergebnissen (Suche + Erweiterte Suche) See You
  4. Hallo liebe XTC Gemeinde, ich habe ein lästiges Bannerproblem. Ich weiß "Suche benutzen", hab ich schon. Mittlerweiler stöber ich schon seit zwei Tagen herum und gehe jedem Lösungsvorschlag nach, aber ohne Erfolg. Einige Beiträge führen ins Sponsorenforum andere auf die Forum Hauptseite, aber Hilfe habe ich keine erfahren. Da ich nicht mehr weiter weiß, erstelle ich jetzt in Echtzeit ein Banner und schreibe euch genau auf was passiert. In der Hoffnung das jemand meinen Fehler sieht. Ich arbeite Lokal auf meinem PC mit xtcommerce v3.0.4 SP1 - release 01.Okt.2005, AppServ v 2.5.5 und WinMYSQL. Gleichzeitig baue ich den Shop online auf http://www.rivotech-electronics.de bei 1&1 auf. Schritt 1. Gehe in den Banner Manager und lege ein neues Banner an. Titel: Test Banner URL: http://localhost/shop24/shop_content.php?coID=15 Banner Gruppe: BANNER alles ausprobiert Großbuchstaben, kleine... Bilddatei: F:\RivoTech_Shop\Cover\xbox\doom3_xbox.jpg Schritt 2. Banner einfügen. Dann kommt wieder der Banner Manger mit zwei grünen Balken. Erfolg. Hochgeladene Datei wurde erfolgreich gespeichert. Erfolg. Der Banner wurde eingefügt. Bild wurde ordnungsgemäß im Shopverzeichnis unter /images/banner/ abgelegt. Aber im Banner Manger müßte doch normalerweise ein kleines Vorschaubild des Banners angezeigt werden. Oder irre ich mich da? Schritt 3. Klicke dann in Menueleiste auf SHOP Indexseite wird aufgerufen. Wieder kein Banner sichtbar. :mad:Shit. Schritt 4. So nun schaue ich mir den index.html code im shoptemplate an, ob auf das banner verwiesen wird. Folgender Eintrag: {if $BANNER} <table width="100" border="0" align="center" cellpadding="0" cellspacing="0"> <tr> <td>{$BANNER}</td> </tr> </table> {/if} Alles OK, oder? Schritt 5. Gehe nun noch in die Banners.php. Folgender Eintrag: <?php /* ----------------------------------------------------------------------------------------- $Id: banners.php 899 2005-04-29 02:40:57Z hhgag $ XT-Commerce - community made shopping http://www.xt-commerce.com Copyright © 2003 XT-Commerce Released under the GNU General Public License ---------------------------------------------------------------------------------------*/ require_once(DIR_FS_INC . 'xtc_banner_exists.inc.php'); require_once(DIR_FS_INC . 'xtc_display_banner.inc.php'); require_once(DIR_FS_INC . 'xtc_update_banner_display_count.inc.php'); if ($banner = xtc_banner_exists('dynamic', 'banner')) { $smarty->assign('BANNER',xtc_display_banner('static', $banner)); } ?> Auch alles OK. Habe auch schon die index.html durch die Originale ersetzt. Ohne Ergebnis. Wenn ich mir den Index.html code nach der Generierung anschaue, finde ich auch keinen Bannerverweis im Quelltext. Ich gehe mal davon aus, daß die Variable nicht übergeben wird. Was nun aber sehr verwunderlich ist: Geht man später wieder in den Banner Manager, werden in der Statistik Banneranzeigen durch den blauen Balken angezeigt, obwohl ich keine Banner sehe. WOW!!!!!!!Irre Desweiteren: Wenn ich nun genau dieses Banner mit samt dem Bild lösche kommt folgende Fehlermedung: Fehler: Bild existiert nicht, obwohl es ordungsgemäß bei Erstellung gespeichert und abgelegt wurde Erfolg: Der Banner wurde gelöscht. Bilder von Produkten oder Content Inhalten werden super dargestellt. Da ich mich nur beschränkt auskenne in Sachen PHP und HTML Prog. hoffe ich das mir vielleicht ein paar erfahrene Kräfte unter die Arme greifen können. Für Hilfe wäre ich sehr dankbar.
  5. Hallo zusammen. Bin mal wieder am Ende meines Latains. Ich m?chte in der Gruppe "Neue Produkte" auf der Startseite den jeweiligen Kategorienamen des Artikels mit Link zur productlisting beif?gen. Habe dieses schon in der product_listing.html eingef?gt: {$CATEGORIES_NAME} ohne Verlinkung weil es ja sowieso die gleiche Kategorie ist. Funzt wunderbar. Dieses habe ich nun auch in der new_products_default.html eingef?gt. Aber ohne Ergebnis. Es wird nichts angezeigt. Ich gehe mal davon aus, da? in dem zugeh?rigen php modul eine entsprechende Verkn?pfung fehlt. Wei? aber nicht welche Datei (in welchem Verzeichnis?) und was ich hinzuf?gen mu?. Also zusammenfassend: Wo mu? ich was hinzuf?gen, um in den Neuen Produkten auf der Startseite deren Kategorie mit dem daraufliegenden LINK zur Kategorie?bersicht zu sehen ????? Dank euch allen vorab.
  6. Hallo. Ich habe eben fast 2 Stunden dieses Forum abgegrast und doch nicht gefunden. Ich m?chte anstatt dem normalen Artikelbild das Artikelbild 1 bei den Top gesetzten Artikeln anzeigen die auf der Startseite, als neue Artikel erscheinen. Dazu habe ich in der Datei "new_products_default.html" folgende ?nderung ausprobiert: Habe nun den Code wie bei dem Artikelbild {if $module_data.PRODUCTS_IMAGE}{/if} umge?ndert in: {if $module_data.PRODUCTS_IMAGE_1}{/if} Nun wird aber gar kein Bild angezeigt. Fehlt eine gewisse Verkn?pfung, oder mu? ich noch weitere ?nderungen Vornehmen? Wenn ja, wo mu? ich diese dann durchf?hren. Dank vorab.
  7. Hallo zusammen! Ich arbeite mit appserv-win32-2.3.0.exe in einer Testumgebung auf meinem Computer. Wiedermal folgendes Problem: Ich lege einen neuen Artikel an. Alles super. Bis zu dem Punkt, an dem ich Bilder speichern m?chte. Egal ob es sich hierbei um Produktbilder oder Zusatzbilder in der Artikelbeschreibung handelt. Sie werden nicht hochgeladen. Der Artikel wird ohne Bilder angelegt. Es erscheint keine rote Fehlermedung oben am Bildschirm. Wenn ich aber bei einem bestehenden Artikel die Bilder ?ndern oder hinzuf?gen m?chte, geschieht das gleiche, nur erscheint nachher die Fehlermeldung: Fehler: Artikel k?nnen nicht in der gleichen Kategorie verlinkt werden. So langsam werde ich wahnsinnig. Ich wei? mir nicht mehr zu helfen. Und ich wollte n?chsten Monat online gehen. Vielen Dank im vorraus.
  8. Hallo. Ich m?chte meine product_info um die {$PRODUCTS_SHORT_DESCRIPTION} erweitern. Dazu mu? ich, so wurde es mir gesagt die SQL-Abfrage um die Zus?tze nach Zeile 40 pd.products_description, pd.products_short_description, und nach Zeile 121 $info_smarty->assign('PRODUCTS_SHORT_DESCRIPTION',stripslashes($product_info['products_short_description'])); erweitern m?sse. Alles gut soweit. Aber welche Datei ist f?r die SQL Abfrage verantwortlich. In welcher Datei mu? ich dieses erg?nzen. Habe schon eltiche Durchgeschaut un d nichts gefunden. Dank euch im voraus.
  9. Danke f?r die schnelle Hilfe. Aber wo in welcher datei mu? ich die SQL Abfrage ?ndern. Arbeite mit phpMyAdmin Database Manager Version 2.5.4 und PHP Information Version 4.3.4 Sorry, aber da hab ich gar keine Ahnung. Gru? Axel
  10. Hallo, mu? mal wieder was erfragen. Ich m?chte auf der product_info ein weiteres textfeld rechts neben dem Bild einf?gen da ich noch weitere Informationen hinzuf?gen mu?. Dies wollte ich nun mite der Kurzbeschreibung erreichen. Problem: Wie bekomme ich diese auf die product_info? {$module_data.PRODUCTS_SHORT_DESCRIPTION} habe ich eingetragen, aber es wird nichts angezeigt. Eine Seite zuvor im productlisting ist die Kurzbeschreibung aber zu sehen. Gehe jetzt mal davon aus, da? der Modulbefehl nicht f?r die product_info geeignet ist. Wie konn ich nun die Kurzbeschreibung in die product_info integrieren? Dank an alle?
  11. Hallo zusammen, folgende Frage: Ich m?chte die Eingabefelder der Searchbox, Sofortkaufbox, Loginbox und Newsletterbox farbig gestallten. Wei? aber nicht wie. Bei Eintr?gen in die stylesheet.css bezieht sich die Formatierung immer auf die Tabellenzelle. In den php's der jeweiligen Box finde ich keine Hinweise auf das Aussehen der Felder. Wo kann ich die farbige Gestalltung ?ndern oder wie. Vielen Dank vorab.
  12. Hallo. Geh mal im Hauptverzeichnis von xtcommerce auf /lang/german und ?ffne die Datei german.php. Suche dann nach und ?ndere dies in Ich hatte das gleiche Problem. Hab's dann so gel?st. Hoffe das das die L?sung f?r Dich ist. Tsch?ssi.
  13. Nochmals hallo. Ich m?chte in meinem Shop Filme verkaufen und brauche auf der product_info noch weiter Kreterien; wie z.B. FSK (z.B. Frei ab 12), Hersteller (z.B. Sony), Genre (z.B. Action) und System (z.B. DVD). Diese sollten in einer Tabelle neben der Abbildung stehen. Zugleich sollten diese Angaben einen Link besitzen, der nach allen Produkten dieser Kategorie sucht (z.B. das alle Filme die mit FSK ab 12 ausgezeichnet sind aufgelistet werden). Ist dieses ?berhaupt ohne gro?e Programmierungsarbeiten zu realisieren? Oder gibt es Erweiterungen, die man irgendwo erwerben mu?. Wenn ja, wo? Bin f?r jede Hilfe dankbar.
  14. Hallo zusammen, wiedermal ben?tige ich Hilfe. Wie bekomme ich den Herstellernamen auf die product_info. Ich m?chte nicht die manufacturers_info_box am Seitenrand stehen haben. Es sollte sich neben dem Produktbild auf der product_info stehen. Wie bekomme ich das hin. Dank an alle die immer wieder helfen.
  15. Alles klar. Hat geklappt. Ich Dummerle. Naja, manchmal sieht man den Wald vor lauter B?umen nicht. Danke. Bis zum n?chsten mal.
×
×
  • Create New...