Jump to content
xt:Commerce Community Forum

firefly.com

Members
  • Content Count

    229
  • Joined

  • Last visited

Everything posted by firefly.com

  1. Hallo Zusammen, ich möchte meine Ultimate Version verkaufen. Darf ich das und was muss ich beachten. VG Steffen
  2. ...die Datei liegt dort. Eine Änderung der Einstellungen oder Verkürzung der Cache Zeit ändert leider nichts. :-(
  3. Hallo, früher ging es einfach einen Javascript wie Google Adwords etc. in den Shop einzubinden. Man hat einfach in seinem Template die Datei js.php im Ordner Javascript aufgerufen, den Code eingegeben und Javascript hat funktioniert. Seit dem Update auf 4.1 existiert kein Beispiel mehr für eine erfolgreiche Integration. Ich habe folgendes in der js.php versucht: $xtMinify->add_resource(_SRV_WEB_TEMPLATES . _STORE_TEMPLATE.'/javascript/xxx.js',100); $xtMinify->add_resource(_SRV_WEB_TEMPLATES . _STORE_TEMPLATE.'/javascript/script.js',160); $xtMinify->add_resource('xtFramework/library/jquery/pikaday.jquery.min.js',200); $xtMinify->add_resource('xtFramework/library/jquery/moments.js',220); ?> Dann habe ich im selben Ordner eine Datei mit dem Namen xxx.js erstellt und den Code dort eingebettet. Was passiert - nichts! Also wie kann man ein Javascript erfolgreich eintragen? VG Steffen
  4. ...vielen Dank. Jetzt noch einmal für Nichtprogrammierer. Ich hätte die <div id="clickme"></div> um meinen "Company-Bereich" in der templates/xt_grid/xtCore/pages/login.html untergebracht. Mit dem PHP Code komme ich nicht zurecht. Den baue ich in der /xtCore/customer.php oder /xtCore/pages/customer.php ein? Ich hätte es an dieser Stelle versucht... $( "#clickme" ).click(function() { $( "#hideme" ).toggle( "slow", function() { $customer_tpl_data = array('show_company'=> _STORE_ACCOUNT_COMPANY == 'true' ? 1:0, . . . // Animation complete. }); }); Aber das klappt nicht. VG Steffen
  5. Hallo, die meisten unserer Kunden sind Endkunden. Ich möchte in der login.html eine Checkbox einbauen. Wenn der Check "Firma" aktiviert wird, sollen die Firmendaten sichtbar werden. Ist das mit html umsetzbar, oder muss hier Javascript her? VG Steffen
  6. :-) darauf wäre ich nicht gekommen. Hatte schon überall gesucht. Danke!!! VG Steffen
  7. Danke schön. Manchmal sieht man den Wald vor lauter Bäumen nicht. :-)
  8. Hallo xtLer, ich finde die Stelle nicht, an der ich sagen kann, dass die Versandkostenauswahl vor dem Text (content Versandkosten) erscheinen sollen. Ich nutze das xt-grid. Danke für Hinweise Steffen
  9. Hallo xtLer, ich finde die Stelle nicht, an der ich sagen kann, dass die Bilder von der Startseite vor dem Text (content Startseite) erscheinen sollen. Ich nutze das xt-grid. Danke für Hinweise Steffen
  10. Hmm, sobald ich hinter meineseite.de das "/de" setze, funktioniert die Weiterleitung überhaupt nicht. RewriteCond %{HTTP_HOST} ^(.*)meineseite.de/de$ [NC] RewriteRule ^(.*)$ https://www.meineseite.com/$1 [L,R=301] Wäre es besser, wenn ich die .de Domain einfach aus meinem Shop entferne, einen neuen Ordner auf dem Server anlege und im httpdocs Ordner die htaccess mit der Umleitung anlege und den Apache neu starte? VG Steffen
  11. Hatte den Fehler mit der fehlerhaften Auflösung schon jemand? Liegt das am Multimandantensystem?
  12. Hallo erfahrene Nutzer, Google straft meine Webseiten wegen duplicate Content ab und ich möchte jetzt einen Shop von meinem Multishopsystem auf eine andere Domain umleiten lassen. In der .htaccess kann ich jetzt eine dauerhafte Weiterleitung von www.meineseite.de auf www.meineseite.com mit der 301er Umleitung einleiten. Leider würden dann alle Unterseiten die Google von der .de Domain gelistet hat auf die .com Hauptseite leiten. Ich dachte, dass ich das auch so managen kann, dass er einfach von www.meineseite.de/de/kategorie1 auf www.meineseite.com/de/kategorie1 routet. Wenn ich das aber versuche, dann kommt der folgende Linkaufbau: www.meineseite.com/index.html/kategorie1 ??? Woher kommt diese "index.html" Ausgabe? Das ist der Teil in meiner .htaccess: RewriteCond %{HTTP_HOST} ^(.*)meineseite.de$ [NC] RewriteRule ^(.*)$ https://www.meineseite.com/$1 [L,R=301] Vielen Dank für eure Unterstützung! VG Steffen
  13. Hallo Dennis, vielen Dank. Hab alles gefunden. Wenigstens einer, der hier hilfsbereit ist. :-) LG Steffen
  14. Hallo, unter unseren Masterartikeln kann man die Slaves über den Reiter "Bitte wählen Sie die gewünschte Größe" auswählen. Dort werden alles Slaves gelistet, doch leider fehlt die Anzeige der Grundpreise. Wenn ich die Zeile: <p class="product-base-price">{$module_data.base_price.formated} {txt key=TEXT_SHIPPING_BASE_PER} {$base_price.vpe.name}</p> in die Html vom Slave Plugin (ms_product_list_default.html) eintrage, dann erscheint nur der Texttrenner "/" und nichts weiter. Kann mir jemand erklären an welche Stelle ich sonst den Grundpreis eintragen muss, wenn nicht in die ms_product_list_default.html? VG Steffen Version 4.1.1
  15. Hallo, ich möchte die Option "Ich möchte als Gast bestellen" als Vorauswahl beim Kundenlogin haben. Leider weiß ich nicht, wo genau die Anpassung vornehmen muss. Weiterhin interessiert mich, wie ich das Feld "E-Mail-Adresse bestätigen" weg bekomme. Wenn ich es "ausblende" kommt der Hinweis, dass die bestätigte Email nicht der ersten Email entspricht. In welcher .php finde ich diese Daten. Hintergrund ist der, dass es unnötige Arbeit für den Kunden ist und der Kunde copy + paste verwendet. Die erste Adresse wird also einfach falsch übernommen. Danke Steffen Version 4.1.1
  16. Hallo, seit Umstellung des Shopsystems auf die Version 4.1 erscheint als Land in den Bestellungen, ab und zu "Alabama, Deutschland". Es kam auch schon vor, dass das amerikanische Bundesland bei Dänemark oder den Niederlanden enthalten war. Kennt jemand den Fehler oder könnte er von der PayPal Schnittstelle oder dem Update auf die Version 4.1 kommen? VG Steffen PayPal 2.1.0
  17. Hallo Leute, vielleicht habt ihr ja eine Idee. Unser SEO hat uns gerade darauf aufmerksam gemacht, dass der Canonical von der Startseite auf den folgenden Link verweist: <link rel="canonical" href="http://www.unsershop.de/de/index" /> Wenn ich diesen Link in die Adresszeile eingebe, lande ich auf einer 404 Seite. Das ist für einen Canonical ziemlich kontraproduktiv. Wir hatten bislang die Canonical Version 1.0.1 im Einsatz. Diese habe ich heute gegen die aktuelle Version 1.0.3. ausgetauscht. Leider ergab dies keine Änderung. Was kann man da machen? Soll ich einen Redirect festlegen? In den Unterkategorien wird der Canonical wie folgt angezeigt: http://www.unsershop.de/de/Beispiel-Kategorie Ist Zustand: <link rel="canonical" href="http://www.unsershop/de/Beispiel-Kategorie?cat=582'>http://www.unsershop/de/Beispiel-Kategorie?cat=582" /> Wie bekomme ich die Anzeige der Kategorie ID aus dem Canonical? Soll-Zustand <link rel="canonical" href="http://www.unsershop/de/Beispiel-Kategorie" /> ??? Vielen Dank Steffen xt-Version Ultimate 4.0.16
  18. ...Auch eine Installation einer älteren Version vom Modul brachte keine Besserung. Der Support kannte das Problem bereits und es soll in der nächsten Version des Plugins behoben werden. Die aktuelle Version 1.0.6 ist also defekt. Gruß Steffen
  19. Hallo Leute, ich habe heute die letzten beiden Shopupdates von 4.0.14 auf 4.0.15 und 16 durchgeführt. Die Module PayPal und xtPayments habe ich nach dem Update gelöscht und neu eingespielt. Jetzt kann ich die Reihenfolge von xtPayments zwar im Backend anpassen, aber in meinen Frontend bleibt xtPayments immer auf Platz eins. Auch wenn ich andere Zahlungsarten wie z.B. Vorkasse oder Paypal auf 0 oder -1 setze, dann bleibt xtPayments im Frontend beim Checkout oben stehen. Ist das von xt so gewollt? Hat noch jemand dieses Problem? Gruß Steffen
  20. Hallo Britta, jetzt hat es geklappt. Einen Test kann ich erst später machen. Die Antwort die ich erhalten habe, lautet: "...Zum einen ist das Updatescript bei Ihnen nicht komplett durchgelaufen...und zum anderen scheint der Ordner /conf/ nicht ausgetauscht worden zu sein. (Nur die Datei /conf/config.php darf nicht überschrieben werden)..." Viele Grüße Steffen
  21. Hallo Britta, hab deine Nachricht gerade erst gelesen. Den Frontend hatte ich noch nicht getestet. Bin gleich zurückgerudert und hab das scharfe System zurückgesetzt. Ich habe jetzt dem Support meine Daten geschickt. Bin gespannt ob die was finden. VG Steffen
  22. Hallo Leute, ich habe gerade versucht das Update von 4.0.14 auf 4.0.15 einzupflegen. Dazu bin ich nach der Anleitung vorgegangen und habe erst die Datenbank aktualisiert und dann die neuen Dateien eingespielt. Gehe ich jetzt in das Backend und klicke auf "Bestellungen" oder "Kunden" sehe ich nichts. Es kommt nur eine weiße Seite. Ich habe danach alle Dateien zurückgespielt und die Datenbank zurückgesetzt. Nachdem ich alle Schritte noch einmal durchgegangen bin, komme ich darauf, dass die Datei xtFramework\classes\class.countries.php diesen Fehler hervorruft. In der Updateanleitung steht bezüglich einer weiße Seite: "Dieses ist ein klares Zeichen für einen Fehler innerhalb der Smarty-Syntax. Prüfen Sie alle Änderungen erneut". Der Hinweis bezieht sich bestimmt auf den Frontend. Woher bekomme ich eine funktionierende Datei, damit die Bestellungen und Kunden im Backend auch sichtbar sind? VG Steffen
  23. Ich habe gerade versucht die Lösung von ChristianGr einzusetzen. Geht bei mir nicht. Ich bekomme nur eine weiße Seite und der Shop geht nicht mehr. Vielleicht ist es den Programmierern entgangen, aber ein Enddatum ist wirklich wichtig. Setzt man dieses bei Sonderpreisen nicht, dann geht man das Risiko einer Abmahnung ein. Sonderpreise müssen laut Preisangabenverordnung zwingend ein Enddatum haben! VG Steffen
×
×
  • Create New...