Jump to content
xt:Commerce Community Forum

webwalkers

Members
  • Content Count

    32
  • Joined

  • Last visited

  1. Hallo, ich wäre auch an dem Modul interessiert. Gruß Andi
  2. Hallo, hast Du dafür schon eine Lösung gefunden? Bei Pandaro lösen die das mit Javascript, ist aber SEHR unglücklich. Könnte man auch mit PHP machen in dem man bei Klick auf den Reiter eine Variable mit übergibt. Naja soweit so gut aber der Anfang zum Einrichten fehlt mir noch. Gruß Andi
  3. Ja hast ja recht, war nur so ungeduldig. Gruß Andi:rolleyes:
  4. Also nachdem mir hier keiner helfen konnte habe ich mich durch den PHP Code gewühlt und ein strpos($_POST['shipping'], '_' gefunden. Meine zusätzlichen Module hiessen table_eu und table_non_eu. Das war der Fehler. Habe jetzt überall die _ in der Datei und den Dateinamen entfernt und es klappt einwandfrei. Gruß Andi
  5. Hallo, weiss keiner Rat wo die tables.php evt. noch abgefragt wird? Installiert habe ich alle drei Tabellarsiche Versandkosten und da ich ja keine Fehlermeldungen bekomme und der Versandbetrag auf der checkout_shipping richtig angegeben wird scheine ich nicht alles verkehrt gemacht zu haben. Kann es evt. sein das die Versandkostenart zwar richtig angezeigt wird aber beim Klick auf Weiter nicht als Auswahl übernommen wird? Hmm brächte nur einen Ansatzpunkt. Gruß Andi
  6. Hallo, habe ein Problem mit den Tabellarischen Versandkosten. Da wir drei Zonen im Shop haben müssen und die Versandkostenstaffelungen nach Warenwert gehen brauche ich die tabellarsichen Versandkosten 3 mal. Also habe ich die table.php 2x dubliziert und alles table in den beiden neuen Datein entsprechend umbenannt. Die Language Dateien habe ich auch entsprechend angepasst und editiert. Funktioniert soweit einwandfrei, jedoch komme ich jetzt bei den beiden neuen Zonen nicht mehr über die checkout_shipping hinaus. Er zeigt mir dort die richtigen Versandkosten an, jedoch gelange ich beim Klick auf den Weiter-Button immer wieder auf die selbe Seite checkout shipping. Weiss jemand ob ich die beiden neuen Module der tabellarischen Versandkosten noch sonst irgendwo eintragen muss damits funktioniert? Gruß Andi
  7. Hallo, die Frage wurde schon einige Male gestellt, aber ich konnte keine Antwort finden. Ich möchte in Product_info unten die weiteren Produkte dieser Kategorie anzeigen und zwar 6 auf einer Seite mit Blätterfunktion. Beim Blättern wird immer das selbe Produkt in der Detailansicht angezeigt nur die produkte unten werden durchgeblättert. Hat jemand einen Lösungsansatz für mich? Könnte man dafür nicht einfach die new_products.php nehmen und die etwas umschreiben? Mit freundlichen Grüßen webwalkers
  8. Juhuu habs gelöst. Also ich habe die Foreach Schleife gedoppelt. In der einen gebe ich jetzt ein Javascript-Array mit allen Elementen aus, in der anderen die alte Anzeige der Randomprodukte mit dem Unterschied das ich um jeden HTML Bereich noch einen div gesetzt habe mit einer indivbiduellen Kennzeichnung also produktcontainer1 und produktcontainer 2. Unten im Modul rufe ich dann eine Javascriptfunktion auf die zwei Zufallszahlen generiert und dann mittels document.getElementById('topcontainer1').innerHTML die Inhalte der beiden Topproduktbereich austauscht. Das Ganze hat den Vorteil das ohne Javascript beim User halt nur nach wie vor die beiden Randoprodukte ex PHP gezeigt werden halt ohen Rotation. Bei Interesse am Code bitte PM an mich. Gruß Andi
  9. Hallo, habe mir das Random Products Modul installiert und angepasst. Funktioniert wunderbar. Gibt es eine Möglichkeit einzelne Module von XT-C zu refreshen ohne die Seite neu zu laden. Da PHP Serverseitig ist fällt mir dazu keine Lösung ein. Oder gibt es eine Möglichkeit mit Javascript das zu lösen. Das komplette Foreeach jedoch mit document.wright neu zu schreiben scheint mir recht unsinnig. Gruß Andi
  10. Vielen dank für die prompte Hilfe. Hat wunderbar funktioniert. Gruß Andi
  11. Hallo, ich habe ein kleines Problem mit der Seitennavigation innerhalb der Produkte einer Kategorie. Es werden die Seiten unten angezeigt jedoch ist hier der Link falsch. Als Link wird angzeigt: http://www.meinedomain.de/index.php/category/Ersatzteile-aussen-liegend/page/2 Dieser Link führt zur Shopstartseite. Richtig wäre: http://www.meindedomain.de/index.php/cPath/20/category/Ersatzteile-aussen-liegend/page/2 Weiss jemand wo man das editieren kann? Hab in der split_page_result.php geguckt aber das blick ich beim zumsammensetzen des Links nicht ganz durch. Gruß Andi
  12. Hallo, gibts es eine Möglichkeit die Produktattribute als Pflichtfeld einzubauen? Hintergrund ist das ich einen Shop habe über den ein Pizzaservice verwaltet wird und der Kunde muss bei bestimmten Produkten ein Attribut auswählen wie z.B. eine bestimmte Zutat. Ich habe das Checked rausgenommen aber er prüft nicht ob eins der Attribute ausgewählt ist sondern packt einfach ohne Attribut in den Warenkorb. Gruß Andi
  13. Hallo das Modul gibt es, ist auch installiert und tabellarische Versandkosten eingegeben. Im Shop geht das auch aber nicht bei Bestellungen über den Adminbereich. Da muss man die VK manuell eintragen. Ich habe den ganze Bestellvorgang über das Backoffice selbst umprogrammiert und vereinfacht. Kunden suchen bzw. anlegen, Neue Bestellung, Bestellung bearbeiten, Artikel hinzufügen, speichern und drucken. Habe einige Zwischenschritte einfach übersprungen. Klappt wunderbar. Aber trotzdem danke für die Antwort. Gruß Andi
  14. Hat niemand einen Anhaltspunkt für mich? ich bin doch bestimmt nicht der einzige der dieses Problem hat... Gruß Andi
  15. Hallo, habe mein System (Pizzaservice) jetzt so am laufen das über den Adminbereich Bestellungen aufgegeben werden können und nach Speichern eine Mail an mich rausgeht. Problematisch sind die Versandkosten, Die müssen auch mit auf die Rechnung und da das Ganze über ein CallCenter läuft wäre eine Funktion nötig, die die im Shop eingestellten, gestaffelten Versandkosten automatisch der Bestellung bzw. der Rechnung hinzufügt. Manuell geht das natürlich indem ich bei Bestellung bearbeiten auf Versandkosten, Zahlungsweisen, Währungen, Sprachen usw bearbeiten und einfügen klicke und die dort eintrage. Aber bei CallCenter ist Zeit = Geld und somit sollte der Schritt entfallen. Hat da jemand einen Ansatz für mich? Gruß Andi
×
×
  • Create New...