Jump to content
xt:Commerce Community Forum

wolkenkraft.com

Members
  • Content Count

    87
  • Joined

  • Last visited

About wolkenkraft.com

  • Rank
    Benutzer

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hallo iTV, Ich habe den Thread erst jetzt gesehen, daher die verspätete Antwort. Prinzipiell erhält bei uns jeder Kunde sehr umfangreichen Support und Unterstützung bei Problemen mit der Installation der von uns angebotenen Produkte. Das haben Sie Eingangs ja auch mit Ihrem Hinweis ("..sehr bemüht") bestätigt. Was wir leider nur in beschränktem Ausmaß anbieten können ist die kostenfreie Grundlagen-Schulung in CSS und HTML5. Liebe Grüße, Michael Fürst
  2. Hallo iTV, Ich habe den Thread erst jetzt gesehen, daher die verspätete Antwort. Prinzipiell erhält bei uns jeder Kunde sehr umfangreichen Support und Unterstützung bei Problemen mit der Installation der von uns angebotenen Produkte. Das haben Sie Eingangs ja auch mit Ihrem Hinweis ("..sehr bemüht") bestätigt. Was wir leider nur in beschränktem Ausmaß anbieten können ist die kostenfreie Grundlagen-Schulung in CSS und HTML5. Liebe Grüße, Michael Fürst
  3. Soweit ich jetzt rausfinden konnte, dürfte es am Plugin selbst liegen, dass das Main-Template nicht nach einem vorhandenen Subtemplate durchsucht. Falls jeman das gleiche Problem hat, hier ein WorkAround: https://www.wolkenkraft.com/de/post/bug-in-xt_ship_and_track-plugin-template-account_history_infohtml-ueberladen
  4. Guten Morgen zusammen, Ich kämpfe derzeit mit dem Überladen des xt_ship_and_tack plugin Templates in meinem eigenen Template. Das Überladende Template File liegt in folgendem Verzeichnis (identisch wie bei allen anderen Plugins): /templates/<template>/plugins/xt_ship_and_track/pages/account_history_info.html Das Vorhandensein dieses Subtemplates lässt xt:Commerce allerdings kalt - es wird stets das Template aus dem Pluginverzeichnis gezogen. Habt Ihr vielleicht einen Tipp (anderer Pfad!?) für mich? Danke vorweg & einen schönen Arbeitstag, Mike
  5. Hallo Community, Ich habe bei einem Template das Problem, dass die Auswahl bei mehreren Attributen in allen Browsern außer Firefox funktioniert. Mein aktueller Wissenstand: Wählt man die Attribute aus, wird deren Wert in einer Session am Server gespeichert. Sind alle Attribute beim Master Artikel korrekt gewählt , wird der Client per 302 auf die entsprechende Slave-Artikel Seite umgeleitet. Der Server schickt bei allen Browsern den 302 Redirect (+ location im response header), nur bei Firefox erhalte ich als Antwort stehts einen 200 und damit wieder die Master-Artikel Seite (keine Weiterleitung). Mit dem Original-Template xtgrid gibt es das Problem im Übrigen nicht. Ich habe wirklich schon alles kontrolliert aber ich fürchte ich sehe den Wald vor lauter Bäumen nicht mehr: Request Header bei beiden Themes identisch Post Parameter bei beiden Themes identisch Cookies bei beiden Themes identisch Langsam bin ich mit meinem Latein etwas am Ende. Vielleicht hat jemand einen Einfall oder hatte schon ein ähnliches Problem!? System Version: 4.1.10 Danke Euch im Voraus & liebe Grüße, Michael
  6. Hallo, Ich habe hier das Problem, dass ich gerne das Template des xt_ship_and_track Plugins mit meinem eigenen Design im Template überladen möchte. Das funktioniert bei allen Plugins problemlos außer bei diesem. Templatefile im Plugin: /plugins/xt_ship_and_track/templates/pages/account_history_info.html Templatefile im Template (überlädt das Original) /templates/<template>/plugins/xt_ship_and_track/pages/account_history_info.html Das sollte (folgt man den Konventionen aller anderen Plugins) funktionieren - es will schlichtweg aber nicht. Der einzige Unterschied der mir aufgefallen ist, ist das Unterverzeichnis "pages", das in den anderen Plugins nicht genutzt wird. Hat jemand eine Idee? Oder vl. auch das gleiche Problem? Bitte keinen Vorschlag wie "Ändere es einfach im Plugin" - das wäre nicht zielführend Danke Euch vorweg & LG
  7. Hi, Die Source files (zumindest die von Version 4.1.00) sind noch mit einer Encoderversion verschlüsselt, die PHP 5.5 nicht unterstützt. Es ist also kein Problem des Loaders, sondern des Encoders: [Sun Jun 15 13:03:53 2014] [error] [client x.x.x.x] PHP Fatal error: The file /xtc-4.1.00/index.php was encoded by the ionCube Encoder for PHP 5 and cannot run under PHP 5.5.\n Please ask the provider of the script to provide a version encoded with the ionCube Encoder for either PHP 5.3 or PHP 5.4 or PHP 5.5. in Unknown on line 0. Nachdem es diese Version (5.5) bereits seit einem Jahr gibt, wäre ein entsprechendes Upgrade dringend nötig. EDIT: Gerade gesehen/getestet - 4.1.10 wurde schon mit einer neuen Encoderversion verschlüsselt. LG
  8. Hi, Auch korrekt, aber genau das war meine Frage. Welche Parameter können für die Felder über die _getParams() Methode definiert werden? Leider ist das weder über die default_table Klasse noch über das Wiki/Manual/Confluence festzustellen... LG
  9. Guten Morgen, Ich arbeite derzeit an einem Plugin um einen Slider dynamisch gestalten zu können. Dieses Plugin ermöglicht in der Administration das Festlegen der einzelnen Slides und den Upload von Images pro Datensatz. Der Administrations-Teil ist von der Klasse "default_table" geerbt, nutzt also die klassische Tabellen-Darstellung sowie das automatisierte Bearbeiten der Datensätze. Eines der Felder eines solchen Datensatzes, soll nun ein Bild sein. Leider finde ich weder in der Doku noch im Source im Moment heraus, wie dieses Feld definiert werden muss, damit der Upload funktioniert. Nach Möglichkeit sollen die Bilddaten auch direkt im Plugin Ordner gespeichert werden (Keine Nutzung der Media Library). Die Methode zum Definieren der Parameter sieht im Moment so aus - das Feld um das es geht ist "image_filename": function _getParams() { global $language, $xtPlugin; $header=array(); $params=array(); $params['display_checkCol'] = true; $params['display_statusTrueBtn'] = true; $params['display_statusFalseBtn'] = true; $params['display_newBtn'] = true; $header['id'] = array('type' => 'hidden'); $header['target_url'] = array('type' => 'textfield'); $header['created'] = array('type' => 'hidden'); $header['image_filename'] = array('type' => 'file'); $params['header'] = $header; $params['master_key'] = $this->_master_key; return $params; }[/PHP] In diesem Fall wird zwar für "Image Filename" in der "Bearbeiten" Ansicht des Datensatzes ein Dateiupload-Element angezeigt, aber es ist scheinbar keinerlei Funktion hinterlegt. Es gibt hier sicher noch eine Menge Parameter (zB. Upload-Ziel) die definiert werden können, leider habe ich weder in der Doku noch im Source noch in den Manuals irgendwelche Hinweise gefunden. Vielleicht hat ja jemand einen Tipp für mich, vielen Dank & LG Mike
  10. Hi Alex(s), @Alexsm: Sorry, dass meinte ich nicht - dennoch danke @[email protected]: Wie unterscheidest Du, wenn der Pluginname (der ja eindeutig ist) als Identifikator genutzt wird? Ein Plugin kann ja nur einen Namen/ID haben - somit wäre für mich schlüssig, dass ich nur eine Box innerhalb eines Plugins laden kann. Beispiel: Pluginname (verzeichnisname): /mein_plugin PHP File für Box: /mein_plugin/boxes/mein_plugin.php Template für Box: /mein_plugin/templates/boxes/box_mein_plugin.html Vielleicht hast Du noch einen Tipp für mich.. Danke vorweg & LG
  11. Hallo, Ist es möglich mit einem Plugin mehrere unabhängige Boxen zu erstellen? Mir ist bislang nur die automatisch Auflösung über den Name bekannt und ich konnte leider auch nichts anderes finden. Vielleicht hat jemand einen Tipp? Danke & LG Michael
  12. Hi, Kennt jemand eine Möglichkeit, wie ich auf das Currency Objekt (das soweit ich das sehe immer die aktuell gewählte CurrencyId enthält) aus dem Template zugreifen kann? Gibt es diese Möglichkeit oder ist die Umsetzung über ein zusätzliches Plugin, dass das Objekt in eine Smarty-Variable mapped, nötig? Danke im Voraus & LG Michael
  13. So liest man sich mal wieder. Danke für die Hilfe - der passt...
  14. Hallo, Ich möchte Smarty gerne mitteilen, dass es neben dem Standardverzeichnis "plugins" ein zusätzliches Verzeichnis in meinem Template als Settings im Parameter "plugins_dir" übernimmt. An sich ja eine recht einfache Übung, allerdings finde ich keinen Hook, wo ich diese Zuweisung global einhängen kann. Sämtliche Versuche sind bisher gescheitert, weil ich das Smarty Objekt das schlußendlich im Tempalte landet über keinen Hook erwische. Hier die Zuweisung des zusätzlichen Plugin Directories: $template->content_smarty->plugins_dir=array('plugins',$template->content_smarty->template_dir.'/wolkenkraft_rainbow/smarty');[/PHP] Vielleicht hat jemand einen Tipp, in welchen Hook ich die ganze Sache hängen kann...!? Danke & LG Michael
  15. Hi, Puh, das ist schon lange her.. Ich glaube das Problem war, dass der Parameter ENABLED in der DB nicht gesetzt war. Der ist Pflicht, sonst geht gar nix. LG Mike
×
×
  • Create New...