Jump to content
xt:Commerce Community Forum

smeyli

Members
  • Content Count

    9
  • Joined

  • Last visited

About smeyli

  • Rank
    Neuer Benutzer
  • Birthday 06/12/1977

Converted

  • Biografie
    Das Wichtigste ist ein Ziel - der Weg findet sich schon irgendwie...
  • Beruf
    Webdesigner
  1. das ist schön, daß dieses problem nun endlich gelöst scheint!!!! Hoffentlich hilft es auch den anderen vielen Usern, die probleme mit dem Admin-Login haben...
  2. @kird_ape ich hatte auch dieses problem: anmeldung als admin und wieder beim kundenlogin gelandet ... ich wußte keinen rat mehr und habe mich einfach an meinen provider gewendet, da ich die vermutung hatte, daß es nicht mehr in meinder macht lag. diese haben dann etwas an der benutzertabelle geschraubt (ich weiß aber nicht was, da hinterher alles so aussah wie vorher) danach ging dann wieder alles problemlos. ich nehme an, daß ich als admin gelöscht und per hand neu angelegt wurde. ich würde mal folgendes versuchen. registriere dich als neuer nutzer, und gebe dir in phpmyadmin einfach admin-rechte. vielleicht ist das der schlüssel zur problemlösung... alle anderen (abenteuerlichen) maßnahmen funktionierten bei mir auch nicht. poste mal, ob's erfolg gebracht hat... viele grüße, smeyli
  3. ich hatte auch das problem, nachdem ich meine domain umgestellt habe. auch die zahlreichen posts in diesem forum halfen nichts - weder config-einstellungen, noch datenbank-veränderungen. nun habe ich mich vertrauensvoll an den support von "all inkl" gewendet und siehe da - ES GEHT WIEDER. Nun wollte ich aber auch wissen, was die gemacht haben. die haben irgendwas am customer-table umgestellt (admin-eintrag). ich kann jedoch keine veränderungen sehen. nun bleibt ein kleines rätsel offen, doch das nehme ich gerne in kauf, wenn die ursprünglichen funktionalitäten wieder hergestellt sind. noch eine anmerkung: ich habe noch nirgendwo einen so guten und freundlichen support genossen wie bei "all inkl".
  4. smeyli

    Stylessheet

    ich habe es so gemacht, daß ich im firefox einfach die entsprechenden stellen markiert und den auswahlquelltext anzeigen lassen habe. dann siehst du ja alle klassen und ids. nach diesen dann im css-file suchen und durch eigene farben ersetzen. background-grafiken einfach durch hex-code ersetzen oder die rgb-schreibweise. in jedem ordentlichen fotoprogramm siehst du den zugehörigen code zur farbe. somit sollte es ein leichtes sein... tipp: in Firefox gibt es ein plugin speziell für css (zum anzeigen) - ich benutze dieses teil ständig - gibt's auf erweiterungen.de viele grüße
  5. habe dazu, wie so viele andere, vor kurzen auch einen thread dazu geschrieben - mit dem selben login-problem. domain umgestellt - alles läuft problemlos (bestellungen, kunden-login ...) bis auf den admin-login... mittlerweile habe ich das forum hier nach lösungen durchforstet und alles mögliche ausprobiert. hier einige dinge, die nichts gebracht haben: - sessions in DB speichern - suchmaschinenfreundliche URLs ein/aus - verschiedene session-einstellungen - verschiedene chache-einstellungen - browser-cache + temp geleert - verschiedene browser getestet - quellcode in verschiedenen files auskommentiert - hoffen ich bin nun mit ideen und probierereien auch am ende. kann es evtl. am provider liegen. vielleicht wird irgendwas in der datenbank selbst gecached? diesen cache kann ich leider nicht leeren, da die rechte an dieser stelle fehlen... jetzt überlege ich, ob ich von 3.0.2 auf 3.0.4 umsteige. doch wie bekomme ich die daten dann in den neuen shop? sehen die tabellen genauso aus oder sind diese anders?
  6. es funktioniert immernoch nicht. habe jetzt alle 4 configures nochmal kontrolliert - ist meiner ansicht nach alles korrekt. jetzt habe ich die sessions im SESSION-table gelöscht - ohne erfolg. kann denn noch irgendwo etwas zwischengespeichert sein??? der shop liegt in meiner webpräsenz unter /xtcommerce/ die domain hat vorher erst auf das root-verzeichnis gezeigt. Jetzt zeigt sie direkt in das xtcommerce-verzeichnis. Alles funktioniert bis auf den admin-login. rufe ich .../admin/start.php springt der shop auf account.php um. hier einfach mal die configures-listings... frontend: define('HTTP_SERVER', 'http://www.anti-kultur.de'); // eg, Default PLESK Page - should not be empty for productive servers define('HTTPS_SERVER', 'http://www.anti-kultur.de'); // eg, https://localhost - should not be empty for productive servers define('ENABLE_SSL', false); // secure webserver for checkout procedure? define('DIR_WS_CATALOG', ''); // absolute path required define('DIR_FS_DOCUMENT_ROOT', '/www/htdocs/w0076775//xtcommerce/'); define('DIR_FS_CATALOG', '/www/htdocs/w0076775//xtcommerce/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ORIGINAL_IMAGES', DIR_WS_IMAGES .'product_images/original_images/'); define('DIR_WS_THUMBNAIL_IMAGES', DIR_WS_IMAGES .'product_images/thumbnail_images/'); define('DIR_WS_INFO_IMAGES', DIR_WS_IMAGES .'product_images/info_images/'); define('DIR_WS_POPUP_IMAGES', DIR_WS_IMAGES .'product_images/popup_images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES',DIR_FS_DOCUMENT_ROOT. 'includes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_FS_CATALOG . 'lang/'); define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); define('DIR_FS_INC', DIR_FS_CATALOG . 'inc/'); // define our database connection define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers define('DB_SERVER_USERNAME', '**********'); define('DB_SERVER_PASSWORD', '**********'); define('DB_DATABASE', '**********'); define('USE_PCONNECT', 'false'); // use persistent connections? define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql' admin: define('HTTP_SERVER', 'http://www.anti-kultur.de'); // eg, Default PLESK Page or - https://localhost should not be empty for productive servers define('HTTP_CATALOG_SERVER', 'http://www.anti-kultur.de'); define('HTTPS_CATALOG_SERVER', 'http://www.anti-kultur.de'); define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module define('DIR_FS_DOCUMENT_ROOT', '/www/htdocs/w0076775//xtcommerce/'); // where the pages are located on the server define('DIR_WS_ADMIN', 'admin/'); // absolute path required define('DIR_FS_ADMIN', '/www/htdocs/w0076775//xtcommerce/admin/'); // absolute pate required define('DIR_WS_CATALOG', ''); // absolute path required define('DIR_FS_CATALOG', '/www/htdocs/w0076775//xtcommerce/'); // absolute path required define('DIR_WS_IMAGES', 'images/'); define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/'); define('DIR_FS_CATALOG_ORIGINAL_IMAGES', DIR_FS_CATALOG_IMAGES .'product_images/original_images/'); define('DIR_FS_CATALOG_THUMBNAIL_IMAGES', DIR_FS_CATALOG_IMAGES .'product_images/thumbnail_images/'); define('DIR_FS_CATALOG_INFO_IMAGES', DIR_FS_CATALOG_IMAGES .'product_images/info_images/'); define('DIR_FS_CATALOG_POPUP_IMAGES', DIR_FS_CATALOG_IMAGES .'product_images/popup_images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/'); define('DIR_WS_CATALOG_ORIGINAL_IMAGES', DIR_WS_CATALOG_IMAGES .'product_images/original_images/'); define('DIR_WS_CATALOG_THUMBNAIL_IMAGES', DIR_WS_CATALOG_IMAGES .'product_images/thumbnail_images/'); define('DIR_WS_CATALOG_INFO_IMAGES', DIR_WS_CATALOG_IMAGES .'product_images/info_images/'); define('DIR_WS_CATALOG_POPUP_IMAGES', DIR_WS_CATALOG_IMAGES .'product_images/popup_images/'); define('DIR_WS_INCLUDES', 'includes/'); define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_WS_CATALOG. 'lang/'); define('DIR_FS_LANGUAGES', DIR_FS_CATALOG. 'lang/'); define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/'); define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/'); define('DIR_FS_INC', DIR_FS_CATALOG . 'inc/'); // define our database connection define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers define('DB_SERVER_USERNAME', '**********'); define('DB_SERVER_PASSWORD', '**********'); define('DB_DATABASE', '**********'); define('USE_PCONNECT', 'false'); // use persisstent connections? define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql' Ich bin über jeden tipp dankbar, da ich unbedingt im admin-bereich arbeiten muß. Vielen Dank im vorraus.
  7. danke für die antwort. ich habe beide configure.php und beide configure.org.php (also frontend + admin) geändert. dabei habe ich die absoluten pfade "umgebogen" define('HTTP_SERVER', 'http://www.anti-kultur.de'); define('HTTPS_SERVER', 'http://www.anti-kultur.de'); define('ENABLE_SSL', false); define('DIR_WS_CATALOG', '/xtcommerce/'); // vorher define('DIR_WS_CATALOG', '/'); // nachher define('DIR_FS_DOCUMENT_ROOT', '/www/htdocs/w0076775//xtcommerce/'); define('DIR_FS_CATALOG', '/www/htdocs/w0076775//xtcommerce/'); diese änderung natürlich in allen 4 configures.
  8. Ich komme nicht mehr weiter, habe schon einiges probiert... Nachdem ich meine Domain direkt ins xtcommerce-verzeichnis gelinkt habe, kann ich mich nicht mehr als admin anmelden, sondern werde behandelt, wie ein "normaler" kunde. mein admin-eintrag ist aber noch als solcher vorhanden... Vor dieser Umstellung lief der Shop tadellos. Folgende anpassungen habe ich nach der domain-Umstellung vorgenommen: bei beiden configure.php & configure.org.php habe ich den relativen pfad rausgenommen, damit der shop wieder normal läuft, sprich aus "/xtcommerce/" -> "/" gemacht. die physikalischen pfade habe ich so gelassen. dann habe ich nach recherchen hier im forum store_sessions auf mysql gesetzt define('STORE_SESSIONS', 'mysql'); doch auch danach war ich kein admin. nach weiteren recherchen im forum habe ich nun im configuration table die urls nicht mehr suchmaschinenfreundlich gestaltet (auf false gesetzt) - (sehe dabei aber keine logik), doch probieren... hat jemand einen tipp, was ich noch tun kann? evtl. sessions löschen? oder? habe ich irgendwo etwas vergessen? viele vielen dank im voraus...
  9. Hallo, dies ist mein erster post in diesem forum - bis jetzt konnte ich mir immer durch lesen helfen, doch nun bin auch ich mal an einer stelle, an der ich nicht weiterkomme... bei der backup-funktion im backend kommt nach etwa 1-2s folgende fehlermeldung: Warning: exec() has been disabled for security reasons in /www/htdocs/w0076775/xtcommerce/admin/backup.php on line 156 Warning: Cannot modify header information - headers already sent by (output started at /www/htdocs/w0076775/xtcommerce/admin/backup.php:156) in /www/htdocs/w0076775/xtcommerce/admin/includes/functions/general.php on line 146 mein shop liegt auf einem shared-server (wenige kunden) mit ausreichend ressourcen (wegen skript-laufzeiten). kann der fehler durch irgendwelche fehlenden rechte oder falsche mod-einstellungen verursacht werden? danke schonmal für eure hilfe!
×
×
  • Create New...