Jump to content
xt:Commerce Community Forum

user_peter

Members
  • Content Count

    7
  • Joined

  • Last visited

About user_peter

  • Rank
    Neuer Benutzer
  1. Hallo *, ich hab schon wieder ein Problem nach dem verschieben eines Shops. Ich habe die Configure.php Dateien angepasst und es läuft alles bis auf eine von mir selbst geschriebene Box vorher ging alles und alle anderen Boxen gehen auch jetzt noch. Es sieht so aus als könnte die Smarty Template Engine das HTML nicht parsen zumindest bekomme ich nach einem $smarty->fetch nichts zurück. Weiß jemand womit das zusammenhängt? Danke und viele Grüße, Peter
  2. Hat sich erledigt. Beim Kopieren über FTP hat es eine Datei nicht mit kopiert. Jetzt gehts. Kann geclosed werden.
  3. Hallo *, ich habe einen Shop aufgesetzt und ihn an meine bedürfnisse angepasst. Nun habe ich ihn noch einmal verschoben und die Pfade in den configure Dateien geändert. Im Prinzip funktioniert auch alles nur das er die Sprachdateien nicht mehr zu finden scheint und deshalb zum Beispiel statt Katalog, HEADER_TITLE_CATALOG dasteht. Weiß jemand welchen Pfad ich ändern muss damit das wieder klappt oder wie ich mir ausgeben lassen kann unter welchem Pfad der die Sprachdateien sucht. [EIDT] Es sind doch nicht die Sprachdateien die nicht geladen werden können. Es muss eine andere Datei sein die irgendwelche Platzhalter ersetzt... Vielen Dank und schöne Grüße, Peter
  4. Hallo *, ich habe den Fehler gefunden. Es liegt wohl an dem etwas seltsamen Verhalten des Browsers und an meinem schlechten Code :-( Ich hatte für die Tabellenzelle ein Stylesheet "height" angegeben und der Browser ignoriert diesen Stylesheet nicht einfach bei längeren Texten sondern lässt den Text drüber fliesen. Jetzt habe ich aus "height" ein "min-height" gemacht und es funktioniert. Vielen Dank an alle die sich die Mühe gemacht haben mir zu Helfen. Viele Grüße, Peter
  5. Hallo *, ich habe ein eigenes Template für den Shop geschrieben nun habe ich folgendes Problem: Die AGBs und das Impressum welche als Links unter dem Shop angezeigt werden ragen über die Links und das © von XT:C hinaus. Ich kann mir nicht erklären wieso diese Texte aus der Tabelle herraus "fliesen" bei anderen Seiten in dem Shop ist es mir noch nicht aufgefallen da die Texte nicht so lang sind. Ich habe mal ein Bild zur besseren Verdeutlichung angehängt. Vielen Dank und Grüße, Peter
  6. Hallo sff, danke für die Hinweise aber leider haben sie nichts gebracht da ich den Namen an der Stelle "zerstückle" wo er auch vorher angehängt wurde. Und da ich die Stringverkettung mit dem </u> in einer Anweisung mache kann eigentlich nichts dazwischen geschoben werden. Das If sollte auch stimmen da er ja nur an den gewünschten Stellen das </u> einfügt. Viele Grüße Peter [EDIT]: Hat sich geklärt. Die Teilunterstreichung findet jetzt mit einem Bild statt was im Hintergrund liegt. Das hat den Vorteil das alle Kategorien gleich lang unterstrichen sind. Und der IE kanns auch darstellen ^^. Danke für deine Mühe sff.
  7. Hallo, ich bin gerade dabei ein eigenes Template für xt:C zu erstellen. Nun habe ich folgendes Problem bei der Kategoriennavigation: Ich möchte bei jeder Hauptkategorie die ersten drei Buchstaben unterstreichen das mache ich in dem ich in der Datei "xtc_show_category.inc.php" abfrage ob die Kategorie eine Top-Level-kategorie ist. Wenn ja setze ich vor den Namen ein <u> und schreibe in die Variable "$closeU" den schliesenden U-Tag. Danach schreibe ich den Kategorienamen so in die "$categories_string" Variable: $categories_string .= substr($foo[$counter]['name'], 0, 3). $closeU. substr($foo[$counter]['name'], 3); Wenn ich mir aber den HTML Quelltext der generiert wird ausgeben lasse sieht das ungefähr so aus: <u> <b> <a href="URL" _base_href="URL"> <b> Tes <!-- hier dazwischen sollte nur ein </u> stehen! --> </b> </a> </b> </u> <b> <a href="URL" _base_href="URL"> <b> <!-- und nicht noch so ein haufen andere Tags :-( --> t </b> </a> </b> Es geht um den Teil in den Kommentaren. Das dürfte dort gar nicht stehen! Ich weis der Variable $closeU nur das "</u>" oder garnichts zu. Weiß jemand wie das passieren kann und wie ich es beheben kann? Es ist nicht sehr schön das ich da zwei Links für ein Wort habe. viele Grüße Peter
×
×
  • Create New...