Jump to content
xt:Commerce Community Forum

Schippi

Members
  • Content Count

    149
  • Joined

  • Last visited

About Schippi

  • Rank
    Erfahrener Benutzer
  • Birthday 06/15/1975

Contact Methods

  • AIM
    CarstenSchippers
  • MSN
    schippi@t-online.de
  • ICQ
    293283230
  • Skype
    carsten.schippers

Converted

  • Wohnort
    Heinsberg
  1. Die Kaufabwicklung funktioniert und der Kunde kann den Artikel auch Downloaden. Aber jetzt kommt das Komische. Wenn der Link angeklickt wird, wird die entsprechende RAR-datei runtergeladen, diese ist aber anstatt der tatsächlichen 56MB nur 0MB groß. Logischrweise kommt beim entpacken dann eine Fehlermeldung. Die 56MB große datei liegt aber tatsächlich auf dem Server im Verzeichniss "download". Was ist da los?? Habe hier auch noch mal die Einstellungen der Scripte beim Provider angehängt. Übrigens wird oft auch berichtet wenn der obige Fehler auftritt würde auch der Download von Anleitungen zu den verkauften Produkten, welche im Artikel-Content-Manager erstellt wurden, nicht funktionieren. Dies kann ich nicht bestätigen. Dort funktioniert alles bestens! Würde mich freuen wenn mir jemand weiterhelfen könnte! Hoster ist übrigens Hosteurope Webpack 3.0 L
  2. Habe einen SQL Fehler wenn ich im Adminbereich bei einer Bestellung auf den Rechnungsbutton klicke. Kann mir jemand sagen wo der Fehler liegt? Hier die Meldung: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 SELECT banktransfer_owner,banktransfer_number, banktransfer_bankname, banktransfer_blz FROM banktransfer WHERE orders_id= [XT SQL Error]
  3. Hallo Liebe Mitstreiter, habe folgendes Problem: wenn ich ein Artikel neu anlege kann ich ja ganz unten die Steuerklasse wählen. Standartmäßig steht dort "keine". Ich wähle also meine gewünschte Steuerklasse aus und gehe auf speichern aber die Steuerklasse wird nicht mitgespeichert. Wenn ich den Artikel wieder aufrufe zum z.B. editieren steht dort wieder "keine". Zugegeben habe ich das ein oder andere Modul installiert und kann jetzt nicht mehr genau sagen wann der Fehler aufgetaucht ist. Kann jemend helfen? Als Anlage habe ich mal die Datei angehängt von der ich glaube das dort der Fehler liegt: /admin/includes/modules/new_products.php new_product.rar
  4. In der Datenbank in der Tabelle newsletter_recipies
  5. In der Datenbank, dort in der Tabelle newsletter_recipiens!
  6. Die Spalte customers_newsletter in der Tabelle customers ist ein überbleibsel aus früheren Versionen. D.h.: Ob dort 0 oder 1 steht hat keine Auswirkungen auf den Newsletter-Versand. Auch eine Veränderung im Adminbereich unter Kunde-Bearbeiten-Newsletter abboniert oder nicht abboniert bewirkt nichts! Einzig und allein die Tabelle newsletter_recipients ist für den Newsletterversand zuständig. Wobei man klar sagen muß das der Newsletterversand noch nie richtig funktioniert hat, bis zur letzten Version!
  7. Mal prüfen ob die Zahlungsart Kreditkartte überhaupt installiert ist!
  8. Ich habe diese Sache vor längerer Zeit beri mir eingebaut, und bin mir deswegen nicht ganz sicher aber mach mal folgendes: Root/admin/customers.php folgendes nach <tr> <td width="80" rowspan="2"><?php echo xtc_image(DIR_WS_ICONS.'heading_customers.gif'); ?></td> <td class="pageHeading"><?php echo $cInfo->customers_lastname.' '.$cInfo->customers_firstname; ?></td> </tr> <tr> <td class="main" valign="top">XT Customers</td> </tr> <?php einfügen: // Guthabenabfrage echo "aktuelles Guthaben: "; $gv_query = "SELECT * FROM ".TABLE_COUPON_GV_CUSTOMER." WHERE customer_id = '".$_GET['cID']."'" ; $gv_query = xtc_db_query($gv_query); $result= xtc_db_fetch_array($gv_query); echo $result['amount']; Vorher Datensicherung!!!! Das Guthaben wird dir dann oben wenn du auf Kunden bearbeiten gehst über dem Namen angezeigt!
  9. Also wenn sich doch jemand nur für den Newsletter einträgt und den Aktivierungslink bestätigt, dann will er doch den Newsletter haben würde ich sagen. Das ist aber auch nicht mein größtes Problem. Ich habe schon mal mein eigendliches Problem in einem anderen Posting geschrieben. Also: Gäste die sich nur für den Newsletter anmelden bekommen in der Newsletter_recipiens-Tabelle die customer_id=0. Das kann ich ja verstehen. Wenn Sie aber ein Gast bei mir im Shop registriert bekommt er den Status Neukunde und bei der Anmeldung kann er ein Häkchen setzen ob er den Newsletter haben möchte. Automatisch bekommt er dann auch den Aktivierungslink zugeschickt. Was aber nicht funktioniert, er steht dann direkt in der Tabelle Newsletter_recipiens aber die customer_id ist 0, müßte aber laut Tabelle customers eine andere sein. Also wird die customer_id nicht an die Tabelle Newsletter_recipiens übergeben. Also habe ich irgendwo einen Fehler, weil es bei anderen xt-Usern funktioniert. Ich kann noch nicht mal sagen ob ein Fehler in der Datenbank vorliegt oder in einer Datei. Aber wo muß ich bei der Suche ansetzen. Vielleicht weiss du ja Rat John! Wäre für Tips sehr dankbar.
  10. Weis jemand was in welcher Datei geändert werden muß, damit auch Gäste, die sich nur für den Newsletter angemeldet haben diesen bekommen? Kann doc nicht sein das man für jeden Gast ein Kundenkonto anlegen muß bloß wegen dem Newsletter?
  11. Hier ist eine gute Anleitung für den Import von Artikeln. Wichtig ist: Genau an diese Anleitung halten und alles genau durchlesen!!! How_To_Import_Data_With_XTCommerce.pdf.zip
  12. Um Deinen Text in das Bild einzubinden, bzw den vorhandenen Text zu ersetzen brauchst Du z.B. Adobe Photoshop. Wenn du dann das Bild mit diesem Programm öffnest, findest du direkt unter dem Bild eine Anleitung! Es handelt sich um eine PSD-Datei.
  13. Wenn ich das Tool installieren will kommt folgende Fehlermeldung: Warning: include_once(/is/htdocs/wp1063059_PMMHCFQ0OW/livesupport/hcl/inc/version.php) [function.include-once]: failed to open stream: No such file or directory in /is/htdocs/wp1063059_PMMHCFQ0OW/livesupport/inc/config.php on line 264 Warning: include_once() [function.include]: Failed opening '/is/htdocs/wp1063059_PMMHCFQ0OW/livesupport/hcl/inc/version.php' for inclusion (include_path='.:/usr/share/pear/php5') in /is/htdocs/wp1063059_PMMHCFQ0OW/livesupport/inc/config.php on line 264 Critical database error - Selecting Database Habe die config angepasst, bin mir aber nicht sicher ob ich alles richtig gemacht habe. Hoster ist Hosteurope. Hat jemand eine Anleitung da ja alles in Englisch erklärt wird?
  14. da hab ich mich falsch ausgedrückt. Das problem ist, glaube ich, nicht der verbrauchte Speicher sondern der Arbeitsspeicher der belegt wird wenn du diese Funktion ausführst. Das kann man meines wissens nur ändern, wenn man einen eigenen kompletten Server anmietet (teuer). Probier mal das von mit vorgeschlagene Programm, ist wirklich idiotensicher www.mysqldumper.de
×
×
  • Create New...