Jump to content
xt:Commerce Community Forum

genji

Members
  • Content Count

    16
  • Joined

  • Last visited

  1. Hallo Rovert, danke für deine Antwort. Ich dachte, wenn require_once dort steht wird die Funktion nur einmal aufgerufen. Aber nun wird versucht 2mal die Funktion einzubinden. Ich habe die Funktion date_long im /admin/general.php mal auskommentiert. Nun bekomme ich die Fehlermeldung: Fatal error: Cannot redeclare xtc_address_format() (previously declared in /hp/at/aa/em/www/regale_center/admin/includes/functions/general.php:464) in /hp/at/aa/em/www/regale_center/inc/xtc_address_format.inc.php on line 76 Danach kam noch 4 mal die gleiche Meldung für weitere Funtionen. Habe nun alle auskommentiert. Nun funktioniert es. Die Bestellungen werden mir wieder angezeigt. Ich hoffe, dass nun nicht neue Fehler an anderer Stelle auftreten werden.
  2. Hallo rivendarkness, geht plötzlich nichtmehr. Am Shop habe ich nichts verändert. Ich habe nur die DB von 5 nach 4 exportiert und in den configure.php und configure.org.php die neue DB eingestellt. Alles andere funktioniert. Ich hatte in der xtc_date_long.inc.php die Funktion den Fehler abzufangen: if (!function_exists('xtc_date_long')) { function xtc_date_long($raw_date) { if ( ($raw_date == '0000-00-00 00:00:00') || ($raw_date == '') ) return false; $year = (int)substr($raw_date, 0, 4); $month = (int)substr($raw_date, 5, 2); $day = (int)substr($raw_date, 8, 2); $hour = (int)substr($raw_date, 11, 2); $minute = (int)substr($raw_date, 14, 2); $second = (int)substr($raw_date, 17, 2); return strftime(DATE_FORMAT_LONG, mktime($hour,$minute,$second,$month,$day,$year)); } } Dann kann aber ein neuer fehler. Also habe ich es wieder rückgängig gemacht. Hast du eine Idee?
  3. Hallo, bisher hat mein shop problemlos funktioniert. Ich hatte eine MySQL DB 5.0. Nan hatte ich auf 4.0 runtergeschaltet und bekomme nun diese Fehlermeldung: Fatal error: Cannot redeclare xtc_date_long() (previously declared in /hp/at/aa/em/www/regale_center/admin/includes/functions/general.php:197) in /hp/at/aa/em/www/regale_center/inc/xtc_date_long.inc.php on line 31 Liegt das an 4.0? Hat jemand eine Lösung? Würde mich sehr darüber freuen.
  4. Hallo, habe das gleiche Problem. Hast du eine Lösung gefunden? Ich hoffe.
  5. Hallo, wenn ich im Backend etwas ändere wird die Änderung erst nach mehreren Minuten im Frontent sichtbar. Woran kann das liegen? Als Provider habe ich 1blu. Als Browser benutze ich Firefox. Ich lösche auch den Cache vorher. Im Backend habe ich unter Konfiguration/Cache/Cache benutzen eingestellt.
  6. Hallo, habe den gleichen Fehler. Würde mich ebenfalls sehr freuen, wenn mir jemand weiterhelfen könnte.
  7. Hallo, hatte die gleiche Fehlermeldung und habe es so geändert wie besschrieben. Nun bekomme ich die Meldung 'Diese Kontonummer ist nicht pruefbar, bitte kontrollieren zur Sicherheit Sie Ihre Eingabe nochmals.' Hat jemand eine Lösung?
  8. Hallo, würde mich auch interessieren. Ich bekomme den gleichen Fehler. Habe Version 3.04 SP2.1. Bitte Lösung mitteilen.
  9. Hallo, ich habe aus Versehen den admin gelöscht. Wie kann ich einen neuen admin anlegen um mich wieder ins Backend einzuloggen?
  10. Hallo, ich möchte die Versandkosten nach Zonen nach Preis berechnen. Das Modul "Versandkosten nach Zonen" berechnet die Versandkosten leider nur nach Gewicht. Im Prinzip müssten die beiden Module "Versandkosten nach Zonen" und "Tabellarische Versandkosten" nur miteinander kombiniert werden. Kennt jemand eine Lösung? Oder kann mir jemand das programmieren? Freue mich über jede Hilfe.
  11. Hallo yummi, dein Tipp war schon sehr gut. Ich überleg jetzt, ob ich nicht versuchen sollte die "Vesandkosten nach Zonen" umzuschreiben. Anstatt nach Gewicht sollen die Versandkosten halt abhängig vom Preis sein. Allerdings habe ich mich noch nicht sonderlich mit PHP befasst, dass soll noch kommen. Es müssen ja nur die beiden Versandkosten - nach zone und tabellarisch - kombiniert werden. Hast du da noch einen heißen Tipp. Wäre klasse. Einfacher ist es whrscheinlich auch den Preis der Artikel beim Gewicht anzugeben. Das geht wahrscheinlich schneller, da ich auch nicht si viele Artikel habe. Beste Grüße
  12. Hallo yummi, vielen Dank für den super Tipp. Ich versuche das gerade zu realisieren. Wie es aussieht bezieht sich das aber auf das Versandmodul "Vesandkosten nach Zonen" (zones). Das Modul berechnet den Preis leider nach Gewicht und nicht nach Preis. Hast du noch einen guten Tipp?
  13. Hallo, ich möchte die tabellarischen Versandkosten nach Preis für verschiedene Länder mit unterschiedlichen Preisen angeben. Wie kann ich das machen? Kann ich das Modul mehrere Male installieren? Freue mich über jeden Tipp.
  14. Hallo, ich habe auch das Logo geändert. Insbesondere für den Ausdruck. ich habe das logo extra mit 300dpi dafür angelegt. xtcommerce rechnet das Logo nun auf 72dpi runter und vergrößert es. Gibt es eine Lösung das Logo für den Ausdruck auf 300dpi zu lassen?
  15. Hallo, ich möchte auch, dass nur der Gesamtpreis also der Attributpreis angezeigt wird. Ich habe das auch soweit geändert und es funtioniert. Bei Artikelpreis habe ich nichts eingetragen. Nur leider steht dann beim Artikel "ab 0,00 EUR". Wie kann ich es ändern, dass der niedrigste Attributpreis dort angezeigt wird? Ich möchte, dass der Artikelpreis oder der niedrigste Attributpreis beim Artikel angezeigt wird, z.B. "ab 10.00 EUR". Zur Berechnung soll aber nur der Attributpreis benutzt werden. Ich versuche schon seit Tagen die richtige Datei zu finden, wo ich den Code entsprechend ändern kann. Im Prinzip darf bei der Berrechnung halt nur nicht der Artikelpreis addiert werden. Besten Dank für jeden Tipp.
×
×
  • Create New...