Jump to content
xt:Commerce Community Forum

schurich

Members
  • Content Count

    33
  • Joined

  • Last visited

  1. Danke für die schnelle Antwort und noch eine erfolgreiche Woche. Gruss
  2. Hallo, ich habe eine xtcommerce 3.04SP2.1. Jetzt kam von HostEurope eine email, dass folgende updates eingespielt werden: MySQL: 5.1.49 => 5.5.20 Ruby: 1.8.7 => 1.8.7 und 1.9.1 Perl: 5.10.0 => 5.10.1 Python: python 2.5 => 2.5 und 2.6 TCL 8.3 => 8.3, 8.4 und 8.5 Hat das Auswirkungen auf meinen shop? Danke im Voraus.
  3. Hallo, falls noch welche das Problem haben, in der shop_content.php muss bei xtc_php_mail STORE_OWNER_EMAIL_ADDRESS als Absender eingetragen werden. Gruss
  4. Hallo, meine [email protected]_domain.de ist z.B. [email protected]_domain.de, die domain, wo auch der shop zu erreichen ist. Das Versenden über smtp sollte weiter möglich sein. Ich möchte nur wissen, welche Datei ich bearbeiten muss, damit im Kontaktformular als Absender-Adresse STORE_OWNER_EMAIL_ADDRESS eingetragen wird und die von den Kunden angegebene Adresse nicht als "From" sondern z.B. als "Reply-To" übergeben wird. Ich hoffe es ist verständlich.
  5. Hallo, es ging 4 Jahre lang, jetzt hat HostEurope das oben beschriebene umgestellt. Hier meine Einstellungen: eMail Transport Methode: smtp Der Pfad zu Sendmail: /usr/sbin/sendmail Adresse des SMTP Servers: wpXXX.webpack.hosteurope.de Adresse des SMTP Backup Servers: localhost SMTP Port: 25 SMTP Username: wpXXXXXXX-X SMTP Passwort: mein Passwort SMTP AUTH: true eMail Linefeeds: LF Benutzen von MIME HTML beim Versand von eMails: true Überprüfen der eMail Adressen über DNS: false Senden von eMails: true Kontakt - eMail Adresse: [email protected]_domain.de Kontakt - Antwortadresse: [email protected]_domain.de Kontakt - Weiterleitungsadressen: keine eingetragen Ich habe im Netz leider nur die Problemlösung für die Bestellbestätigung gefunden, da wird die send_order.php bearbeitet. Siehe hier: xtc-supportforum.de • Thema anzeigen - (gelöst) Message was not sent Mailer Error: SMTP Fehler Die send_order.php hat doch aber nichts mit dem Versand des Kontaktformulars zu tun, oder? Danke für die Hilfe.
  6. Hallo, ich habe einen xtc304sp2.1. Nun kann aus dem Kontaktformular nichts mehr versendet werden bei email-adresse gmx usw. Fehlermeldung: Message was not sent Mailer Error: Die folgende Absenderadresse ist nicht korrekt: [email protected] Antwort von HostEurope: "Es ist nicht mehr möglich, E-Mail Adresse von z.B. web.de, GMX, Yahoo, Googlemail, Hotmail, etc. als Absenderadresse zu benutzen. Dies wurde vorher nicht unterbunden, war jedoch auch kein Feature der Produkte. Es hängt aktuell von der jeweiligen Domain ab, es handelt sich hauptsächlich um Domains von großen Mailprovidern. Die von Ihnen genannten E-Mail Adressen gehören zu diesen Domains. Bitte passen Sie Ihr Skript so an, dass die Absender-Adresse zu Ihrer Domain gehört und die von den Kunden angegebene Adresse nicht als "From" sondern z.B. als "Reply-To" übergeben wird." Die Bestellbestätigungen funktionieren, es ist nur das Kontaktformular. Was muss ich ändern? Danke.
  7. Hallo, ich nutze zur Zeit noch den ssl-proxy von hosteurope. Jetzt habe ich ein eigenes ssl-zertifikat beantragt. Auf was miuss ich bei der Umstellung achten? Bei der erstinstallation muss ja nur filgendes einrichten: includes/configure.php Aber von der Installation mit ssl-proxy sind ja noch andere dateien betroffen: Muss ich in diesen Dateien jetzt bei der Umstellung auf das eigene SSL-Zertifikat auch etwas ändern? Mein Shopsystem ist 3.04 SP2.1. Ich hoffe, daß es verständlich ist. Danke im voraus. Gruss Schurich
  8. Hallo, wenn ich die url im Browser eingebe, steht da, seite nicht vorhanden. Hier ein Auszug aus der logdatei bei der suche unter buchkatalog: "www.domain.de" 87.159.172.192 - - [26/Jan/2011:10:16:57 +0100] "GET /index.php/buchkatalog/shop_content.php?coID=10&XTCsid=b95cd5d8kr9kocn7ql1a6s3at5 HTTP/1.1" 200 74506 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10" und z.B. "www.domain.de" 87.159.172.192 - - [26/Jan/2011:10:17:05 +0100] "GET /index.php/buchkatalog/shop_content.php?coID=1&XTCsid=b95cd5d8kr9kocn7ql1a6s3at5 HTTP/1.1" 200 74414 "-" "Java/1.6.0_22" www.domain.de" 87.159.172.192 - - [26/Jan/2011:10:19:16 +0100] "GET /index.php/buchkatalog/detail.php?id=228&PHPSESSID=f77c0f59aec1cff1fde2427fa16fbd7b HTTP/1.1" 200 75031 "-" "Java/1.6.0_22" www.domain.de" 87.159.172.192 - - [26/Jan/2011:10:20:52 +0100] "GET /index.php/buchkatalog/ch7.swf HTTP/1.1" 200 74541 "-" "Java/1.6.0_22" das kommt nun ziemlich oft vor in dem logfile. Was kann das mir sagen? Danke im voraus Frank
  9. Hallo, ich habe im Admin bei wer ist online folgende eintäge gesehen, hier als bild: ich habe in meinem shop keinen ordner buchkatalog angelegt und auch der 3. Eintrag von unten vvb.Sport, damit kann ich nichts anfangen. Ist das normal, oder hat da wirklich jemand unseren shop gehackt? Shopsystem xt:Commerce v3.0.4 SP2.1 Danke im voraus.
  10. Hallo, ich habe jetzt in der xtc_php_mail.inc.php die signatur gefunden, welche bei emails aus dem shop in den header der email mit angehängt wird. Die wurde wohl 2007 fest reingeschrieben. Also hat sich erledigt. Danke
  11. Hallo, den Text für die Bestellemail kann du im ordner dfeines templates bei mail ändern. Frank
  12. Hallo, Danke für die Antwort. ich benutze keine modified-Version, ich habe die normale xt-version. Eine Datei signatur.html(txt) habe ich nicht gefunden bei mir. In meiner order_mail.txt steht als letztes Ihre Bestellten Produkte zur Kontrollle ---------------------------------------------------------------------- {foreach name=aussen item=order_values from=$order_data} {$order_values.PRODUCTS_QTY} x {$order_values.PRODUCTS_NAME} {$order_values.PRODUCTS_PRICE} {if $order_values.PRODUCTS_ATTRIBUTES !=''}{$order_values.PRODUCTS_ATTRIBUTES}{/if} {/foreach} {foreach name=aussen item=order_total_values from=$order_total} {$order_total_values.TITLE}{$order_total_values.TEXT} {/foreach} {if $address_label_payment} Rechnungsadresse ---------------------------------------------------------------------- {$address_label_payment} {/if} Versandadresse ---------------------------------------------------------------------- {$address_label_shipping} Also ist dort die alte Adresse ja auch nicht fest eingefügt. Von wo holt sich dann die Bestellbestätigung, Kontaktanfrage usw. noch die Signatur, welche man bei der email erst nicht sieht, sondern nur, wenn man auf Antworten geht, steht die alte Firmenanschrift noch unter unserer email. Für weitere Hilfe wäre ich dankbar. Frank
  13. Hallo, ich habe ein Problem bei der Bestellbestätigung und bei der Kontaktanfrage. Angezeigt wir bei der Bestellbestätigungsemail als letztes z.B. Summe: 93,70 EUR Wir sind umgezogen und ich habe im Admin bei shop/Geschäftsadresse und Telefonnummer etc unsere neue Adresse eingefügt. Wenn ich auf antworten gehe, steht in der Antwortemail auf einmal noch eine Signatur mit der alten Anschrift und Telefonnummer usw. In der order_mail.txt steht als letztes Versandadresse ---------------------------------------------------------------------- {$address_label_shipping} und in der order_mail.html steht als letztes {$order_total_values.TITLE}{$order_total_values.TEXT} {/foreach} Danach erscheint aber dann in der Bestellbestätigung wenn ich auf diese antworte noch die alte Adresse mit Telefon usw. Wo kann ich das denn ändern? Danke im voraus Frank xtcommerce SP2.1
  14. für alle anderen, folgendes war es bei mir: In den Dateien includes/application_top.php, application_top_export.php und aapplication_top_callback.php den Quelltext (hier am Beispiel des Providers „Hosteurope“) $request_type = (getenv('HTTPS') == '1' || getenv('HTTPS') == 'on') ? 'SSL' : 'NONSSL'; ersetzten durch: $request_type = ($_SERVER['HTTP_X_FORWARDED_HOST'] == 'ssl.webpack.de') ? 'SSL' : 'NONSSL'; Darüberhinaus ist noch eine Änderung in der Datei inc/xtc_redirect.inc.php notwendig: function xtc_redirect($url) { if ( (ENABLE_SSL == true) && (getenv('HTTPS') == 'on' || getenv('HTTPS') == '1') ) { // We are loading an SSL page if (substr($url, 0, strlen(HTTP_SERVER)) == HTTP_SERVER) { // NONSSL url $url = HTTPS_SERVER . substr($url, strlen(HTTP_SERVER)); // Change it to SSL } } Durch folgendes ersetzen: function xtc_redirect($url) { if ( (ENABLE_SSL == true) && ($_SERVER['HTTP_X_FORWARDED_HOST'] == ‘ssl.webpack.de’) ) { // We are loading an SSL page if (substr($url, 0, strlen(HTTP_SERVER)) == HTTP_SERVER) { // NONSSL url $url = HTTPS_SERVER . substr($url, strlen(HTTP_SERVER)); // Change it to SSL } } und „ssl.webpack.de“ durch die jeweilige Domain des SSL-Proxys entsprechend abändern. Danke und ein schönes Wochenende.
  15. Hallo, SSL war schon bei der Installation vorhanden und wurde nicht nachträglich gemacht. in den beiden configure.php steht: define('HTTPS_CATALOG_SERVER', 'https://ssl.webpack.de/www.vetena.de'); define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module ich habe alle bilder als relativen pfad angegeben. Wenn ich mit src="http:// im Quelltext suche, zeigt er mir auch nichts an. Warum kommt dann die Fehlermeldung mit nicht sichere Objekte? Bitte ansehen unter vetena.de. Danke im Voraus.
×
×
  • Create New...