Jump to content
xt:Commerce Community Forum

elektroede

Members
  • Content Count

    89
  • Joined

  • Last visited

Everything posted by elektroede

  1. Hallo zusammen, auf der Seite von dem o.g. Plugin (http://addons.xt-commerce.com/de/Module-und-Plugins/Statistik-/-Tracking/Google-Adwords-Conversion-Tracking.html) steht bei Kompatibilität "5.1.4, ..." aber bei den Downloads steht "Shop-Version (Minimum): 6.2.2". Das ist aus meiner Sicht widersprüchlich. Funktioniert das Plugin nun bei 5.1.4 oder nicht? Danke vorab!
  2. Jezt habe ich ein sehr ähnliches Problem mit einem Video, welches ich in die Artikelbeschreibung eingebunden habe. Wenn ich die Beschreibung speichere, wird das Video schön dargestellt. Aber wenn ich den Editor neu lade, dann schmeißt er mir die Zeile aus dem Quelltext. In der o.g. Datei und auch sonst kann ich aber nichts derartiges finden. Jemand eine Idee? Das ist mein html in der Artikelbeschreibung: <video src="https://verzeichnis/winkender_airdancer.mp4" poster="https://verzeichnis/prev_winke_video.JPG" controls></video> Das wird durch den Editor immer ersetzt durch <video>&nbsp;</video> Hat jemand einen Vorschlag?
  3. Danke für den Tip! Wenn ich das richtig verstehe, ist das aber das Delay bevor der erfolgte Klick auf die Seite führt. Der dort Fragende möchte anschließend verzögern, bevor zum Anker gescrollt wird und fragt nach einer Lösung dafür. Das wäre dann womöglich auch eine Lösung, die mein Problem beheben könnte. Es gibt in diesem Post aber noch keine Antwort und noch keine Lösung dafür.
  4. oputz hat recht. Ganz kurz sieht man, dass die richtige Stelle angezeigt wird und dann verschiebt sich alles wieder nach unten. Kann man das irgendwie beheben?
  5. Wenn man hier auf der Artikelseite https://www.skydancer24.de/2-beiniger-skydancer-7m-standhoehe auf den Link mit dem Ankertext Skydance-Gesichtern in der Artikelbeschreibung klickt. Landest Du dann an der richtigen Stelle?
  6. Hallo! Ich habe ein paar Anker auf einer Kategorieseite in der Kurzbeschreibung gesetzt, wo ich erweiterte Erklärungen zu Material und Farben u.s.w. unter den entsprechenden Überschriften zusammengefasst habe. Wenn ich diese Anker von der Kategorieseite aus der Beschreibung verlinke, springt das Bild ganz wunderbar genau zu der Stelle, an der der Anker positioniert ist. Nun möchte ich diese Anker aber auch von Artikelseiten aus verlinken. Wenn ich dies tue, springt die Navigation irgendwo auf die Mitte der Kategorieseite, bei den Produkten. Aber nicht auf den Anker. Hier ein Beispiel: https://www.skydancer24.de/skydancer#gesichter Kann mir jemand sagen, wie ich es anstellen kann, dass der Aufsetzpunkt korrekt ist? Ich hoffe, man versteht, was ich meine. Danke vorab! Grüße in die Runde! Bleibt schön gesund!
  7. Wunderbar! Das war es! Ich hatte den Cache nicht gelöscht! Danke!
  8. Zu früh gefreut. Ich habe in meiner costum_config.js den folgenden Code gefunden und auskommentiert. Aber der Editor macht das immer noch. if(htmlFilter) { htmlFilter.addRules({ elements: { $: function (element) { try { // for images add !important to height and width if (element.name == 'img') { var style = element.attributes.style; if (style) { // check !important added already var match = /(?:^|\s)width\s*:\s*(\d+)px!important/i.exec(style); if (match == null) { match = /(?:^|\s)width\s*:\s*(\d+)px/i.exec(style); if (match) { style = style.replace(match[0], match[0]+'!important'); } } // same for height var match = /(?:^|\s)height\s*:\s*(\d+)px!important/i.exec(style); if (match == null) { match = /(?:^|\s)height\s*:\s*(\d+)px/i.exec(style); if (match) { style = style.replace(match[0], match[0]+'!important'); } } element.attributes.style = style; } } } catch(err) { alert(err.message); } } } }); } else { alert('ckeditor custom_config.js : could not get instance of htmlFilter, img style did not get the !important rule applied') } Das if(htmlFilter} lässt mich hoffen, dass man dieses Verhalten irgendwo abschalten kann. Ich kann aber leider nichts derartiges finden. Hat jemand noch eine Idee?
  9. Du bist ja gut! Ich habe zwar die Datei config_ckeditor.js bei mir nicht gefunden aber dafür die costum_config.js, wo anscheinend genau das gemacht wird. Ich hatte mich vorher, aufgrund eines Posts hier im Forum, auf das Verzeichnis \xtFramework\library\ckeditor\ beschränkt und dort nur eine Datei mit !important gefunden, die sich mit meinem Editor nicht sauber öffnen ließ. Ich werde den Part in meiner costum_config.js auch mal auskommentieren... Danke schon mal für den guten Tip!
  10. Stimmt. Wenn ich im Editor html code bearbeite und !important lösche und dann auf "Speichern", dann ist das raus. Aber wenn ich den Content dann wieder im Editor öffne, haut der mir wieder das !important rein. Und das nervt.
  11. Hallo! Das Problem habe ich jetzt auch. Konntest Du das irgendwie in den Griff bekommen?
  12. Schnipsel werden ja alle Nase lang getauscht und übrigens auch beim Erwerb von Plugins mitgeliefert. Ich sehe das nicht so problematisch. Wenn ich wüsste wie, würde ich sofort loslegen. Dass es um die breadcrumb.htm geht ist mir schon klar, ich habe ja da den code von Crafter schon erfolgreich ausprobiert. S. oben. Wenn du mir einen horrenden Stundensatz dafür bezahlst justier ich dir auch den Bias von deinem Verstärker aber vielleicht würdest du es auch gerne selber verstehen und dann selber machen. Dann könntest du dir beim nächsten mal vielleicht selber helfen. So geht das jedenfalls mir. Und interessant ist das in jedem Fall. Ich finde daran nichts verkehrt. Ich hatte angenommen, dass man sich hier gegenseitig versucht zu helfen, wenn das mit angemessenem Aufwand machbar ist. Als Auftragsvermittlung für Coder hatte ich das Forum nicht eingestuft. Was nimmst du denn für deine Dienste?
  13. Hallo! Ich habe zwar nicht viel Ahnung von der Materie und weiß auch nicht, wie deine Anzeigen aussehen, aber man kann mit der Methode Box mit Content über den Content Manager einiges machen. Das lässt sich dann auch relativ komfortabel pflegen. https://xtcommerce.atlassian.net/wiki/spaces/MANUAL/pages/917525/Neue+Box+anlegen Diese Box kann man dann in der templates/dein_template/index.html im Footer an der gewünschten Stelle einbinden. Wenn du das nur z.B. auf der Startseite haben willst, kannst du es mit einer if-Anweisung darauf beschränken. {if $page == index} {box name=deinetollebox htmlonly=1} {/if} Vielleicht ist das was für dein Vorhaben.
  14. Das hast du wirklich schön zusammengefasst. Danke. Nur, gerade in diesem Fall: wieso sollte hier copy/paste nicht gehen? Wenn oputz das schon erfolgreich umgesetzt hat, wäre es doch ein Leichtes, den Schnipsel hier zu posten. Oder? Könnte ja sein, dass hier auch mal jemand versucht Hilfe zu bekommen, der nicht selbst programmieren kann und einen Satz wie "den Wert für Content liefert z.B. {$smarty.foreach.aussen.iteration} " einfach nicht versteht. Kannst du dir das vorstellen? Es soll ja auch Leute geben, die nicht wissen, wie man den Bias von einem Class-A Verstärker kalibriert. Wenn ich dem jetzt sage, dass er den Bias auf 15mA einstellen soll, wird der sich auch wundern, was nun wirklich zu tun ist.
  15. Hallo oputz, vielleicht kannst Du Deinen Code auch hier posten, damit wäre anderen auch gleich mit geholfen und das Thema hätte einen würdigen Abschluss.
  16. Vielen Dank, Crafter!! Ich habe deinen Code statt der vorhandenen elseif-Anweisung in meine breadcrumb.html eingesetzt und die erste Überprüfung der Navigationspfade in der Search Console war positiv. Ich denke, damit hat sich das für mich erstmal erledigt. Nochmal: Danke! Grüße!
  17. Das klingt vielversprechend. Wenn Du das schon umgesetzt hast, könntest Du die geänderte breadcrumb.html hier einmal posten? Grüße!
  18. Hallo Spezialisten, ich habe gerade einen Hinweis von Google erhalten, dass meine strukturierten Daten veraltet wären. Fehler in der Search Console: " data-vocabulary.org schema deprecated". Dabei geht es offenbar um den Code <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"> u.s.w. auf den Artikelseiten. Nach meinen ersten Recherchen sieht es so aus, dass ab April 2020 die strukturierten Daten mittels data-vocabulary.org nicht mehr von Google akzeptiert werden. Ich fürchte, dass sich das auf das Ranking niederschlagen wird. Kann mir jemand sagen, wie damit umgegangen werden sollte? Gruß in die Runde!
  19. Gibt es da irgendwelche Ansätze, wie man dem Problem auf die Schliche kommen könnte? Hast Du Beispiele für Fehler, die dazu führen? Gruß
  20. Weiß jemand, woran das liegen könnte? Das Layout bei der Ausgabe der Startpage Products ist manchmal geschrottet und manchmal ist es OK. Der Titel und die Kurzbeschreibung sind dann auf dem Bild und damit nicht gut lesbar. Das passiert vorwiegend beim Firefox. Auf dem Smartphone, wie auch auf dem Desktop. Wenn man die Seite x-mal neu lädt ist es dann irgendwann OK aber nach weiteren Aufrufen eben wieder nicht. Völlig undefiniert. Über Hinweise oder Lösungsansätze u.s.w. würde ich mich freuen. Danke vorab! Ich wollte Bildschirmauschnitte zur Illustration anhängen, kann hier aber nur max. 30kB hochladen. Warum das, eigentlich?
×
×
  • Create New...