Jump to content
xt:Commerce Community Forum

M!m

Members
  • Content Count

    12
  • Joined

  • Last visited

About M!m

  • Rank
    xt:Commerce Support Kunde
  1. Ich habe jetzt zur Sicherheit alle Bestellungen gelöscht. Das heißt ich habe in der Datenbank die Tabelen 'orders', 'orders_products', 'orders_status_history' und 'orders_total' geleert und den auto_increment Wert auf 1 zurückgesetzt. Und siehe da es funktioniert! Danke dir Mr. Proxy.. Gruß M!m
  2. Ich werde es einfach mal ausprobieren. Vielen Dank schon mal =) Ich melde mich wieder mit Ergebnissen. Gruß M!m
  3. Da habe ich mich wohl missverständlich ausgedrückt. Ich meinte bei den Kunden in der Tabelle orders ist alles in Ordnung. Keine doppelten orders_id und der auto_inc Wert ist auch korrekt. Das mit den Produkten steht ja bei orders_products aber dort sind nur die entsprechenden Produkte der id zugeordnet. Auch die Falschen nicht Bestellten Produkte sind dort hinterlegt. Hmm, also du meinst das ich am besten mal alle Bestellungen komplett löschen sollte und dann alles wieder funktioniert? Also einmal fast alle orders Tabellen säubern und zurücksetzten?
  4. Was meinst du genau mit: "Was steht in der Datenbank?" In der Tabelle orders_total steht dann folgendes: INSERT INTO `orders_total` (`orders_total_id`, `orders_id`, `title`, `text`, `value`, `class`, `sort_order`) VALUES (161, 31, 'Zwischensumme:', ' 2.409,30 EUR', 2409.3000, 'ot_subtotal', 10), (162, 31, 'Versandkosten:', ' 0,00 EUR', 0.0000, 'ot_shipping', 30), (163, 31, '<b>Summe, netto</b>:', '<b> 2.409,30 EUR</b>', 2409.3000, 'ot_subtotal_no_tax', 40), (164, 31, 'zzgl. USt. 19%:', ' 457,77 EUR', 457.7700, 'ot_tax', 50), (165, 31, '<b>Summe, brutto</b>:', '<b> 2.867,07 EUR</b>', 2867.0700, 'ot_total', 99), (574, 31, 'Pauschale Versandkosten (Bester Weg):', ' 6,90 EUR', 6.9000, 'ot_shipping', 30), (575, 31, '<b>Summe, netto</b>:', '<b> 63,78 EUR</b>', 63.7800, 'ot_subtotal_no_tax', 40), (576, 31, 'zzgl. USt. 19%:', ' 12,12 EUR', 12.1200, 'ot_tax', 50), (577, 31, '<b>Summe, brutto</b>:', '<b> 75,90 EUR</b>', 75.9000, 'ot_total', 99); Bei den Produkten in der orders Tabelle sieht alles normal aus, auch beim Kunden kann ich nichts feststellen. Oder meinst du eine andere Tabelle?
  5. Hallo, ich habe ein interessantes Problem. Beim Kauf eines oder mehrerer Produkte per Nachname werden zufällig andere Produkte zur Bestellung hinzugefügt. Ebenso wird die Bestellung doppelt im Adminbereich angezeigt und in dieser auch doppelt die MwSt. berechnet. Beide Bestellungen besitzen dieselbe ID haben aber unterschiedliche Produkte. Das ganze passiert auf einem XT-Commerce 3.04 SP2.1. Das Modul Nachname ist mehrfach installiert und deinstalliert worden. Ebenso habe ich ein Update der Dateien durchgeführt mit den Dateien aus einer Neuinstallation. Wenn jemand eine Idee hat würde ich mich sehr freuen, ich bin mittlerweile ratlos. Gruß M!m
  6. Vielen Dank für die schnelle Antwort, genau das war es was ich brauchte um weiterzukommen. Habe auch schnell ein Moduk gefunden was genau meinen Wünschen entspricht: Link Gruß M!m
  7. Hallo, ich habe mal eine generelle Frage zu 3.04 SP2.1. Ich möchte gerne mehrere Produkte verkaufen, was ja nichts ungewöhnlich ist. Nehmen wir an es handelt sich um diverse Schnürsenkel, Schuhe und Kartons. Man kann sich alles einzelnd kaufen, aber ich möchte den Kunden auch die möglichkeit bieten die drei Sachen frei Kombiniert als ein Produkt zu verkaufen. Ist das realisierbar? Wenn ja, wie? Ich meine über Attribute kann man eine Menge machen, aber es währe sehr geistlos wenn man alle Produkte auch nochmal als Attribute anlegen muß. Ich bin auf Eure Ideen gespannt. Gruß M!m
  8. hallo, ich möchte gerne bei meinem shop das datum für das ende eines angebots anzeigen lassen. ich habe mir auch schon in der specials.php die DB-abfrage angeguckt und feststellen müssen das die expires_date spalte mit abgerufen wird, nur weiß ich jetzt nicht wie ich diese angezeigt bekomme. ich meine alle anderen kann man mit {$box_content.XYZ} abrufen und ausgeben, aber expires_date nicht. gruß M!m
  9. hallo, ich habe leider feststellen müssen das ich durch den xtc-code nicht mehr durchblicke. ich hatte einmal eine stelle gefunden wo man das gleich folgende einstellen konnte, aber ich weiß nicht mehr wo.. evt. könnt ihr mir helfen. es geht um den aufbau folgender variablen: z.B. {$box_content.PRODUCTS_PRICE} bevor jetzt jeder schreit das hatten wir schon tausend mal wollte cih gerne wissen/verstehen der bereich PRODUCTS_PRICE zustande kommt? meines wissens nach ist das ja ein teil einer smartyvariablen, aber wie wird der generiert? ich habe 'ne mysql-abfrage die in ein array gepackt wird und dann..? ich hoffe ihr könnt licht ins dunkel bringen. mit freundlichen grüßen M!m
  10. Danke für deinen Tipp Gecko, leider sind die Schreibrechte korrekt, war nämlich auch mein erster Gedanke bei dieser Fehlermeldung. Hmm, das mit dem Blöd stellen ist ne gute Idee. Ich hoffe ich schaffe es in noch weiteren 3 Tagen den Fehler zu finden. Gruß M!m
  11. hallo, ich habe das selbe problem wie chinni. bei mir taucht auch der fehler auf: "error creating folder /var/www/......../html/images/ (Can`t create directory)" merkwürdigerweise habe ich alle exakt so gemacht wie in der anleitung beschrieben und bei der einen installation hat es geklappt auf dem anderen webspace hingegen kommt jetzt diese fehlermeldung. hat einer 'ne idee? mfg M!m
×
×
  • Create New...