Jump to content
xt:Commerce Community Forum

BlackViper73

Members
  • Content Count

    17
  • Joined

  • Last visited

About BlackViper73

  • Rank
    Neuer Benutzer
  1. Guten morgen, ich hab mal alles deaktiviert und dann hab ich als erstes admin_dropdown.php:dropdown aktiviert --> alles ok als nächstes class.search.php:_search_filter aktiviert und voila 500er. Was da allerdings falsch sein soll erschliesst sich mir nicht ganz. Dort steht doch nur $this->sql_products->setFilter('Sorting', (is_data($_GET['sorting'])) ? $_GET['sorting'] : WOV_SEARCH_STANDARD_SORTING); drin. VG Viper
  2. Habs gerade mal probiert, leider ohne Erfolg. Der 500er Fehler bleibt. Der Hookpoint vom "module_search.php:default_tpl_data" sieht bei mir nun so aus $wov_productlist = new products_list(0); $wov_sort_dropdown = (is_array($search_result)) ? $wov_productlist->getSortDropdown() : ''; $wov_sort_default = WOV_SEARCH_STANDARD_SORTING; $wov_tpl_data = array('sort_dropdown' => $wov_sort_dropdown, 'sort_default' => $wov_sort_default, 'heading_text' => TEXT_SEARCH_HEADING.' "'.htmlspecialchars($_GET['keywords']).'&quot', 'keywords' => htmlspecialchars($_GET['keywords'])); $tpl_data = array_merge($tpl_data, $wov_tpl_data); Ich würd ja auf die 4.0.14 umsteigen, aber in dem ganzen System wurde soviel verändert, und da fehlt mir im Moment die Zeit das zu machen. VG Viper
  3. Oha Shit, dann wird das wohl demnächst nichts werden VG Viper
  4. Hmm also bei uns bekomme ich das Plugin nicht zum laufen. Zum einen gibts selbst im Standardtemplate den gewissen Teil garnicht, den ich ersetzen soll. Also habe ich es mal so eingebaut {if $sort_dropdown.options} <div class="products_sort"> {form type=form name=sort_dropdown action='dynamic' method=get} {if isset($current_manufacturer_id)}{form type=hidden name=page value='manufacturers'}{form type=hidden name=mnf value=$current_manufacturer_id} {elseif isset($current_category_id)}{form type=hidden name=page value='categorie'}{form type=hidden name=cat value=$current_category_id} {else}{form type=hidden name=page value='search'}{form type=hidden name=keywords value=$keywords}{/if} {form type=select name=sorting value=$sort_dropdown.options default='' onchange='this.form.submit();'} {form type=formend} </div> {/if} Wenn ich das Plugin aktiviere geht bei mir nun die Suche garnicht mehr. Es kommt direkt ein 500er Fehler. Wir haben die 4.0.13 im Einsatz. Oder ist dieses Plugin für eine andere Version gedacht? VG Viper
  5. Anscheinend sind wir hier wirklich die einzigen beiden, bei denen das so ist oder die anderen brauchen diese Funktionalität nicht. Eigentlich schade, dass sich niemand weiter meldet und mal einen Anhaltspunkt geben kann woran es letztendlich liegen könnte. VG Viper
  6. Das wäre der Brüller schlechthin. Selbst 10 Jahre alte Shopsysteme beherrschen das ohne Probleme. Und wenn man Veyton für knapp 1000 EUR kauft, kann man eigentlich erwarten, das solche Grundlegenden Dinge funktionieren. Ich hab nun mal zum Test ein "Jungfräuliches" Veyton 4.0.13 installiert. Auch dort geht es nicht das Suchergebnis zu sortieren. Also kurz und knapp --> Mist VG Viper
  7. Das gleiche Problem haben wir hier auch. Am Template kanns auch nicht liegen, da es selbst beim xt_default nicht funktioniert. Anscheinend ist die Template Variable $sort_dropdown.options leer. Echt komischer Shop wo man suchen, aber nicht nach dem Ergebnis sortieren kann:eek: Was mich nur wundert, sind wir die beiden einzigen hier wo dieses Problem Auftritt? Derzeit haben wir die Version 4.0.13 im Einsatz. VG Viper
  8. Hallo, und noch etwas ist mir aufgefallen. Laut Updatebeschreibung von 4.0.12 auf 4.0.13 soll man ja z.B. in der Templatedatei adress_book.html diese Sache mit dem {if $addresses.allow_change == true} einbauen. Soweit so gut, jetzt wird der entsprechende Teil zwischen dem {if} und {/if} nicht mehr angezeigt. Tja nur wo schalte ich wieder an, dass adressen bearbeitet werden dürfen? Am Template selber liegt es nicht, da auch das Originale xt_default den entsprechenden Teil zum Adressen bearbeiten nicht mehr anzeigt. Also irgendwo ist da noch der Wurm drin. Im Backend habe ich auch nichts entsprechendes gefunden. Kann mir mal jemand auf die Sprünge helfen? VG Jarno EDIT: habs gefunden. In der class.customer.php war etwas falsch.
  9. Hi Alex, ne daran liegt es nicht. Ich kann mich auch als erstes anmelden, dann etwas in den Warenkorb packen und den Bestellprozess abschließen. Trotzdem werde ich am Ende aus dem System geworfen. Bei ner Gastbestellung hätte ich es verstanden. VG Jarno
  10. Hallo, wir haben hier einen sehr unschönen Effekt mit dem Veyton 4.0.13 Ultimate. Bis zum absenden der Bestellung verläuft alles ganz normal. Der Kunde legt etwas in den Warenkorb, geht zur Kasse, Meldet sich an und bestimmt Versand bzw. Zahlungsart. Wenn er dann die Bestellung abschliesst, bekommt er die Seite zu sehen, dass seine Bestellung eingegangen ist. Er landet also auf der Seite www.unseredomain.de/index.php?page=checkout&page_action=success Ab diesem Zeitpunkt ist er dann aber vom System abgemeldet oder mit der Session stimmt etwas nicht. Die Bestellung jedoch wird ordnungsgemäß gespeichert. Hat einer von euch eine Ahnung, wo ich mit suchen anfangen kann? VG Jarno
  11. Nun also wir haben hier die 4.0.13 auf Whitelist und damit gehts eigentlich Problemlos. Dazu haben wir als Versandart Selbstabholer angelegt und für alle Kundengruppen aktiviert. Folgende Einstellungen in der Zahlungsart haben wir: xt_cashpayment aktivieren Berechtigungen für die einzelnen Kundengruppen setzen beim Tab Versandarten den Selbstabholer aktivieren und für die anderen Versandarten deaktivieren Und schon lief das ganze. VG Viper
  12. Guten morgen, gibt es eigentlich irgendwo eine Übersicht, welches Feld in der DB für was zuständig ist? Ich bin gerade dabei eine Schnittstelle von unserer Warenwirtschaft zu Veyton zu Programmieren. z.B. das Feld external_id in der Tabelle products. Dieses wird anscheinen garnicht vom Shop her gebraucht, also könnte ich das mit Daten befüllen, welche ich in der Warenwirtschaft benötige? Gruß Jarno
  13. Hallo, danke für die Antwort. Nun dass es das ganze nicht als Standart gibt war mir eigentlich klar Aber so ganz ohne Probleme lässt sich das wohl doch nicht einbauen. z.B. suche ich derzeit krampfhaft, wo denn die Kundendaten in die DB gespeichert werden. Also ansich insert into ... Und genau dies habe ich bisher nirgendwo gefunden Gruß Jarno EDIT: ich habs gefunden, wo die Daten in die DB gespeichert werden
×
×
  • Create New...