Jump to content
xt:Commerce Community Forum

NilsK

Members
  • Content Count

    1,014
  • Joined

  • Last visited

  • Days Won

    21

Everything posted by NilsK

  1. Hallo, nö - hat ja die ganze Zeit wunderbar funktioniert (bis auf das Löschen, daß sie dann nicht auf dem Server ebenfalls weg sind). ? Gegenfrage: Warum sollte man die Bilder denn nicht überschreiben, also welchen Vorteil hätte es? Im Normalfall wird das Bild nie wieder benötigt und wenn doch, dann speichere ich es eh anders ab. Herzliche Grüße Nils
  2. Hallo, also, ich kann mich Homer nur anschließen. Wenn es ein aktuelles Produktbild gibt, hat es den selben Namen bekommen und wurde so schnell und einfach überschrieben. Zudem möchte ich den Namen "selbst" bestimmen, da ich diesen teilweise mit weiteren Wörtern versehen habe (um noch besser gefunden zu werden, 60 Zeichen sind ja erlaubt) und da möchte ich nun nicht irgendwas anderes drin haben. ? Es ist immer sehr lästig gewesen, wenn man alle Ordner erst durchsuchen muß um die alten Einträge zu löschen (gibt eh viel zu viele), daß ist echt sehr sehr aufwendig. Von daher war das überschreiben - in diesem Fall - super! Und warum soll ich unnötig Bilder speichern/aufbewahren, die ich nicht benötige (da möchte ich auch kein Image processing durchführen, da diese ja bestimmt mit berücksichtigt werden)? Aus Sicherheitsgründen, kann ich es ja noch verstehen, aber da ist ein "Speichern" vergessen wesentlich schlimmer, als diese Funktion. xtc kann es aber gerne als Auswahlkriterium ins Backend packen, dann sind beide Seiten zufrieden oder wie Alex es geschrieben hat: wenn löschen, dann sollte es auf dem Server auch weg sein (inkl. in allen Unterordnern), ist es aber nicht. Es ist aber immer wieder interessant zu sehen, wie Entwickler denken und wie wir Händler denken (ist jetzt nicht negativ gemeint - ihr sitzt ja praktisch an der Schnittstelle zu allen). ? Herzliche Grüße Nils
  3. Hallo, früher war das nicht so, fragt mal beim [email protected] nach. Herzliche Grüße Nils
  4. Hi, schau' mal in den changelog für 5.1.4 rein (wird vermutlich Anfang nächster Woche erscheinen): https://xtcommerce.atlassian.net/wiki/spaces/MANUAL/pages/77594628/xt+Commerce+5.x.x+Changelog Da werden so einige Fehler behoben. ? War aber mal sortiert. ? Sortierte Grüße Nils
  5. Hallo zusammen, Dankeschön. Bei: Widerrufs- & Kontaktformular Preisanfrage gibt es ja ein Captcha eingebaut, nur nicht bei der Neuregistrierung - vergessen? Es scheint sich ja eine neue Version 5.1.4 anzukündigen, da kann xtc ja gleich noch mal schnell nachbessern. ? Den Code von den oben genannten Formularen kann man vermutlich nicht einfach da rein kopieren, oder? Das Google Recaptcha wollte ich eigentlich nicht nutzen, weil dann die Datenschutzgeschichte wieder angepaßt werden muß, aber wenn es besser ist und xtc nichts neues liefert, werde ich es natürlich machen. ? @Alex, Warum wäre ein Captcha auf der Kundenregistrierung nicht gut? Oder ist es nur der Unterschied zwischen Captcha/Recaptcha? Spamfreie Grüße Nils
  6. Hallo ""Elektroede", vermutlich hast Du eine php.ini Datei und dort mußt Du dann die PHP-Version anpassen, also 7.2 reinschreiben. Ordner muß nicht geleert werden, einfach überspielen und Wizard starten, danach sollte alles funktionieren (Cache löschen). Falls nicht, wird Dir der Fehler angezeigt. Danach den Wizard wieder löschen... ? Herzliche Grüße Nils PS: Die php.ini Datei muß dann natürlich auch in die entsprechenden Unterordner (falls nötig) kopiert werden, also immer dort, wo die Fehlermeldung auftaucht.
  7. Hallo liebe Experten, da der Spam zunimmt, muß ich hier noch mal nachfragen, denn mittlerweile sieht es so aus: - täglich mehrere "Contact Request" (Kontaktformular) aus dem nahen Osten (vermutlich Russlang) - Kundenregistrierungen aus dem nahen Osten, die die auszufüllenden Felder mit dem selben Text ausfüllen - Seit kurzem "Mail delivery", die meinen originalen Mail-Footer besitzen Fragen: Gibt es eine Schwachstelle im System oder sind es einfach nur gute Roboter die da arbeiten? Soll ich das normale Standard-Recaptcha weglassen und dafür das Google-Teil nutzen? Wie handhabt Ihr das...? Spamfreie Grüße Nils
  8. Hi, ja, aber die siehst Du ja dann unter [Seo & Shop Optimierung / Weiterleitungs URLs / 404 Seo-URLs] und kannst dann da eine Umleitung auf das gewünschte Produkt machen. Mußt Du nur regelmäßig reinschauen. Herzliche Grüße Nils
  9. Hallo, die langen Wartezeiten hatte ich vor kurzem auch mal. Schreib mal den Helpdesk an ([email protected]), immerhin verlinken die es ja komplett (ohne die Kunden zu fragen ;-) ). Manchmal sind die xtc-Seiten auch extrem langsam im laden, sollte eigentlich auch nicht vorkommen. Erfolgreiche Grüße Nils
  10. Hallo Alex, Div: war in der 4.2er auch weg, kam mit der 5er Version wieder zurück. TinyMCE ist im Backend nicht aktiviert, nur cke. Wo könnte man es noch sehen? DB-Cache: was muß man denn da ändern? Vermutlich einer, dieser Zeilen (0 -> 1?), oder? "define('_CACHETIME_DEFAULT',0); // db cache time define('_CACHETIME_LANGUAGE_CONTENT',0); define('_CACHETIME_MANUFACTURER_LIST',_TIME_24_HOURS); /** * activate Smarty Template Cache */ define('USE_CACHE','false');" Dankende Grüße Nils
  11. Hallo Alex, Dankeschön, mit Winmerge schaue ich mal. Ja, cke ist immer so eine Sache und wenn er nicht weiter erneuert werden darf, sollte xtc es auch so vermitteln, macht sonst keinen guten Eindruck, denn cke hat mittlerweile viele Fehler beseitigt, z.B. dieses blöde einfügen von zahlreichen Divs-Tags und wenn man dann Versionen hinterher hinkt fragt man sich warum... xtc kann den auch gerne so gestalten, daß man es selbst updaten dürfte (sofern Lizenzen keine Rolle spielen). Es geht mir auch nicht draum, daß ich tausend bunte Farben verwenden muß/würde, aber cke ist schon so mächtig, daß man schöne Sachen machen könnte, es aber leider nicht kann. Es ist halt ein schönes cms und soetwas gehört aus meiner Anwendersicht einfach dazu. Ich hätte auch nichts dagegen, wenn ich es im Backend selbst auswählen könnte, zwischen: Normal, Mittel, Vollversion. Welchen DB(?) Cache muß ich denn (wie) aktivieren oder wie/wo kann man es sehen? Herzlichen Dank im Voraus!! Herzliche Grüße Nils
  12. Hallo, Chace gelöscht & Backend neu geladen (Rechtsklick im linken Menübaum, bzw. bei der Kategorie)? Ansonsten mal den Support anschschreiben. Herzliche Grüße Nils
  13. Hallo Unbekannte/r, Updates solltest Du immer einspielen, allein, wegen der Sicherheit oder um einfach nur Fehler zu beheben. Und, wenn Du die Software eh erst gerade frisch hast, kann Dir eh nichts, bzw. fast nichts passieren (was den "Nachkauf" angeht). Die Programmierer werden Dir nun sagen: Lokal ändern und dann - nach ausgiebigem Test - auf den Server schicken, am besten, wenn keiner drauf zugreift (oder per Wartungsschild solange "stillsetzen" => Häkchen bei Shopstatus entfernen). Bei so kleineren Updates, wenn kein Script durchlaufen muß, mache ich es - nach allen Sicherungen - z.B. nachts im laufenden Betrieb, sind ja meistens nur wenige Dateien, die Überspielt werden (vorher einfach mal reinschauen und drauf achten, daß man selbst nichts geändert hat, z.B. falls es eine Template-Datei oder sonstiges ist). Plugins: Wenn Du welche gekauft hast, mußt Du drauf achten, aber eigentlich nur, bei größeren Versionsupdates - zur Not den Hersteller fragen. Wenn Plugin-Updates zur Verfügung stehen, wird es eigentlich im Shop angezeigt. PP ist z.B. ein freies, gibt es aber schon in einer wesentlich höheren Version als aktuell in der 5er Version enthalten ist, es gibt übrigens viele Plugins, die noch nicht freigeschaltet sind, k.A. warum. Also, rann an die Buletten... Herzliche Grüße Nils
  14. Hallo liebes Forum, nach dem Update auf 5.1.3 mal ein kleines Feedback: Nun zu den kleineren "aber" & Fragezeichen: Noch offen: - in der Updateanleitung ist ganz unten ein Änderungsprotokoll zum Standard-Template - was hat es damit auf sich oder was wurde da verändert? - CKEditor ist leider mehr als veraltet 4.5.9 statt 4.10.1, leider auch keine Farbauswahl für farbige oder Warn-Texte, schade, denn der CKE ist fast das Herzstück und bietet so wenig. Fügt auch lauter <divs> ein, ein Fehler der bei cke schon längst gepatched wurde (und in einer früheren Version auch schon mal weg war). - im Backend werden die Slider-Bilder immer noch nicht angezeigt, vermutlich liegt es am doppelten "//" vor dem Bild (https://domaine.de/media/images//bild.jpg) - wie bekäme man diesen Fehler weg (sofern er das ist, ist seit dem Update von 4.2 auf 5.0)?? - im Frontend ist die Parse Time verschwunden, obwohl in der DB aktiviert - hat jemand eine Idee warum (PHP 7.2 ist eingestellt) und wie man sie wieder angezeigt bekommt? - Ruft man eine Kategorie auf, dauert es ca. 1-2 Sekunden, bis der Inhalt angezeigt wird, war früher nicht. Der Rest ist erledigt oder war nicht mehr wichtig, seitens xtc: Dankeschön.? Herzliche Grüße Nils
  15. Hallo liebe Profis, mir ist noch ein kleinerer Fehler aufgefallen: der Sprachwechsel funktioniert nur, wenn ich jedes mal eine andere Seite aufrufe, ansonsten bleibt die Sprache eingestellt, die gerade ist (springt praktisch zurück, d.h. von EN nach D geht nicht, nur wenn ich eine andere Seite anklicke, sonst lande ich wieder bei EN (und umgekehrt)). Hat jemand eine Idee, woran das liegen könnte? Merci. Herzliche Grüße Nils
  16. Danke Alex! Bei wem werden denn die neuen Slaves angezeigt und sieht die Tabelle da eventuell anders aus? Einzige Lösung derzeit ist, dass jeder neue Artikel mit einem Zeit-stempel in der DB angepasst werden muss, damit er sichtbar wird... Herzliche Grüße Nils
  17. Hallo Alex, Danke, aber dann kommt eine Fehlermeldung "#1067 - Invalid Default value for date_added". So sieht es aus: Name [date_added], Typ [DATETIME], Länge/Werte [ ], Standard [NULL], Kollation [ ], Attribute [ ], Null [], A_I [ ], ...(Rest ist leer) Muß evtl. Datetime auf Timestamp gestellt werden...? Herzliche Grüße Nils
  18. Hallo Alex, noch eine Frage dazu: Seit dem Update werden alle neuen Produkte nicht mehr unter xt_new_products angezeigt (zumindest keine Slaves), hier steht das Datum auf Null in der DB. Ein normales Produkt wird ganz normal angezeigt. Muß da in der DB auch noch was geändert werden? Danke im Voraus! Herzliche Grüße Nils
  19. Hallo Alex, super, Dankeschön - dass war es!!! Herzliche Grüße Nils
  20. Hallo liebe Spezialisten, jetzt wollte ich gerade ein Slave-Artikel kopieren und es kommt zu einer SQL-Fehlermeldung (bei einem normalen Artikel klappt alles wie gehabt) und es lässt sich im Artikel auch nichts speichern (außer: Bild & Metadaten, jedoch kein Text, es erfolgt dann eine Fehlermeldung). Der Artikel wird in der DB auch nicht unter xt_products_description angelegt, unter xt_products schon. Hier mal die Fehlermeldung: (2018-07-24 21:51:11) mysqli error: [1048: Column 'reload_st' cannot be null] in EXECUTE("INSERT INTO xt_products_description ( PRODUCTS_ID, LANGUAGE_CODE, RELOAD_ST, PRODUCTS_NAME, PRODUCTS_DESCRIPTION, PRODUCTS_SHORT_DESCRIPTION, VIDEO_HTML, PRODUCTS_KEYWORDS, PRODUCTS_URL, PRODUCTS_STORE_ID ) VALUES ( 2312, 'de', null, '', '', '', null, '', '', 1 )") #0 /pfad/pfad/pfad/pfad/pfad/xtFramework/library/adodb-5.20.12/adodb.inc.php(1264): ADODB_Error_Handler(...) #1 /pfad/pfad/pfad/pfad/pfad/xtFramework/library/adodb-5.20.12/adodb.inc.php(1228): _Execute(...) #2 /pfad/pfad/pfad/pfad/pfad/xtFramework/library/adodb-5.20.12/adodb.inc.php(2164): Execute(...) #3 /pfad/pfad/pfad/pfad/pfad/xtFramework/admin/classes/class.adminDB_DataSave.php(0): AutoExecute(...) #4 /pfad/pfad/pfad/pfad/pfad/xtFramework/classes/class.product.php(1821): saveDataSet(...) #5 /pfad/pfad/pfad/pfad/pfad/xtFramework/admin/classes/class.ExtAdminHandler.php(0): _set(...) #6 /pfad/pfad/pfad/pfad/pfad/xtAdmin/adminHandler.php(0): saveClassData(...) Hat jemand eine Idee, woran es liegen könnte und wie man den Fehler beheben kann? Shop ist aktuell (5.1.2) und vor dem Update lief alles bestens. Freue mich über jede Antwort. Herzliche Grüße Nils
  21. Hallo Manfred, ohje, ne leider nicht. Kann der Hersteller von dem "tollen" Plugin nicht dafür gerade stehen? Ansonsten hoffe ich, daß sich hier noch andere melden, die sich besser damit auskennen. Daumendrückende Grüße Nils
  22. Hallo, suche mal nach ".less" oder less Dateien, da solltest Du ein paar Infos finden, ist zu Beginn etwas kompliziert, aber wenn man es einmal gerafft hat sehr einfach. Nutze auch unbedingt den Firefox, rechte Maustaste auf die gewünschte Änderung und "Element untersuchen", da kannst Du es dann vortesten/ansehen und die Stelle dann in der entsprechenden Datei suchen. Aber Achtung, alle anderen Seiten (Produkt-, Kontakt-, Content-, Popupseiten usw.) kontrollieren, ob sich da nichts oder auch etwas geändert hat, da vieles miteinander eine Quelle nutzt. Erfolgreiche Grüße Nils
  23. Hallo Manfred, - Menüpunkt (Kategorie) anlegen - rechtsklick auf den frisch angelegten Menüpunkt - individueller Link / "Link zu Inhaltsseite" auswählen. So sollte es funktionieren, die Contentseiten sollten natürlich vorher angelegt sein. Dann tauchen die Seiten im Menü auf. Erfolgreiche Grüße Nils
  24. Hallo Raymond, habe mir Deinen Shop nicht angeschaut, aber vermutlich hast Du die Schriftfarbe geändert und diese kann auch für das Login zuständig sein. Heißt, da auch noch alles farblich ändern oder mittels css bzw. .less ändern/hinzufügen. Bei Änderungen der Schriftfarbe immer alles anschauen (Produkt, Kategorie, Überschriften, Formulare, Anmeldung, Content-Seiten, User-Backend, usw. usw....) ? Testen kannst Du es am besten per Firefox (rechte Maustaste, Element untersuchen) und wenn da alles passt, dann Ändern. Herzliche Grüße Nils
  25. Hallo, scheint ja ein ioncube-Fehler zu sein. Stimmt die PHP-Version mit der (ioncube-)php.ini-Datei überein? Denn wenn php 7.2 installiert sein sollte, aber in der php.ini nur 5.5 steht, stimmt es nicht und dann quittiert xtc das ganz schnell mit einer weißen Seite oder im besten Fall einer Fehlermeldung (in der php.ini Datei 5.5 mit 7.2 ersetzen, bzw. das, was der Hoster anbietet/unterstützt - 5.5 wäre etwas veraltet). Die php.ini Datei kommt einmal ins Hauptverzeichnis rein und auch in den ioncube-Ordner sowie in den Wizzard-Ordner, denn sonst läßt sich das auch nicht richtig installieren. Sollte eigentlich in der Anleitung alles richtig drin stehen und wenn man es mal verstanden hat, geht es auch einfach (außer, das der Hoster ggf. mit einem zu kleinen Paket gelockt hat?). Erfolgreiche Sonntagsgrüße Nils
×
×
  • Create New...