Jump to content
xt:Commerce Community Forum

yumwebdesign

Members
  • Content Count

    129
  • Joined

  • Last visited

About yumwebdesign

  • Rank
    Erfahrener Benutzer

Converted

  • Wohnort
    Frankfurt am Main
  • Beruf
    Webdesign, Online Strategie
  1. Plugin ist aktiviert Standardkategorie ist gesetzt Feld "Google-Produktkategorie" in Exportdefinition hinzugefügt Variable {$data.google_productcategory} eingefügt -------------------------- Variable wird nicht ersetzt. Woran kann das liegen? Bei einer Angabe der Google Produktkategorie auf Kategorie oder Produktebene passiert ebenfalls nichts. Woran kann das liegen? "Im Downloadpaket befindet sich die class.export.php der aktuellen Version 4.0.14" In der Zip ist keine solche Datei.
  2. Als "Feature" wünsche ich mir, dass es endlich ein Update-Skript für 4.0.13 auf 4.0.14 gibt. Das Integral-Update gibt es ja nun schon seit 1. April, aber dann müssten Produktoptionen über das Optionen-Plugin neu angelegt werden und die Produktilder glaube ich auch, wenn wan einfach Export-Import der Produktdaten macht. Daher warte ich seit 3 Monaten auf das Update-Skript.
  3. Im Content und in Produktbeschreibungen gibt es erst recht Probleme mit hart kodierten Links, denn da werden die unvollständig dokumentierten Smarty-Schreibweisen a la {link page=index} ja gar nicht interpretiert.
  4. Missverständnis! Es sind kostenlos verteilte Rabatt-gutscheine, die selten in Geschäften kombiniert eingesetzt werden dürfen. Geschenkgutscheine, die vom Laden für Geld verkauft werden müssen auch in Höhe dieses Geldwerts zum Kauf von Waren akzeptiert werden, und zwar egal welche sonstigen Ermässigungen noch gerade auf dem Produkt sind. Wenn man jetzt das Gutschein Plugin sowohl für kostenlose Rabattgutscheine wie für Geschenkgutscheine einsetzen will hat man ein rechtliches Problem, das nicht Gegenstand einer kostenpflichtigen Weiterentwicklung sein kann. Das muss inklusive sein. Darum geht es.
  5. Vor dem letzten Update einer bestimmten Datei der 4.0.12 trat das SID Problem auch bei den Default-Links im Shop auf, richtig. Unabhängig davon tritt es aber auch danach noch auf, wenn man eigene Links ins Template oder in Produktbeschreibungen hart kodiert, d.h. so wie man HTML Links nun mal standardmässig schreibt. Die Dokumentation fehlt wie man es mit Veyton/Smarty macht.
  6. Das weiß keiner? Die Frage kommt in ähnlicher Form noch öfters im Forum... alle hart-kodierten Links bekommen in Veyton ein hässliches SID xfa26=9384h8gfhs8hfsdfhg etc.
  7. Das liegt daran, dass eine Dokumentation fehlt wie man Links im Template in Smarty korrekt kodiert. Meine Frage unter http://www.xt-commerce.com/forum/fragen-zur-software/74618-wie-setzt-man-einen-kategorie-link-richtig-im-template.html ist leider ebenfalls ohne Antwort geblieben. Vielleicht kann mal jemand mit einem Service-Vertrag die Frage an die Geschäftsleitung stellen und die Antwort hier teilen. Eigentlich finde ich aber, dass die Info gratis in die Doku gehört.
  8. Gute Frage, in Mails fehlt mir die Möglichkeit mit {debug} die verfügbaren Variablen anzuzeigen um die richtige zu identifizieren. Ich habe stattdessen geschaut welche anderen Variablen standardmässig in der E-Mail Vorlage verwendet werden und wo diese in der Datenbank stehen. Da ich in denselben Tabellen keine Produktlinks finden konnte habe ich daraus geschlossen, dass die richtige Variable eventuell in E-Mails gar nicht zur Verfügung steht, weil die URL z.B. nur im Produktkontext nicht aber im Bestellungskontext definiert ist und die E-Mail ja im Bestellungskontext ist.
  9. Ja, die button.php mal gründlich umbauen erscheint mir auch das beste. Leider bin ich dazu nicht in der Lage. Es könnte aber auch sein, dass es die Parameter schon gibt um die Schriftfarbe etc. pro Button einzustellen und diese nur in der Dokumentation fehlen. So wären wir am schnellsten einen Schritt weiter wenn da von der Geschäftsleitung jemand was dazu sagen könnte...
  10. @oldbear Dass es nur die Schriftfarbe verändert war mir bewusst. Jetzt habe ich es auch für die 3 Standardbuttons hingekriegt, die Farbe zu verändern. Nur sobald ich meinen eigenen (orangenen) Button spezifiziere ist die Farbangabe ohne Wirkung (immer hellgrau). Meine letzte Idee war eben noch, dass es am Alpha-Channel meiner Gifs liegt, weil die Standard GIFs keinen haben. Leider liegt es auch daran nicht. Was Du über Transparenz sagst sehe ich genau andersrum. Das rechte Button-Ende darf eben NICHT transparent sein, sonst verdeckt das darunter liegende lange linke GIF die Rundung nach rechts. D.h. natürlich, dass man mit dem Veyton-System nur Hintergrund-spezifische Buttons erstellen kann. Auch die Standard-Buttons haben weisse und keine transparenten Pixel in den Ecken - muss ja so sein, ohne Alpha Channel. Muss man genau hingucken, weil die nur minimal runde Ecken haben. Auf einem nicht weissen Hintergrund würde es deutlich werden.
  11. Hoppla, ich merke gerade, dass die font color Einstellungen in der button_config.php bei mir gar keine Wirkung haben, auch nicht bei Verwendung der tpl_button_1.gif. @oldbear: wie hast Du das hingekriegt? Ich habe natürlich einen Button vorher gelöscht und dann durch Seitenaufruf neu erstellen lassen und wie Du alles auf Grün gestellt. Nur die Farbe ist unverändert geblieben...
  12. Ich finde die Farbangabe für den Button-Text sollte einfach auf Button-Tag-Ebene akzeptiert werden, z.B. so: {button text=$smarty.const.BUTTON_CHECKOUT file='checkout.gif' font_color_r='0' font_color_g='255' font_color_b='0'}[/CODE] So wären verschiedenfarbige Button-Texte innerhalb desselben Templates flexibel möglich. Das es nur über die button_config.php läuft und sich diese nur auf die erste Button Template auswirkt ist mehr als unpraktisch. Gleiches gilt meines Erachtens für die _BUTTON_FONT_POS_VERTICAL, dann könnte man innerhalb desselben Templates Buttons mit unterschiedlicher Höhe verwenden.
  13. Wie setzt man einen Link zu einer Kategorie im Haupt-Template, z.B. für die horizontale Navigation? So, dass es nicht hart-kodiert ist, sondern im Sinne Veytons mit Smarty Tags... In der Dokumentation habe ich dazu nichts finden können und auch hier im Forum nur wenig. Für Content Links geht es wohl so: {link page=content seo_url='Impressum'} ... aber wie adressiert man eine spezifische Kategorie? und wie adressiere ich die Startseite als '/' anstatt als '/index.php&page=index', was nämlich bei {link page=index} passiert und SEO-ungünstig ist. Danke!
  14. Ich habe auch gerade mal die Datei ausgetauscht weil ich eine alte Version hatte, den Veyton Cache geleert und dann meinen Shop über die neue "Abruf wie beim Googlebot"-Funktion der Webmaster Tools geprüft. Leider erscheinen da immer noch unzählige xaf26a-Links... @prost: wie sieht das denn bei dir aus? Wie setzt man denn einen korrekten Link zu einer Kategorie im Template? Für Content Links geht es ja wohl so: {link page=content seo_url='Impressum'} ... aber wie adressiert man eine spezifische Kategorie? und wie adressiere ich die Startseite als '/' anstatt als '/index.php&page=index', was nämlich bei {link page=index} passiert.
  15. Wie kann ich die gekauften Produkte in Bestellbestätigungs-E-Mails zu klickbaren Links machen? Es sieht so aus als wären die nötigen Variablen nicht in E-Mails verfügbar...
×
×
  • Create New...