Jump to content
xt:Commerce Community Forum

astumpp

Members
  • Content Count

    18
  • Joined

  • Last visited

About astumpp

  • Rank
    Neuer Benutzer

Converted

  • Wohnort
    Hohenau
  • Beruf
    selbständig: IT-Service Andreas Stumpp
  1. OK, der Shop läuft ja soweit auch ohne das die aktuellen Sprachdateien drin sind. Allerdings fehlen jetz eineige Sprachvariablen. Kann man die irgendwie nachinstallieren? Beste Grüße
  2. Hallo, bei uns ist das gleiche Problem. Im Server-Error-Log steht folgendes: [Thu Dec 04 09:12:33 2014] [error] [client xxx.xxx.xxx.xxx] PHP Fatal error: Using $this when not in object context in /is/htdocs/www/xtWizard/lib/StartPageScript.php on line 0, referer: http://domain.tld/xtWizard/index.php?next=1&wpage=pluginsUpdate&install_lang=de&script=StartPageScript&WizardType=2[/CODE] Beste Grüße
  3. Hallo Leute, ich habs grad selber rausgefunden. Ich musste das Template xt_grid/xt_core/pages/shipping/shipping_default.html in meinem eigenen Template anlegen. Dann wurden dir Versandkosten angezeigt. Allerdings frage ich mich gerade, warum das nicht aus dem Standard-Template verwendet wurde? Viele Grüße Andreas Stumpp
  4. Hallo Leute, ich finde den Fehler einfach nicht. Nach dem Update von 4.0.16 auf 4.1 sind keine Versandarten im Bestellprozess mehr auswählbar. Ich habe das Template basierend auf xt_grid neu aufgebaut. An den Templates für den Checkout-Prozess habe ich keine Änderungen vorgenommen. Es sollte daher auf die von xt_grid zurückgegriffen werden. Verwende ich als Template xt_grid werden mir die Versandkosten angezeigt. Stelle ich auf mein Template um, sind die Versandkosten weg. Woran kann das liegen? Viele Grüße Andreas Stumpp
  5. Hallo Leute, ich wollte ein Plugin erstellen, das die Hersteller auf der Startseite mit Bild ausgibt. Dazu habe ich eine Page erstellt welche auch als ?page=hersteller_liste aufgerufen und angezeigt wird. Möchte ich diese nun mit dem {page}-tag auf der Startseite ausgeben kommt leider nichts. Ich hab dann nochmal ein neues Plugin erstellt. Analog zum Hello_World-Plugin aus dem Praxishandbuch. Beim Hello_World-Plugin wird mir die Page auf der Startseite ausgegeben. Bei meinem analog zum Hello_World erstellten Plugin erfolgt keine Ausgabe. Ich habe am Quellcode von Beispiel Hello_World lediglich solche Änderungen durchgeführt, dass alles zu meinem Pluginnamen und Templatenamen passt. XML-Datei umbenannt und Daten angepsst auch den Hook-Code: <hook>page_registry.php:bottom</hook> <phpcode><![CDATA[ define('PAGE_HERSTELLER_LISTE', _SRV_WEB_PLUGINS.'st_hersteller/pages/hersteller_liste.php'); ]]></phpcode>[/PHP] Dateien für page und template umbenannt und Änderungen durchgeführt: hersteller_liste.php: [PHP]defined('_VALID_CALL') or die('Direct Access is not allowed.'); $tpl_data = array('_hello_world'=>'Ich bin die Herstellerliste.'); $template = new Template(); $tpl = 'hersteller_liste.html'; $template->getTemplatePath($tpl, 'st_hersteller', '', 'plugin'); $page_data = $template->getTemplate('smarty_hersteller_liste', '/'.$tpl, $tpl_data);[/PHP] In der default.html meines Templates: [PHP]{page name=hersteller_liste type=user}[/PHP] eingefügt Rufe ich die Seite mit index.php?page=hersteller_liste direkt auf wird mir diese auch angezeigt. Auf der Startseite erfolgt entgegen zum Hello_World-Plugin keine Ausgabe. Wo bitte mache ich einen Fehler? Oder darf nicht jedes Plugin Ausgaben auf der Startseite machen? Ach ja, es handelt sich um xt:Commerce VEYTON 4.1 Danke bereits im Voraus für eure Hilfe. Andreas
  6. Hallo, ich hab das selbe Problem nachdem ich gerade auf 4.0.16 aktualisiert habe. Bei den Kundendetails steht Bundesländer auf TRUE. Im HTML-Quellcode werde auch die US-Bundesländer aufgeführt aber nicht angezeigt. Ach dann nicht, wenn als Land United States ausgewählt wurde. Kann es sein, dass der JavaScript-Code nicht ganz korrekt ist? Viele Grüße Andreas Stumpp
  7. Hallo, auch wenn der Beitrag schon älter ist - gibt es hierzu bereits Lösungsideen? Ich hab das gleiche Problem bei einem Kunden mir der russichen Übersetzung. Löschen der Suma-URL und selber reinschreiben bringt auch nichts. Viele Grüße astumpp
  8. Hallo erstmal! Die Datei db_error.log ist bei uns voll mit diesen Fehlermeldungen: MySQL server has gone away] in EXECUTE("SELECT COUNT(*) AS cnt FROM xt_sessions2 WHERE /*! BINARY */ sesskey = '...'") MySQL server has gone away] in EXECUTE("UPDATE xt_sessions2 SET expiry = NOW() + INTERVAL 3600 SECOND ,expireref='', modified = NOW() WHERE /*! BINARY */ sesskey = '...' AND expiry >= NOW()") Es sind auch noch andere Meldungen drin, aber nicht so häufig wie diese beiden. Wir schalten in unserem Shop so alle 14 Tage neue Artikel frei und zwar Freitags, um 13:30 Uhr. Da es sich bei diesen Artikeln um Sammlerartikel handelt, die sehr begehrt sind, kommt es zu dieser Zeit zu einem sehr hohen Besucheraufkommen, die alle die neuen Artikel sehen wollen. Wir haben einen Virtual Server Managed von HostEurope und von der Support-Abteilung haben wir folgende Mitteilung zu den u.g. Meldungen erhalten: "Werden hier noch irgendwo Sessions in die Datenbank geschrieben? Wenn das der Fall ist könnte man versuchen, diese in das Dateisystem auszulagern. Sessions in der Datenbank sind alles andere als performant." Was ist euere Meinung dazu? Kann mann das Session-Handling umstellen? Eine Antwort vom Entwickler-Team wäre hierzu wohl am hilfreichsten! Danke schon mal im vorraus für euere Bemühungen. Viele Grüße Andreas Stumpp
  9. Hallo, kann irgendjemand einen Tipp geben, wie man erweiterte Produktdaten in einem neuen Tab darstellt. @Mario und Team: Habt Ihr einen Tipp für uns oder ist das vielleicht gar nicht möglich? Viele Grüße astumpp
  10. Hallo Leute, ich möchte auch meine Produktdaten erweitern, hätte dazu aber gerne einen weiteren Tab wie zum Beispiel "Artikel auf Startseite anzeigen" unter Artikel bearbeiten. Wie bekommt man das hin?
  11. War längere Zeit nicht im Forum und hab daher erst jetzt gesehen, dass ein paar Leute diese PlugIn gerne hätten. Ich habe es euch nun angehängt. Viel Spaß damit. IT-Service Andreas Stumpp xt_productsquestion.zip
  12. Hallo, ich habe das Problem neulich auch gehabt. Es hängt irgendwie mit dem Erstellen und Löschen von Kundengruppen zusammen. Ich konnte das Problem nachvollziehen, indem ich eine Kundengrupper erstellt habe. Diese hatte dann die Kundengruppen-ID 4. In der Datenbanktabelle xt_products wird ein neues Feld mit Namen price_flag_graduated_4 erstellt. Soweit ist alles kein Problem. Wird nun diese Kundengruppe wieder gelöscht, bleibt das Feld price_flag_graduated_4 in der Tabelle xt_products erhalten und im Admin-Bereich wird beim Artikel bearbeiten TEXT_PRICE_FLAG_GRADUATED_4 angezeigt. Wo genau das Problem nun liegt, sollten sich die Entwickler mal ansehen. Wir haben übrigens auch das PlugIn xt_customersdiscount installiert, vielleicht hängt es ja damit zusammen. Viele Grüße
  13. Hallo, ich möchte dieses Thema nochmal aufgreifen, da mein Kunde unter Shop->Artikel die Sortierung über alle Artikel hinweg vornehmen möchte, da es extrem umständlich ist, sich durch aktuell 54 Seiten durchzuklicken um alle Artikel mit der gewünschten Sortierung für z.Bsp. den Status durchzusehen. Wäre die Sortierung über alle Artikel hinweg, würde er nur ein paar Seiten ansehen müssen und nicht geleich alle 54 was ja einem hohen Zeitaufwand entspricht. Toll wäre es wenn beim Drop-Down für die Sortierung zwei zusätzliche Auswahlmöglichkeiten wären, die die Sortierung über aller Artikel erlaubt. Um dem Kunden kurzfristig zu helfen, wäre er auch mit einer Änderung am Core einverstanden, bis eine entsprechende Lösung vorhanden ist. Dazu bitte ich um einen Hinweis wo was zu ändern wäre. Oder wäre das auch über Hookpoints realisierbar und wenn ja mit welchem Hookpoint. Im Admin-Bereich ist ja ziemlich der ganze Quellcode verschüsselt. Viele Grüße Andreas Stumpp
  14. Gleiches Problem auch bei meinem Kunden. VG Andreas Stumpp
×
×
  • Create New...