Jump to content
xt:Commerce Community Forum

kevinha

Members
  • Content Count

    20
  • Joined

  • Last visited

  1. hallo dukie666, dankesch?n f?r deinen tipp. ich musste aber auch noch die product_listing.html entsprechend anpassen. gruss kevinha
  2. hallo, ich h?tte den shop auch gerne in einer festen breite und mittig. habe im template-ordner die index.html aufgerufen und im oberen table-tag die breite und center eingegeben. ?ber die tabelle habe ich noch ein logo integriert. passt beim seitenaufruf auch. passt auch, wenn ich eine kategorie aufrufe. wenn ich aber dann eine unterkategorie aufrufe (wo ja der artikel abgelegt ist), dann zieht sich die tabelle in die breite und ist imverh?ltnis zum logo zu breit. sieht aus wie a.... die navis / bl?cke rechts und links scheinen sich nicht zu verbreitern. problem liegt beim mittleren content. habe schon im ordner module in der main_content.html versucht die "restbreite" (gew?nschte gesamtbreite minus breite der rechten und linken bl?cke) dort festzulegen - funktioniert jedoch nicht. wenn jemand rat weiss - bitte tipp/anleitung geben. url kann ich nicht mitteilen, da artikel alle fsk18 sind und nicht gesch?tzt ;-) gruss kevinha
  3. hallo. schlicht aber ansprechen - find' ich gut :-) von langsam keine spur - ist bis zur letzten ecke alles sofort da - dabei hab' ich hier @home nur stinknormales dsl. wenn ich die schnelligkeit auf mein 3000er dsl im laden hochrechne, m?ssten die pics schon aufgerufen und angezeigt sein, bevor ich die links ?berhaupt geklickt habe ciao kevinha
  4. hallo. ist es m?glich verschiedenen kunden unterschiedliche zahlarten zuzuweisen? z.b. - gast oder angemeldeter kunde erstmal grunds?tzlich nur vorkasse - sp?ter ?ber den adminbereich freischalten f?r rechnung oder - wenn bereits f?r rechnung freigeschaltet unnd die zahlungsmaral nachl?sst, nur noch nachnahme oder vorkasse ciao kevinha
  5. hallo, diese fehlermeldung erhalte ich, wenn im shopbereich bei gang zur kasse die seite mit den versandkosten angezeigt und dann weiter geklickt wird. Warning: main(/usr/local/httpd/htdocs/www/web39/html/inc/): failed to open stream: Success in /usr/local/httpd/htdocs/www/web39/html/checkout_payment.php on line 45 Fatal error: main(): Failed opening required '/usr/local/httpd/htdocs/www/web39/html/inc/' (include_path='.:/usr/local/lib/php') in /usr/local/httpd/htdocs/www/web39/html/checkout_payment.php on line 45 durchnummierung ist gegeben - den code von @miral habe ich auch mal versucht - bringt alles keine fehlerbehebung. ich hab' den shop jetzt schon 100 x installiert und deinstalliert - hab' diesen und jenen fehler gehabt, die immer irgendwie behoben werden konnten. bestellvorg?nge konnten IMMER bei den vorherigen installationen fehlerfrei durchgef?hrt werden. und nun das ich krieg' die kr?tze`. ciao kevinha
  6. hallo. was mich pers?nlich sehr st?rt ist, dass bei srollen bis seitenende die navis rechts und links nicht gleich mit dem mittelteil abschliessen. mir ist klar, dass dies evtl. nicht ohne grosse umprogrammierung machbar ist, doch sollte zumindest die eingangs- / startseite optisch gleich sein. also oben gelich hoch anfangen und unten gelich abschliessen. als weiteren punkt MUSS ich deine sonderaktion 3 % rabatt bem?ngeln. es ist zwar nett, dass du den verkauf ankurbeln m?chtest - hierf?r ist das 3%ige rabattangebot auch f?rderlich - aber nur 1 x anf?hren und nicht verl?ngern. sieht immer (f?r mich so aus) dass diese shop-angebote niemand will, beziehungsweise jemand mit "gewalt" seine nicht beliebten produkte los werden will. wenn du das 3%-angebot verl?ngerst erst gar nicht auf verl?ngerung darauf hinweisen, sondern einfach nur kommentarlos das datum ?ndern. ciao kevinha
  7. hallo. aus shopbetreiber-/admin-sicht, w?re es von vorteil, wenn im adminbereich "artikel" bei jedem artikel der preis und ein evtl. sonderpeis als ?nderbar angezeigt wird und korrigierbar w?re ohne den preislich zu ?ndernden artikel jedesmal einzeln neu anzeigen zu lassen. beispiel in etwa so: Preis und Sonderpreis als eingabefelder der SAVE-button 1 x auf der seite, so dass man bei bedarf alle auf der seite angezeigten artikel preislich bearbeiten kann und nach erfolgter preiskorrektur 1 x den SAVE-button klickt und die preise "in einemrutsch" aktualisiert werden. w?re f?r den admin bei hoher artikelanzahl eine zeitsparende unterst?tzung. ciao kevinha
  8. hallo mzanier, ich versteh' euch "proggis" / entwickler und erkenne eure leistung (und das ist wirklich eine leistung ) an. ich sag' es mal aus meiner sicht: meine branche sind medien (bespielte tr?germedien, magazine, ...). genau wie bei euch "proggis" stress hoch drei. wenn ich jedoch von meinem stress (nicht von der t?tigkeit) abspanne, "treibe" ich mich auch in den einschl?gig bekannten "fach"-foren rum. wenn ich nun in einem thread etwas anmerken / hilfe geben kann, dann mache ich dies so ausf?hrlich wie m?glich. das heisst aber nicht, dass ich nun ?berall dort, wo mein wissen hilfreich sein k?nnte auch antworte. im gegenteil - ich nehme mir die "auszeit" vom stress mal f?r'n paar stunden - und diese zeit versuche ich hilfreich umzusetzen - aber nicht l?nger. was in dieser zeit nicht beantwortet wird, bleibt liegen f?r's n?chstemal oder f?r andere - soll schliesslich auch nicht in stress ausarten. vielleicht hast du die falsche einstellung ?!? es bringt nichts ?berall pr?sent zu sein, etwas zu antworten, SCHNELL zu antworten - ist zwar lobenswert - sondern dem anderen (dem "dummen") die thematik / die l?sung auch plausibel zu machen. der hilfe- / ratsuchende kann ruhig mal etwas warten - wenn dann hinterher das problemchen erkl?rend gel?st ist, wird die anerkennung f?r deine leistung / deine hilfe umso gr?sser sein. bei wirklich dringenden "hilferuf" oder fatalen bugs wirst du als entwickler aufgrund deiner erfahrung schon das richtige h?ndchen haben erstmal die spreu vom weizen zu trennen und die problemchen bevorzugt und effektiv behandeln. hilfe ist nicht gleich hilfe - auch wenn sie gut gemeint ist - schliesslich (denke ich) ist das forum dein "hobby". lass es also "ruhiger" angehen, aber werde bitte mit deinen antworten pr?ziser. sehr, sehr freundliche gr?sse - schliesslich habe ich grosse achtung vor deiner leistung kevinha
  9. hallo. nun streitet euch mal nicht beziehungsweise versucht nicht dem andren seine eigene einstellung / sichtweise "auf's auge zu dr?cken". versucht lieber mal - und das gilt f?r (fast) ALLE forum-mitglieder - erst einmal einfach nur die sichtweise / das problem / die situation des anderen zu sehen und zu verstehen. der/die/das macher von xt-commerce hat schon etwas tolles, feines, vern?nftiges programmiert - was eigentlich anhand der kurzanleitung auch von laien installiert werden kann. nu ist nat?rlich nicht jeder laie oder etwas fortgeschrittenere in der lage xt-commerce sofort fehlerfrei zu installieren - kein problem, dann wird es eben wiederholt (evtl. mit den gleichen fehlern, welche man vorher auch gemacht hat). aus fehlern sollte man eigentlich lernen - doch wie ist dieser lernprozess m?glich, enn man die fehlerursache nicht kennt, beziehungsweise oftmals bei "forum-hilferuf" mit ein paar floskeln abgefertigt wird. ich sage es mal aus meiner "laiensicht" (trotz guter html-kenntnisse und kleinem ansatz von php): ich WILL das "ding" verstehen - nicht einfach nur damit "rumspielen", oder vielleicht sogar selber versuchen die zu programmieren - NEIN, einfach nur verstehen UND aus den gemachten fehlern lernen. doch um zu lernen muss auch jemand bereit sein mehr als nur 2 worte zu antworten/zu helfen. ich verstehe die "proggis" - haben alle h?nde und ihr k?pfchen damit zu tun den (uns) anwendern etwas kostenloses ins k?rbchen zu legen und m?ssen sich dann mit "dummen" fragen bombardieren lassen. aber, wenn ihr proggis euch die zeit nehmt mal "auszuspannen" und ins forum schaut, dann nehmt euch doch bitte auch die zeit und antwortet etwas ausf?hrlicher, erkl?render. die anwender hingegen sollten mal nicht so ungeduldig sein - klar es juckt, man will das "ding" ja ausprobieren, testen, best?cken, .... - und etwas r?cksicht auf die mit den arbeitende fraktion nehmen auch wenn ich meine anmerkungen hier in diesen thread schreibe, heisst dies nicht, dass sich nun 2 poster dieses threads angp.... f?hlen sollten nein ich wollte meine anmerkungen einfach nur posten und habe durch zufall diesen thread gew?hlt @abacho ich habe den shop 4-5 mal installiert - immer hatte ich irgendwo fehlermeldungen nach der installation. einiges habe ich aufgrund meiner kenntnisse ausb?geln k?nnen, anderes nach posting oder suche im forum - letztendlich war aber immer noch der ein oder andere fehler vorhanden. schau nach seit wann ich hier mitglied bin - seitdem habe mich fast nur und beinahe rund um die uhr mit installation und deinstallation von xt-commerce besch?ftigt. heute habe ich das handtuch geworfen und bei ** angerufen. war nach 17:00 uhr - aber kein problem - man hat mich noch "dazwischen geschoben" und das "ding" mal eben so installiert - gegen bezahlung selbstverst?ndlich - aber kleines geld. * bitte keine werbung * kann ich dir nur empfehlen - ?rgere dich nicht unn?tz, sondern gib die installation in fachm?nnische/-frauliche h?nde und hinterher l?sst du dir dann die bei deiner installation aufgetretenen fehler erkl?ren - schliesslich m?chte man ja nicht dumm sterben ich denke mal, dass auch andere hier im forum ein gute arbeit machen - evtl. hat ja der ein oder andere user noch einen tipp. meine premisse war vordergr?ndig ein noch zu erstellendes template und damit alles in 1 hand bleibt habe ich auf das kosteng?nstige installationsabgebot von seven-art.de zugegriffen. noch einmal - ghib die installation in profi-hand, versuche aus deinen fehlern zu lernen, lass diese bzw. die ursache dir erkl?ren und "vergeude" nicht wertvolle zeit mit weiteren experimenten ciao kevinha
  10. hallo. folgende fehlermeldung erscheint im shopbereich bei klick auf angelegten hersteller: D:\xt-commerce\XT-version-2.0rc1.2\xtcommerce\templates\xtc2\module\product_listing\product_listing_v1.html --> web88.space.net /html/templates/xtc2/module/product_listing product_listing_v1.html 2004.08.01 01:24 A D:\xt-commerce\XT-version-2.0rc1.2\xtcommerce\templates\xtc2\module\product_listing\product_listing_v1.html --> space.net /html/templates/xtc2/module/product_listing product_listing_v1.html was bedeutet das - was sollte wie ge?ndert werden? ciao kevin
  11. hallo, adminbereich - module - xt-module - xt-imageprocessing imageprocessing wurde installiert - danach export folgende fehlermeldung wird angezeigt: Warning: Division by zero in /usr/local/httpd/htdocs/www/web39/html/admin/includes/classes/image_manipulator.php on line 52 Warning: imagecolorclosest(): supplied argument is not a valid Image resource in /usr/local/httpd/htdocs/www/web39/html/admin/includes/classes/image_manipulator.php on line 215 Warning: imagecolorclosest(): supplied argument is not a valid Image resource in /usr/local/httpd/htdocs/www/web39/html/admin/includes/classes/image_manipulator.php on line 215 Warning: Division by zero in /usr/local/httpd/htdocs/www/web39/html/admin/includes/classes/image_manipulator.php on line 52 Warning: imagecolorclosest(): supplied argument is not a valid Image resource in /usr/local/httpd/htdocs/www/web39/html/admin/includes/classes/image_manipulator.php on line 215 Warning: imagecolorclosest(): supplied argument is not a valid Image resource in /usr/local/httpd/htdocs/www/web39/html/admin/includes/classes/image_manipulator.php on line 215 Warning: Division by zero in /usr/local/httpd/htdocs/www/web39/html/admin/includes/classes/image_manipulator.php on line 52 Warning: Cannot modify header information - headers already sent by (output started at /usr/local/httpd/htdocs/www/web39/html/admin/includes/classes/image_manipulator.php:52) in /usr/local/httpd/htdocs/www/web39/html/admin/includes/functions/general.php on line 146 ich habe imageprozessing gestartet, um die positionierung des overlay-gif's zu aktualisieren. trotz fehlermeldung funktioniert die aktualisierung. ciao kevin
  12. hallo. kann mir das bitte mal jemand erkl?ren: overlay.gif,10,-50,60,FF0000) overlay.gif - klar, image-name und format 10 - ??????????? -50 - ?????????? 60 - ??????????? FF0000 - klar, farbe - aber wozu eine farbangabe ? danke ciao kevin
  13. hallo. habe ich mal schnell getestet - funtioniert. beim artikel im adminbereich kann mann zwar den artikelstatus (auf lager oder nicht vorr?tig) markieren, habe ich jedoch nicht beachtet, sondern die voreinstellung "auf lager" belassen. artikeldaten eigegeben und dann artikelanzahl 0. artikel wurde im shop angezeigt, war auch klickbar. beim versuch diesen artikel zu bestellen erschien jedoch folgende meldung Die mit *** markierten Artikel sind leider nicht in der von Ihnen gew?nschten Menge auf Lager. artikel konnte nicht bestellt werden. ciao kevin
  14. hallo. ich habe es zwar noch nicht versucht, denke jedoch, dass es funktioniert. versuche einmal folgendes: - im adminberich - "lagerwaltungsoptionen aufrufen" - "einkaufen nicht vorr?tiger ware erlauben" aufrufen - auf FALSE ?ndern dann im PRODUKTKATALOG (kategoerien / Artikel) beim jeweiligen artikel, welcher zwar angezeigt, aber nicht verkauft werden soll, den lagerbestand mit 0 (null) eingeben. ich denke mir, dass so der artikel zwar angezeigt wird, jedoch nicht kaufbar ist. einfach probieren und testbestellung versuchen. vorsicht bei eingabe eines artikelpreises von 0,00 euro !!! wenn sich ein iteressent die angezeigte seite ausdrucken l?sst und per fax oder post als bestellung zuschickt, musst du innerhalb der gesetzlich vorgeschrieben fristen die bestellung zum preis von 0,00 euro ablehnen, sonst kann es dir passieren, dass du den artikel f?r 0,00 euro auch abgeben musst. ciao kevin
  15. hallo, danke f?r den hinweis bei durchsuchen "alle" beitr?ge habe ich die info gefunden und es funktioniert. was nicht funktioniert ist das anzeigen von 2 bannern nebeneinander . ich habe die entsprechenden codes in includes/banners.php eingef?gt und in der index.html (nat?rlich differenziert mit BANNER und BANNER_2) - wird aber nur BANNER angezeigt. dann habe ich auch mal versucht - einfach nur mittels html-tag - z.b. <a href="http://www.URLderWebsite.de" target="_blank"><img src="URL-Verzeichnispfad-des-Banners.de" alt="xxx" height="60" width="468"></a> bei anlegen einer neuen kategorie in die kategoriebeschreibung einzuf?gen. wird aber leider nichts angezeigt. oder ist die eingabe im adminbereich bei kategorie von html nicht m?glich? bei suche mit "html" (ist ja eigentlich ein gebr?uchlicher begriff) wird ?berhaupt kein suchergebnis angezeigt - suche in ALLEN beitr?gen und foren!?! naja, kann ich mit leben ist nicht so wichtig - aber neugierig bin ich schon, ob und wie man das realisieren kann. ciao kevin
×
×
  • Create New...