Jump to content
xt:Commerce Community Forum

sandra77

Members
  • Content Count

    248
  • Joined

  • Last visited

Everything posted by sandra77

  1. Hallo, in der DB-Tabelle "xt_products_description" habe ich das Feld "products_ingredients" hinzugefügt mit den Einstellungen: Typ:"TEXT", Kollation:"uft8_general_ci", Null:"ja" Im Backend wird mir das Textfeld angezeigt mit der Bezeichnung: "TEXT_PRODUCTS_INGREDIENTS:" Doch im Frontend erhalte ich keine Ansicht der Einträge! Kann mir bitte jemand damit weiterhelfen? Danke, Sandra
  2. Hallo, in meinem Shop sind nun 2 Mandanten eingerichtet. Wenn ich nun in den Optionen eines Artikels unter "Shop" einen Mandanten anklicke (natürlich schön speichere und neu lade), wird mir dieser Artikel im Frontend nicht mehr angezeigt. Erst nach Deaktivierung (Herausnahme des Häckchens) im Mandanten wird er wieder angezeigt. Ich habe nun viele Artikel, die es in einem Mandanten geben soll und im anderen Mandanten nicht. Was muss ich sonst noch einstellen, damit ich den Artikel einem Mandanten zuordnen kann und er dann auch angezeigt wird? Hat es damit was zu tun: Hinweis: Ihr Rechte-System ist eingestellt auf "Blacklist" Wenn Sie eine Berechtigung auswählen wird dieser Datensatz für die Gruppe deaktiviert! oder muss ich in der Mandanten-Einrichtung etwas einstellen? Beste Grüße, Sandra
  3. Mit Domain setzt Du eine Installation gleich? Also sind 2 veyton Installationen notwendig! Richtig? LG
  4. Hallo, kann es sein, dass, wenn ich unter localhost 2 Mandanten laufen lassen möchte, 2 Installationen brauche? Ich kriege das mit 1 Installation, nur mit "Url http:=http://localhost/" und der Template-Auswahl nicht hin. Online scheint das ja irgendwie mit Weiterleitungen auf die Domains zu funktionieren (hoffe ich für später). Es geht darum für die 2 Mandanten unterschiedliche Versandkosten, Lieferbedingungen, Email-Texte, etc... anzulegen. Das ist mit der Merchant-Version schon möglich oder? Danke im Voraus, Sandra
  5. super, danke. noch eine Frage: sobald ich im Backend eine Kategorie einem Shop mit Häkchen zuweise("Kategorie bearbeiten", "Shop") wird diese Kategorie im Frontend nicht angezeigt. Wenn die Häkchen nicht gesetzt sind, wird es angezeigt. Das kommt mir etwas komisch vor, denn ich es sollen ja nicht alle Kategorien in allen beiden Shops sichtbar sein. Müssen die Shops noch anders definiert werden, evtl. nicht mit Blacklist? Viele Grüße, Sandra
  6. Hallo Forum, nachdem ich die Tabellen xt_categories, xt_categories_description, xt_categories_permission in meinen lokalen Shop importiert habe, sind sie zwar im Backend sichtbar, aber nicht im Frontend. Welche Tabellen muss ich noch aus dem funktionierenden Shop importieren, damit ich den kompletten Kategorienstamm sichtbar und funktionstüchtig mit allem richtig verknüpft erhalte? Viele Grüße, Sandra
  7. Hallo, nachdem ich gestern ionCube erfolgreich auf Xampp installiert habe, bekomme ich nun meinen veyton-shop zwar installiert, aber nicht geöffnet. Fehlermeldungen siehe Thread von gestern ganz unten (worauf leider niemand gepostet hat, deswegen mein Versuch mit neuem Thread) http://www.xt-commerce.com/forum/fragen-zur-software/79377-installationspfad-wirft-leere-seite-aus.html#post363319 Irgendetwas stört die ganze xt Software an meinem neuen Rechner. Kann es am 64bit System liegen, oder an der PHP-Version 5.3 ? Liebe Grüße, Sandra
  8. also, dank des ioncube wizard tools konnte ionCube richtig installiert werden (übrigens in meinem Fall im Ordner "php" mit Scropt-Aufruf: zend_extension = "C:\xampp\php\ioncube\ioncube_loader_win_5.3.dll" Nach entpacken von veyton im webspace und einfügen der licenzdatei und erfolgreicher Installation (xt:Commerce VEYTON 4.0 Enterprise wurde erfolgreich installiert!) nun folgende Fehlermeldung beim Aufruf des Frontends: Fatal error: Cannot redeclare date_add() in C:\xampp\htdocs\veyton\xtFramework\functions\date_short.inc.php on line 81 und folgende Fehlermeldungen beim Aufruf des Backends: Deprecated: Function split() is deprecated in C:\xampp\htdocs\veyton\xtFramework\library\adodb\adodb-perf.inc.php on line 94 Deprecated: Function split() is deprecated in C:\xampp\htdocs\veyton\xtFramework\library\adodb\adodb-perf.inc.php on line 97 Deprecated: Function split() is deprecated in C:\xampp\htdocs\veyton\xtFramework\library\adodb\adodb-perf.inc.php on line 94 Deprecated: Function split() is deprecated in C:\xampp\htdocs\veyton\xtFramework\library\adodb\adodb-perf.inc.php on line 97 Deprecated: Function split() is deprecated in C:\xampp\htdocs\veyton\xtFramework\library\adodb\adodb-perf.inc.php on line 94 Deprecated: Function split() is deprecated in C:\xampp\htdocs\veyton\xtFramework\library\adodb\adodb-perf.inc.php on line 97 Fatal error: Cannot redeclare date_add() in C:\xampp\htdocs\veyton\xtFramework\functions\date_short.inc.php on line 81 Der ausgeführte Veyton server_test sagt es sei alles in Ordnung. Ist die PHP-Version 5.3.1 nicht passend? Weiss jemand Rat? online läuft der Shop, am Mac ebenso. Nun würde ich den Shop aber auch gerne an meinem neuen PC zur Entwicklung installieren! Muss das so kompliziert sein? Liebe Grüße, Sandra
  9. ok, ; ist entfernt: keine Änderung Auschnitt aus php.ini: ... ;extension=php_pdo_oci.dll ;extension=php_rar.dll zend_extension_ts = "C:\xampp\ioncube\ioncube_loader_win_5.2.dll" ;zend_extension = "C:\xampp\php\ext\php_eaccelerator.dll" ;zend_extension = "C:\xampp\php\ext\php_xdebug.dll" ;;;;;;;;;;;;;;;;;;; ; Module Settings ; ;;;;;;;;;;;;;;;;;;; ... leere Seite, nach wie vor auch beim Aufruf der testdatei unter http://localhost/server_test/index.php
  10. bin die gesamte Installationanleitung durchgegangen. ioncube sollte installiert sein (habe Einträge wie angegeben gemacht, kann aber in der php-info im xampp-panel keinen Eintrag dazu finden, mod-rewrite gesetzt. Kein Erfolg. Allerdings gibt es in meiner php.ini kein direktes [ZEND] Nur die 2 Zeilen ;zend_extension = "C:\xampp\php\ext\php_eaccelerator.dll" ;zend_extension = "C:\xampp\php\ext\php_xdebug.dll" unter die ich ;zend_extension_ts = "C:\xampp\veyton\ioncube\ioncube_loader_win_5.2.dll" so gesetzt habe. und in der http.conf steht nun: LoadModule rewrite_module modules/mod_rewrite.so (habe den Link auf den ioncube-ordner in veyton gelegt, da da der ordner ioncube schon vorhanden war. Versuche zuvor, in denen ioncube direkt in xampp lag, brachten auch keinen Erfolg. Habe nun schon x Versuche und Änderungen durch. Kein Erfolg Leere Seite im Browser, keine Fehlermeldungen. Hat noch jemand eine Idee (Vor einem halben Jahr ließ sich veyton einwandfrei am mac installieren, also da gings) Liebe Grüße, SAndra
  11. Hallo Forum nach Installation von Xampp unter Windows, dem Entpacken von veyton und Einfügen der Lizenzdatei ist es mir nicht möglich, das Installationsscript unter http://localhost/shop/xtInstaller/index.php zu öffnen. Leere Seite, ohne Quelltext im Browser!!!! Das gleiche Dilemma mit dem Server-Text von xtCommerce: http://localhost/shop/server_test/index.php Habe es mit Firewall deaktiviert versucht, kein Erfolg! Hat jemand eine Idee an was das liegen könnte? Liebe Grüße, Sandra
  12. Hallo, wie kann ich in veyton bewirken, dass statt der Flaggen für die Sprachen die Texte "Deutsch" "Englisch" dastehen? Habe es über das Backend in -Einstellungen-Lokalisierung-Sprachen- versucht, indem ich en.gif und de.gif rausgelöscht habe. Leider bewirkt er das gewünschte nur im Firefox, nicht im Chrome-Browser. Im Chrome werden mir gebrochene also fehlende Images angezeigt. Gibt es noch eine saubere Script-Lösung, z.b in box_language Datei im folgenden Code? {foreach name=aussen item=box_data from=$lang_data} <a href="{link page='dynamic' params='action=change_lang&new_lang' params_value=$box_data.code}">{img img=$box_data.image type=w_media_flags alt=$box_data.name}</a> {/foreach} Vielen Dank im Voraus Sandra
  13. "Artikel als Geschenk verpacken" soll eine Option sein, genauso wie bei amazon angeboten. also nicht fix in den Versandkosten verankert. wie könnte das ohne Programmieraufwand ablaufen? Liebe Grüße, Sandra
  14. Hi Matthias, leider kann ich in den veyton-modulen die von mir beschriebenen Module nicht finden. Wahrscheinlich meinst Du xt-Module? Weißt Du zufälligerweise, wie diese Module heissen, bzw unter welchem Namen ich sie finden kann? Das wäre mir eine sehr große Hilfe. Danke im Voraus, Sandra
  15. Hi, ich suche einen PHP/MySQL-Programmierer, der mir meinen veyton-shop für Naturkosmetik erweitert. Folgendes soll ergänzt werden: - Integration von Hauttypen-Images pro Artikel (mansche Artikel sind für 2 oder 3 Hauttypen geeignet, etc...standardmäßig werden alle 5 angezeigt) - Integration der Option im Checkout-Prozess "als Geschenk für 2,95 € verpacken" und dies in der Endsumme mit einbeziehen. - bei Klick auf den Button "in den Warenkorb" nicht den Warenkorb selbst öffnen sondern lediglich einen Layer anzeigen, in dem steht "Artikel wurde in den Warenkorb" gelegt. Für eine ausführliche Projektbeschreibung kontaktiert mich bitte unter sandra[at]calfeel.com Hoffe es findet sich jemand der Lust hat das umzusetzen. Liebe Grüße, Sandra
  16. habe das geschilderte Problem gelöst, indem ich MAMP auf die Standard Port Einstellungen zurückgesetzt habe. Viele Grüße
  17. Hallo, nach erfolgreicher Installation (wurde angezeigt) von veyton am mac unter MAMP bekomme ich die Startseit vom Shop unformatiert angezeigt (http://localhost:8888/shop/index.php). Jeder weitere Versuch auf eine Unterseite zu kommen verweist auf "Firefox kann keine Verbindung zu dem Server unter localhost aufbauen." Der Link "Startseite" des Shops veweist auf die URL: http://localhost/shop/index.php?page=index eben mit der Fehlermeldung "Fehler, Verbindung fehlgeschlagen"! Der Admin bereich hingegen läßt sich ohne Probleme unter http://localhost:8888/shop/xtAdmin/ejsadmin.php öffnen. In der "config.php" von veyton stehen folgende Paramater: define('_SYSTEM_DATABASE_HOST', 'localhost'); define('_SYSTEM_DATABASE_USER', 'root'); define('_SYSTEM_DATABASE_PWD', 'root'); define('_SYSTEM_DATABASE_DATABASE', 'shop'); define('DB_PREFIX','xt'); Die Datenbank wurde entsprechend angelegt. In der Datei httpd.conf in .../conf/apache/httpd.conf steht: ServerName localhost:8888 in MAMP-Startsite steht: Host localhost Port 8889 User root Password root Über die MAMP-Konsole in Einstellungen-Ports: Apache-Port: 8888 MySQL-Port: 8889 (Die Firewall steht, um dieses Problem zu lösen, auf off) Welche Paramteter gilt es zudem einzustellen bzw. was ist bei den obigen falsch? Hilfe dringend erbeten. Viele Grüße, Sandra
  18. Hallo Forum, habe soeben am Mac Veyton installiert. Es kam auch die Nachricht "erfolgreich installiert" mit den Optionen zum Frontend oder zum Admin-Backend zu gehen. Der Link zum Backend funktionierte. Der Link zum Frontend verwies ständig in einen neuen Installationsprozess!! Ich habe den Mac daraufhin neu gestartet. Beim Aufruf des MAMP-Panels "Startseite öffnen " wird ausgegeben: Error: Could not connect to MySQL server! In der der config.php stehen die DB-Einträge drin, wie ich sie zuvor beim Erstellen der DB eingerichtet habe. (localhost, root, (geheimes passwort), präfix xt) ioncube loader ist auch erfolgriech installiert. Warum bin ich nach der Installation schon nicht aufs Frontend gekommen? Welche Eintragungen muss ich ändern, um Zugriff zum mysql server zu erhalten? Vielen Dank im Voraus, Sandra
  19. Hallo, ich versuche gerade im Backend die "Hersteller", einzelne "Produkte" als auch "Kategorien" manuell für die Anzeige im Frontend zu sortieren, da mein Kunde dies für seinen Shop wünscht. In der Demo-Version kann man anscheinend nur Kategorien manuell sortieren (Leider rutscht bei jedem Versuch die zu verschiebende Kategorie als Unterkategorie rein, für was ich hoffentlich noch Anleitung finde). Gibt es ein Plugin, dass es dem Backend-Benutzer ermöglicht, Hersteller, Produkte und Kategorien manuell zu verschieben? Vom xt-commerce-Email Support bekam ich auf diese Frage folgende Antwort: "Sie können in jeder Kategorie die Reihenfolge der Artikel händisch hinterlegen." Allerdings finde ich das im Demo-Shop so nicht vor, wird aber vom Kunden erwünscht. Bevor ich mich für den Kauf von Veyton entscheide, würde ich den zusätzlichen Programieraufwand für derartiges gerne abschätzen. Viele Grüße, Sandra
  20. Hi, auch ich musste leider lange suchen, bis ich erst hier im Forum Hinweise zum deaktivierten Bilderupload in der Demo gefunden habe. Viele Grüße, S
×
×
  • Create New...