Jump to content
xt:Commerce Community Forum

Schober

Members
  • Content Count

    5
  • Joined

  • Last visited

Everything posted by Schober

  1. Hallo Community, ist es möglich für die verschiedenen Produktgruppen Mengeneinheiten anzugeben? Bei Produkten aus Produktgruppe 1 soll die Mengeneinheit in Stück sein, bei Produkten aus Produktgruppe 2 soll die Mengeneinheit 100mm sein. Dieses sollte dann auch im Warenkorb angezeigt werden. Bisher habe ich dazu leider nichts gefunden. Weiterhin soll bei Produkten aus Produktgruppe 2, wenn z.B. als Bestellmenge 247mm eingetragen wird, automatisch der Preis für volle 300mm berechnet werden. Ich sollte jedoch zum Einen die bestellte Menge und die abzurechnende Menge im Warenkorb und danach auch in der Bestellbestätigung angezeigt bekommen. Ist hierfür eine Lösung vorhanden oder bin ich der Erste, der derartiges wünscht? Mit freundlichen Grüßen, Alex
  2. Hallo zusammen, ich habe wie einige Andere auch ein Problem mit der TagCloud. Es geht um die aktuelle Version des Shops, Veyton 4.0.13. Natürlich bin ich im Besitz des Veyton Buches, habe daraufhin versucht, die Tag Cloud zu installieren. Von der Umsetzung her ist das Ganze ja nicht sonderlich komplex. Leider wird die Cloud nicht angezeigt. 1. Plugin heruntergeladen 2. Plugin installiert 3. Plugin aktivert 4. In den Einstellungen die Zahl der Mindestsuchbegriffe auf 1 gesetzt 5. {box name=xt_tagcloud type=user} in der index.html eingebaut (auch mehrfach an verschiedenen Stellen - zu Testzwecken) - vergeblich 6. Einige Produkte über die Suche gesucht 7. Einige Tage gewartet, nichts passiert Habe ich irgendwo einen Fehler/Denkfehler drin? Etwas in der CSS vergessen?! Bin auch in zwei anderen Shops genau wie oben beschrieben vorgegangen.... auch ohne Erfolg. Ich bin etwas verzweifelt. Würde mich sehr freuen, wenn sich jemand der Sache annehmen würde. Vielen Dank im Voraus!
  3. Mod_Rewrite lässt sich wie folgt testen. Erstellen Sie eine Datei mit dem Namen "rewrite.php" und eine Datei mit dem Namen ".htaccess". Kopieren Sie den folgenden Quellcode in die "rewrite.php" und laden Sie diese auf den Webserver: _________________________________________________ <h2 align=center> <?php // mod_rewrite Test Page // Copyright 2006 Webune.com if($_GET['link']==1){echo"You are not using mod_rewrite";} elseif($_GET['link']==2){echo"Congratulations!! You are using Apache mod_rewrite";} else{echo"Linux Apache mod_rewrte Test Tutorial";} ?> </h2> <hr> <head> <title>How To Test mod_rewrite in Apache Linux Server</title> </head> <body> <p align="center">by <a href="http://www.webune.com">Webune</a></p> <p><a href="rewrite.php?link=1">LINK1</a> = rewrite.php?link=1</p> <p><a href="link2.html">LINK2</a> = link2.html</p> <p>How this works: both links are for this same page, except they both are different. link one is without the mod_rewrite and link2 is using mod_rewrite. Link1 show the php file, with with mod_rewrite we are mascarading the php file into a html file. you can use whatever type of extension you want, you can change it to .htm or .shtml etc... all you have to do is to make sure you also chang it in the .htaccess file</p> <p><< <a href="http://www.webune.com/forums/viewtopic-p-62.html">Go back to webune forums.</a></p> </body> </html> _________________________________________________ Kopieren Sie den folgenden Quellcode in die ".htaccess" und laden Sie diese auf den Webserver: _________________________________________________ RewriteEngine On RewriteRule ^link([^/]*).html$ rewrite.php?link=$1 [L] _________________________________________________ Sind beide Dateien gespeichert und hochgeladen, können Sie den Test durchführen. Tippen Sie die URL Ihrer Domain in den Browser und ergänzen Sie den Namen um die Erweiterung "/rewrite.php". Beispiel: "http://www.domainname.xyz/rewrite.php" Abschließend beide Links testen und im besten Falle, ist alles in Ordnung. Mit freundlichen Grüßen, Alexander Schober
  4. Habe nun herausgefunden wo mein Problem war... Nachdem ich noch die Funktion des "mod_rewrite" getestet hatte und dies auch erfolgreich war, ist mir zuerst leider nicht viel eingefallen... Durch einen dummen Zufall habe ich den Inhalt der Ordner auf dem Server überprüft... Und da war schon der Fehler, sehr simpel eigentlich. Hatte vergessen die Lizenz-Datei in den "lic"-Ordner zu kopieren. Vielleicht hilft es ja jemandem weiter... Nun noch die Verzeichnisrechte wie angegeben anpassen... Evtl. muss in der ".htaccess" noch die folgende Zeile eingefügt werden um alle Anforderungen zu erfüllen: php_flag magic_quotes_gpc on Danach hat bei mir alles wunderbar funktioniert und ich konnte die Installation korrekt durchführen. Installationslink: "http://www.domain.de/xtInstaller/index.php" Mit freundlichen Grüßen, Alexander Schober
  5. Hallo Community, weiß leider noch nicht so ganz wo mein Fehler steckt... Ich versuche einen Veyton 4.0.13 zu installieren. Habe die Archivdatei entpackt, via FlashFXP, im Binary-Mode, hochgeladen. Rufe ich die Seite nun auf, erklärt er mir, dass ich den ioncube loader installieren soll. Ich kopiere die Dateien nach "/usr/local/ioncube" und erweitere die "/etc/php5/apache2/php.ini" um den Eintrag "zend_extension /usr/local/ioncube/ioncube_loader_lin_5.2.so". Ich kopiere die Datei "ioncube-loader-helper.php" nach "/srv/www/vhost/domainname/httpdocs/ioncube" und führe diese aus. Der Test sagt aus, dass ioncube erfolgreich eingebunden wurde und der ioncube loader bereit ist. Rufe ich nun die Domain selbst auf, erhalte ich die Meldung: "HTTP 500 - Interner Serverfehler" Rufe ich die Installationsroutine über "http://www.domain.de/xtInstaller/index.php" auf, erhalte ich ebenfalls die besagte Meldung. PHP.ini kann bei Bedarf zur Fehlerdiagnose gerne zur Verfügung gestellt werden. Das Ganze läuft auf einem virtuellen Server, der bei 1&1 gehostet ist. Als Betriebssystem ist ein openSUSE 11 mit Plesk 9 (64 Bit) Linux (2.6.25.20-0.5) installiert. Für Eure Hilfe bedanke ich mich sehr!
×
×
  • Create New...