Jump to content
xt:Commerce Community Forum

mjuergens

Members
  • Content Count

    55
  • Joined

  • Last visited

  • Days Won

    1

mjuergens last won the day on February 3

mjuergens had the most liked content!

About mjuergens

  • Rank
    Benutzer
  1. Hallo, ich habe Artikel mit Varianten im Shop und die jeweiligen Variantenartikel haben aktuell alle einen Rabatt von 25 %. Wenn man zuerst auf der Seite des Masterartikels ist, ohne bereits eine Variante ausgewählt zu haben, dann wird nicht angezeigt, dass es für den bzw. die Artikel Rabatt gibt. Das erscheint erst wenn man eine Variante auswählt. Die Artikel erscheinen auch gar nicht in der Liste wenn man sich alle Angebote anzeigen lässt.
  2. Ich habe gerade bei meinem Shop www.pronautics.shop ein Update auf 6.4. gemacht aber jetzt wird keine einzige Seite mehr angezeigt. Nur noch die Shopseite selber. Hat das Problem auch schon jemand gehabt? Edit: Wenn mod_rewrite in den SEO-Einstellungen abschalte, dann funktioniert es. Muss ich da vielleicht in der .htacces noch was anpassen? Edit 2: Scheint wohl tatsächlich an main_handler.php zu liegen. Mit dem main_handler von der 6.3.3 funktioniert es. Mit dem main_handler gab es ja wohl auch Probleme, aber ich habe schon die 6.4.1 installiert und ich dacht da wäre das schon gefixt?
  3. Danke für den Hinweis bzw. Link. Wahrscheinlich hat das noch niemand getestet, weil alle das nicht wissen wie man an die Version kommt wenn die Links hier aus der Seite nicht passen. Ich werde das mal direkt in meiner lokalen Installation testen. Ich bin mal gespannt mit welchen Bugs uns das Update überraschen wird.
  4. "Nicht gut gelöscht" ist aber sehr milde ausgedrückt. Ich hab zwei Shops wo die anscheinend gar nicht gelöscht werden, denn da wächst die Tabelle ziemlich schnell auf mehrere hunderttausend Datensätze.
  5. Danke für den Link, aber wo sollte ich das CDATA denn einbauen? Ich verwende in der Exportdefinition das Feld products_description_clean und da ist ja dann schon der "Fehler" drin, dass eben z.B. "&amp," statt "&" steht. Die Ersetzung des Semilkolons durch das Komma passiert ja in der Funktion, die die bereinigte Artikelbeschreibung zur Verfügung stellt. Ich kann das im Quelltext auskommentieren aber das kann ja nicht die Lösung sein. Wenn ich das dann hochlade steht da ja als Text "&amp," mitten in der Artikelbeschreibung. Das ist natürlich auch nicht gewollt. Oder stehe ich da gerade irgendwo auf dem Schlauch?
  6. Wo gibt es das Update denn? Da steht zwar was von Download, aber die Links hier auf der Seite verweisen alle noch auf die Version 6.3.3.
  7. Wenn ich Artikeldaten mit einem Export als XML speichere um diese dann bei Google-Shopping hochzuladen, dann werden zwar die Sonderzeichen wie z.B. das Und-Zeichen (&) in der Artikelbeschreibung zuerst richtig übersetzt in den entsprechenden HTML-Code (&) aber im Anschluss wird dann durch eine weitere Funktion das Semikolon durch ein Komma ersetzt, was dann dazu führt, dass die HTML-Codierung nicht mehr richtig ist und der Import bei Google mit einem XML-Formatierungsfehler abbricht. Ist das ein Bug oder muss ich dazu irgendwo was anders konfigurieren?
  8. Das Problem hatte ich auch. Das liegt daran, dass die Tabelle "xt_sessions2" zu gross wird und dann kommt ein Timeout von der Datenbank beim Zugriff auf die Tabelle. Das Problem tritt meistens auf, wenn ein angemeldeter Benutzer sich wieder abmeldet. Dann wird anscheinend versucht die Session-Daten wieder aus der Tabelle zu löschen und das läuft auf ein Timeout wenn die Tabelle zu viele Datensätze enthält. Temporär kann man sich damit helfen die Tabelle einfach zu leeren. Auf Dauer kann das aber nicht die Lösung sein. Ich würde eigentlich davon ausgehen, dass alte Session-Daten irgendwann automatisch aus der Tabelle gelöscht werden aber das scheint entweder gar nicht so zu sein oder nicht zu funktionieren. Falls das Problem nach dem neuen Update 6.4 (Was ja jeden Moment kommen dürfte, so wie es aussieht) immer noch besteht, dann werde ich mir wohl einen Cron-Job einrichten, der die alten Daten regelmäßig löscht.
  9. Hallo, ich habe in der Tabelle xt_products ein neues Feld angelegt und ich möchte dieses Feld in die Suche mit einbeziehen. (Version 5.1.4) Mir ist schon klar, dass ich das in den Klassen "search.php" und "search_query.php" machen kann bzw. muss. Dort kann man ja über einen Hook den SQL-Query-String erweiteren. Aber das funktioniert irgendwie nicht richtig. Entweder werden dann zuviele Suchergebnisse angezeigt oder gar keine mehr. Wenn man sich den resultierenden SQL-String anschaut, dann wird eine Erweiterung der WHERE Bedingung aber auch mitten drin eingefügt udn nicht am Ende der WHERE Bedingung. Hat jemand vielleicht ein konkretes Beispiel wie man das korrekt erweitert um ein weiteres Feld in die Suche einzubeziehen? Oder gibt es vielleicht auch die Möglichkeit eine komplett neue SQL-Abfrage für das neue Feld zu erstellen und das Ergebnis davon dann an das vorherige Suchergebnis dran zu hängen?
  10. Ich versuche jetzt auch schon seit Tagen ein zusätzliches Plugin für den ckeditor zu integrieren und zwar in diesem Fall ein Plugin um fontawesome-icons einfügen zu können. Ich habe dazu dass Plugin in den entsprechenden Ordner von xt_ckeditor kopiert und auch noch einstellungen für das plugin in den Einstellungen im Adminbereich gemacht, aber es passiert nichts. In der Debug-Konsole wird zwar aufgelistet, dass das ckeditor-Plugin gefunden wird, aber es wird nicht aktiviert. Ich haben in den Admin-Einstellungen auch noch andere Anpassungen gemacht (Buttons im ckeditor ausgeblendet) und das funktioniert auch. Aber das Plugin will absolut nicht funktionieren. Hat jemand schon mal damit erfolgreich ein weiteres Plugin in den ckeditor integrieren können?
  11. Wenn man den Shop generell auf Bruttopreise einstellt (was ja bei einem reinen B2C Shop sowieso sinnvoll ist) dann sollte das aber schon genau so funktionieren, oder liege ich da jetzt falsch?
  12. Aber klar ist das schon aufgefallen! Kam heute Nachmittag irgendwann. Hab auch schon direkt ein Update in einem Shop von einer Version 4.1.10 gemacht. An einigen Stellen muss man ein bisschen aufpassen weil die Doku für das Update nicht ganz eindeutig bzw. etwas missverständlich ist (vor allem beim Update des Templates), aber im grossen und ganzen klappt das recht reibungslos. Das "mehr" an Funktionalität gegenüber 4.1.10 ist aber eher unspektakulär. Ich hätte die Version wohl eher 4.1.2 genannt.... ;-) Aber für alle Downloadshops ist natürlich die neue Steuerbehandlung ab dem 1.1.2015 immens wichtig, von daher lohnt sich dafür ein Update auf jeden Fall bzw. ist notwendig. Sehr interessant ist natürlich auch die neue Funktion der integrierten Behandlung für 301 Redirects bei alten bzw. gelöschten URLs. Es war allerdings angekündigt das man auch manuell Einträge machen können soll, aber das funktioniert noch nicht (Der Button fehlt schlichtweg...)
  13. Das Update hat schon mal funktioniert. An der ein oder anderen Stelle muss man beim Update des Templates allerdings ein bisschen aufpassen, das ist nicht ganz eindeutig, bzw. etwas missverständlich, beschrieben manchmal. Dann wohlen wir jetzt mal testen was wir so alles an schönen neuen Features (und vielleicht auch neuen Bugs) bekommen haben.
  14. OK. Die ist aber jetzt echt erst vor ein paar Minuten "rein" gekommen.... Heute mittag war die noch da! ;-)
  15. Aber auch 4.2 erst mal haben.... ;-)
×
×
  • Create New...