Jump to content
xt:Commerce Community Forum

chrispeg

Members
  • Content Count

    357
  • Joined

  • Last visited

Everything posted by chrispeg

  1. Hallo, warum funktioniert das bei V6.xx nicht mehr? LG chrispeg
  2. Tja, anscheined führe ich hier wieder einmal ein Selbstgespräch. Schade. Das Problem muss doch irgendwie zu lösen sein ???? Falls sich doch noch jemand bereit erklärt, mir zu antworten bzw. einen Lösungsvorschlag mitzuteilen, an Den LG Chrispeg
  3. Hallo, dann hast Du mir gerade den entscheidenden Hinweis gegeben. Herzlichen Dank! Die Grundpreise sind enthalten: {$data.products_name} ({$data.base_price.price}/{$data.base_price.vpe.name}) € Mag vllt. etwas umständlich sein; funktioniert aber ... Liebe Grüße chrispeg
  4. Hallo df:bug, na vielen Dank; immer gleich ein weiteres Plugin!? Es geht doch lediglich um einen kleinen String, der die Preise an der richtigen Stelle ausgibt! Das mit dem EUR geht auch anders... LG chrispeg Folgender String müßte geändert werden: {$data.products_price.plain|string_format:"%.2f"|replace:".":","} Offensichtlich bezieht der sich nicht auf den Master-Preis
  5. Hat denn niemand eine Lösung? Bei der Ausgabe der txt-Datei für Google ist das jedesmal eine äußerst aufwändige Angelegenheit, die Preise wieder zu ersetzen, obwohl die ja für die Masters angegeben sind! Wieso holt sich das System die Preise vom teuersten Slave-Artikel? Hat denn niemand dieses Problem? Dann müsste es bei mir an den Einstellungen liegen - aber an welchen? LG chrispeg
  6. Hallo liebe Gemeinde. 1. wenn ich einen export starte, der wie folgt aussieht; {$data.products_id}~{$data.products_name} ({$data.base_price.price}/{$data.base_price.vpe.name})~{$data.products_price.plain|string_format:"%.2f"|replace:".":"," }~neu~{$data.products_description_clean}~auf Lager~{$data.products_model}~{$data.products_link}~{$data.products_image_org}~{$data.manufacturers_name}~DE::Standard:4.35~{$data.google_product_cat_BAK}~{$data.products_isbn} werden für die Masterartikel die Preise für den teuersten Slave-Artikel übernommen??? Die Preise sind "ab" Preise und jeder ab-Preis (also der billigste Preis) ist beim Masterartikel hinterlegt. Warum wird der teuerste Preis ausgegeben? 2. Dann hätte ich noch eine Frage: Ändere ich ~DE::Standard:4.35~ auf ~DE::Standard:4.35 €~ oder ~DE::Standard:4.35 EUR~ legt ein export erst gar nicht los ...? Ist das System so starr oder mache ich was falsch? Für Eure Hinweise/Ratschläge bin ich sehr aufgeschlossen und dankbar.... Liebe Grüße Chrispeg
  7. Weiß denn niemand Rat? Warum funktionieren die Einträge, die ja auch in den anderen email Vordrucken funktionieren, hier nicht? Wäre dankbar für eine Idee ! Vorher kann ich die Ermächtigung nicht nutzen, da die Kunden über Ihre Kundennummer ihr Mandat erteilen. LG chrispeg
  8. Hallo liebe Forumisten! xt:Commerce übernimmt nicht ein wichtiges Detail im Sepa-Mandat. Ich möchte für die Mandatsreferenz die Kundennummer einpflegen. Ich habe alle Codes schon durch (z.B. {$data.customers_id}, {$data.customers_cid}, {$order_data.customers_id}, {if $order_data.customers_cid} {txt key="TEXT_CUSTOMERS_CID"}: {$order_data.customers_cid}, {$order_data.customers_cid} etc.). Es ist doch sinnvoller, die Kundennummer anzeigen zu lassen, als den Kunden für jeden Auftrag ein separates Mandat ausfüllen/abgeben zu lassen! Egal, was ich einfüge: Die Kundennummer wird nicht angezeigt. Hat jemand eine Lösung? Ich wäre sehr dankbar! Viele liebe Grüße chrispeg
  9. Hallo Matzel, konntest Du das Problem lösen? Ist bei mir genau der gleiche Fehler. Da das Mandat nicht auf eine Order ausgestellt werden soll, sondern auf die Kundennummer? Leider sagt mir <pre>{$data|print_r}</pre> nicht, was anstelle eingefügt werden soll Viele Grüße Chrispeg
  10. Hallo df:bug, vielen Dank, aber ich hatte eigentlich nicht vor mir ein Plugin zuzulegen, zumal das snippet bereits einmal veröffentlich wurde und auch funktionierte. Leider finde ich es nicht mehr im Forum... Ich dachte an eine kleine Korrektur
  11. Hallo, liebe Forumisten vor eniger Zeit wurde mal irgendwo ein Sitemap inhalt für das Generieren von Contentseiten wie Zahlung/Versand etc. angeboten. Dieser Inhalt funktioniert jetzt nach langer Zeit leider icht mehr. {php} $added = false; if (!$added) { global $db; $rs = $db->Execute("SELECT * FROM xt_seo_url WHERE link_type=3 AND language_code='de'"); while (!$rs->EOF) { echo '<url> <loc>'._SYSTEM_BASE_HTTP._SRV_WEB.$rs->fields['url_text'].'</loc> <lastmod>'.date('c', time()).'</lastmod> <changefreq>weekly</changefreq> <priority>0.9</priority> </url>'.; $rs->MoveNext(); } $added=true; } {/php} Kann mir den Inhalt jemand korrigieren, damit die Kontent-Seiten ausgelesen werden können? Für Eure Hilfe herzlichen Dank im Voraus. Viele liebe Grüße Chrispeg
  12. Hallo, habe vom helpdesk eine Datei erhalten, die das Problem in meinem shop gelöst hat. Die Datei einfügen unter -> xtFramework->classes Viel Erfolg! LG chispeg Das Hochladen funktioniert nicht ... Wende Dich an den helpdesk class.checkout_base.php
  13. Liebe Leute! wie kann ich die Kurzbeschreibung für den Warenkorb aktivieren? Die Inhalte sind für jeden Artikel vorhanden, weden im Warenkorb jeodch nicht ausgegeben. Hat jemand eine Idee? DANKE LG chirspeg
  14. Liebe Leute! Gibt es eine Möglichkeit, bestimmte Kunden (Schweiz) einer Kundengruppe (->Nettokunde) bereits bei Anmeldung zuzuordnen? Bin bereits seit ein paar Tagen auf der Suche - hab' aber nix Passendes gefunden; oder hab' ich Tomaten auf den Augen? Für einen Tipp herzlichen Dank im Voraus! LG chrispeg
  15. Der letzte Eintrag des Strato-Error log. Kann man daraus etwas erkennen? Die vorhergehenden Einträge sind genauso und verweisen auf index.php 20.04.2019 10:12:39 aetherische-oele.biz [client 54.36.20.0] End of script output before headers: index.php Dateigröße 6860 kb. Was ist denn da faul? LG chrispeg
  16. ... die Antwort von Strato: Fehler mit Hinweis auf die max_user_connections deuten weniger auf einen Datenbankfehler hin, sondern darauf, dass in der Programmierung Ihrer Website viele Datenbankverbindungen geöffnet werden, ohne dass diese wieder geschlossen werden. irgendwann übersteigt die Anzahl der aktiven Verbindungen den Grenzwert, der gesetzt wurde, um eine Überlastung der Syasteme zu verhindern. Ich rate Ihnen daher, Ihre Programmierung dahingehend zu überprüfen. Was kann ich dem Techniker denn da antworten, damit er zunächst mal die Limitierung höher setzt.??? Wo muss ich denn in der Programmierung des Shops suchen, damit das Problem nicht mehr auftritt??? Für hilfreiche Hinweise herzlichen Dank im Voraus. Seit Tagen ist der Shop jetzt tot ... LG chrispeg Muss in der Datenbank etwas gelöscht /geschlossen o. ä. werden zB. adodb hat eine Menge Einträge und es werden ständig mehr, obwohl der shop gar nicht zugänglich ist ...? Verzweifel ... Tägliche Zugriffe auf zB. Operationen auf Ihrem Webspace: April 19 06:04:00 ausfuehrendes Script: .../index.php betroffene Datei: .../cache/adodb/43/adodb_43b464fa251d6421db5515 Vorgang: create April 19 06:04:00 ausfuehrendes Script: .../index.php betroffene Datei: .../cache/adodb/43/adodb_43b464fa251d6421db5515af Vorgang: open April 19 06:04:00 ausfuehrendes Script: .../index.php betroffene Datei: .../cache/adodb/6e/adodb_6e00fe33557add1ebeaff5 Vorgang: create April 19 06:04:00 ausfuehrendes Script: .../index.php betroffene Datei: .../cache/adodb/6e/adodb_6e00fe33557add1ebeaff5b7 Vorgang: open April 19 06:04:00 ausfuehrendes Script: .../index.php betroffene Datei: .../cache/adodb/6e/adodb_6e00fe33557add1ebeaff Vorgang: setattr April 19 06:04:00 ausfuehrendes Script: .../index.php betroffene Datei: .../cache/adodb/20/adodb_200392fa778b2db0fc6bb Vorgang: setattr April 19 06:04:00 ausfuehrendes Script: .../index.php betroffene Datei: .../cache/adodb/71/adodb_7184934fa743a9e4aa5f57 Vorgang: create Am 19.04. um 06:04:00 war der shopp schon 3 Tage inaktiv ... Wieso wird da etwas created und Attr. gesetzt?
  17. .. ja, mit dem Gedanken spiele ich auch; würde gern Deinen Rat einholen: Bitte an email info@aetherische-oele.com
  18. Hallo Alex, leider erscheint ja jetzt der Internal Server Error und Strato lehnt jede Hilfe ab, da es sich um ein internes - also Shop-Problem handelt. Die schauen nicht mal danach ... ???? Und jetzt??
  19. Hallo, liebe Leute, mit dieser Fehlermeldung: max_user_connection bzw jetzt ein Internal Server Error funktioniert mein shop nicht mehr. Ich habe mehrfach gelesen, dass man in einer Datei (php.ini?) eine Einstellung erhöhen muss. Kann mir jemand sagen, welche Datei und was ich da eintragen muss? Die Links hier im Forum aus den letzten Jahren funktionieren nicht mehr. Wie kommt denn sowas? Das letzte was ich im Shop getätigt habe, sind mehrere neue Artikel (Master/Slave) anlegen. Vielen Dank im Voraus chrispeg Ach so: V6.1.1
  20. Hallo liebe Leute! mit der V6.1.1 wird wohl nun entgültig auf paypal gebaut. Leider funktioniert das Plugin nicht mehr. Bei der Nutzung erhalte ich folgende Fehlermeldung: xt_shutdown_function Array ( [type] => 1 [message] => Uncaught Error: Call to a member function _filter() on null in /mnt/web010/e1/12/538312/htdocs/xt_thuja/xtc5neu/plugins/xt_banktransfer/hooks/module_checkout_php_checkout_payment_check.php:16 Stack trace: #0 /mnt/web010/e1/12/538312/htdocs/xt_thuja/xtc5neu/xtFramework/classes/class.checkout_base.php(253) : eval()'d code(2): include() #1 /mnt/web010/e1/12/538312/htdocs/xt_thuja/xtc5neu/xtFramework/classes/class.checkout_base.php(253): eval() #2 /mnt/web010/e1/12/538312/htdocs/xt_thuja/xtc5neu/xtFramework/classes/class.checkout_base.php(199): checkout_base->process_pageAction_payment() #3 /mnt/web010/e1/12/538312/htdocs/xt_thuja/xtc5neu/xtCore/pages/checkout.php(57): checkout_base->process_pageAction('payment') #4 /mnt/web010/e1/12/538312/htdocs/xt_thuja/xtc5neu/index.php(103): include('/mnt/web010/e1/...') #5 {main} thrown [file] => /mnt/web010/e1/12/538312/htdocs/xt_thuja/xtc5neu/plugins/xt_banktransfer/hooks/module_checkout_php_checkout_payment_check.php [line] => 16 ) Ist denn da eine Möglichkeit das PlugIn zu nutzen? PayPal reißt hier alle Zahlungsweisen an sich - Das will ich nicht unterstützen! Vor allem die sensiblen Kundendaten sind dabei ja wieder ein DSGVO-Problem! Von wegen Hacken, Server wer weiß wo ... etc. Für einen Tipp wäre ich sehr dankbar! Liebe Grüße Chrispeg gibt's eigentlich kein Handbuch mehr ??? Alle Themen enden in einer weißen Seite.
  21. Herzlichen Dank für den Hinweis, hatte zuvor noch einiges übersehen .... Wohl dem, der lesen kann! ... Ein schönes Wochenende! LG chrispeg
  22. Beim Öffnen der Startseite des Shops: Versioninfo corrupt - please contact xt:Commerce Support via helpdesk@xt-commerce.com ... Versionsinfo Habe ich nachträglich hochgeladen... ... Am Ende des mit vorgenannten Fehlermeldungen missglückten "Updating plugin": Update-Schritt abgeschlossenen. Klicken Sie auf "Weiter" um das Update fortzusetzen. Klicke ich auf "Weiter" geht alles wieder von vorne los - eine Endlosschleife also. Abbruch geht nicht Weiter geht auch nicht Was jetzt?
  23. Hallo liebe Leut' kann mir jemand sagen, was diese Fehlemeldung beim Update der Plugins bedeutet? [ERROR (StartPageScript)] Call to undefined method plugin::getRequiredStoreLicenseTypeFromXml() Danke Euch LG chrispeg ... weitere Einträge: #0 /mnt/web010/e1/12/538312/htdocs/xt_thuja/xtc5neu/xtWizard/lib/ControllerCommand.php(197): StartPageScript->{closure}(Object(ControllerCommand)) #1 /mnt/web010/e1/12/538312/htdocs/xt_thuja/xtc5neu/xtWizard/lib/ExecutableScript.php(302): ControllerCommand->executeCommand() #2 /mnt/web010/e1/12/538312/htdocs/xt_thuja/xtc5neu/xtWizard/lib/StartPageScript.php(1950): ExecutableScript->execAsyncAction(Object(WizardPage)) #3 /mnt/web010/e1/12/538312/htdocs/xt_thuja/xtc5neu/xtWizard/lib/WizardPage.php(175): StartPageScript->pluginsUpdate(Object(WizardPage)) #4 /mnt/web010/e1/12/538312/htdocs/xt_thuja/xtc5neu/xtWizard/lib/Wizard.php(337): WizardPage->process() #5 /mnt/web010/e1/12/538312/htdocs/xt_thuja/xtc5neu/xtWizard/lib/Wizard.php(295): Wizard->dispatch() #6 /mnt/web010/e1/12/538312/htdocs/xt_thuja/xtc5neu/xtWizard/index.php(105): Wizard->run() #7 {main} Beim Öffnen der Startseite des Shops: Versioninfo corrupt - please contact xt:Commerce Support via helpdesk@xt-commerce.com
  24. Guten Morgen, eine Kundin aus Österreich kann keine Zahlungsweise auswählen; das muss an ihren Browsereinstellungen liegen, da ich, als österreichischer Kunde eingeloggt, alles auswählen kann. Welche Browsereinstellungen müssen erfüllt sein? Für einen kurzen Tipp wäre ich sehr dankbar. Viele liebe Grüße chrispeg
  25. Hallo liebe Gemeinde, das Plugin habe ich jetzt zum Laufen bekommen. Jetzt passiert nur Seltsames: Der bezahlte Rechnungsbetrag eines Kunden lautet 113,75 €. In meinem paydirekt-Konto sehe ich folgendes: Bestelldetails: Warenwert: 126,59 € (? woher dieser Betrag) Gesamtbetrag 109,16 € (dieser Betrag wurde meinem Bank-Konto gutgeschrieben - kein Gebührenabzug!) Nach Kontaktaufnahme mit haendler@paydirekt habe ich den Hinweis erhalten, dass das plugin die Einstellung "gemischt" benötigt, um den vollen Betrag zu erhalten. Leider kann ich den Plugin-Einstellungen eine solche Möglichkeit ("gemischt") nicht entnehmen. Ist da beim Programmieren ein Fehler aufgetreten? Wo kann ich diese Einstellung vornehmen? Für Eure Rückmeldung herzlichen Dank im Voraus. chrispeg
×
×
  • Create New...