Jump to content
xt:Commerce Community Forum

Sussanne

Members
  • Content Count

    10
  • Joined

  • Last visited

  1. Hi, habe mir das Modul Print order (bui_print_order) downgeloade und installiert. Hatte nicht gesehen das man einen Lizenzfile dafür benötigt. Habs dann wieder deinstalliert. Jetzt bekomme ich eine Fehlermeldung und komme weder auf Shop noch Admin Bereich. Fatal error: The encoded file /homepages/14/d364163393/htdocs/xtcommerce/plugins/bui_print_order/classes/class.bui_print_order.php requires a license file ../lic/bui_print_order.txt. in Unknown on line 0 Löschen des Plugins via FTP bringt einen weißen Bildschirm. Hat jemand nen Rat?
  2. - wenn hir nicht richtig bitte verschieben - Hallo, vielleicht kann mir ja jemand helfen. Bs gestern kam noch die Emailbestätigung der Bestellung bei der Bestellemail an. Heute nochmals getestet und geht nicht mehr. Hatt bi dato aber keine Änderungen durchgeführt. Jetzt habe ich mal im Forum gelesen und SMTP eingestellt. Main Store -> Email Einstellungen smpt.1und1.de user Name: u12345678 passwort Empfänger-Kontaktformular: info@name.de SMTP Auth: true Einstellungen -> Konfiguration -> Einstellungen Path zu sendmail: /usr/sbin/sendmail E-mail system: smtp Unter Inhalte Email Manager habe ich die Weiterleitung auf "info@name.de, xxxxxxx@gmx.de" eingestellt. Es kommt nach dem Bestellvorgang aber keine Email mehr an. Auch wenn ich wieder auf sendmail umschalte hilft das nicht. Weiß echt nicht weiter. Kann es sein das ich bei 1und1 noch was aktivieren muss für smtp? Oder woran kann das Problem noch liegen. ------------------------- Hab noch mal auf sendmail umgeschaltet Dann geht nur das Kontaktformular
  3. Hier noch mal eine Installationsanleitung direkt von 1&1 kommt. Bitte beachten folgenes beachten: Punkt 4 Da wird /htdocs/ioncube als Pfad genannt. Bei 1&1 sieht man das Verzeichnis /htdocs nicht Legt /ioncube im Verzeichnis an wo auch die anderen Ordner drin sind Als z.B. /xtcommerce/ioncube Punkt 5 Die "loader-wizard.php" direkt nach der URL aufgerufen wird. Also www.xxxxxx.de/loader-wizard.php Nur so funktioniert der Wizard Ich mußte dann zusätzlich noch die php.ini in das Verzeichnis /xtAdmin kopieren und habe in der php.ini noch rewritebase / ergänzt. "Der ioncube Loader ist Standardmäßig nicht installiert. Sie können den ioncube Loader jedoch selbst installieren. Wie wird der ioncube Loader installiert? Damit der PHP-Quellcode vor Beobachtung, Änderung und Diebstahl geschützt wird, kann der "ionCube Loader" installiert werden. Mit dem ionCube Loader werden diese kodierten Dateien "ausgeführt". Wenn Ihr das so macht, sollte es funzen. Anleitung ohne Shell 1. Von der ionCube Webseite (PHP Encoder, protection, installer and performance tools from ionCube: Loader Download) das passende Archiv herunterladen (Linux x86 für Shared-Hosting und Homepage-Server, 32Bit). Der Archivtyp ist von Ihnen nach eigener Vorliebe wählbar. 2. Das Archiv entpacken. 3. Die Datei "loader-wizard.php" per FTP in das gewünschte Zielverzeichnis hochladen. 4. Die .so Dateien aus dem entpackten Archiv gehören in /htdocs/ioncube, ist der Ordner nicht vorhanden bitte erstellen. 5. Über einen Domain-Namen, von dem aus man das Verzeichnis in dem wizard liegt erreichen kann, die Datei "loader-wizard.php" aufrufen. 6. Der Anleitung gemäß "Shared" wählen und "Next" klicken. 7. Als Hosting Provider bitte 1und1 oder 1and1 angeben 8. Als URL des Hostingproviders bitte 1und1.de oder 1and1.pl 9. Auf der nachfolgenden Webseite liefert Punkt 3 alle weiteren notwendigen Informationen. * Nach Bestätigung ist der Wizard soweit fertig. Die php.ini wird im Rootverzeichnis abgelegt bzw. eine bestehende php.ini im Rootverzeichnis wird ergänzt (nicht überschrieben!). * Die php.ini aus dem Rootverzeichnis gegebenenfalls in das Verzeichnis kopieren in dem der wizard abgelegt ist. * "Click here to test the Loader" wählen. Es sollte nun angezeigt werden, dass ioncube korrekt installiert und verwendet werden kann. Wir freuen uns, wenn wir Ihre Frage umfassend beantworten konnten.
  4. So, habe heute nochmals alles neu installiert. Also Dateien und Verzeichnisse nach /xtcommerce (mein angelegter Ordner unter eshop.domainname.de) kopiert per FTP. Dann Verzeichnis unter erstellt (/xtcommerce/ioncube). Dort alle Dateien aus dem Download "ioncube_loaders_lin_x86" reinkopiert. Dann die .htaccess ergänst um RewriteBase .htaccess # RewriteEngine on # RewriteRule !\.(js|ico|gif|jpg|png|css)$ index.php AddType x-mapp-php5 .php DirectoryIndex index.php RewriteEngine on RewriteBase / RewriteCond %{REQUEST_URI} !^/media/ RewriteCond %{REQUEST_URI} !^/extAdmin/ RewriteCond %{REQUEST_URI} !^/skin/ RewriteCond %{REQUEST_URI} !^/js/ RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-l RewriteRule .* index.php php.ini sieht wie folgt aus zend_extension = /homepages/14/d364163393/htdocs/xtcommerce/ioncube/ioncube_loader_lin_5.2.so Diese in /xtcommerce/xtInstaller und in /xtcommerce kopiert Wenn ich dann die Installation starte klappt alles Problem los. Angaben eingeben und bis zum Schluss keine Fehler. Wenn ich dann aber auf Backend klicke kommt: Site error: the file /homepages/14/d364163393/htdocs/xtcommerce/xtAdmin/login.php requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator. Habe dann noch mal die php.ini auch in den Ordner /xtAdmin kopiert. Dann http://www.exxxx.xxxxxx.de/xtcommerce/xtAdmin/login.php und er springt auf http://xxxxx.xxxxx.de/de/404 Wenn ich allerdings dieses eingebe http://www.xxxxx.xxxxxx.de/xtAdmin/login.php komme ich ich auf den Admin Login (schon mal ein Stück weiter) Allerdings kommt nach Eingabe des Benutzernamens und das Passworst, die am Ende der Installation angezeigt worden, folgender Hinweis: Sie haben einen falschen Benutzernamen oder ein falsches Kennwort eingegeben. Gehen Sie bitte die richtigen Daten ein. Haben Sie vielleicht Ihr Kennwort vergessen? UND NUN? Kann es sein, das die php.ini noch in andere Verzeichnisse muss? Update: So, habe jetzt noch das Admin Passwort zurückgesetzt und siehe da, komme in den Adminbereich. Die Frage ist nur, wie kann ich jetzt sehen ob wirklich alles korrekt installiert ist. Muß die php.ini noch in andere Verzeichnisse kopiert werden? Beim Aufruf des Shops zeigt er unter XT:Commerce News "login required? Wenn ich dann auf Register Bestellungen, Kunden oder Verkäufe klicke, wird so ein Pfad angezeigt: http://xxxxx.xxxxx.de/xtAdmin/chart-data.php?resource=orders&type=mamount Woran liegt das denn?
  5. So hab den Shop nochmals installiert Nach der Installation auf backend gedrückt und dann kommt das: Site error: the file /homepages/14/d364163393/htdocs/xtcommerce/xtAdmin/login.php requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator. Es wurde aber angezeigt, das alles ohne Problem installiert worden ist. Meine ini.php sieht so aus: zend_extension = /homepages/14/d364163393/htdocs/xtcommerce/ioncube/ioncube_loader_lin_5.2.so Liegt im /xtcommerce und in xtInstaller xtInstaller nach der Installation gelöscht Hab ich hier was falsch gemacht?
  6. Da bin ich mir nicht sicher. Wo gebe ich das denn an ob ich über subdomain installiere. Bei der Lizenzdatei habe ich es angegeben. Wo kann ich das denn in der Datenbank ausstellen?
  7. Das ich das richtig verstehe http://www.subname.name_url.de/verzeichnis(beimir xcommerce)/xtAdmin Fehlt da noch was? Wenn nicht geht das nicht. Hinter der URL kommt dann /de/404 im Browser
  8. Hallo erst mal, habe mir heute XT:commerce neuste Version installiert. Läuft nach vielen hin und her auch. Allerdings habe ich keine Ahnung wie ich in den Admin Bereich komme. Habe scho viel gelesen. Angeblich kann man sich mit der bei der Installation angelegten email und dem dort vegebenen Passwort erstmalig anmelden und bekommt dann den Button angezeigt. Ist das bisher so richtig? Ich kann mich allerdings nicht einloggen. Bekomme dann diese Bild: Sie haben einen falschen Benutzernamen oder ein falsches Kennwort eingegeben. Gehen Sie bitte die richtigen Daten ein. Haben Sie vielleicht Ihr Kennwort vergessen? Sie haben bisher 3 mal versucht, sich anzumelden. Nach dem 5. fehlerhaften Versuch ist eine Anmeldung für die nächsten 20 Minuten nicht mehr möglich. Hab schon ein 2. Mal den Shop installiert und auch vorher die Datenbank gelöscht und neu angelegt. Ich habe keine Ahnung was ich jetzt machen muß. Bin übrigens bei 1&1 Schon mal Danke.
×
×
  • Create New...