Jump to content
xt:Commerce Community Forum

Search the Community

Showing results for tags 'editor'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • xt:Commerce - Professionelle eCommerce Shopsoftware
    • Fragen zur Software
    • xt:Commerce Plugins
    • xt:Commerce 4 Sprachen
    • xt:Commerce Online Handbuch
    • Häufige Fragen (FAQ)
    • Fragen zur Software (Pre Sale)
    • Anleitungen - Patches - Downloads
  • xt:Commerce Office - Shop & Warenwirtschaft
    • Allgemeine Fragen
  • xt:Commerce Allgemein
  • xt:Commerce 3 Shopsoftware Community Area (nur Lesen)
    • Allgemeine Diskussionen
    • Installation und Konfiguration
    • Shopbereich
    • Admininterface
    • Modul Entwicklung
    • Template System
    • xt:Commerce Schnittstellen ERP Systeme
    • PHP & MysQL Forum
    • HTML & CSS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biografie


Wohnort


Interessen


Beruf

Found 61 results

  1. Hallo zusammen, hat jemand seine 4.200 schon mal mit dem aktuellen CKEditor ausgestattet? Frage deshalb weil ich seit Tagen im 404 Bereich über 100 verschiedene Scans/Versuche mit ../fckeditor/../uploadtest.html habe und die Version in der 4.200 ja auch schon etwas betagter ist. Danke für Euer Feedback
  2. Hallo zusammen, Problem: Der standard-HTML-Editor lässt keine IMG-endtags zu. Beispiel Eingabe <img Bild-jpg </img> Editor erzeugt <img Bild-jpg > Funktioniert zwar in den üblichen Browsern aber der W3C markert dies als Code-Fehler. Da Veyton in XHTML ist, müssen IMG-tags zwingend ein End-tag haben. Siehe auch http://www.w3schools.com/tags/tag_img.asp Weis jemand Abhilfe? Nachtrag: Der Editor von veyton baut noch weitere tags in HTML um. Damit erzeugt der Editor insgesamt keinen sauberen code mehr und ist nicht XHTML-konform.
  3. Hi, in unserem 4.0.14er shop taucht seit einiger Zeit sporadisch der bug auf, dass nach simplen Änderungen des Beschreibungstextes von Produkten (zB. Passagen in der Schriftfarbe ändern, Text ergänzen..) im Editor der Quelltext plötzlich voller \n, \t oder \" -Schnipsel daherkommt. \n und \t sind dann dutzendfach im Frontend sichtbar, und es werden uns auch div-tags usw. zerschossen, so dass Formatierungen etc. leiden. Dass vereinzelt mal ein "\n" irgendwo auf der Seite auftaucht, wusste ich bereits, und da ist ja hier im Forum recht gut beschrieben, wie man das wieder los wird. Aber die Ausmaße hier sind anders, ich hab grad 200+ von den Viechern im Quelltext eines Produktes gelöscht Wobei ich übrigens nicht beschwören kann, dass das Ganze direkt nach dem Editieren und Speichern auftritt; wer immer bei uns editiert ist eigentlich angehalten, sich die Seite danach im Shop anzusehen, und eigentlich wird das auch gemacht.. Ach ja, und vor ein paar Wochen haben wir eine Auflistung von Zielen bei den Versandoptionen (" Wir liefern nach x, y, z...") hinterlegt, und diese wurd im Frontend auch mit "\n" gespickt.. scheinbar kam nach jedem Speichern ein neues "\n" pro Aufzählungsglied dazu.. ich hab die dann alle rausgelöscht, und danach wars OK... Hat jemand eine Idee, was das sein kann? Gut, wir verwenden ein Fremd-template, aber eigentlich läuft der shop jetzt >1,5 Jahre ohne diesen Käse... und gehostet sind wir beim "Empfohlenen", daher sollte server-seitig eigentlich auch nix vorliegen, was sich mit xtc nicht verträgt.. aus ner anderen Quelle copypasten machen wir beim Editieren übrigens auch nicht, insofern ich mir auch nicht vorstellen kann, dass da was aus Word eingeschleppt wurde etc. Danke für jede Idee, Durchblick
  4. Hallo, folgendes Problem stellt sich mir. Ich nutze Firefox & Chrome mit dem neusten Adobe Flash. Wenn ich im Backend bei 4.1 den TinyMCE Editor aktiviere, wird mir im Content nichts angezeigt. Ich kann den vorhandenen Content nicht einmal mittels Texteditor bearbeiten, da auch dieser verschwunden ist. Woran kann es liegen dass der TinyMCE Editor nicht läd und ich den Content nicht bearbeiten kann? Vielen Dank im Vorfeld! Grüße
  5. Hallo zusammen, bin recht neu und habe mich die letzten 2 Wochen ausführlich mit dem Shop befasst...Konnte mir auch schon einiges aus dem Forum zu nutzen machen dafür erst mal Daumen hoch Nun zu meinem eigentlichen Problem. Ich habe heute nochmal den Shop neu installiert, Layout angepasst etc....Nun versuche ich gerade dabei die Texte einzupflegen allerdings bleibt es beim versuchen. Sobald ich längere Texte mit dem Simple HTML Editor wie z.B Datenschutz und AGBs einpflegen möchte so speichert er es entweder gar nicht und es kommt die Fehlermeldung "Kein Erfolg" oder er speichert nur einen bestimmten Teil des Textes. Das Problem tritt sowohl bei Firefox als auch bei Chrome auf. Die Texte wurden sowohl als Klartext als auch in HTML versucht abzuspeichern. Der Tiny funktioniert gar nicht, da wird noch nicht einmal ein Feld zum bearbeiten angezeigt. Ist diese Problem schon bekannt ?
  6. Hallo, kann sein ich habe es übersehen. In der 3.04 konnte ich über den Editor Bilder auf den Contentseiten einfügen, bei dem neuen Editor gibt es diese Funktion leider nicht mehr. Wenn ich in Veyton den Contentseiten Bilder hinzufügen möchte, geht dies dann nur durch eingabe des Html-Codes <img src="">[/HTML] ???? v.g. micha
  7. Amrit

    Editor

    Moin, ich habe ein Text-Eingabefeld im Backend/ Artikel eingebaut, damit will ich Atributstexte für die Slaves eingeben, finde es umständlich immer zu den Slaves gehen zu müssen um die zu ändern. Funktioniert auch, aber wie kann ich dem Textfeld den Editor zuweisen, dass ich den Text auch formatieren kann, habe irgendwo gelesen dass das geht finde es aber nicht mehr, kann mir da jemand auf die Sprünge helfen wie ? läuft z.Zt. über die css, hätte es gern Komfortabler. Grüße Manfred
  8. Hallo, Mit dem SimpleHTML Editor funktioniert alles wunderbar. Aber der TinyMCE ändert mir immer den Code um: <script type="text/javascript">meinCode</script> ändert der immer in: <script type="text/javascript">// <![CDATA[meinCode// ]]></script>[/code] um. Wie kann ich das abschalten? hab schon in der conf_tinymce.php geguckt, da lies sich nichts machen. mfg
  9. Gibt es eine Möglichkeit Bilder im Editor nicht nur über URL in dir Artikel/Kategorie Beschreibung einzugeben, sondern auch direkt über Upload. Oder zumindest eine Möglichkeit die über Media Manager hochgeladene Bilder auszuwählen. Denn im Moment sind Artikelbilder und HTML Editor zwei verschiedene Welten. Und diese würde ich gerne miteinander verknüpfen. Gibt es vielleicht ein Workaround oder evtl. ein Modul?
  10. Hallo Zusammen, mich stören die wenigen Funktionen der Standardinstallation des TinyMCE Editors daher habe ich hier im Forum nach einer Lösung gesucht und leider nichts gefunden. Nun habe ich mittlerweile festgestellt das in der conf.tinymce Datei folgendes hinterlegt ist: var tinyMCESettings = { mode : "specific_textareas", language : "en", theme : "advanced", editor_selector : "TinyMce", dennoch wird im Admin-Bereich ausschließlich der simple-mode angezeigt.... lässt sich das irgendwie ändern? Hab auch schon mit den Sprachdateien herumgespielt aber keine Änderung erfahren. ...
  11. Hallo zusammen. Ich setze meinen ersten xtc v3.0.4 SP2.1 Shop auf. Wo kann ich den WYSIWYG Editor für die Artikelbeschreibung einschalten? Danke im voraus.
  12. Heyho, Ich mache gerade meine ersten Erfahrungen mit xt:commerce und wurde nun glatt in's kalte Wasser geschmissen. Ein bestimmter Textteil soll mit einem bestimmten HTML Code umgeben werden. Sprich bestimmter Textteil soll zu <htmlcode...> bestimmter Textteil </htmlcode> werden. Klar könnte ich auch manuell machen, die Shopbetreiber jedoch nicht. Das heißt ich muss einen Weg finden wie das zu automatisieren. Hätte mir sowas vorgestellt wie ein Button im Editor. Prinzip ist ja Beispielsweise bei der Vergebung einer Schriftgröße das selbe. Es wird einfach ein <font> tag um den markierten Bereich erstellt. Doch wie setze ich so etwas um und wie bekomme ich es in den Editor? Gruß CanTK
  13. hallo, stehe for einem problem welches ich leider nicht gelöst bekomme! ich moechte artikel eingeben. jedoch versagt der fck editor im admin seinen dienst! die menueleiste des editors ist vorhanden jedoch wird das textfeld fuer die artikelinformationen nicht angezeit!!!! kann also keine artikelinformationenn hinterlegen. was kann ich tun??? ueber hinweise oder fuer ratschlaege waere ich sehr dankbar. beste gruesse feminissimo
  14. Wie <h1/2/3>, <br />, wie <p> erstellen? Wie kann man das einstellen? Das ideale Verhalten wäre: Return = neues <p> Shift + Return = <br /> Aktuell ist: Return = <br> (kein XHTML) <h1/2/3> & <p> nur manuell über Code View
  15. Hi zusammen, ich will im Content Manager lieber mit Quellcode arbeiten... Dieser Tiny Mode macht mich krank. Der schreibt mir nicht sauber genug. Kann mir jemand sagen, wie ich umstellen kann auf Quellcode. Oben steht ja dick Quellcode, aber da bekomme ich ein extra Fenster auf, wo ich aber nichts geändertes speichern kann etc. Es erscheint immer nur dass, was ich in dem Editor (WYSIWYG) geschrieben habe. Will aber direkt am Code was ändern... Vielleicht total die doofe Frage, aber ich bin am verzweifeln schon. Kann doch nicht so schwer sein, oder? Wie gesagt, er zeigt mir den Code im seperaten Fenster an etc. aber ich kann nichts ändern, bzw. speichern... Freundliche Grüße Björn
  16. Hallo miteinander! Irgendwie habe ich beim letzen Male den Editor zerschossen...., ich möchte im Bereich " Kategorien" was ändern, es zeigt sich allerdings nur der HTML-Editor. Habe von HTML keine Ahnung, ich möchte bequem Text schreiben, ohne HTML Gedöns. Ich finde auch keinen "Knopf" um das Teil umzustellen. Frage: Wie bekomme ich meinen WYSIWYG Editor wieder???? Bin für jede Idee dankbar!
  17. Hallo in die Runde, ich habe irgendwo einmal einen grafischen Editor gesehen, der es erlaubte, beim Kauf ein Produkt mit einer Gestaltung zu versehen. Hintergrund ist folgender: wir würden gerne ein Produkt mit Aufdruck anbieten und der Kunde soll den Aufdruck selber gestalten - gibt es hierfür soetwas wie einen Editor, der eine Bilddatei generiert, welche bei einer Bestellung beigefügt wird? Vielen Dank im Voraus, J. Sommer
  18. Wollte mal fragen wie man es schafft, nur den Font für die Artikelbeschreibung zu ändern. Hatt es mit der "stylesheet.css" im Templateordner versucht, aber dann ändert sich ja gleich alles. Da ich jetz schon fast 1000 Artikel habe, möchte ich jetz nicht alle nochmal mit dem Editor ändern, dass geht doch auch bestimmt einfacher, oder!? MFG
  19. und schon wieder ein Frage... im WYSIWYG Modus kann man ja auch Styles ausw?hlen... wie und wo kann ich die denn hinterlegen ? Mit der "normalen" Styledatei, die ich innerhalb des Templates anpassen kann, klappt es wohl nicht.... ist da noch eine Datei, die man anpassen k?nnte... Ich hab selber mal in einer meiner Applikationen einen WYSIWYG-Editor eingebaut. Da gab es eine .TXT Datei, die included wurde und in der man die Styles definieren konnte... Gruss Morix... :?:
  20. Hi, es wurde der neue Editor eingebaut und fuktioniert einwandfrei - nur: es werden keine Bilder über den "Bilder einfügen/edittieren" eingesetzt. Bilder wurden heruntergeladen und im Text erscheint nur ein leerer Bilderrahmen ( ebenso in der Vorschau des Editors ). Beim Speichern der Seite wird dieser Bilderrahmen aber wieder gelöscht. Beim Vorgänger des jetzigen Editors hat es noch einwandfrei funktioniert - wo könnte der Fehler liegen ? Danke für Eure Hilfe ciao Klaus
  21. Ich könnte den FCK an die Wand klatschen... Seit Tagen versuche ich den Bilder-upload zum laufen zu bekommen. Ich habe folgende Fehlermeldung: The server didn't send back a proper XML response. Please contact your system administrator. XML request error: Forbidden (403) Requested URL: http://www.domain.de/admin/includes/modules/fckeditor/editor/filemanager/connectors/php/connector.php?ServerPath=%2F&Command=GetFoldersAndFiles&Type=Image&CurrentFolder=%2F&uuid=1216367782344 Response text: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> <HTML><HEAD> <TITLE>403 Forbidden</TITLE> </HEAD><BODY> <H1>Forbidden</H1> You don't have permission to access /admin/includes/modules/fckeditor/editor/filemanager/connectors/php/connector.php on this server.<P> <P>Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. </BODY></HTML> Diesen Fehler haben unzählige auch und die foren sind voll damit. Es scheint aber keine "so-geht-es-Lösung" zu geben. Ich will den FCK nicht mehr haben, ich will den TinyMCE und dann ist Ruhe... Geht das und wenn ja wie?
  22. Ich weiß, ja nicht ob es schon mal wem aufgefallen ist, aber unter SAFARI geht der HTML Editor nicht... Gibt es da einen patch dafür?
  23. Hallo, ich versuche gerade einen neuen WYSIWYG Editor im Admin Interface einzubauen, da der alte Fehlerhaft ist und nicht alles korrekt ausführt. Ich möchte den InnovaEditor nutzen. Leider komme ich einfach nicht weiter. Hier mein Versuch(xtc_wysiwyg.inc.php): $js_src = "http://www.xtadmin.de/xtc/editor/script/innovaeditor.js"; switch($type) { // WYSIWYG editor content manager textarea named cont case 'content_manager': $val ='<script type="text/javascript" src="'.$js_src.'"></script>'; break; case 'content_manager1': $val ='<script type="text/javascript"> window.onload = function() { var oEdit = new InnovaEditor("oEdit"); oEdit.width="100%"; oEdit.height=550; oEdit.features=["FullScreen","Preview","Print", "Search","SpellCheck","|", "Superscript","Subscript","|","LTR","RTL","|", "Table","Guidelines","Absolute","|", "Flash","Media","|", //"InternalLink","CustomObject","|", "Form","Characters","ClearAll", //"XHTMLFullSource", "XHTMLSource","BRK", "Cut","Copy","Paste","PasteWord","PasteText","|", "Undo","Redo","|","Hyperlink","Bookmark","Image","|", "JustifyLeft","JustifyCenter","JustifyRight","JustifyFull","|", "Numbering","Bullets","|","Indent","Outdent","|", "Line","RemoveFormat","BRK", "StyleAndFormatting","TextFormatting","ListFormatting", "BoxFormatting","ParagraphFormatting","CssText","Styles","|", //"CustomTag", "Paragraph","FontName","FontSize","|", "Bold","Italic","Underline","Strikethrough","|", "ForeColor","BackColor"]; oEdit.css="'.$css_src.'"; oEdit.cmdAssetManager = "modalDialogShow(\''.$manager.'\',640,465)"; //Command to open the Asset Manager add-on. oEdit.cmdInternalLink = "modelessDialogShow(\'links.htm\',365,270)"; //Command to open your custom link lookup page. oEdit.cmdCustomObject = "modelessDialogShow(\'objects.htm\',365,270)"; //Command to open your custom content lookup page. oEdit.arrCustomTag=[["First Name","{%first_name%}"], ["Last Name","{%last_name%}"], ["Email","{%email%}"]];//Define custom tag selection oEdit.customColors=["#ff4500","#ffa500","#808000","#4682b4","#1e90ff","#9400d3","#ff1493","#a9a9a9"];//predefined custom colors oEdit.mode="XHTMLBody"; //Editing mode. oEdit.REPLACE("cont"); } </script>'; break; }[/PHP] Ich habe hier 2 case machen müssen, der eine wird im HEAD geladen und der zweite muß nach der TEXTAREA geladen werden. Leider wird er nicht angezeigt! Wenn ich die Zeile window.onload = function() { aus kommentiere dann ist er endlich da, aber das ist ja nicht der Sinn! Bei den Alten FCKEditor ist die window.onload = function() { auch vorhanden. Meine Speicherung nimmt er auch nicht an. Hier mein Versuch(html_output.php): [PHP]function xtc_draw_textarea_field($name, $wrap, $width, $height, $text = '', $params = '', $reinsert_value = true) { $field = '<textarea id="'.$name.'" name="' . $name . '" wrap="' . $wrap . '" cols="' . $width . '" rows="' . $height . '"'; if ($params) $field .= ' ' . $params; $field .= '>'; /* function encodeHTML($sHTML) { $sHTML=ereg_replace("&","&",$sHTML); $sHTML=ereg_replace("<","<",$sHTML); $sHTML=ereg_replace(">",">",$sHTML); return $sHTML; } if(isset($text)) { $sContent=stripslashes($text); $text .= encodeHTML($sContent); } */ if ( ($GLOBALS[$name]) && ($reinsert_value) ) { $field .= $GLOBALS[$name]; } elseif ($text != '') { $field .= $text; } $field .= '</textarea>'; return $field; }[/PHP] Habe beide Varianten probiert, aber nichts... Kann mir vielleicht jemand weiterhelfen, damit ich es endlich zum laufen bekomme! Vielen Dank
  24. Wenn ich m?chte ein Artikel mit Editor einf?gen oder editieren kommt zu Fehler: Bei link einf?gen in ?LINK-Webseitendialog? ?ffnet sich eine graue Fenster mit: Zeile ? 178 Zeichen - 2 Fehler ? style ist null oder kein Objekt Code ? 0 URL - admin/includes/modules/fckeditor/editor/fckdialog.html Wie kann ich diese Problem l?sen ? Mfg james3fx
  25. Hallo Ich suche ein Übersetzungstool (Editor) Hab Ihn hier in Forum schon mal gefunden vor vielen Monaten aber jetzt werde ich einfach nicht fündig auch nicht mit der such option. Es war ein einfaches Programm, dass auf 2 Spalten geteilt war. Links war eine Sprache und rechts sollte man die Übersetzung rein tun und wenns fertig ist einfach nur abspeichern. Könnt Ihr mir bitte helfen ! Wie hiess der Editor oder vllt irgendwelche änliche Programme. MfG Damian.W
×
×
  • Create New...