Jump to content
xt:Commerce Community Forum

Search the Community

Showing results for tags 'iis'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • xt:Commerce - Professionelle eCommerce Shopsoftware
    • Fragen zur Software
    • xt:Commerce Plugins
    • xt:Commerce 4 Sprachen
    • xt:Commerce Online Handbuch
    • Häufige Fragen (FAQ)
    • Fragen zur Software (Pre Sale)
    • Anleitungen - Patches - Downloads
  • xt:Commerce Office - Shop & Warenwirtschaft
    • Allgemeine Fragen
  • xt:Commerce Allgemein
  • xt:Commerce 3 Shopsoftware Community Area (nur Lesen)
    • Allgemeine Diskussionen
    • Installation und Konfiguration
    • Shopbereich
    • Admininterface
    • Modul Entwicklung
    • Template System
    • xt:Commerce Schnittstellen ERP Systeme
    • PHP & MysQL Forum
    • HTML & CSS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biografie


Wohnort


Interessen


Beruf

Found 16 results

  1. Hallo Zusammen, ich habe ein großes Problem mit Version 4.1 unter Windows/IIS 7. Die Installation inkl. Iconcube hat problemlos funktioniert. Auch url_rewrite habe sofort hinbekommen. Der Shop selbst läuft auch soweit. Wenn ich aber jetzt versuche im Backend Artikel anzulegen oder zu bearbeiten oder im Content Manager Seiten zu ändern, kommt entweder nur die Eieruhr oder die Meldung kein Erfolg. Daten werden nicht in die DB geschrieben und selbst der Editor-Reiter bleibt offen. Daten können aber direkt per phpmyadmin in die DB geschrieben werden. Verzeichnisrechte sind auch alle gesetzt. Hat jemand eine Idee, was ich noch vergessen haben könnte?
  2. Hallo, Ich habe ein Problem mit der Installation von XTC. Wie in der Anleitung habe ich nun den kompletten XTCommerce Ordner entpackt und auf den Webserver geladen. Schreibrechte wurden auch gesetzt. Wenn ich jetzt versuche den Installer aufzurufen bekomme ich ich nur eine wei?e Seite angezeigt. Keine Fehlermeldung wie erwartet. Ich habe hier ja schon in einigen Beitr?gen gelesen das es mit einem Windows Server mit IIS und Plesk Probleme geben soll. Dort habe ich gelesen das man diverse Variablen $_Server['DOCUMENT_ROOT'] durch $_Server['VirtualDocumentRoot'] gegeneinander austauschen soll. Leider wurde nirgends beschrieben in welchen Dateien diese ?nderungen vorgenommen werden sollen und um wieviele ?nderungen es geht, damit man alle nach einander abarbeiten kann. Es w?re nett wenn sich jemand bereit erkl?ren w?rde mir dabei ein wenig zu helfen. Damit ich das Problem in den Griff bekomme. Vielen Dank schon mal daf?r im vorraus. Gru? Happy30
  3. Hab hier eine Lösung gefunden für alle die Probleme mit der Installation von XTC auf einem IIS haben. baut den Code ganz unten unmittelbar vor if (!defined('DIR_FS_DOCUMENT_ROOT')) { define('DIR_FS_DOCUMENT_ROOT', $_SERVER['DOCUMENT_ROOT']); in der /xtc_installer/includes/application.php ein dann gibts kein Problem mehr mit der fehlenden $_SERVER['DOCUMENT_ROOT Variable: if(!isset($_SERVER['DOCUMENT_ROOT'])){ if(isset($_SERVER['SCRIPT_FILENAME'])){ $_SERVER['DOCUMENT_ROOT'] = str_replace( '\\', '/', substr($_SERVER['SCRIPT_FILENAME'], 0, 0-strlen($_SERVER['PHP_SELF']))); }; }; if(!isset($_SERVER['DOCUMENT_ROOT'])){ if(isset($_SERVER['PATH_TRANSLATED'])){ $_SERVER['DOCUMENT_ROOT'] = str_replace( '\\', '/', substr(str_replace('\\\\', '\\', $_SERVER['PATH_TRANSLATED']), 0, 0-strlen($_SERVER['PHP_SELF']))); }; };
  4. Hi, My Installation hang on step 2, 1) I copy distributive xtcommerce directory to wwwroot directory 2) To avoid access problem I set for "Jeder" - fullcontrol. 3) I run http://127.0.0.1/xtcommerce/xtc_installer/index.php 4) I select English lang - click continue 5) I fill fields for MySQL with my local mySQL settings, localhost,root,xxx,xtcommerce 6) I leave rest fields as it is by default 7) I click continue - half of next page appears, Language bar is checked. 8) Using MySQL Administrator I see no user activity (Aktive Verbindungen) Any help. Thanks Denis Gavrikov
  5. Hi, Die Grundinstallation von XTC auf meinem IIS war erfolgreich, aber wenn ich zum SHOP gehe wird dort alles untereinander angezeigt und Grafiken (z.B Anmeldebutton) werden auch nicht angezeigt. Umschalten auf ein anderes Template funktioniert und lt. Quelltext wird das auch eingebunden, aber die Anzeige stellt sich genauso wieder dar. Hätte vielleicht jemand eine Idee, oder kann jemand der XTC unter IIS zum Laufen gebracht hat eine configure.php posten Danke Hier die configure.php define('HTTP_SERVER', 'http://www.meinserver.at'); // eg, http://localhost - should not be empty for productive servers define('HTTPS_SERVER', 'https://www.meinserver.at'); // eg, https://localhost - should not be empty for productive servers define('ENABLE_SSL', false); // secure webserver for checkout procedure? define('DIR_WS_CATALOG', '/yang/shop/'); // absolute path required define('DIR_FS_DOCUMENT_ROOT', 'd:/websites/meinserver/yang/shop/'); define('DIR_FS_CATALOG', 'd:/websites/meinserver/yang/shop/'); define('DIR_WS_IMAGES', 'images/'); define('DIR_WS_ORIGINAL_IMAGES', DIR_WS_IMAGES .'product_images/original_images/'); define('DIR_WS_THUMBNAIL_IMAGES', DIR_WS_IMAGES .'product_images/thumbnail_images/'); define('DIR_WS_INFO_IMAGES', DIR_WS_IMAGES .'product_images/info_images/'); define('DIR_WS_POPUP_IMAGES', DIR_WS_IMAGES .'product_images/popup_images/'); define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/'); define('DIR_WS_INCLUDES',DIR_FS_DOCUMENT_ROOT. 'includes/'); define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/'); define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/'); define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/'); define('DIR_WS_LANGUAGES', DIR_FS_CATALOG . 'lang/'); define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/'); define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/'); define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/'); define('DIR_FS_INC', DIR_FS_CATALOG . 'inc/');
  6. Hallo Leute, ich weiß, es nervt langsam. Zu diesem Thema habe ich schon duzende Beiträge gefunden. Der Grund weshalb die XTC Installation auf einem Windows-System mit IIS nicht funktioniert ist, dass der IIS die $_SERVER['DOCUMENT_ROOT'] Variable nicht unterstützt, kennt, oder was auch immer. Dieser Aufruf aber in div. PHP-Skripten enthalten ist. Jetzt weiß ich auch, dass ich diese durch irgendwas austauschen und / oder anpassen muß. Nur habe ich beim besten Willen hier im Forum keinen zuverlässigen Hinweis gefunden, was ich dort eintragen muss (anhand eines Beispieles) bzw. was überhaupt zu ändern ist. Sitze jetzt schon die 2te Nacht daran und bin kurz vorm Verzweifeln. Wenn ich dann lese, das andere mit dem gleichen Problem bei Step 6 hängenbleiben !!!! Grrrrrrrr!!! Soweit komme ich erst gar nicht. Fehlermeldung: Warning: main(c:\inetpub\vhosts\meine-domain.de/xtcommerce/includes/classes/boxes.php) [function.main]: failed to open stream: No such file or directory in C:\Inetpub\vhosts\meine-domain.de\httpdocs\xtcommerce\xtc_installer\includes\application.php on line 36 Fatal error: main() [function.require]: Failed opening required 'c:\inetpub\vhosts\meine-domain.de/xtcommerce/includes/classes/boxes.php' (include_path='.;./includes;./pear') in C:\Inetpub\vhosts\meine-domain.de\httpdocs\xtcommerce\xtc_installer\includes\application.php on line 36 Aber die Pfadangaben stimmen. Die Dateien sind da!!! Hier muß es doch irgendwie eine Lösung geben. Immerhin tauchen im Internet div. Anbieter auf, die angeblich einen Webspace mit Plesk, IIS und XTC vermieten, anbieten, etc. Wer von Euch hat dieses Problem denn schonmal gelöst und ist einem genervten gelegentlichen Möchtegernprogrammierer behilflich. Und bitte: kommt mir nicht mit ner Apache-Lösung. Ich habe Windows Server mit Plesk und IIS und diese möchte (muss) ich auch nutzen. Danke!!
  7. Hier im Forum wurde schon viel über IIS und eine nicht korrekte einrichtung des php geschrieben vom XT Team aber wirkliche lösungen habe ich nicht gefunden... also hier dann vielleicht mal einen sammlung aller ansätze um einen weg zu bekommen... 01. Am document root solls liegen! wie kann man diesen fehler umgehen??
  8. Hallo Gemeinde, wir ziehen in betracht das wir uns einen XT commerce Shop zulegen. Aufgrund der Suchmaschinen Taktik sind natürlich "reale URLS" anzustreben. Aufgrund der Tatsache das wir einen wechsel auf ein Linux System oder Apache nicht in erwägung ziehen beschäftige ich mich gerade damit mittel "ISAPIREWRITE" dies vom Apache zu emulieren. Für Typo3 funktioniert das auch tadellos. Wie sieht es hier mit XTC aus? Gibt es hierfür auch Rules für ISAPIREWRITE? Gruß Christian
  9. hallo. hat jemand lust und zeit, uns den xtcommerce auf einem windows rechner mit IIS 6.0 zu installieren. die install läuft bei uns durch, ohne fehler, aber nach der install ist weder ein shop sichtbar noch ein login möglich. bitte pauschalpreis offerieren oder stundenansatz < 50 euro. meldet euch bei mir unter ctek (at) ctek.ch. danke
  10. Für alle Leid geprüften in diesem Forum, die vergeblich versucht haben, ein XT Commerce unter IIS zu installieren oder von den lieben Apache Verfechtern eine Antwort zu erhalten.... Hier die Anleitung für die Installation: 1) PHP Installation Holt Euch auf php.net die aktuelle Windows Installation für den IIS. Das sollte Problemlos durchlaufen. Das Installationsprogramm nimmt alle wichtigen Einstellungen vor Stellt sicher, dass euer Web die Berechtigung: "Scripts und ausführe Dateien" hat und die php.exe unter den Weberweiterungen hinzugefügt und erlaubt ist. 2) MySQL Installation Installiert MySQL, am besten die Version 4.1, eher kein 5.0. Die Install findet Ihr unter www.mysql.org. Auch hier gibt es eine Install-Datei, die Ihr durchklicken könnt 3) XT Commerce installieren Jetzt auf XT commerce den Download holen und entpacken in einem virtuellen Webroot, ich nehme hier jetzt mal c:\inetpub\web1\ Dann öffnet Ihr die Datei "xtc_installer/include/application.php" und ergänzt ganz oben folgende Zeile: $_SERVER['DOCUMENT_ROOT']='c:/inetpub/web1/'; Jetzt einfach den Installer ausführen.
  11. ich habe einen windows sever mit iis, php5 und mysql nun habe ich das problem, dass ich xtcommerce nicht installieren kann... weiss da einer weiter? danke...
  12. Hallo! Ich weiss nicht, ob es mit dem IIS zusammenh?ngt, aber alle Pfade, die in der configure.php definiert sind, f?hren xtc in die Irre. Es sieht so aus, als ob generell eingebundene Dateien (sowohl require als auch include) immer eine Datei dort sucht, wo sie selbst beheimatet ist. Anders ausgedr?ckt: wenn eine Pfadangabe vor die Datei gestellt wird, wird sie nicht gefunden. Ist bei allen Einbindungen so. Was tun? Gruss Reinhard
  13. MJSmith

    IIS und SQL

    Hallo Zusammen, hat jemand von euch Erfahrung, ob xt-commerce auch auf SQL mit IIS l?uft? Konfiguration: Win2003Server, SQL2000 SP3a... Ciao Andreas
  14. Hallo, ist es m?glich XTCommerce auf einem MS IIS zu installieren? Gruss Ralf
  15. Hallo, habe den Shop erfolgreich auf einem MS IIS installiert. Es l?uft dort ein Dyn Fx Mailserver 2.2 Beim Versuch emails an externe Adressen zu senden, bekomme ich folgende Fehlermeldung: Warning: mail(): SMTP server response: 550 relaying not allowed Habe verschiedene Einstellungen probiert aber komme hier nicht weiter. Wie sollte ich am besten den Mailserver konfigurieren, ohne da? er zum offenen Scheunentor wird?
  16. Hallo, damit der erste Aufruf von install.php nicht bereits mit Frust endet: -Mofifikation von application.php f?r IIS Anwender !!: nach Zeile 18: if (!defined('DIR_FS_DOCUMENT_ROOT')) { folgende Zeile einf?gen: $_SERVER["DOCUMENT_ROOT"] = str_replace($_SERVER["PATH_INFO"], "", ereg_replace( "[\][\]", "/", $_SERVER["PATH_TRANSLATED"] ))."/"; Gruesse Joerg
×
×
  • Create New...