Jump to content
xt:Commerce Community Forum

Search the Community

Showing results for tags 'kategoriebilder'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • xt:Commerce - Professionelle eCommerce Shopsoftware
    • Fragen zur Software
    • xt:Commerce Plugins
    • xt:Commerce 4 Sprachen
    • xt:Commerce Online Handbuch
    • Häufige Fragen (FAQ)
    • Fragen zur Software (Pre Sale)
    • Anleitungen - Patches - Downloads
  • xt:Commerce Office - Shop & Warenwirtschaft
    • Allgemeine Fragen
  • xt:Commerce Allgemein
  • xt:Commerce 3 Shopsoftware Community Area (nur Lesen)
    • Allgemeine Diskussionen
    • Installation und Konfiguration
    • Shopbereich
    • Admininterface
    • Modul Entwicklung
    • Template System
    • xt:Commerce Schnittstellen ERP Systeme
    • PHP & MysQL Forum
    • HTML & CSS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biografie


Wohnort


Interessen


Beruf

  1. Hallo zusammen, nach dem Update (von 5.0) auf aktuell Version 6.3.3 haben wir beobachtet, dass die Bilder in der Kategorie zu groß sind. In der Regel sieht unser Verzeichnisbaum wie folgt aus: wwwShop --Oberkategorie -----Kategorie1 -------Farbe1 -------Farbe2 -------Farbe3 -----Kategorie2 -------Farbe1 -------Farbe2 -------Farbe3 -----Kategorie3 -------Farbe1 -------Farbe2 -------Farbe3 danach erfolgen dann Produkte (in je Farbe) In der Regel legen wir innerhalb der Oberkategorien mehrere Kategorien. DIese Kategorien erhalten Ihre Kategoriebilder - vorher auf 175x175 erstellt, in die Medien hochgeladen und eingepflegt. Hier ist die Anzeige so wie es soll. Gehe ich nunmehr in die jeweilige einzelne Kategorie und öffne sie , zB in Kategorie 3, um weitere Unterkategorien (Farbe 1-3) zu sehen, wird das Logo - also das Kategoriebild 3 pixelig groß dargestellt. In den EIgenschaften der Seite kann ich sehen, dass die Bilder wie folgt gelinkt sind: /media/images/category/listingTop/ und bei Bildmaßen steht: 175*175 (skaliert auf 838x838). Mein Problem: WIr finden nirgends die Anweisung, dass eine skalierung erfolgen soll. In den Bildtypen ist zB im Bereich category/listingTop folgendes eingestellt: Also noch nichtmals eine hohe Angabe, die das Bild daher künstlich hochskaliert. Ich finde auch nirgends die 838er Skalierung. Meine Frage: Wo könnte ich im Template ggf noch nachsehen, in welcher (css) Datei ? Der Grund warum skaliert wird, entschließt sich mir nicht. In der nächsten einzelnen Kategorie (Farbe 1-3) passiert genau das gleiche, wo das Produkt näher vorgestellt wird und dann wird das ebenfalls so groß skaliert. Imageprocessing, Cache und Template-Cache löschen - bisher keine Erfolge. Auch die Anpassung unter Bildtypen brachten keine Ergebnisse oder Veränderungen. Wenn jemand eine Idee hat.... Herzlichen Dank
  2. Der Titel ist etwas kompliziert, aber hier die Erklärung: Wenn ich Zweitbilder für Kategorien im Backend anlege so bekommen die Bilder in der Tabelle "xt_media" die class: category In Veyton 4.2 wurde die Klasse "class.nested_set.php" eingeführt, die für die Zusammenstellung der Kategoriebäume verantwortlich ist. Hier werden auch zusätzliche Bilder geladen. Allerdings werden die Bilder so erfragt (Zeile 551): $media_images = $mediaImages->get_media_images($category['categories_id'], __CLASS__); In dem __CLASS__ steht zu dem Zeitpunkt "nested_set". Das hat zur folge, das die zusätzlichen Bilder nicht gefunden werden. Gibt es dafür einen passenden Workarround? Ich behelfe mir gerade in dem ich statt __CLASS__ "category" da rein schreibe. Es ist aber nicht schön, da in der Core was zu ändern. Grüße, Mario
  3. Hallo Community Wir verwenden ein Mouseover-Menü in welchem jeweils das zweite Kategoriebild als Icon angezeigt wird. Um die Kategoriebilder vom 2. Level auszulesen benutzen wir die Variable $sub_data.more_images. (Vollständiger Code im Anhang) Dies hat problemslos funktioniert in Version 4.0, 4.1, 4.1.10. Seit dem Update von 4.1.10 auf 4.2 (SP1) werden die zweiten Kategoriebilder nicht mehr in das Menü eingebunden. So wie es aussieht, wird die .more_images nicht mehr unterstützt!? Oder es handelt sich um einen Bug und die ".more_images" Variable wird in der class.category.php nicht mehr korrekt übernommen. Tauschen wir die Variable zu $sub_data.categories_image wird, wie erwartet, das erste Kategoriebild angezeigt. Vielleicht kann mir jemand einen Gedankenanstoß geben oder, falls die Variable geändert wurde, kennt einer von euch vielleicht die neue Variable!? Oder vielleicht führt auch noch ein anderer Weg zum Ziel das 2. Kategoriebild anzuzeigen und ich bin gerade nur betriebsblind... Über Unterstützung/ Input wäre ich sehr dankbar! Danke schon mal im Voraus! Viele Grüße Der ganze Code: <a class="topmenu-sub-items {if $sub_data.UPLOAD_STATUS eq 1}category_upload_image{/if}" {if $count=='7'}style="margin-right:0;"{/if} href="{$sub_data.categories_link}" style="background-image:url({img img=$sub_data.more_images.0.file type=m_org path_only=true});">(Das Menü in Funktion auf der v4.1.10 könnt ihr auf paintify.de sehen)
  4. Hallo Zusammen, es gibt im Backend ja die möglichkeit mehrere Kategoriebilder auszulesen. Das erste Kategoriebild kann ich dann im Template auch über die Variable "$categories_image" auslesen. Wie ist es mir möglich auch auf die anderen hochgeladenen Kategoriebilder zuzugreifen. Da die Möglichkeit des Uploads besteht muss das ja irgendwie möglich sein oder? Wenn jemand die Antwort weiss, freue ich mich sehr über eine Rückmeldung. Viele Grüße, Tschaenssen
  5. Werte Fachmänner, seit einiger Zeit Versuche ich in meinem xtCommerce Veyton (4.0.14) die Einstellungen/Sichtbarkeit meiner Kategoriebilder zu verändern, aber ich komme leider nicht weiter. Dieses Problem taucht nur bei einigen Kategorien bzw. Kategoriebildern auf. Wie kann ich verhindern das mein kleines Kategoriebild aus der Übersicht auch in der Subkategorie angezeigt wird? Ich habe schon viele Wege getestet, Bildgrößen verändert, Image Processing etc. und bestehende Threads durchforstet aber finde leider keine Lösung für mein Problem. Vielleicht hat hier ja jemand einen Rat woran das liegen könnte. Ein paar Screenshots habe ich beigefügt. Ich danke vorab schonmal für eventuelle Rückmeldung und entschuldige mich für die etwas laienhafte Fehlerbeschreibung und stehe bei Rückfragen natürlich zur Verfügung. Liebe Grüße Karsten
  6. hallo, ich habe eine frage: im muss von einem shop die kategoriebilder in einen neuen shop übernehmen. gibt es da eine schnelle variante diese einzubinden? die ganzen bilder per admin einzeln einzubinden ist mir zu aufwändig. wo sind diese kategoriebilder in der datenbank hinterlegt ? ich bin für jeden tipp dankbar. lg c.pirc
  7. Hallo, der Titel sagt schon alles :-) Wir betreiben VEYTON 4.0.12 Merchant mit 2 Mandanten. Ich möchte nun in beiden Shops unterschiedliche Kategoriebilder benutzen. Ist dies möglich? Hab leider keine Infos zu finden können... Bin für jeden Tipp dankbar. Dank im Voraus.
  8. Hallo an alle, die das lesen. Ich bitte um Nachsicht, wenn ich noch nicht jede Frage korrekt formuliere und an der richtigen Stelle stelle. Ich lerne erst jeden Tag dazu. Meine aktuelle Herausforderung: Ich habe Kategorien und Subkategorien angelegt und zu jeder davon ein Bild eingefügt. Wenn ich im Frontend eine Subkategorie öffne, wir mir über den einzelnen Artikeln auch mein Text und das Bild dargestellt, aber nicht eine Ebene höher. Ich möchte auch in der Hauptkategorie, da wo "Weitere Kategorien" steht dass nicht nur Text und eine Box dargestellt ist, sondern auch ein Bild. Wie mache ich das? Zum besseren Verständnis, weil ich die Begriffe noch nicht genau kenne und daher nicht genau formulieren kann, anbei ein Bild. Danke, wenn mir jemand auf die Sprünge helfen kann.
  9. Hallo ich benutze die 4.1 Startversion ist es hier möglich Kategoriebilder anzeigen zulassen? Habe zwar sch welche hinzugefügt, diese werden aber im shop nicht angezeigt.
  10. Hallo, benutze die XT Commerce 4.1 Start Edition mit dem Template xt_grid. Bei mir werden keine Kategoriebilder angezeigt. Diese werden doch genauso wie die Artikelbilder hochgeladen, die bei mir auch funktionieren. Nur wenn ich auch mehrer Artikelbilder habe werden die in der Vorschau auch nicht angezeigt, es steht nur der Artikelname da, worauf man auch klicken kann und es danach angezeigt wird. Dies würde mich auch nicht so sehr stören aber an den Kategoriebildern verzweifele ich. Hoffe es kann jemand helfen. Danke im Voraus! Gruß Erik
  11. Hallo, nachdem ich alles ausprobiert hab und hier langsam wahnsinnig werde, hoffe ich, dass mir hier jemand helfen kann. ich möchte lediglich Kategoriebilder austauschen: dazu habe ich ein neues Kategoriebilder hochgeladen und das alte bild gelöscht. Danach wurde aber immernoch das alte Bild angezeigt. Daraufhin habe ich den Ordner "cache" geleert. Nun werden leider keine Kategoriebilder mehr angezeigt. Was habe ich falsch gemacht? Was kann ich tun, damit die Bilder angezeigt werden? Danke vorab!
  12. Guten Tag Das Auflisten der Kategorien bereitet mir Kopfschmerzen Leider übersteigen diese PHP Scripts mein Können. Gibt es eine Möglichkeit je 4 Kategoriebilder (sauber und bündig) pro Zeile aufzulisten? Info: Die Kategoriebilder-Thumbs wurden in der Grösse vordefiniert und das Image-Processing habe ich durchlaufen lassen. Der Code aus der "categorie_listing_V1.html" Datei <h1>{$categories_name}</h1> {if $categories_description}<p>{$categorie_description}</p>{/if} {if $categories_listing !=' '} {php}$i=0;{/php} <div id="cat_listing"> {foreach item=module_data from=$categorie_listing} {php}$i++;if ($i % 2 == 0){{/php} <div class="s_cat odd"> {php}}else{{/php} <hr class="spacer" /> <div class="s_cat even"> {php}}{/php} <div class=img_wrap"> <a href="{$module_data.categories_link}" title="{$module_data.categories_name}"> {img img=$module_data.categories_image type=m_category_thumb class=productImageBorder alt=$module_date.categories_name|escape:"html"} </a><h2><a href="{$module_data.categories_link}" title="{$module_data.categories_name}">{$module_data.categories_name}</a></h2> </div> </div> {/foreach} <div style="clear:both;"></div> </div> {/if} Das Abändern dieser Zeile auf: "{php}$i++;if ($i % 1 == 0){{/php}" gibt mir 4 Kat.Bilder pro Zeile aus, jedoch chaotisch in der Darstellung und alles andere als sauber und bündig. Wäre um jeden Tipp dankbar. Mfg
  13. Hallo Ihr Lieben Ich arbeite zur Zeit mit dem xt-Shop Veyton 4.0.13 und benutze das Template 8w_velocity. Ich würde gerne für die Unterkategorien Bilder vergeben, will aber nicht so recht klappen. Würde mich über den einen oder anderen Tip freuen. Liebe Grüße
  14. Guten Abend, Ich ärgere mich schon den ganzen Tag mit dem Umgehen des MediaManager rum, da wir gerade dabei sind ~35.000 Artikel zu portieren und der MediaManager alles andere als "prozessoptimiert" ist. Weiter führen wir, wie jeder gut situierter Onlineshop, einen CDN Server, auf dem wir alle Medien lagern. Unser Problem ist nun, dass wir damit beschäftigt sind, die Bilder in guter Qualtität auch im xt:C anzeigen zu lassen, was sich als schwieriges Unterfangen erweist, da sich die einzig logische Stelle, an der Tag-Defs an Smarty übergeben werden könnten IonCube codiert ist in der class.Template.php. Meine Frage ist daher: Weiß jemand, wie ich den Bildpfad beeinflussen kann, ohne unsere High-Quality Bilder durch nen PHP Bildprozessor verhackstückeln zu lassen? (Von Serverperformance und Lastenverteilung mal ganz zu schweigen.......) Danke, Chris
  15. Hallo zusammen, ich würde gerne meine Navigation mit den Kategoriebildern versehen, finde aber keine gescheite anleitung dafür. Vielleicht hat ja von euch einer eine Beschreibung zur Hand. Würde mir sehr helfen. Gruß Misterweb
  16. Servus Leute, ich möchte bilder für die kategorien importieren. Aber die richtige vorgehensweise fehlt mir. Wenn im im media-gallery > kategoriebilder auf import klicke passiert nichts, egal ob die - zu importierenden bilder - im verzeichnis media/import oder media/images/org zu liegen. Woher sollen die bilder denn importiert werden? Oder kann man kategoriebilder nicht importieren? viele grüße Michael
  17. Guten Tag, ich suche eine Möglichkeit die Kategoriebilder in der index.html zu integrieren um sie als Header darstellen zu können. Die $categories_image kennt es leider in der index.html noch nicht. Für XTC habe ich eine Lösung gefunden:xt:Commerce - Ein paar Ideen für Category Images (gunnART - Grafik, Layout, Konzeption) Aber dies lässt sich ja nicht übertragen oder? mit freundlichen Grüßen Rune
  18. hallo. hab gerade alles hier im forum durchsucht was mit kategoriebildern im veyton shop zu zun hat. ein bischen hab ich gefunden aber nicht viel weitergeholfen. ich möchte gerne. auf der startseite die kategoriebilder der hauptrubriken anzeigen lassen so 2 bis 3 stück nebeneinander. das gleiche möchte ich wenn ich auf eine hauptkategorie clicke, dass dann bei den unterkategorien die bilder angezeigt werden. bis jetzt stehen nur diese text-links bei den unterrubriken. was ich schon mal hinbekommen habe ist. wenn ich in eine unterrubrik rein clicke und die artikel aus dieser angezeigt werden, dass oben drüber das kategoriebild angezeigt wird. aber nur wenn ich den typ=m_info nehmen also von den schon vorhandenen. wenn ich aber einen neuen bildtyp im admin anlege z.b. categorie (bildgrösse 525x120px) und dann typ=m_categorie ausgebe, erschein dann überhaupt nichts mehr. folgenden code hatte ich in der categorie_listing eingefügt: {if $categories_image}<a href="{$categories_link}">{img img=$categories_image type=m_categorie}</a>{/if} vielen dank im vorraus, für jede hilfreiche antwort. mfg patrick
  19. Momentan werden die Unterkategorien in Schrift und einer Box mit grauem Hintergrund angezeigt. Will jedoch Bilder da drinne haben statt die Schrift denn meine Bilder enthalten die Schrift der Unterkategorien schon. Wie kann ich das denn ändern?Denn wenn ich jetzt Kategoriebilder hochlade werden die ganz klein obenlinks in die graue Box gequetscht mfg Nighteyes
  20. Hallo zusammen, stehe kurz vorm Nervenzusammenbruch: Problem Nr.1: gestern habe ich einen Master-Artikel mit Artikelbild kopiert, Slaves erstellt, festgestellt dass die falschen Bilder drinne sind, flott geändert, allerdings sind im neuen Masterartikel in der Adminansicht nun zwei Bilder drin: an erster stelle eines welches nicht abrufbar ist (x), an zweiter Stelle das gewünschte Artikelbild. Gehe ich auf Bilder bearbeiten zeigt er mir nur das richtige Bild an. Im Shop ist der Master-Artikel "unbebildert" (ACANA Lamb & Apple), hat jemand ne Idee was ich tun könnte? Problem Nr.2: Als ich mich heute morgen Problem Nr. 1 wieder annehmen wollte musste ich mit erschrecken feststellen dass 3 der vor einigen Tagen angelegten Kategoriebilder nun in den Artikeln auf der Seite Frischfleisch Großpackungen angezeigt werden (kann man unschwer erkennen da sie sich stark von den restlichen Artikelbildern unterscheiden). In der Mediaverwaltung im Adminbereich stehen diese 3 "Schwerenöter" nun zwar in der Kategorie "Kategoriebilder" aber wenn ich da reingehe werden sie mit der Klasse "product" ausgewiesen...
  21. Hallo zusammen, habe gerade den 4.0.12 neu installiert, 3 Kategorien mit Kategoriebilder angelegt und folgende Probleme bemerkt: 1.) Die Kategoriebilder werden im Backend aber nicht im Frontend angezeigt. 2.) Kann im Frontend in den Kategorien und Informationen navigieren. Bei allen anderen Dateien, die mit http://www.meineseite.de/indexphp?....... beginnen, bekomme ich hingegen diese Fehlermeldung: #Fehler: Umleitungsfehler Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann.# Für einen Tipp zur Fehlerbehebung wäre ich sehr dankbar. Grüße Friedrich
  22. Ich möchte nachträglich die Thumbnailgröße meiner Kategoriebilder verändern dachte ich kann das über "Dateitypen" und das Image Processing hinbekommen. Nur leider zeigt die Media Gallery meine Bilder nicht an. Wie kommt´s und wie könnte ich das hinbekommen? Danke und Gruß
  23. Hallo Leutz, ich möchte gerne meine Kategorien mit Bildern darstellen! Ist auch soweit kein Problem! Alle meine Bilder sind in der Größe 150*200px! Nun möchte ich aber eine Kategorie in einem breiteren Bild darstellen! Füge ich das Bild ein, wird es zentriert, so wie es sein soll dargestellt, nur verschieben sich alle anderen 150*200px Bilder nach rechts! Was muss ich machen! Hier mal noch ein Bildschirmfoto:
  24. kann mir einer das geheimnis verraten, warum manche kategoriebilder angezeigt werden und andere nicht?? Zubehör gibt es eine zauberformel, auf welchem weg man narrensicher kategoriebilder hochlädt, so daß sie sicher angezeigt werden? gibt es restriktionen im dateinamen, in der reihenfolge der auswahl oder sonstwas nicht dokumentiertes? irgendeine idee??
  25. Ich frage mich, wie ich in einer Kategorie wie z.B Textilien, mit den Unterkategorien Pullovern und T-shirts Bilder einfügen kann, sodass mir für die Unterkategorie nicht nur "T-Shirt" angezeigt wird, sondern ebenfalls ein Beispielbild, welches zu den verschiedenen Shirts führt.
×
  • Create New...