Jump to content
xt:Commerce Community Forum

Search the Community

Showing results for tags 'kontaktformular'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • xt:Commerce - Professionelle eCommerce Shopsoftware
    • Fragen zur Software
    • xt:Commerce Plugins
    • xt:Commerce 4 Sprachen
    • xt:Commerce Online Handbuch
    • Häufige Fragen (FAQ)
    • Fragen zur Software (Pre Sale)
    • Anleitungen - Patches - Downloads
  • xt:Commerce Office - Shop & Warenwirtschaft
    • Allgemeine Fragen
  • xt:Commerce Allgemein
  • xt:Commerce 3 Shopsoftware Community Area (nur Lesen)
    • Allgemeine Diskussionen
    • Installation und Konfiguration
    • Shopbereich
    • Admininterface
    • Modul Entwicklung
    • Template System
    • xt:Commerce Schnittstellen ERP Systeme
    • PHP & MysQL Forum
    • HTML & CSS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biografie


Wohnort


Interessen


Beruf

Found 109 results

  1. Hallo liebe Formumleser, ich habe ein Problem mit meinem Shop: Mein Rechtsanwalt hat mir gesagt, dass ich lt. aktueller Rechtssprechung im Kontaktformular (also da wo der Kunde, seinem Namen, seine Email und seine Frage eintragen kann und auf "Senden" klickt.) eine Checkbox mit dem Titel: "Unsere Datenschutzbestimmungen habe ich gelesen und akzeptiert" unterbringen muss. Der Kunde muss ein Häkchen in die Checkbox setzen, sonst kann er die Mail nicht absenden. Da dachte ich mir, okay ich kopiere einfach die Daten aus der Checkout_payment.php (Denn da muss der Kunde die AGB´s sowie die Datenschutzerklärung mit zwei Checkboxen bestätigen) und regele die Bestätigung genauso in der Kontaktseite bzw. in der Shop_content. Ich habe es leider nicht hingekriegt. Es gibt ja die Möglichkeit mit javascript oder mit PHP zu blockieren, wobei PHP natürlich eleganter wäre, da Javascript ja abgeschaltet werden kann. Kann mir jemand so ein Script geben bzw. gibt es schon so etwas? Ich habe schon überall nachgeguckt, auch im Forum gesucht, für die Kundenkonto eröffnen Seiten oder die CheckoutPayment gibt es ja genug Anleitungen, aber auch für das Kontaktformular?! Zu meinem Wissensstand: Dass in auf der Kontakt-Seite eine Checkbox mit verlinkter Datenschutzerklärung erscheint hab ich hingekriegt. Nur die Überprüfung, ob das Häkchen wirklich gesetzt wurde, krieg ich nicht hin. Wäre euch sehr dankbar für eure Hilfe. Viele Grüße Roman
  2. Hallo, ich habe das gleiche Problem wie bereits in dem Thread Reply erwähnt: http://www.xt-commerce.com/forum/installation-und-konfiguration/109763-kontaktformular-reply.html Und muss das Thema noch mal aufwärmen. Meine Shop Version 4.1 Problem: Wenn ich eine Anfrage über das Kontaktformular bekomme (und es kommen viele täglich) hätte ich gerne, dass der Absender automatisch eingesetzt wird, sobald ich in der Mail auf antworten klicke. Sprich das was in der Mail mit {$Mail} angegeben wurde, soll ans Reply Adresse verwendet werden. Was muss in das Feld Reply im E-Mail Manager bei der "contact_mail-admin"? Ich habe schon {$mail} ausprobiert (wie im mail template). allerdings passiert dann garnichts, dann ersetzt er den marker nicht sondern schreibt {$mail} Es ist mühsam, jedesmal die E-Mail Adresse aus dem Feld rauszukopieren..
  3. Hallo Gemeinde, ich konnte leider nichts passendes finden weshalb ich mich nun an euch wende. Ich versuche ein selbst erstelltes Anfrageformular (Kopie der original contact.php) in einen Reiter der Artikelseite (product.html) einzubinden. In der product.html meines Themeordners habe ich erfolgreich den (oder heißt es das) Tab erstellt und als Inhalt {$_content_10.content_body}[/HTML] (content ID 10 ist in meinem Fall die Produktanfrageseite) hinterlegt. Der Inhalt der Produktanfrageseite wird als solcher richtig im Tab angezeigt, jedoch leider nicht das zusätzliche Formular, welches ich unter "Content Formular" ausgewählt habe. Die Produktanfrageseite samt Formular funktioniert beim Aufruf als normale Content Seite über die URL oder einen Link wie sie soll. Auch habe ich die original Kontaktseite (Content 6) mal versucht. Da ist gibt es das selbe Ergebniss, weshalb ich Fehler in meinem Produktanfrageformular ausschließen kann. Wie gesagt, der Inhalt wird angezeigt, das Formular jedoch nicht. Eventuell reicht einfach das [HTML]{$_content_10.content_body}[/HTML] nicht aus um auch das eingehängte Formular einzublenden. Ein Versuch mit [HTML]{$_content_10.content_form}[/HTML] blendet nicht das Formular sondern nur den Formularnamen (bei mir productast.php) ein. Weiß vielleicht jemand Rat? Ich betreibe die Community Edition in der Version 4.1.00. Für eure Hilfe bedanke ich mich im Voraus. MfG Viktor
  4. Hallo, ganz seltsam. Auf einmal gehen keine Bestellungen mehr und das Kontakformular auch nicht. Somit vermute ich, alles was mit "POST" zu tun hat geht nicht. Die Seite läd dann im allerletzten Bestellschritt ewig und kommt dann nach ca. 1-2 Minuten auf die Success-Seite. Allerdings hat die Bestellung dann nicht funktioniert und es wird auch keine Mail versand. Mit dem Kontakformular ist es gleich. Hat da jemand eine Idee?
  5. Hallo! Ich beschäftige mich immernoch mit dem Kontaktformular. Jetzt ist mir aufgefallen, dass im Frontend das Captcha (Standard) nicht zu sehen ist. Ich benutze xt 4.1 und das System ist noch nicht online, sondern auf Xampp installiert. Browser: Firefox Dies habe ich schon probiert: Webseiten-Cache gelöscht, Cache und template_c geleert. Liegt es eventuell daran, dass ich den Shop noch nicht im www geladen habe? Besten Dank!
  6. Hallo. Shop 4.1.1 Wenn ich über das Kontaktformular sende, bekomme ich eine leere Mail. Es steht nur drin: E-Mail Template missing looked for-eMail Type:contact_mail-admin lang:de group:1 Special:-1 Shop:1 Habe nun einen Benutzer angelegt. Bekomme keine Email.(Kontoemail) An die Shop Email bekomme ich eine mit dem selben Fehler wie oben beschrieben. Hoffe man kann mir weiter helfen. Gruß V. Hampel Habe nun alle Einstellungen von diesem Post ausprobiert: http://www.xt-commerce.com/forum/installation-und-konfiguration/83044-looked-e-mail-type-update_order-admin-lang.html Geht immer noch nicht.
  7. Hallo, ich suche nach einer Möglichkeit ein Feld "Betreff" als "Select-Feld" im Kontaktformular einzubauen. Welche Dateien muss ich dazu anpassen? Ich habe versucht das {form type=select name=default_address[customers_gender] value=$gender_data default=$default_address.customers_gender note=*} vom Loginbereich anzupassen, aber ich weiß leider nicht, in welchen Dateien ich noch Informationen hinzufügen muss. Weiß jemand eine Lösung? Vielen Dank & liebe Grüße
  8. Wir haben gerade das Problem nach einem Update auf 4.1, dass das Kontaktformular keine Mails mehr versendet. Es erscheint ganz normal: "Ihre Anfrage wurde gesendet" Es kommt aber keine Mail an. Alles andere im Shop funktioniert. Eingestellt in den EMail-Einstellungen ist sendmail. Die anderen Einstellungen habe ich aber auch schon ausprobiert. In der DB habe ich _STORE_CONTACT_EMAIL gefunden. Das wird ja für die Mail benutzt. Kann man das irgendwo im Detail verfolgen und nach Fehlern suchen?
  9. würde gerne wissen wie ich das Kontaktformular übver die ganze Breite center setzen kann. LINK
  10. Ich habe heute auf das 4.1 gewechselt und nun ein Problem mit dem Kontaktformular. Zuvor war es so, das wenn mir ein Kunde über das Kontaktformular geschrieben hat, Ich direkt drauf antworten konnte. Jetzt steht jedoch meine Shop Mail zum Antworten als Standard so das Ich manuell immer die Mail ändern muss. Wie bekomme Ich das wieder so wie es war das der Shop die Mail direkt setzt. Der aktuelle Patch löst das Problem leider nicht. mfg
  11. Hallo, habe das Problem, dass das Kontaktformular an die falsche email gesendet wird. Das für den Kunden kommt beim Kunden an, aber das für uns kommt nicht zu der Adresse wie in "Shop-Einstellungen->Mandanten->SHOP_NAME->Email Einstellungen->Empfänger - Kontaktformular:" eingetragen. Email ist korrekt - das is ok. Das System sendet die an die Mail des admin. nur über "Inhalte->E-Mail Manager->contact_mail-admin->Weiterleitung an (E-Mail):" Erreiche ich gewünschtes Ergebnis, aber sie kommt noch immer beim admin an - warum? Thx
  12. Hallo! Ich beschäftige mich gerade mit dem Kontaktformular. Hier möchte ich die Variable "TEXT_CONTACT" ändern. Ich habe die Änderung in den Sprachtexten (Lokalisierung) und versuchsweise auch in der Datenbank direkt vorgenommen. Leider wird im Kontaktformular im Frontend die Änderung nicht angezeigt, sondern nur der ursprüngliche Satz "Ihre Kontaktinformationen". Ich benutze xt 4.1 und das System ist noch nicht online, sondern auf Xampp installiert. Browser: Firefox Dies habe ich schon probiert: Webseiten-Cache gelöscht, Cache und template_c geleert. Hat jemand eine Idee, was ich noch tun könnte? Besten Dank!
  13. Hallo, sendet ein angemeldeter Kunde eine Nachricht, funktioniert alles tadelos. Sendet ein Gast eine Nachricht, erscheint nach dem Absenden eine weiße Seite. (Die Nachricht kommt nicht an) Shop: Veyton 4.1 Neuinstallation Patches: alle Vermute, dass das Problem bei der Captcha Abfrage liegt. Weiß jemand Rat? Gruß Alex.
  14. Hallo, ich muss für das Trusted Shop Siegel die Kontaktseite auf SSL verschlüsseln. Im Backend habe ich zwar das Häckchen für SSL aktiviert, aber leider funktioniert das nicht. Das Kontaktformular wird weiterhin über http aufgerufen. Hab mich auch in diversen Foren schlau gemacht und wie empfohlen den code in der .../template/xtCore/forms/contact.html auf zeile 5 wie folgt umgeändert: ...method=post conn=SSL}... Leider erscheint immer noch kein https wenn ich das Kontaktformular aufrufe Hat jemand eine Idee?
  15. Hallo, ich möchte im Kontaktformular das Feld FIRMA umbenennen und zum Pflichtfeld machen. In der Datei contact.html habe ich die gewünschten Änderungen erledigen können, das Aussehen ist wie ich es haben möchte. Habe nun in der contact-php folgende Zeile ergänzt: $form_check->_checkLenght($_POST['phone'], _STORE_PHONE_MIN_LENGTH, ERROR_PHONE);[/PHP] Allerdings erfolgt bei Absendung keine Prüfung, ob das Feld ausgefüllt wurde. Wo finde ich denn den entsprechenden Code? Oder gibt es eine andere Möglichkeit für mein Vorhaben? Danke Gruß Charlie
  16. Hallo, ich habe folgendes Problem: in den Shopeinstellungen - Emaileinstellungen kann man eine Mailadresse hinterlegen, zu der die Kundenanfragen aus dem Kontaktformular des Shops gesendet werden sollen. Leider landen aber alle Mails vom Kontaktformular bei meiner Admin-Mailadresse und nicht bei der hinterlegten Mailadresse. Weiterleiten funktioniert zwar, aber ich möchte nur eine Mail bekommen. Ich nutze SMTP (funktioniert auch) und xtcommerce4.1start. Hat jemand von Euch eine Lösung für das Problem. Vielen Dank im voraus. Dennis
  17. Hallo Leute, viele von euch haben das Problem, dass Nachrichten über das Kontaktformular leer ankommen. Beim wem dies auftritt, der bekommt auch keine Bemerkungen in einer Bestellung geliefert. Denn dieses Feld wird ebenfalls geleert. Mit dem Unterschied, dass man dort noch nicht einmal mitbekommt, dass eine Bemerkung geschrieben wurde! Es gibt viel Text hier im Forum aber keine Komplettlösung für beide Probleme. Darum will ich euch hier meine Lösung vorstellen. Angeblich soll es reichen wenn man magic_quotes_gpc in der php.ini auf on stellt... siehe: http://www.xt-commerce.com/forum/fragen-zur-software/79653-leere-mail-durch-kontaktformular-8.html#post387107 ...aber wer diese Möglichkeit nicht hat, kann folgendes probieren: öffne die Datei /xtFramework/security_handler.php[/CODE] suche (bei mir Zeile 58): [PHP] if ($post_filter) $_POST = $filter->_filterXSS($_POST);[/PHP] ersetzten durch: [PHP] if ($post_filter) { $array = array( 'customer_message', // Nachrichten-Feld uas Kontaktformular 'comments' // Bemerkungen-Feld aus Bestellprozess ); // Felder säubern $tmp_ary = array(); foreach($array as $value) { if ($_POST[$value]) { $tmp_ary[$value] = $_POST[$value]; $tmp_ary[$value] = htmlspecialchars(strip_tags($tmp_ary[$value],ENT_QUOTES)); // im Bestellprozess lästige \r\n entfern und durch <br \> ersetzen if ($value == 'comments') { $tmp_ary[$value] = preg_replace("#(\r|\n)#i", "", nl2br($tmp_ary[$value])); } } } // Original Filterbefehl von xt:Commerce $_POST = $filter->_filterXSS($_POST); // gesäuberte Felder wieder an POST übergeben foreach($tmp_ary as $key => $value) { $_POST[$key] = $value; } }[/PHP] Mit dieser Schnipsel sollten die Mails wieder ankommen und auch die Felder vor XSS geschützt sein. Auch die Bemerkung im Bestellprozess wird nun geliefert. Auch werden die lästigen [b]\r\n[/b] entfernt und durch vernünftige Umbrüche (<br />) ersetzt. Ich hoffe ich kann damit einigen helfen. Viel Spaß!
  18. Hallo! Ich habe zwei Fragen, irgendwie versendet das Kontaktformular keine Mails obwohl ich bei den E-Mail Einstellungen alle Varianten durchprobiert habe, die mir eingefallen sind. (Die Mail liegt auf world4you.com) Auch bei den Bestellungen kann ich keine Notiz oder Rechnung versenden(wird vermutlich am gleichen Fehler liegen). Kann mir hier jemand weiterhelfen. Auch die PDF Rechnung kann von mir nicht aufgerufen werden obwohl das Plugin installiert und alle Zeilen eingetragen sind. Vielen Dank im Voraus!
  19. Hallo, Veyton läuft auf Strato bei mir problemlos, aber beim Kontaktformular erscheint Internal Server Error. Hat jemand Tipp, wo man Einstellungen vornehmen müsste ? Danke & Grüße rabele
  20. Hallo, ich habe einen xtc304sp2.1. Nun kann aus dem Kontaktformular nichts mehr versendet werden bei email-adresse gmx usw. Fehlermeldung: Message was not sent Mailer Error: Die folgende Absenderadresse ist nicht korrekt: xxx@gmx.de Antwort von HostEurope: "Es ist nicht mehr möglich, E-Mail Adresse von z.B. web.de, GMX, Yahoo, Googlemail, Hotmail, etc. als Absenderadresse zu benutzen. Dies wurde vorher nicht unterbunden, war jedoch auch kein Feature der Produkte. Es hängt aktuell von der jeweiligen Domain ab, es handelt sich hauptsächlich um Domains von großen Mailprovidern. Die von Ihnen genannten E-Mail Adressen gehören zu diesen Domains. Bitte passen Sie Ihr Skript so an, dass die Absender-Adresse zu Ihrer Domain gehört und die von den Kunden angegebene Adresse nicht als "From" sondern z.B. als "Reply-To" übergeben wird." Die Bestellbestätigungen funktionieren, es ist nur das Kontaktformular. Was muss ich ändern? Danke.
  21. Hallo zusammen, habe da ein Problem: ich habe das Kontaktformular geklont um eine Newsletterfunktion zu basteln. Klappt auch ganz gut, allerdings würde ich das ganze gerne an eine andere Addresse senden lassen. Das System nimmt aber natürlich die als Kontaktadresse hinterlegte(_STORE_CONTACT_EMAIL). Alle "normalen" Varianten mit PHP frisst das System nicht. Hat jemand sonst eine Idee? $newsMail = new xtMailer('none'); $newsMail->_addReceiver(_STORE_CONTACT_EMAIL,_STORE_NAME); $newsMail->_setSubject(TEXT_Newsletteranmeldung); $newsMail->_setContent($content,$body_html); $newsMail->_setFrom(_STORE_CONTACT_EMAIL,_STORE_NAME); $newsMail->_addReplyAddress($_POST['email_address'], $_POST['firstname'].' '.$_POST['lastname']); $newsMail->_sendMail(); $info->_addInfo(SUCCESS_EMAIL_SEND,'success');[/PHP] Bin um jeden Rat dankbar!
  22. Hallo, habe seit ein paar Tagen folgenden Fehler: Beim Versenden einer E-Mail über das Kontaktformular der Shopsoftware xt:Commerce VEYTON 4 Version 4.0.13 ist die Nachricht - sofern sie über mehrere Zeilen geht - leer. Hat jemand eine Erklärung oder Lösung zu diesem Problem? BG, Raimund
  23. Hallo, ich habe eine Frage zum Kontaktformular. Wenn das Formular abgeschickt wurde, erscheint oben über dem Formular der Hinweis, dass es erfolgreich abgeschickt wurde. Darunter steht dann noch einmal das komplette Formular mit den ausgefüllten Feldern. Ist es möglich, dass man das Formular nach dem erfolgreichen Senden nicht mehr zeigt, sondern nur eine Antwortseite? Ich finde, dass das den Absender verwirrt und er sich nicht mehr sicher ist, ob es wirklich gesendet wurde. Gibt es da Lösungen. Ich habe keine gefunden :-(( Danke und viele Grüße schipper
  24. Weiss jemand warum die E-Mail an den Admin ueber das Kontaktformular in englischer Sprache ankommt, obwohl nur die deutsche Sprache aktiviert ist u. wie man das abaendern kann? email_address : yxyxyx firstname : yxyxyx lastname : yxyxyx company : yxxyx order_id : 1234 customer_message yxyxyxyx
  25. Hallo, Anfragen, die über das Kontaktformular gesendet werden kommen nie an?! Ich bekomme nach dem submit eine Meldung, das alles funktionieren würde, aber die angeschickte Email kommt nie an. Im Backend steht unter Shopeinstellungen/Email-Einstellungen Empfänger - Kontaktformular: meine Adresse Maile ich ich direkt aus Outlook an diese Adresse kommen die Mails auch an. Auch kommen alle Bestellungen an. Nur eben keine Anfragen über das Kontaktformular. Was kann ich jetzt tun? Wie kann ich dieses Problem lösen?
×
×
  • Create New...