Jump to content
xt:Commerce Community Forum

Search the Community

Showing results for tags 'master slave'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • xt:Commerce - Professionelle eCommerce Shopsoftware
    • Fragen zur Software
    • xt:Commerce Plugins
    • xt:Commerce 4 Sprachen
    • xt:Commerce Online Handbuch
    • Häufige Fragen (FAQ)
    • Fragen zur Software (Pre Sale)
    • Anleitungen - Patches - Downloads
  • xt:Commerce Office - Shop & Warenwirtschaft
    • Allgemeine Fragen
  • xt:Commerce Allgemein
  • xt:Commerce 3 Shopsoftware Community Area (nur Lesen)
    • Allgemeine Diskussionen
    • Installation und Konfiguration
    • Shopbereich
    • Admininterface
    • Modul Entwicklung
    • Template System
    • xt:Commerce Schnittstellen ERP Systeme
    • PHP & MysQL Forum
    • HTML & CSS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biografie


Wohnort


Interessen


Beruf

Found 6 results

  1. Hallo, ich glaube ich stehe auf dem Schlauch und finde auch im Forum keine Lösung. Mein Problem bei XTC 5.0.8: Ich hätte gerne in den Artikelnamen der Slave Artikel die M/S Attribute mit dabei. Bsp.: Artikelname-Slaveattribut: Shirt-rot-L Bisher haben die Slaveartike zu einem Master alle den selben Artikelnamen. Im Warenkorb, in der Bestellbestätigung und auch beim Artikel Export über den Export Manager können diese nur über die Artikelnummer unterschieden werden. Bei der SEO übernimmt der Shop die Slave-Attribute als Text in die URL. Ich hätte das gerne auch bei den Artikelnamen auf der Artikeldetailseite, im Warenkorb, in der Bestätigungsmail und auch im Export. Gibt es eine Variable, die ich dort überall mit an den Artikelnamen hängen kann, das die Attribute mit ausgegeben werden? Oder gibt es eine andere Lösung? Ist es eine Einstellungsfrage? Hoffe ich habe mich halbwegs verständlich ausgedrückt und freue mich auf Eure Lösungen... DANKE
  2. Hallo Zusammen, ich versuche schon seit einiger Zeit die Anzahl der angezeigten Varianten in meinem Shop zu erhöhen. Zur Zeit werden nur 10 Artikelvarianten angezeigt obwohl ich mehr angelegt habe. Ich habe dazu schon einige Beiträge im Forum gefunden, leider helfen mir diese nicht weiter. In einem Beitrag wird von einem Button im Backend in den Einstellungen vom Master_Slave Plugin gesprochen, diesen habe ich jedoch nicht gefunden. In einem anderen Beitrag wird dies erwähnt: " Das geht nur über eine Versteckte Plugin-Option direkt in der Datenbank: SELECT * FROM `xt_config_plugin` WHERE `config_key` LIKE '_PLUGIN_MASTER_SLAVE_SHOW_MAX_PRODUCTS' " damit kann ich jedoch auch nicht viel anfangen. Leider habe ich auch nichts dazu im Online-Handbuch gefunden. Kann mir jemand weiterhelfen? Mit freundlichen Grüßen Philipp
  3. Hallo zusammen, beim Einbinden der Cross Selling Funktion in Master Slave Umfeld fiel uns gerade ein Bug auf, der unserer Meinung nach nicht auf einen Konfigurationsfehler zurück zu führen ist. Wenn ein Master-Artikel A, der seine Preisauszeichnung als "Auto Preis" gesetzt hat, per Cross-Selling einem anderen Master-Artikel B zugeordnet wird, funktioniert erst mal alles gut. Im Artikel Listing B wir unten drunter als Empfohlenes Zubehör Artikel A zusammen mit "ab EUR ..." angezeigt. Wählt man nun aber im Artikel Listing B einen der Slaves aus, um diesen zu kaufen, wird zwar immer noch korrekterweise Artikel A per Cross-Selling angeboten, aber es erscheint dort kein "ab-Preis" mehr, sondern der fixe Preis, der dem Master Artikel A zugeordnet ist. Das geht natürlich gar nicht, wenn Artikel A eben Slaves mit unterschiedlichen Preisen hat (dafür gibt es Einstellungen wir Auto Preis ja schließlich). Hat hierfür jemand eine Lösung - oder sind sich mzanier & Co. dieses Bugs bewusst?
  4. Hallo, seit heute morgen funktioniert der Shop eines Kunden auf einmal nicht mehr. Sobald ich das Master-Slave Plugin deaktiviere läuft er, wird es wieder aktiviert, laufen insbesonders die Kategorien wo Master-Slave-Artikel enthalten sind nicht. Habe das Plugin nun neu installiert jedoch ohne Erfolg. Hat jemand eine Idee? LG David
  5. Shop Version 4.2.00 Master/Slave Version 1.2.9 Plugin Einstellungen: Standard / Auslieferung also die relevanten: Weiterleitung auf Slaveartikel: Ja Anzeige Optionsauswahl: Ja Anzeige Slaveartikel Liste: Ja Slave-Liste filtern nach Auswahl: Nein Folgendes Szenario: Es gibt eine Farb-Option mit drei möglichen Farben: Blau, grün, rot. Man wählt in der Optionsauswahl blau aus. Jetzt ist blau ausgewählt und bei den Produktvariationen tauchen noch die zwei anderen Möglichkeiten auf: Grün und rot. Das ist korrekt. Die Verlinkungen stimmen auch. Es lässt sich aber per Produktvariation nur grün korrekt anklicken. Wenn man rot anklickt, wird man automatisch zur Artikelseite von blau umgeleitet (was zuvor per Option ausgewählt wurde). Wenn man keine Optionsauswahl benutzt, sondern nur in den Produktvarationen hin und her klickt, läuft alles korrekt. Aber sobald man einmal eine Optionsauswahl getätigt hat, kann man eine Produktvariation (in dem Fall rot) nicht mehr korrekt anwählen. Ich weiß nicht, ob dieser Fehler schon bekannt ist. Jedenfalls habe ich dazu nichts gefunden. Gruß Sepp
  6. Hallo liebe Gemeinde, ich habe ein Problem mit meinen Master/Slave-Artikeln mit mehr als einer Artikeloption. Das Problem kann ich am besten anhand eines Beispiels erklären: - Ich habe einen Master-Artikel mit vielen Slaves (80) und 2 Attributen - Die Attribute sind 5x"Größe" und 16x"Farbe" - Sobald der Masterartikel ausgewählt wird, muss man danach beide Optionen auswählen (normal) - Wenn man zuerst nur eine Option auswählt (z.B. Größe S), ist nur die Größe markiert und keine Farbe (normal) - Damit direkt ein Slave markiert wird wenn man auf den Master-Artikel klickt (weil man Master-Artikel nicht bestellen kann), habe ich im M/S-Plugin eine Hook eingebaut der direkt ein Slave auswählt: in /plugins/xt_master_slave/hooks/module_product.phptop.php if ($p_info->data['products_master_flag']==1 && $p_info->is_product!=false) { $rs = $db->Execute("SELECT products_id FROM ".TABLE_PRODUCTS." WHERE products_master_model='".$p_info->data['products_model']."' and products_status=1 LIMIT 0,1"); if ($rs->RecordCount()==1) { $tmp_link = $xtLink->_link(array('page'=>'product','params'=>'info='.$rs->fields['products_id'])); $xtLink->_redirect($tmp_link); } } - Nun wird direkt ein Slave ausgewählt mit z.B. Farbe Gelb und Größe S Nun zum Problem: Sobald ich dann (beide Optionen sind markiert) eine andere Option auswähle z.B. -Farbe von Gelb nach Blau- oder -Größe von S auf M- ändert sich zwar die Markierung, aber der Preis nicht und wenn ich es dann im Warenkorb lege, bleibt die alte Option. Ich muss erst beide Optionen (Farbe und Größe) erneut auswählen, damit das richtige Produkt ausgewählt wird. Der Link geht also nicht aufs Produkt sondern der Link ändert sich in z.B. "product?action_ms=1&info=1255". Ich bin ratlos... wäre um jede Hilfe sehr dankbar!
×
×
  • Create New...