Jump to content
xt:Commerce Community Forum

Search the Community

Showing results for tags 'modrewrite'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • xt:Commerce - Professionelle eCommerce Shopsoftware
    • Fragen zur Software
    • xt:Commerce Plugins
    • xt:Commerce 4 Sprachen
    • xt:Commerce Online Handbuch
    • Häufige Fragen (FAQ)
    • Fragen zur Software (Pre Sale)
    • Anleitungen - Patches - Downloads
  • xt:Commerce Office - Shop & Warenwirtschaft
    • Allgemeine Fragen
  • xt:Commerce Allgemein
  • xt:Commerce 3 Shopsoftware Community Area (nur Lesen)
    • Allgemeine Diskussionen
    • Installation und Konfiguration
    • Shopbereich
    • Admininterface
    • Modul Entwicklung
    • Template System
    • xt:Commerce Schnittstellen ERP Systeme
    • PHP & MysQL Forum
    • HTML & CSS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biografie


Wohnort


Interessen


Beruf

Found 28 results

  1. Hi zusammen, ich habe das Problem das sobald ich im Adminpanel die Option einstellungen->Suchmaschinen-> Mod Rewrite URL aktiv setze bekomme ich bei jedem Link nur noch "not Found" also 404. Ich habe im root der Installation eine .htaccess mit folgendem Inhalt: # RewriteEngine on # RewriteRule !\.(js|ico|gif|jpg|png|css)$ index.php DirectoryIndex index.php RewriteEngine on RewriteCond %{REQUEST_URI} !^/media/ RewriteCond %{REQUEST_URI} !^/extAdmin/ RewriteCond %{REQUEST_URI} !^/skin/ RewriteCond %{REQUEST_URI} !^/js/ RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-l RewriteRule .* index.php Bitte um Hilfe. Danke, Amanor
  2. Hallo, Ich versuche xt:commerce auf meien webspace bei 1&1 zu installieren. Der Systemtest meldet alles ok außer "Apache - mod_rewrite (SEO Urls!)" In diversen Foren findet man muss RewriteEngine On RewriteBase / in die .htaccess einfügen. Dies hab ich in verschiedenen Varianten (neue .htaccess oder bereits vorhandene im xtcommerce hauptverzeichnis. Funktioniert beides nicht. Rotes Ausrufungszeichen bleibt bei Systemtest bestehen. Was kann ich tun? So sieht meine .htaccess aus: Sie befindet sich im hauptverzeichnis welches mit der URL verbunden ist und in der die xtcommers dateien und ordner liegen. AddType x-mapp-php6 .php AddHandler x-mapp-php6 .php # RewriteEngine on # RewriteRule !\.(js|ico|gif|jpg|png|css)$ index.php DirectoryIndex index.php <IfModule mod_rewrite.c> SetEnv HTTP_MOD_REWRITE On RewriteEngine on RewriteBase / RewriteCond %{REQUEST_URI} !^/media/ RewriteCond %{REQUEST_URI} !^/extAdmin/ RewriteCond %{REQUEST_URI} !^/skin/ RewriteCond %{REQUEST_URI} !^/js/ RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-l RewriteRule .* index.php </IfModule> <IfModule mod_expires.c> ExpiresActive On ExpiresDefault "access plus 1 seconds" ExpiresByType image/x-icon "access plus 2692000 seconds" ExpiresByType image/jpeg "access plus 2692000 seconds" ExpiresByType image/png "access plus 2692000 seconds" ExpiresByType image/gif "access plus 2692000 seconds" ExpiresByType application/x-shockwave-flash "access plus 2692000 seconds" ExpiresByType text/css "access plus 2692000 seconds" ExpiresByType text/javascript "access plus 2692000 seconds" ExpiresByType application/x-javascript "access plus 2692000 seconds" </IfModule> <IfModule mod_headers.c> <FilesMatch "\\.(ico|jpe?g|png|gif|swf|css|js)$"> Header set Cache-Control "max-age=2692000, public" </FilesMatch> Header unset ETag Header unset Last-Modified </IfModule> Danke für Hilfe!!! josepe45
  3. Da ich gerade für Analytics das Zieltrichterzeug einrichte, fällt mir auf, dass in einem meiner Shop´s 'mod_rewrite' ab dem Warenkorb nicht mehr funktioniert. Bei den Kategorien und Produkten funktioniert es Tadellos Weiß jemand woran das liegen kann?
  4. Hallo, ich habe ein Problem mit mod_rewrite und 1und1: Ich bekomme selber nicht raus, ob denn mod_rewrite nun aktiviert ist oder nicht. Ich möchte, dass meine URLs in meinem neuen Shop schön kurz und suchmaschinengerecht dargestellt werden, aber jedes Mal, wenn ich in der Shop-Software dieses Modul "Mod Rewrite URL" auf "true" setze, funktioniert nichts mehr außer der Startseite. Liegt das daran, dass mod_rewrite nicht richtig aktiviert wurde? Oder was? In meiner phpinfo.php steht dazu nur folgendes: url_rewriter.tags: a=href,area=href,frame=src,form=fakeentry,fieldset= In meiner htaccess steht folgendes: AddType x-mapp-php5 .php AddHandler x-mapp-php5 .php # RewriteEngine on # RewriteRule !\.(js|ico|gif|jpg|png|css)$ index.php DirectoryIndex index.php RewriteEngine on RewriteCond %{REQUEST_URI} !^/media/ RewriteCond %{REQUEST_URI} !^/extAdmin/ RewriteCond %{REQUEST_URI} !^/skin/ RewriteCond %{REQUEST_URI} !^/js/ RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-l RewriteRule .* index.php Was kann ich ändern, damit das endlich funktioniert? Lieber Gruß an alle Experten...
  5. Hallo zusammen, ich habe folgendes (möglicherweise recht triviales) Problem, das ich auch nach intensiver Suche hier im Forum nicht habe lösen können. Ich leite via .htaccess per RewriteEngine on RewriteCond %{HTTP_HOST} !^www\.meinedomain\.de$ [NC] RewriteRule ^(.*)$ http://www.meinedomain.de/$1 [R=301,L] bzw. RewriteEngine On RewriteCond %{HTTP_HOST} !^www. [NC] RewriteCond %{HTTP_HOST} !^$ RewriteRule ^(.*) http://www.%{HTTP_HOST}/$1 [R=301,L] alles auf www um, um Doppelcontent zu vermeiden. Das funktioniert im root-Verzeichnis "www . meinedomain.de" bei beiden rewrite-Varianten auch so weit, d.h. bei Eingabe von meindedomain.de wird www . meinedomain.de aufgerufen. Wenn ich allerdings innerhalb eines Kategorieverzeichnisses http://www.meinedomain.de/de/Kategorie1/Subkategorie1/Produkt1.html in der Browseradresszeile das "www" lösche und den Browser neu lade, erhalte ich einen 404-redirect auf: http://www.meinedomain.de/de/404.html Der Vollständigkeit halber mal hier die beiden kompletten .htaccess-Varianten: # RewriteEngine on # RewriteRule !\.(js|ico|gif|jpg|png|css)$ index.php DirectoryIndex index.php RewriteEngine on RewriteCond %{REQUEST_URI} !^/media/ RewriteCond %{REQUEST_URI} !^/extAdmin/ RewriteCond %{REQUEST_URI} !^/skin/ RewriteCond %{REQUEST_URI} !^/js/ RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-l RewriteRule .* index.php RewriteEngine on RewriteCond %{HTTP_HOST} !^www\.meinedomain\.de$ [NC] RewriteRule ^(.*)$ http://www.meinedomain.de/$1 [R=301,L] bzw. # RewriteEngine on # RewriteRule !\.(js|ico|gif|jpg|png|css)$ index.php DirectoryIndex index.php RewriteEngine on RewriteCond %{REQUEST_URI} !^/media/ RewriteCond %{REQUEST_URI} !^/extAdmin/ RewriteCond %{REQUEST_URI} !^/skin/ RewriteCond %{REQUEST_URI} !^/js/ RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-l RewriteRule .* index.php RewriteEngine On RewriteCond %{HTTP_HOST} !^www. [NC] RewriteCond %{HTTP_HOST} !^$ RewriteRule ^(.*) http://www.%{HTTP_HOST}/$1 [R=301,L] Die SuMa-Einstellungen unter Einstellungen >> Konfiguration sind wie auf folgendem Screenshot abgebildet, gesetzt: mod-rewrite auf dem Server ist aktiv. Weiss jemand Rat? Vielen Dank! Hans
  6. habe im Forum lange gesucht leider nichts passendes gefunden. Hier das Problem: 1) auf der Startseite die Endung index.php bzw. die Seite umleiten auf www./ domain.de/ 2)habe eine www./ weiterleitung eingebaut, jetzt ist das problem das die unterseiten zb: ohne www./ ihredomain.de/unterseite werden direkt auf Startseite weitergeleitet # RewriteEngine on # RewriteRule !\.(js|ico|gif|jpg|png|css)$ index.php DirectoryIndex index.php AddDefaultCharset utf-8 RewriteEngine on RewriteBase / RewriteCond %{REQUEST_URI} !^/media/ RewriteCond %{REQUEST_URI} !^/extAdmin/ RewriteCond %{REQUEST_URI} !^/skin/ RewriteCond %{REQUEST_URI} !^/js/ RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-l RewriteRule .* index.php RewriteCond %{HTTP_HOST} ^ihredomain\.de$ [NC] RewriteCond %{HTTP_HOST} !^$ RewriteRule ^(.*)$ http://www.ihredomain.de/$1 [R=301,L]
  7. Guten Tag, ich habe gestern XTC Veyton installiert und auch die mod_rewrite Rechte aktualisiert. Leider funktioniert das immer noch nicht. Der Hoster meinte, dass eine .htacces Datei in dem Ordern fehlt, indem der Shop liegt. Woher bekomme ich diese .htacces Datei? MfG
  8. Hallo Community, ich habe gerade dass erste mal VEYTON installiert. Wärend des Checks am Anfang der Installation war alles perfekt - überall grüne Häkchen. Auch wärend der Installation hat alles klappt. Im Adminmenü klappt auch alles, soweit ichs bis jetzt ausprobiert habe. Nur im Frontend verhält sich der Shop sehr merkwürdig. Er findet keine Seite, wenn man auf einen Navigationslink klickt. Wie kommt das!? Scheint mir irgendwas mit dem mod_rewrite zu sein.. der is aber aktiv und ich hatte auch sonst auf selbigen Webspace mit mehreren CMS keine Probleme mit dem rewrite... Könnt ihr mir helfen? Danke! PS: Hier mal zum "ausprobieren".. www.arte-kerzen.de/shop_b2b/
  9. Guten Tag! Auf www.crossstore.eu ist ein shop der eigentlich Monatelang gelaufen ist. Nun gibt es das phänomen das es immer einen Serverfehler gibt 500 in den logs erscheint nichts. Das rewrite funktioniert bei allen unterseiten bis auf die Produkt und Kategorie seiten nciht ... wie ist das möglich? Danke im vorraus. gruß ben
  10. Hallo alle zusammen, ich bin da auf einen merkwürdigen Fehler gestoßen: mod_rewrite ist aktiviert, funktioniert auch im Großen und Ganzen, aber an den Details haperts etwas. Wenn ich meinen Browser neu starte und dann auf die Seite gehe (oder halt noch nicht auf der Seite war seit einer gewissen Zeit), dann stimmen beim ersten Aufruf die URLs nicht. D.h. sie stimmen schon, allerdings hängt an jedem vom Shop generierten Link noch etwas dran, nämlich folgendes: "?x55b02=37019d009fee0ea07f4dc9d3adb5e273" Der Teil vor dem "=" bleibt immer gleich, der Teil danach ändert sich jedes Mal, ich vermute dabei handelt es sich um die Session-ID. Das Problem an der ganzen Sache ist, dass dadurch der Klick auf jeden beliebigen Link zu einem Fehler 404 führt. Danach oder nach einem einfachen Reload der Startseite ist der Fehler weg und alles funktioniert einwandfrei. Wie werde ich diesen Fehler los? Die .htaccess sieht so aus: AddType x-mapp-php5 .php AddHandler x-mapp-php5 .php RewriteEngine on RewriteBase / RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
  11. Hey Veyton-Anhänger uns stellt sich hier erneut eine für uns wichtige Frage: Und zwar besitzt die Veyton-Standardinstallation werkseitig eine .htaccess Datei. Wir haben in dieser natürlich einigen Code eingesehen und fragen uns ob man den kompletten Code anpassen kann/darf ohne mit Konsequenzen auf rechtlicher Schiene rechnen zu müssen oder Gefahr zu laufen die Funktionsweise des Shops nicht mehr sicherstellen zu können? Unser Vorhaben ist es, den Shop mithilfe einer mod_rewrite Lösung NUR über www. ansprechbar zu machen, sodass beispielsweise "google.de" nicht aufrufbar wäre.(google.de ist nur als Platzhalter vorgesehen) Kann man da beispielsweise die .htaccess auch tutti kompletti löschen und mit eigenen Lösungen füllen, die sich nicht auf das vorher bestandene Thema in der .htaccess beziehen oder sollte man sich da vorsehen? mfg, der fexxo
  12. Hallo zusammen, ich habe das Problem, dass mod_rewrite nicht mehr funktioniert, seitdem ich von 1und1 zu hosteurope umgezogen bin. Ich habe bereits mit dem Support telefoniert und sowohl mod_rewrite, wie auch Allowoverride All sind aktiv. Wenn ich jetzt den mod_rewrite Test mit folgender .htaccess durchführe: RewriteEngine On RewriteRule ^ www.google.com [R,L] [/html] dann bekomme ich die Fehlerseite: Zugriff verweigert. Error 403. In der Adresszeile steht dann http://www.carfeature.de/is/htdocs/wp10585176_Y80OO3OQL6/www.google.com Kann unter www.carfeature.de live getestet werden. Der Support von hosteurope konnte mir nur versichern, dass von Serverseite eigentlich alles funktionieren sollte, tuts aber nicht. Deshalb hoffe ich, dass mir jemand von euch weiterhelfen kann, da ich momentan recht ratlos bin. Gruß, Benajmin
  13. Hallo Leute, habe bei mir das /de/ Länderverzeichnis abgeschaltet google hat bei mir Natürlich schon mit de indexiert. www.meinkleinershop.de/de/ein-produkt.html wie bekomme ich es den umgeleitet mit .htaccess das nur das /de/ aus der URI entfernt wird und er auf das Produkt leitet ohne de. www.meinkleinershop.de/ein-produkt.html Danke:D
  14. Hier ist immer wieder die Rede davon, das man MOD-Rewrite per htaccess nutzen soll, um ALLE Shopseiten SEO-konform mit einer vernünftigen URL auszustatten. Würde sich denn mal jemand der Profis erbarmen, eine solch modifizierte htaccess bereitzustellen, welche wirklich ALLE Seiten in Veyton vernünftig darstellt? Also auch die Links der Module TAG-Cloud etc. oder Suche und Seitensortierung. index.php?page=search&keywords=avatar[/HTML] [HTML]index.php?page=categorie&cat=1619&sorting=price-desc[/HTML] Eben ein File was wirklich jede Möglichkeit in Veyton bedenkt und souverän löst. Wäre mal ein erstklassiger Community-Service Danke!
  15. gibt es eine möglichkeit z.b. Seiten wie index.php?page=xt_new_products umzuschreiben in /de/neue-artikel ??? ebenso natürlich index.php?page=xt_special_products usw über eine antwort wären wir sehr dankbar
  16. hi, habe folgendes Problem: der Kunde hat von alter Website auf Veyton umgestellt, möchte aber die alten Google-Einträge auf die entsprechenden Seiten verlinken. Gebe ich nun in der .htacess ein: ... RewriteRule ^agb.php /index.php?page=content&coID=3 ...( weitere Links ) RewriteRule .* index.php funktioniert das beim ersten Aufruf ( habe mich davon auch wunderbar in die Irre führen lassen ) Bestätige ich das nochmal, geht das template flöten , bei nochmal bestätigen wird die Index.html "so halb" ausgeführt, beim dritten Mal ist sie wieder voll da usw. usf. Geht das überhaupt, was ich da machen will ? also alter Link: www.kundendomain.de/agb.php soll auf die AGBs im Shop umleiten usw. für diverse Artikel und Kategorien. Grüsse ( bin am verzweifeln .... )
  17. Hey, wie kann ich denn die Artikelnummer mal direkt aus dem Titel rausbefördern? Geht um Veyton. gruß
  18. Hi, also ich hab schon wieder ein Problem ich bekomme einfach die mod_rewrite url´s nicht gebacken. Jedesmal wenn ich diese aktiviere kommt der 500er Fehler. Nun hab ich schon einiges versucht doch bekomm es einfach nicht hin. Im Handbuch steht man muss (wenn man bei 1und1 ist) dies in die htaccess einfügen: Fügen Sie direkt nach RewriteEngine on Folgende Zeile ein: RewriteBase / hab ich gemacht --> Fehler bleibt. Nun hab ich bei 1und1 nachgeschaut, in denen ihrem Hilfecenter steht man soll: RewriteCond %{REQUEST_URI} news/(.*)\.html$ RewriteRule news/(.*)\.html$ /news.php?id=$1 einfügen, also htaccess nochmals versucht zu ändern --> Ergebnis: leider wieder ohne Erfolg. Fehler 500 bleibt. Kann mir irgendjemand sagen, wie ich dies auf die Reihe bekomm? Gruß Matthias
  19. hi, ich kriegs einfach nicht hin mit der htaccess:( hab ich aus dem Forum ) RewriteEngine on RewriteBase / RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ index.php?q=$1 [L,QSA] Lizenz: Neue Internetprsenz Shop unter www.meinedomain.de/store Lt. Hoster sind ist sowohl mod_rewrite möglich und symlinks auch 1. Problem: schalte ich mod_rewrite ein, kommt die Startseite, aber jeder weitere Klick sagt, er finde die /index.php nicht 2. Problem: setze ich die folgende Zeile ein, wird jeder Klick wieder auf die Startseite umgeleitet: Redirect /index.php http://www.meinedomain.de/store ( ein RewriteBase /store hilft auch nicht ) 3. Problem: es werden zu Laufzeit Symlinks im Verzeichnis media/files_public auf die Dateien in media/files angelegt. Beim Anklicken des Downloads heisst es z.B.: You don't have permission to access /store/media/files_public/xkdbvfhlv/cat_gd910.pdf on this server. Am Server zeigt der Link im Verzeichnis xkdbvfhlv auf: ftp> ls xkdbvfhlv drwxr-xr-x 2 manseaaq manseaaq 26 Aug 29 17:20 . drwxrwxrwx 31 manseaaq manseaaq 4096 Aug 29 17:20 .. lrwxrwxrwx 1 manseaaq manseaaq 57 Aug 29 17:20 cat_gd910.pdf -> /manseaaq/www.meinedomain.de/store/media/files/cat_gd910.pdf manseaaq kommt vom Host H.Zanier hat mal was von einer Standard-htaccess von Veyton erzählt, die hab ich aber noch nirgends gefunden. soviel kann doch da nicht fehlen ... Grüsse Günther
  20. Hallo zusammen, ich habe die 4.0.11 auf einem hosteurope webpack laufen. Sobald ich in der Administration mod_rewrite anschalte bekomme ich bei allen Links nur noch 404 Fehler. Eine .htaccess Datei habe ich angelegt, mit folgendem Inhalt: RewriteEngine on RewriteBase /shop Könnt ihr mir helfen? Danke und lieben Gruß, Julian
  21. Hallo, wenn ich SEARCH_ENGINE_FRIENDLY_URL auf "true" setzte bekomme ich nur: Error! Unable to determine the page link! Kann mir jemand einen Tipp geben, was ich noch zusätzlich anstellen muss? Mod_rewrite ist bei dem Provider (1und1) verfügbar. Jens
  22. Erst mal ein Hallo in die Runde wirft. Nun zu meiner Frage: wir sind bei 1und1 und haben alle unsere Projekte mit Mod_rewrite Suchmaschinenfreundlich gemacht. Wenn ich das jetzt hier im Shop aktiviere kommt nur eine Fehlermeldung. Wo ist die htacces, die diese Dinge hier im Shop macht, damit wir die f?r 1und1 anpassen k?nnen. Ronny
  23. moin, hab hier schon einige threads gelesen zum thema suma-freundliche url`s - allerdings schlau bin ich daraus nicht geworden :cry: ich hab xt-commerce v3.03 19.01.2004 setze ich suchmaschinenfreundl. urls aktivieren auf true => fehler mit mod_rewrite kenne ich mich nicht aus k?nnte mir da bitte jemand helfen, eventuell ein bsp. mod_rewrite posten, oder sonst irgendwelche tipps geben ? danke cu gust.
  24. Hallo, in welchem Verzeichnis finde ich die ht.access in der ich die mod_rewrite Funktion einf?ge?
  25. Hallo an die XT Experten. Seit kurzem habe ich den XT (neueste Version) installiert. Mein XT Shop liegt in einem Unterverzeichnis der Hauptdomain. Puretec unterst?tzt ja mod_rewrite f?r die Suchmaschinenfreundlichkeit. Wer hat Erfahrungen damit und kann mir gegen faire Bezahlung die mod_rewrite Funktion bei Puretec f?r den XT-Shop einrichten. F?r ein Hauptverzeichnis ist es ja kein grosses Problem, da Puretec hierzu ja auch Hilfe anbietet. Aber wie mod_rewrite in einem Unterverzeichnis installiert wird, weiss ich leider nicht, daher suche ich h?nderingend Hilfe...
×
×
  • Create New...