Jump to content
xt:Commerce Community Forum

Search the Community

Showing results for tags 'relative'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • xt:Commerce - Professionelle eCommerce Shopsoftware
    • Fragen zur Software
    • xt:Commerce Plugins
    • xt:Commerce 4 Sprachen
    • xt:Commerce Online Handbuch
    • Häufige Fragen (FAQ)
    • Fragen zur Software (Pre Sale)
    • Anleitungen - Patches - Downloads
  • xt:Commerce Office - Shop & Warenwirtschaft
    • Allgemeine Fragen
  • xt:Commerce Allgemein
  • xt:Commerce 3 Shopsoftware Community Area (nur Lesen)
    • Allgemeine Diskussionen
    • Installation und Konfiguration
    • Shopbereich
    • Admininterface
    • Modul Entwicklung
    • Template System
    • xt:Commerce Schnittstellen ERP Systeme
    • PHP & MysQL Forum
    • HTML & CSS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biografie


Wohnort


Interessen


Beruf

Found 3 results

  1. Also ich bin auch ein Glücklicher. Mein Chef hat von einer Agentur sich Veyton aufschwatschen lassen, die noch nie einen SHOP aufgezogen hat. Jetzt geht natürlich nur die hälfte von dem was die wollen machen mit dem SHOP. Ich bin also der Glückliche der die Arbeit vollenden darf. Die Online Doku finde ich auch sehr mager, eine Liste der classen funktionen währe schon was. Nun ja Meine Chefin hat ohne zu zögern ja gesagt als ich fragte ob wir das Buch kaufen können. Ist also Unterwegs, ich habe also zu warten. Meine dringlichte Frage ist mir ist aufgefallen das immer absolute URL's für z.B. Bilder http://www.domain.tld/folder/picture.png Warum ist das so? Als ich vor 15 Jahren mich das erste mal mit html auseinnandergesetzt habe ich gelernt immer relative urls zu benutzen also /folder/picture.png Wie kann ich das ändern? Das Hauptproblem ist, wenn ich die 302 Umleitung am Apache auf https an mache habe ich eingebettete Bilder mit http Eleganter währe beim Absenden des Formulares. <form name="example" method="https://..."> Danach header('HTTP/1.1 302 Found'); header('Location: http://...'); Moneybroker: Der Kunde muss sich da Anmelden: schöner währe es wenn der Kunde nicht davon mitbekommen würde über wen wir Abrechnen. Was mich noch wundert es gibt doch viele, die hier selber Anpassungen vornehmen ich habe aber hier wenig Posts gesehen mit Sources. Ist doch üblich wenn man was Entwickelt es zu Posten dann können auch andere davon Profitieren wenn man sich schon die Arbeit macht. LG LEO
  2. Hi, beim Links-Setzen in den Contentseiten greift mir der Parameter target="parent" nicht. Ebenso target="self". Es wird ständig ein neuer Tab geöffnet. Hat jemand einen Vorschlag, was ich ändern muss? Beispiel: <a href="http://meinShop.de/index.php?page=categorie&cat=294" target="parent"> <span class="shopinfo">Marken/DiesUndDas</span></a> Hat jemand in dem Fall auch gleich eine Idee, wie ich den absoluten Pfad in einen relativen Pfad ändern muss? Liebe Grüße, Sandra
  3. Hallo Zusammen, ich hoffe das hier der ein oder andere Smartyprogrammierer mal vorbeischaut. Ich experimentiere gerade mit {include file="/php/index.html" type="tpl_include"} und PHP. Ich möchte im Shoptemplate einen DIV Layer haben, indem Bilder per Zufall aufgerufen werden. Dazu habe ich in meinem Template einen Ordner /php angelegt und eine index.html Datei erzeugt. Code Index: {php} $codes = array( "<img src='AbsoluterPfad/img/arrow1.gif'>", "<img src='AbsoluterPfad/img/arrow2.gif'>", ); shuffle($codes); $i=0; $number=1; while(list(, $code) = each($codes)) { if ($i>=$number) { break; } echo "$code"; echo '<br>'; $i++; } {/php}[/code] Unter Angabe des Absoluten Pfades funktioniert das Skript einwandfrei. Komme ich jedoch in den gesicherten Bereich SSL, stimmen die Pfade nicht mehr überein. Ich habe mich nun etwas umgeschaut, wie ich die Pfade relative Angeben kann und bin dabei über: gestolpert. Funktioniert leider nicht. Hat jemand einen Tip für mich wie ich den relativen Pfad in die IMG Source bekommen kann? Viele Grüße Michael
×
×
  • Create New...