Jump to content
xt:Commerce Community Forum

Search the Community

Showing results for tags 'thumbnails'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • xt:Commerce - Professionelle eCommerce Shopsoftware
    • Fragen zur Software
    • xt:Commerce Plugins
    • xt:Commerce 4 Sprachen
    • xt:Commerce Online Handbuch
    • Häufige Fragen (FAQ)
    • Fragen zur Software (Pre Sale)
    • Anleitungen - Patches - Downloads
  • xt:Commerce Office - Shop & Warenwirtschaft
    • Allgemeine Fragen
  • xt:Commerce Allgemein
  • xt:Commerce 3 Shopsoftware Community Area (nur Lesen)
    • Allgemeine Diskussionen
    • Installation und Konfiguration
    • Shopbereich
    • Admininterface
    • Modul Entwicklung
    • Template System
    • xt:Commerce Schnittstellen ERP Systeme
    • PHP & MysQL Forum
    • HTML & CSS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


Location


Interests


Biografie


Wohnort


Interessen


Beruf

Found 13 results

  1. Hallo zusammen, ich würde gerne ein weiteres Format für Thumbnails anlegen, das bei Artikeln für weitere Bilder verwendet wird. Sprich die normalen thumbs haben 120x120 Pixel und weitere Bilder sollen mit 60x60 dargestellt werden. Ich habe jetzt im Mediamanager -> Bildtypen einen weiteren Typ default mit dem Namen "thumb_more" und 60x60 Pixel angelegt (siehe Anhänge). Meinem Verständnis nach müsste ich jetzt im product.html nur noch den Bildtypen zuweisen von: {img img=$img_data.file type=m_thumb alt=$products_name} zu {img img=$img_data.file type=m_thumb_more alt=$products_name}[/code] Leider funktioniert das nicht. Es wird kein Bild angezeigt. Imageprocessing habe ich nach dem Anlegen der neuen Bildtypen bereits durchgeführt. Ich seh hier im Filesystem keine neuen Grafiken Kann mir jemand weiterhelfen? Gruß Frank
  2. Hallo nochmal, ich versuche eben über den Adminbereich über Inhalte -> Media -> Bildtypen die Größe der Produktthumbnails in der CategorieList anzupassen. Hier finde ich mehrere Punkte: thumb manufacturer/thumb category/thumb Ich habe bereits versucht die Größen in deren Eigenschaften anzupassen. Leider erbrachte dies, nach neuladen der Seite, keinen Erfolg. Müssen die Bilder dafür neu hochgeladen werden oder ist die Anpassung der Größe nur über HTML - CSS im Template möglich? Vielen Dank im voraus. LG Thunder
  3. Hallo, wir haben eine Schnittstelle, die unsere Artikelbilder hoch lädt. Diese werden jeweils direkt in die Unterordner geladen (popup, thumb, info). Darauf ist diese leider beschränkt und die Bildqualität lässt auch zu wünschen übrig. Daher lade ich die Bilder in den Ordner "popup" in Originalgröße hoch und möchte sie von dort aus umrechnen lassen, indem ich nach dem Upload ein Script aufrufe. Dafür habe ich mir nun ein Plugin erstellt, in dem ich prüfe, welche Bilder in den Thumbnail Ordnern fehlen oder veraltet sind. Und jetzt kommt der Teil an dem ich nicht weiter komme. Ich arbeite mich nun seit Stunden durch den Code im xtFramework, um zu verstehen wie das "image processing" funktioniert und wie man es aufruft. Leider bleibe ich dabei absolut erfolglos. Das hier ist mein bisheriger Code, anhand dessen ich das an einem einzigen Bild testen wollte: require_once _SRV_WEBROOT._SRV_WEB_FRAMEWORK.'classes/class.image.php'; require_once _SRV_WEBROOT._SRV_WEB_FRAMEWORK.'classes/class.MediaData.php'; require_once _SRV_WEBROOT._SRV_WEB_FRAMEWORK.'classes/class.MediaImages.php'; require_once _SRV_WEBROOT._SRV_WEB_FRAMEWORK.'classes/class.MediaFiles.php'; $mediaImages = new MediaImages(); $mediaFiles = new MediaFiles(); $this->processImage('test_image.jpg', true);[/PHP] Ich habe zum Testen ein Bild manuell in den Ordner "org" geladen, da die Funktionen von xt:Commerce im Standard anscheinend dort die hoch geladenen Bilder erwartet. Das würde ich später natürlich automatisieren. Sobald ich obigen Code in mein Plugin einfüge erscheint beim Aufruf im Browser nur noch ein weißer Bildschirm (Quelltext leer). Ich habe also nicht mal eine Ahnung, warum es nicht geht, da ich keine Fehlermeldung erhalte. Ich bin mir abgesehen davon auch nicht sicher, ob ich die richtige Funktion verwende, da ich aufgrund meiner mangelnden Kenntnis der objektorientierten Programmierung den Aufbau nicht richtig verstanden habe. Es gibt ja so viele Klassen für Bildverarbeitung, da blicke ich nicht durch. Beim zurück verfolgen, wie man die Funktionen aufruft bin ich irgendwann sogar in der Datei cronjob.php gelandet und nicht mehr weiter gekommen. Lange Rede kurzer Sinn - ich hoffe ihr könnt mir irgendwie einen Schritt weiter helfen. Gruß FloM
  4. Hallo Leute, ich kämpfe seit einigen Tagen mit der Installation, Modifikation und Anpassung von einem XT Commerce Shop. Bisher klappt das nach einiger Zeit dank dem Onkel Google auch immer ganz gut. Nun hänge ich jedoch fest und benötige bitte etwas Hilfe. Ich möchte die Darstellung der geöffneten Lightbox etwas verändern. Momentan wird immer ein großes Bild angezeigt, und die Thumbnails der weiteren Bilder UNTERHALB des großen Bildes angezeigt. Diese Thumbnails würde ich gerne rechts oder links vom großen Bild positionieren. Könnt ihr mir da helfen? Ich bekomme das mit den DIV-Boxen nicht gebacken... Mein Shop: Motivshirts-Shop - Shirts mit lustigen und witzigen Motiven, Bildern und Sprüchen bedruckt XT Commerce v3.0.4 SP2.1 Hier ist der Code von der Lightbox: {config_load file="$language/gm_lang_$language.conf" section="lightbox"} <!-- <link type="text/css" rel="stylesheet" href="templates/gambio/system.css" /> <div style="width:{$BOX_WIDTH}px;border:1px dotted red"> <div style="border:1px dotted red; background-color:gray"> --> <div id="product_images_box" style="width:{$BOX_WIDTH}px; margin-left:auto; margin-right:auto"> <h1>{$PRODUCTS_NAME}</h1> <div id="wrap_images" style="width:{$POPUP_WIDTH}px"> <div id="wrap_images" style="width:{$POPUP_WIDTH}px"> <div id="active_image"><img src="{$ACTIVE_IMAGE}" alt="" title="" /></div> {if $image_data} <ul> {foreach name=aussen item=image_item from=$image_data} <li style="width:{$THUMBNAIL_WIDTH}px;height:{$THUMBNAIL_HEIGHT}px" class="inactive" id="image_{$image_item.IMAGE_NR}"> <a href="{$image_item.IMAGE_NAME}" onclick="return false"><img style="padding-top:{$image_item.IMAGE_PADDING}px;" src="{$image_item.IMAGE_NAME}" alt="{$image_item.IMAGE_ALT}" title="{$image_item.IMAGE_ALT}" /></a> </li> {/foreach} </ul> {/if} </div> <div id="footer" onclick="gmLightBox.close_box()">{#gm_window_close#}</div> </div> </div>[/PHP]
  5. Hallo, kann ich nach Änderung der Bildgrößen die Bilder neu generieren lassen, in dem ich z.B. einen cache-Ordner lösche o.ä.? Währe blöd, wenn nach einer Layoutänderung alle Bilder neu hochgeladen werden müssen. Gruß Stephan
  6. Hallo! 1. Ich möchte gerne, dass der/die/das Navtrail nur in den Kategorieansichten und in der Produktansicht gezeigt wird. In der Erweiterten Suche, auf der Startseite u.s.w. soll kein Navtrail vorhanden sein. Ist das möglich? 2. Ich möchte, dass die zusätzlichen Bilder bei der Produktansicht als Thumbnails dargestellt werden, und nicht in groß, jedoch finde ich da keine Einstellung zu. Per CSS verkleinern sieht leider sehr bescheiden aus. lg, laurids Edit: XTC3 aktuellste Version, Mollio Template
  7. Hallo, habe eine Frage zu den Thumbnails in welcher Datei kann ich die Größe der Thumbnails ändern, damit diese größer dargestellt werden? Der Grund ist der, das ich in der Kategoriespalte unteranderem ein Bild für unseren Call-Back Service eingerichtet habe, aber dies nur in der Thumbnailgröße dargestellt wird. Gruß Matthias
  8. Hallo, Ich habe keine Thumbnails mehr im Adminbereich, seit dem Update auf 4.0.12 Ist das ein Fehler? Oder muss man etwas aktivieren dafür?
  9. Hi Leute, habe eine Frage zur automatischen Erstellung der Thumbnails über das Modul "XT-Imageprocessing". Und zwar werden die Thumbnails immer nach der Breite und nicht nach der Höhe ausreichtet. Ich hätte gerne das immer die fixe Höhe gleich ist und die Breite anhand der fixen Höhe berechnet wird. Desweiteren wird das Wasserzeichen nicht mehr angezeigt, das ging ganz an Anfang. Habe in den Einstellungen auch nichts verändert. Wäre super wenn mir jemand helfen könnte. Danke.
  10. servus, auf der suche nach dem richtigen board bin ich mal hier hängengeblieben. 1.nach einem umfangreichen shop-umbau mit den damit verbundenen erneuern bzw. ändern zahlreicher artikel-thumbnails werden diese zwar hochgeladen, jedoch als artikelbild erscheint ein diagonal abgeschnittes und in schwarz-grau geteiltes bild. in der artikelbeschreibung ist das jpg. ebenfalls nicht zu sehen, sondern erst auf den klick auf den platzhalter öffnet es sich per popup. ich habe bereits sämtliche möglichkeiten versucht. bzw. die fehler ausfindig zu machen probiert, jedoch ohne jeglichen erfolg. wo kann ich ansetzen, um dieses nervige ärgerniss aus der welt zu schaffen? 2. kopiere ich einen artikel aus der einen in eine andere kategorie (was bei uns öfter der fall ist), dann verschwinden sämtliche einträge zum artikel (infos, details, etc. etc.) sowie die artikelbilder. auch hier finde ich keinen ausweg. 3. etwas merkwürdig aber war: letzte woche nach abschluss eines ziemlich umfangreichen arbeitstages ist der gesamte server kollabiert, anschliessend war jeder ordner, jedes verzeichnis, jede datei schreibgeschützt. es ging gar nix mehr. da der confixx ja so herrlich zu handeln ist, blieb mir nix über, jede einzelne datei einzeln zu bearbeiten, um mit dem shop weiterzumachen. war oder ist dies ein bug oder vielleicht eine vorsichtsmassnahme des xtc (3.0.4.) danke im voraus für eventuell hilfreiche antworten
  11. Hi ihrs, ich bin noch Neuling also nich gleich schlagen Wie kann ich denn mit Smarty innerhalb einer Box auf das Thumbnail meines Produkts zugreifen? Möglichst ohne eigenen Datenbankabfrage, sondern aus einer dauerhaft verfügbaren Produktvariable, die sowieso schon aufgerufen wird (falls es das gibt). Danke im Voraus und Grüße stone_d
  12. Ich habe mit folgender Anleitung Minithumbnails erstellt. Möchte diese nun in der Productinfo darstellen. mit <a href="{$PRODUCTS_POPUP_LINK_1}" rel="lightbox[{$PRODUCTS_NAME}]"><img src="{$mini_images}" alt="{$PRODUCTS_NAME}" /></a>[/CODE] hats nicht geklappt auch nicht mit allen anderen denkbaren... Muss es erstmal an anderer Stelle angepasst werden? Das Teil wurde ja eigentlich gemacht um z.B. die Bilder im shoppingcart mittels 1. $image = DIR_WS_MINI_IMAGES.$products[$i]['image']; in den php Dateien auszutauschen! EDIT:Ging doch mit mini_images
  13. Hallo, ich habe folgendes Problem. Wenn ich im Shop die Product_listing aufrufe zeigt es mir keine Thumbnails an. Grund dafür ist ein falscher Pfad file:///E:/xtc/komplette usw. Ändere ich das Template ist der Pfad aber richtig. Ich bin mit meinem Latein am Ende. Kann mir bitte jemand sagen, wo dieser Pfad erzeugt wird. Ich komme nicht weiter, weil bei einem Template die Thumbnails angezeigt werden, aber bei dem anderen nicht. Vielen Dank Frank
×
  • Create New...