Jump to content
xt:Commerce Community Forum
Sign in to follow this  
edwedel

Preisberechnung in der Best?tigungsmail fehlerhaft

Recommended Posts

hallo,

folgendes problem:

in der best?tigungsmail, die der kunde und der admin bekommt, werden bei mir die produktpreise falsch berechnet.

z.b. wenn produkt_eins 4.90 EUR kostet, und man 3 St?ck davon bestellt hat, dann macht das nach adam riese

3*4.90 = 14.70 EUR

In der Mail steht aber 14.00 EUR.

Die zwischensumme dadrunter stimmt dann aber seltsamerweise wieder.

Es ist egal , welche produkte ich teste, bei allen stimmt die oben beschriebene aufsummierung nicht. alle summierungen enden mit .00

und die zwischensummen stimmen dann wieder ???!?!!!?

Ich verstehe das nicht. alle preise werden sonst richtig angezeigt, sowohl im shop als auch bei der gesamtberechnung im warenkorb, nur in der best?tigugsmail eben nicht.

wer kennt eine l?sung des problems?

vielen dank,

eddie

Share this post


Link to post
Share on other sites

Originally posted by edwedel@Jul 12 2005, 11:38 AM

hallo,

folgendes problem:

in der best?tigungsmail, die der kunde und der admin bekommt, werden bei mir die produktpreise falsch berechnet.

z.b. wenn produkt_eins 4.90 EUR kostet, und man 3 St?ck davon bestellt hat, dann macht das nach adam riese

3*4.90 = 14.70 EUR

In der Mail steht aber 14.00 EUR.

Die zwischensumme dadrunter stimmt dann aber seltsamerweise wieder.

Es ist egal , welche produkte ich teste, bei allen stimmt die oben beschriebene aufsummierung nicht. alle summierungen enden mit .00

und die zwischensummen stimmen dann wieder ???!?!!!?

Ich verstehe das nicht. alle preise werden sonst richtig angezeigt, sowohl im shop als auch bei der gesamtberechnung im warenkorb, nur in der best?tigugsmail eben nicht.

wer kennt eine l?sung des problems?

vielen dank,

eddie

Quoted post

hallo,

ich habe die l?sung des problems gefunden:

als ich meinen provider nach der umgebungsvariable gefragt habe zur ?nderung des datumformates von english auf deutsch haben die mir folgende angeboten:

setlocale (LC_ALL, '[email protected]', 'de_DE', 'de', 'ge')

diese hat allerdings dazu gef?hrt, dass das datum der best?tigungsmails zwar

in deutsch war, aber die summen mit .00 abgerundet wurden. mir ist das nicht

gleich aufgefallen, sonst h?tte ich mit anderen einstellungen

weitergetestet. jetzt habe ich die richte setlocale - einstellung f?r meinen

shop gefunden:

@setlocale(LC_TIME, 'de_DE')

damit funktioniert jetzt alles einwandfrei*** HEUREKA***

gru?,

eddie

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...