Jump to content
xt:Commerce Community Forum
Sign in to follow this  
pfuchs

Login In Den Adminbereich Klappt Nicht

Recommended Posts

Hallo Forumer,

ich habe mir gestern den Shop lokal installiert.

Als ich das erste Mal den Adminbereich aufrufen wollte (http://localhost/xtcommerce/admin/start.php) passierte erstmal gar nichts.

Ein SSL-Problem habe ich nicht (SSL steht auf false), siehe auch URL.

Ich habe dann festgestellt dass mein includes/local-Ordner komplett leer war. Es gab nur eine readme Datei. Der konnte ich entnehmen dass ich eine configure.org.php umbenennen muss. Die Datei habe ich unter /includes gefunden und entspr. verschoben + umbenannt.

Wenn ich jetzt den Admin-Bereich aufrufen m?chte, komm ich wieder auf die Login-Seite (http://localhost/xtcommerce/login.php)

Und da weiss ich jetzt gar nicht mehr was ich machen soll.

Bin f?r jeden Tipp dankbar!

Beste Gr?sse, Peter

Share this post


Link to post
Share on other sites

wenn du schon auf die login.php geleitet wirst, vielleicht will dir der shop damit mitteilen das du dich anmelden sollst ?

und du hast auch einen admin account bei der installation angelegt, also einloggen....

Share this post


Link to post
Share on other sites

Mit dem Admin-Daten konnte ich mich ja anmelden, sonst w?rde doch vermutlich der <Admin> Button nicht erscheinen.

Ich bekomme ja in der rechten Navi auch die ?berschrift "Admin Info" und Statistiken angezeigt. Doch wenn ich auf diese Links oder Admin-Button klicke komme ich eben wieder auf die /login.php.

Hoffe dies macht das Problem klarer.

Peter

Share this post


Link to post
Share on other sites

Hallo mzanier, pfuchs

hab das selbe problem wie pfuchs,

nach erfolgreichem releaswechsel auf RC1.1.

in beiden configure.php dateien ist folgendes eingetragen:

'Store_session', '' .

habe es ebenfals mal mit 'mysql' versucht aber ohne erfolg.

woran k?nnte es noch liegen bzw. was hast du (pfuchs) dort eingetragen?

gru?

caot

Share this post


Link to post
Share on other sites

@caot

habe gerade diesen thread gesehen und ich habe auch einen ?hnlichen fehler. ich kann mich pl?tzlich nicht mehr anmelden.

habe auch die config-dateien ge?ndert auf mysql, trotzdem nicht geholfen.

was genau passiert bei dir?

ich komme immer wieder auf den ersten fenster wo ich meine daten erneut eingeben muss. allerdings erscheinen in den mittleren fenster alle produkte meines shops.

Share this post


Link to post
Share on other sites

Mu? mich hier wie bei meinem Problem mit der Suchfunktion (keine anzeige von artikeln mit gleicher artikelbezeichnung) wieder anschliessen.

Auch ich logge mich ein, sehe den Admin-Button, werde nach dem Klick aber wieder auf die login-Seite geleitet.

Habe auch in beiden config-Dateien 'mysql' eingetragen.

Gibt's denn da keine L?sung?

Komme echt nicht weiter.

Please help.

Gru?

T.

Share this post


Link to post
Share on other sites

ne gibs eigentlich keine l?sung, weil das problem bei korrekter installtion eientlich nicht auftreten kann.

l?sung gibs leider nur f?r probleme die man auch in irgendeiner weise reproduzieren kann.

bei solchen loginproblemen, ist es meistens ein session problem, welches am server behoben werden muss.

den in 95% hat der user einfach was ?bersehen oder nicht richtig gemacht.

Share this post


Link to post
Share on other sites

danke f?r die schnellen antworten.

ich werde mal meine gemachten ?nderungen an den templates durchforsten, vielleicht finde ich da einen fehler. meistens ist es ja wirklich so, dass fehler aus

unsachgem?ssen ?nderungen resultieren.

Aber wenn ich Euch schon mal dranhabe:

mein Problem mit der Suchfunktion ist wirklich existenziell.

habt ihr da eine idee?

ich arbeite ja gerade an einer bilddatenbank auf basis von XTC und

habe extrem viele artikel eingepflegt, die die jeweils exakt gleiche Artikelbezeichnung haben.

Wenn mittels Suche aber immer nur ein Treffer angezeigt wird, kann ich mir den gesamten Aufbau auch sparen.

W?re super, wenn Euch da noch was einf?llt.

Danke

T.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...