Jump to content
xt:Commerce Community Forum
Sign in to follow this  
franken-pc

Hilfe checke das mit den Pfadangaben nicht

Recommended Posts

Hi versuche den shop auf nem lokalen webserver einzurichten Suse 10

nach der Installation gibt er bei Catalog-button folgendes aus

Warning: main(includes/configure.php): failed to open stream: No such file or directory in /srv/www/htdocs/xt/xtcommerce/includes/application_top.php on line 42

Warning: main(): Failed opening 'includes/configure.php' for inclusion (include_path='/usr/share/php') in /srv/www/htdocs/xt/xtcommerce/includes/application_top.php on line 42

Warning: main(DIR_WS_INCLUDESfilenames.php): failed to open stream: No such file or directory in /srv/www/htdocs/xt/xtcommerce/includes/application_top.php on line 57

Fatal error: main(): Failed opening required 'DIR_WS_INCLUDESfilenames.php' (include_path='/usr/share/php') in /srv/www/htdocs/xt/xtcommerce/includes/application_top.php on line 57

aber die Dateien gibt es ich hab nachgesehen, was ist ein absoluter Pfad ???

ich hoffe mir kann jemand nen tipp geben

Share this post


Link to post
Share on other sites

hi,

dein shop findet die configure.php nicht - f?r mich sieht es nach nem Server-Config-Problem aus, denn normalerweise rennt das out-of-the-box... schau doch mal in die application_top.php Zeile 42 und trag evtl. einen absoluten Pfad zur configure.php ein.

Gru?,

Nov

Share this post


Link to post
Share on other sites

dies ist die zeile 42 meiner application_top.php

include('includes/configure.php');

meinst du mit absoluter Pfad

/srv/www/htdocs/xt/xtcommerce/includes/configure.php ??

sorry f?r die bl?de Frage aber mir is nich klar was mir absolut gemeint is

Share this post


Link to post
Share on other sites

Hi nochmal

jetzt kommt dieser fehler

Warning: main(lang/english/gv_english.php): failed to open stream: No such file or directory in /srv/www/htdocs/xt/xtcommerce/lang/english/english.php on line 438

Warning: main(): Failed opening 'lang/english/gv_english.php' for inclusion (include_path='/usr/share/php') in /srv/www/htdocs/xt/xtcommerce/lang/english/english.php on line 438

Warning: main(templates/xtc2/javascript/general.js.php): failed to open stream: No such file or directory in /srv/www/htdocs/xt/xtcommerce/includes/header.php on line 109

Fatal error: main(): Failed opening required 'templates/xtc2/javascript/general.js.php' (include_path='/usr/share/php') in /srv/www/htdocs/xt/xtcommerce/includes/header.php on line 109

hab ich bei der Installation was falsch gemacht ??

ich hab alles so gelassen wie es der Installer vorschlug.

Arg

Share this post


Link to post
Share on other sites

hi,

Ja, ein absoluter Pfad geht vom root-pfad / bis zur datei. Aber das kann hier nicht klappen, sorry hatte falsch gedacht. Die Datei includes/configure.php ist vorhanden und CHMOD 444? Dann sollte es eigentlich so funzen ;)

Ansonsten mal die Pfadangaben daraus hier posten.

Share this post


Link to post
Share on other sites

hab jetzt immer den angemahnten pfad korrigiert aber dann kommt immer der n?chste Fehler, also hier mal meine configure.php chmod 444 is O.K.

<?php

/* --------------------------------------------------------------

XT-Commerce - community made shopping

http://www.xt-commerce.com

Copyright ? 2003 XT-Commerce

--------------------------------------------------------------

based on:

? 2000-2001 The Exchange Project (earlier name of osCommerce)

? 2002-2003 osCommerce (configure.php,v 1.13 2003/02/10); www.oscommerce.com

Released under the GNU General Public License

--------------------------------------------------------------*/

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://apache'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://apache'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('DIR_WS_CATALOG', '/xt/xtcommerce/'); // absolute path required

define('DIR_FS_DOCUMENT_ROOT', '/srv/www/htdocs/xt/xtcommerce/');

define('DIR_FS_CATALOG', '/srv/www/htdocs/xt/xtcommerce/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ORIGINAL_IMAGES', DIR_WS_IMAGES .'product_images/original_images/');

define('DIR_WS_THUMBNAIL_IMAGES', DIR_WS_IMAGES .'product_images/thumbnail_images/');

define('DIR_WS_INFO_IMAGES', DIR_WS_IMAGES .'product_images/info_images/');

define('DIR_WS_POPUP_IMAGES', DIR_WS_IMAGES .'product_images/popup_images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES',DIR_FS_DOCUMENT_ROOT. 'includes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_FS_CATALOG . 'lang/');

define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

define('DIR_FS_INC', DIR_FS_CATALOG . 'inc/');

// define our database connection

define('DB_SERVER', 'Apache'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'root');

define('DB_SERVER_PASSWORD', '******');

define('DB_DATABASE', 'test');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

?>

werd wahrscheinlich neu installieren m?ssen weil ich jetzt schon zuviel rumeditiert habe, kann der Fehler an der ver?nderten verzeichnisstruktur von Suse liegen ?? :wacko:

Share this post


Link to post
Share on other sites

Der PC heisst Apache ich installier ?ber s LAN also is localhost nich der Weisheit letzter Schluss.

Ich hab jetzt alles gel?scht und nen drop database auf die test gemacht und ne neue test db erstellt, ich glaube der Fehler liegt in den Pfadangaben bei install_step1.php f?r Webserver Informationen:

wo m?ssen hier absolute Pfade rein und wo nicht???????????

Default is so aber das klappt nicht:

Webserver Root Verzeichnis:

/srv/www/htdocs/xt

Webserver "XT-Commerce" Verzeichnis:

/xt/xtcommerce/

Webserver Admin Verzeichnis:

/xt/xtcommerce/admin/

WWW Catalog Verzeichnis:

/xt/xtcommerce/

WWW Admin Verzeichnis:

/xt/xtcommerce/admin/

w?re nett wenn jemand der auch SUSE nutzt mal mit seinen Pfaden vergleicht

Share this post


Link to post
Share on other sites

hi,

prinzipiell m?ssen in der config-datei ?berall wo DIR_WS steht die Webserver-Pfade stehen, also ausgehend vom Root-Pfad deines Webservers, und nicht von der Gesamt-Verzeichnisstruktur.

?berall wo DIR_FS steht, m?ssen die FileSystem-Pfade rein, also ausgehend vom Root-Pfad des Servers... das w?re sowas wie /srv/www/xt/bla... bei SuSE.

Dann sollte man mal einen Blick in die Log-Dateien werfen, woran der Fehler genau liegt ;-) Und halt bissel Ahnung von Linux mitbringen...

Gru?,

Nov

Share this post


Link to post
Share on other sites

Ich bin dem Wahnsinn nahe ich habe jetzt mindestens 500 versuche hinter mir den shop vers 2.0 irgentwas zu installieren.

Abwer immer wenn ich auf catalog button dr?cke kommt

Warning: main(includes/configure.php): failed to open stream: No such file or directory in /srv/www/htdocs/includes/application_top.php on line 42

Warning: main(): Failed opening 'includes/configure.php' for inclusion (include_path='/usr/share/php') in /srv/www/htdocs/includes/application_top.php on line 42

Warning: main(DIR_WS_INCLUDESfilenames.php): failed to open stream: No such file or directory in /srv/www/htdocs/includes/application_top.php on line 57

Fatal error: main(): Failed opening required 'DIR_WS_INCLUDESfilenames.php' (include_path='/usr/share/php') in /srv/www/htdocs/includes/application_top.php on line 57

die Pfade stimmen aber korrigieren bringt auch nix dann kommt eben ein anderer fehler usw.

es muss doch eine m?glichkeit geben diesen shop auf einen lokalen webserver zu installieren. Ich will und muss lokal entwickeln und testen

HILFE !!!!!!!!

Share this post


Link to post
Share on other sites

Hallo,

ich hatte das selbe Problem und folgende Mitteilung irgendwo in einem Forum gefunden - das war bei mir die L?sung (nach tagelangem ?rger); ?brigens auch mit einem vergleichbaren Problem mit Coppermine und SugarCRM:

>>>

Seit SuSE 10.0 wird PHP ohne . im search path installiert, damit findet

er dann includes nicht mehr die nur einfach mit \'includes/functions.php\'

angegeben sind. Funktionieren tun nur noch \'./includes/functions.php\'

Das Thema wurde in folgendem Bug besprochen:

https://bugzilla.novell.com/show_bug.cgi?id=129682

Novell/SuSE stellt sich auf den Standpunkt dass ein . im pfad ein

Sicherheitsproblem sei, w?hrend die meisten anderen distributionen und

auch PHP selbst den punkt vorschl?gt....

Abhilfe verschafft die ?nderung von /etc/php.ini beim Parameter include_path

h?nge einfach ein .: davor

Bei mir mit PHP5 sieht das zB so aus:

include_path = \".:/usr/share/php5:/usr/share/php5/PEAR\"

>>>

Vielleicht hilfts.

Gru?

fg

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...