Jump to content
xt:Commerce Community Forum
Sign in to follow this  
hitachi

Fatal error: Cannot access empty property in /home

Recommended Posts

hallo admin

wenn ich ich falschen ordner bin bitte moven

weiss einer was das bedeutet:

Fatal error: Cannot access empty property in /home/meine seite/ftp/www/checkout_process.php on line 275

gruss

ga

Share this post


Link to post
Share on other sites

Hallo auch wir haben das Problem.

Unsere Fehlermeldung:

Fatal error: Cannot access empty property in /home/www/web81/html/xtc/checkout_process.php on line 278

Die dazugeh?rige Datei sieht so aus:

if (xtc_db_num_rows($stock_query) > 0) {

$stock_values = xtc_db_fetch_array($stock_query);

// do not decrement quantities if products_attributes_filename exists

if ((DOWNLOAD_ENABLED != 'true') || (!$stock_values['products_attributes_filename'])) {

$stock_left = $stock_values['products_quantity'] - $order->products[$i]['qty'];

} else {

$stock_left = $stock_values['products_quantity'];

}

xtc_db_query("update " . TABLE_PRODUCTS . " set products_quantity = '" . $stock_left . "' where products_id = '" . xtc_get_prid($order->products[$i]['id']) . "'");

if ( ($stock_left < 1) && (STOCK_ALLOW_CHECKOUT == 'false') ) {

xtc_db_query("update " . TABLE_PRODUCTS . " set products_status = '0' where products_id = '" . xtc_get_prid($order->products[$i]['id']) . "'");

}

}

}

// Update products_ordered (for bestsellers list)

xtc_db_query("update " . TABLE_PRODUCTS . " set products_ordered = products_ordered + " . sprintf('%d', $order->products[$i]['qty']) . " where products_id = '" . xtc_get_prid($order->products[$i]['id']) . "'");

Rot markiert ist die Zeile 278

Nur kann ich mit der Fehlermeldung und den Hilfen im Forum nichts anfangen. XTC Version 3.0.2 und PHP 5.0.5

Was mu? ich ?ndern, damit das System unter PHP 5 l?uft??

BITTE DRINGEND UM HIIIIILLLLLFFFFFEEEEE :wacko:

Share this post


Link to post
Share on other sites

Da man soviel ich weis an diversen Stellen ansetzen muss, w?rde ich mal auf die aktuelle Version updaten, welche php5 kompatibel ist. Funktioniert einwandfrei unter php5.

Ansonsten mal das $ weglassen, k?nnte evtl. funktionieren!

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...