Jump to content
xt:Commerce Community Forum
Sign in to follow this  
munlock

Popup_image.php ?ffnet Explorerfenster Unendlich

Recommended Posts

Hallo!

Hatte letztens auf einmal ganz viele ge?ffnete Popup_Image Fenster, es ?ffnen sich soviele bis der Rechner am Memory Kollaps abschmiert.

Dachte erst das es ein dummer Zufall ist, ist mir jedoch heute wieder passiert, jedoch auf einem RICHTIG schnellem Server (Hallo HHGAG :) )

Selbst bei gedr?ckter Alt-F4 Taste lie? sich das Chaos kaum reduzieren.

F?r die die es mal reproduzieren m?chten:

1. Artikel aufrufen

2. Auf das Produktbild klicken.

3. Auf Fenster schlie?en klicken (evtl. mit der rechten Maustaste probieren)

4. Mit der rechten (!) Maustaste auf erneut auf das Artikelbild klicken

Evtl. die Prozedur ein paar mal wiederholen...

Verwendeter Browser: IE 6

Die einen w?rden sagen es macht 'nen Irren Spass wenn der Moni in null komma nichts voll ist mit Popup_Image Fenstern, die anderen nehmen es vielleicht zur Server Performance Messung (Mein Server ist bedeutend langsamer als der von HHGAG :) )

Aber mich w?rde Interessieren woran das liegt und wie man es evtl. abstellen

kann.

:grml:

Gru? Munlock

Share this post


Link to post
Share on other sites
Guest HHGAG

Konqueror nicht reproduzierbar

Mozilla nicht reproduzierbar

(OK bei Linux weht der Wind aus ner anderen Richtung, kann sein das es bei Windoof reproduzierbar ist)

Besorg dir nen anst?ndigen Browser (kann sein das Gates & Co. wiedermal nen Bug reingehauen haben) :z:

Share this post


Link to post
Share on other sites

also am shop kann dies nicht liegen, hab ich auch nciht reproduzieren k?nnen.

das popup ist ein normales JS poupup.

die server performance kann sowas nicht knicken, da resigigniert zuerst dein windoof bevor ein popup am server nen merkbaren performance einbruch macht.

Share this post


Link to post
Share on other sites

die server performance kann sowas nicht knicken, da resigigniert zuerst dein windoof bevor ein popup am server nen merkbaren performance einbruch macht.

Nene, so war das auch nicht gemeint sondern die Serverperformance ist so gut,

das so schnell Nachschub kommt das sich mein Windoof in null komma nichts zerlegt.

Wird wohl an meiner kombination von Programmen (IE, Java Runtime etc.), Servicepacks und Windows liegen.

Ist f?r mich auch nur mit IE und nicht mit Opera reproduzierbar.

Hab mir nur sorgen gemacht das andere das Problem auch haben k?nnten

und einen schlechten Eindruck auf den Shop wirft.

Ich werde es im Auge behalten und auf anderen Rechnern auch austesten.

Dennoch vielen Dank f?r Eure Hilfe!

Gru? Munlock

Share this post


Link to post
Share on other sites

ich hatte das selbe problem, ein klick auf schliessen und ein fenster nach dem anderen popt :blink:

allerdings erst nachdem ich das popup_image.php ge?ndert hatte.

hab dann folgendes eingef?gt und seitdem geht es problemlos

<?php echo '<a href="javascript:window.close()">' .schlie?en. '</a>'; ?>
so sollte es aber auch gehen
<a href="{$link_close}">{#text_close#}</a>

Share this post


Link to post
Share on other sites

Richtig, der Rechtsklick danach auf das Bild ist garnicht n?tig...

Hab jetzt in der popup_image.php folgeden Code:

<td class="main" align="center">Fenster schließen</td>

gegen diesen ausgetauscht:

<td class="main" align="center"><?php echo '' .Fenster?schlie?en. ''; ?></td>

Nu gibt es keine Probleme mehr. :bounce:

K?nnte evtl daran liegen das ich im IE die Google und testweise die ALEXA Toolbar installiert habe. Da beide Programme durch den PopUpBlocker mit JavaScript rumspielen.

W?re sch?n wenn SuperMario dies f?r folgende Versionen/Updates mit ?bernehmen w?rde. Schreib ich auch noch in den Bugtracker.

Gru? Munlock

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...